ISDataSource

ISDataSource Documentation
ISDataSource
Send Feedback

Glossary Item Box

This section contains complete information about ISDataSource.

In This Section

Introduction

Getting Started

Walkthrough Topics

How-to Topics

Features and Concepts

Learning More

Server-side References

© 2010 Intersoft Solutions Corp. All Rights Reserved.


Introduction

Introduction
See Also Send Feedback
ISDataSource > Introduction

Glossary Item Box

When Visual Studio 2005 is released to the market, one thing that came into our attention was that Visual Studio 2005 introduced a new concept on how to build data source and utilize it in an ASP.NET application. This new concept is to some extend quite remarkable, considering it can do automatic data-binding to .NET data-bound controls with "no code" or very few codes in the Presentation Layer which also means that we can now have a clear separation between Presentation Layer, Business Logic Layer and Data Layer.

Responding to this new concept, Intersoft Solutions as one of the leading company has started to adapt the concept of its entire data-bound components including WebGrid and WebCombo.

During the research, we found out that it was quite hard and ineffective to perform hierarchical data retrieval using native .NET data source control. Considering this limitation and some other aspects that can be enhanced, Intersoft Solutions decided to develop a new data source control which later called ISDataSource.

The main purpose of ISDataSource is to support Hierarchical Data binding for Intersoft data-bound components. However, it is also embedded with many other fascinating features. The following are the list of enhanced features in ISDataSource:

  • Multi table-view support and Hierarchical-relational support
  • Connects to DataSet and CustomObject in design time
  • Enhanced configuration management
  • Enhanced designer (step-by-step wizard & automatic table generation)
  • Integration with .NET data-bound controls
  • Enhanced caching mechanism
  • Integration with Intersoft data-bound controls

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Architecture
Processing data using ISDataSource.NET


Getting Started

Getting Started
See Also Send Feedback
ISDataSource > Getting Started

Glossary Item Box

This section is designated to help you quickly getting started with ISDataSource. You can use all links below to become familiar with ISDataSource.

Installation

The following topics will guide you how to install ISDataSource and what the system requirements you need to have in order to run ISDataSource in your PC.

  • Installation Guide
  • Manually installing ISDataSource to Visual Studio 2005 ToolBox
  • System Requirements

Deployment

This section will help you to configure and set the application in deploying the project to server. It also provides information on how to use Deployment Manager which contains the essential things you need to manage before proceeding to deployment.

  • Deployment Guide
  • Application Wide Configurations

ISDataSource Walkthroughs

Walkthroughs will guide you through the completion of basic tasks using ISDataSource. Use walkthroughs to become familiar with ISDataSource and know how to implement basic DataBinding.

Term | Definition
Walkthrough: Binding to Data using ISDataSource | Describes the process for binding data with ISDataSource control.
Walkthrough: Binding Generic Collection using ISDataSource | Describes the process for binding generic collection data with ISDataSource control.
Walkthrough: Modifying Data using ISDataSource | Describes the process for modifying data with ISDataSource control.

For additional Walkthroughs, see ISDataSource Walkthroughs.

See Also

Tasks
Walkthrough Topics
How-to Topics

Concepts
Features and Concepts
Learning More


Installation

Installation
See Also Send Feedback
ISDataSource > Getting Started > Installation

Glossary Item Box

This section contains information on installing ISDataSource and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing ISDataSource on your PC.

Manually installing ISDataSource to Visual Studio 2005 ToolBox
Information about installing ISDataSource control to Visual Studio 2005 ToolBox manually.

System Requirements
Read about the Windows version, Visual Studio application, WebUI.NET Framework and other software requirements for installing ISDataSource.

See Also

Other Resources
Deployment
Samples and Walkthroughs


Installation Guide

Installation Guide
See Also Send Feedback
ISDataSource > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing ISDataSource

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid Enterprise 7, WebCombo 4, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, WebTextEditor, WebEssentials and ClientUI components.

Here are the step-by-step instructions to install ISDataSource:

  1. Double click on the "intersoft webui studio 2010 r1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install ISDataSource.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. You can select the target environment for the samples, either Microsoft Visual Studio 2008 or Microsoft Visual Studio 2010.

  6. You can also customize the Start Menu group and choose to create shortcuts for all users or just for yourself.

  7. Click Next to proceed with the installation process.

  8. The wizard is installing WebUI Studio 2010 R1.

  9. A window showing the installation progress appears. It will list the status of components that are being installed.

  10. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2010 R1.

  11. To install the full version of WebTextEditor, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> License Manager.

  12. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  13. Now, Select a product from the combo box. In this case, select ISDataSource Version 1.0.1500 and enter the license according to the component.

  14. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of ISDataSource.

See Also

Other Resources
Manually installing ISDataSource to Visual Studio 2005 ToolBox
System Requirements


Manually installing ISDataSource to Visual Studio 2005 ToolBox

Manually installing ISDataSource to Visual Studio 2005 ToolBox
See Also Send Feedback
ISDataSource > Getting Started > Installation > Manually installing ISDataSource to Visual Studio 2005 ToolBox

Glossary Item Box

This document provides a step-by-step guidance on how to manually install ISDataSource to Visual Studio 2005 ToolBox.

Step-By Step Instructions

To manually install ISDataSource to Visual Studio 2005 ToolBox

  1. Open Visual Studio 2005 application.
  2. Create a new WebSite application.
  3. In the Designer view, refer to the ToolBox on the left side.
  4. Right-click on the ToolBox and choose Add Tab.
  5. Named the Tab as "WebUI Studio.NET".
  6. Right-click on the created Tab and select Choose Items.
  7. Browse and Add ISNet.WebUI.ISDataSource.dll from C:\Program Files\Intersoft Solutions\ISDataSource.NET 1.0\Bin.
  8. Finally, your ToolBox will look like the following.

    ToolBox

See Also

Other Resources
Installation Guide
System Requirements


System Requirements

System Requirements
See Also Send Feedback
ISDataSource > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

  • Microsoft Windows 2000/2003/2008 Server family
  • Microsoft Windows XP Professional or Home Edition
  • Microsoft .NET Framework v2.0 or higher
  • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
  • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

  • Windows Server 2003 Enterprise
  • Windows Server 2003 Web Edition
  • Internet Information Services 6.0 or later
  • Microsoft .NET Framework Version 2.0 or later
  • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

  • Microsoft Internet Explorer 5.5 or higher
  • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
  • Firefox V1.0+ for Windows/Mac/Linux/Solaris
  • Netscape V7.0+ for Windows/Mac/Linux/Solaris

See Also

Other Resources
Installation Guide
Manually installing ISDataSource to Visual Studio 2005 ToolBox


Deployment

Deployment
See Also Send Feedback
ISDataSource > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step checklist instructions for deployment purposes.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the web.config.

See Also

Other Resources
Installation
Samples and Walkthroughs


Using Deployment Manager
See Also Send Feedback
ISDataSource > Getting Started > Deployment > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> WebUI Studio for ASP.NET >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick ISDataSource.NET 1.0.1500 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. Click Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

See Also

WebUI.NET Framework Reference
New SmartWebResources Framework.html


Samples and Walkthroughs

Samples and Walkthroughs
See Also Send Feedback
ISDataSource > Getting Started > Samples and Walkthroughs

Glossary Item Box

This section contains information about location of sample and tutorial files, example codes and how to use ISDataSource in Visual Studio 2010.

In This Section

Locating Sample Files
Discover the locations where sample files are stored on your computer or the installation source.

ISDataSource Walkthroughs
Learn how to create basic applications in ISDataSource with these step-by-step guides.

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Features and Concepts
Learning More


Locating Sample Files

Locating Sample Files
See Also Send Feedback
ISDataSource > Getting Started > Samples and Walkthroughs > Locating Sample Files

Glossary Item Box

The default locations for Sample files in this release are listed below. install represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
C# Samples (Visual Studio 2010 Solution) | C:\install\Intersoft WebUI Studio 2010 R1\Samples\For ASP.NET\ISNet.WebUI.Samples\cs
VB Samples (Visual Studio 2010 Solution) | C:\install\Intersoft WebUI Studio 2010 R1\Samples\For ASP.NET\ISNet.WebUI.Samples\vb

See Also

Other Resources
Walkthrough Topics
How-to Topics


ISDataSource Walkthroughs

ISDataSource Walkthroughs
See Also Send Feedback
ISDataSource > Getting Started > Samples and Walkthroughs > ISDataSource Walkthroughs

Glossary Item Box

These walkthroughs introduce the important basic area of ISDataSource component. Each walkthrough discusses the development of binding data using ISDataSource for the first time, how to modify data using a series of step-by-step instructions.

In This Section

Walkthrough: Binding to Data using ISDataSource
Demonstrates how to bind data using ISDataSource.

Walkthrough: Binding Generic Collection using ISDataSource.NET
Demonstrates how to bind generic collection data using ISDataSource.

Walkthrough: Modifying Data using ISDataSource
Demonstrates how to modify data using ISDataSource.

Walkthrough: Binding to Hierarchical data using ISDataSource.NET
Demonstrates how to bind hierarchical data using ISDataSource.

See Also

Tasks
Walkthrough Topics
How-to Topics


Walkthrough: Binding to data using ISDataSource.NET

Walkthrough: Binding to data using ISDataSource.NET
See Also Send Feedback
ISDataSource > Getting Started > Samples and Walkthroughs > ISDataSource Walkthroughs > Walkthrough: Binding to data using ISDataSource.NET

Glossary Item Box

This walkthrough shows you how to perform binding to data using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource control.
  • Configure Data Source.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • DataSet Component in App_Code.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To bind data using ISDataSource

  1. Drag ISDataSource control from toolbox to the WebForm.
  2. Configure Data Source for the newly created ISDataSource.
  3. Select DataSet for the SchemaType.
  4. Click Schema Name dropdown and select dsNorthWind from the list.

  5. In the next dialog, click AutoGenerate button which is located at the bottom.

  6. Click Finish.
  7. Drag GridView / DetailsView / FormView / WebGrid or others data-bound controls.
  8. Set the DataSourceID (Choose Data Source) to ISDataSource1.
  9. Set the DataMember (View Name) to Categories.

  10. You are all set. Run the page in browser.

ISDataSourceSettings :

<ISDataSource:ISDataSource ID="ISDataSource1" runat="server" SchemaName ="dsNorthwind">
   <Tables>
      <ISDataSource:ISDataSourceTable TableName="Customers"
            OldValuesParameterFormatString ="Original_{0}"
            SelectMethod = "GetData" TypeName ="dsNorthwind.CustomersTableAdapter">
   </Tables>
</ISDataSource:ISDataSource>

See Also

Tasks
Walkthrough: Binding Generic Collection using ISDataSource
Walkthrough: Modifying data using ISDataSource
Walkthrough Topics
How-to Topics

Concepts
Processing data using ISDataSource

References
ISDataSource Class
SchemaType Property
SchemaName Property


Walkthrough: Binding Generic Collection using ISDataSource.NET

Walkthrough: Binding Generic Collection using ISDataSource.NET
See Also Send Feedback
ISDataSource > Getting Started > Samples and Walkthroughs > ISDataSource Walkthroughs > Walkthrough: Binding Generic Collection using ISDataSource.NET

Glossary Item Box

This walkthrough shows you how to perform binding generic collection using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Configure Data Source.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • DataSet Component in App_Code.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To bind generic collection using ISDataSource

  1. Drag ISDataSource control from toolbox to the designer surface.
  2. Configure Data Source for the newly created ISDataSource.
  3. Select CustomObject for the SchemaType.

  4. In the next dialog, add new table with name Customers.
  5. Select BusinessObject = Generic.CustomerDataAccess.
  6. Select SelectMethod = GetCustomers().

  7. Click Finish.
  8. Drag GridView / DetailsView / FormView or others data-bound controls.
  9. Set the DataSourceID to ISDataSource1.
  10. Set the DataMember to Customers.

  11. You are all set. Run the page in browser.

ISDataSourceSettings :

<ISDataSource:ISDataSource ID="ISDataSource1" runat="server" SchemaType ="CustomObject">
   <Tables>
      <ISDataSource:ISDataSourceTable
            DataObjectTypeName ="GenericObject.Customer" DeleteMethod="Delete"
            InsertMethod ="Insert"
            OldValuesParameterFormatString="Original_{0}" SelectMethod="GetCustomers"
            TableName="Customers" TypeName="GenericObject.CustomerDataAccess" UpdateMethod="Update">
            <UpdateParameters>
               <asp:Parameter Name="customer" Type="Object" />
            </UpdateParameters>
            <InsertParameters>
               <asp:Parameter Name="customer" Type="Object" />
            </InsertParameters>
            <DeleteParameters>
               <asp:Parameter Name="customer" Type="Object" />
            </DeleteParameters>
      </ISDataSource:ISDataSourceTable>
   </Tables>
</ISDataSource:ISDataSource>

Based on the capabilities of the business object that the ISDataSource control works with, you can perform data operations such as updates, inserts, and deletes. In order to perform these data operations, you need to set the appropriate method name and any associated parameters for the operation that you want to perform.

For example, for an update operation, set the ISDataSourceTable's UpdateMethod property to the name of business object method that perform updates and add any required parameters to the UpdateParameters collection.

If the ISDataSource control is associated with a data-bound control, the parameters are added by the data-bound control. In this case, you need to ensure that the parameters name of the method match the field names in the data-bound control. The update is performed when the Update method is called, either explicitly by your code or automatically by a data-bound control. The same general pattern is followed for Delete and Insert operations.

Important Note: Business objects are assumed to perform these types of data operations one record at a time, rather than batched.

See Also

Tasks
Walkthrough: Binding to data using ISDataSource
Walkthrough: Modifying data using ISDataSource
Walkthrough Topics
How-to Topics

Concepts
Processing data using ISDataSource

References
ISDataSource Class
SchemaType Property


Walkthrough: Modifying data using ISDataSource.NET

Walkthrough: Modifying data using ISDataSource.NET
See Also Send Feedback
ISDataSource > Getting Started > Samples and Walkthroughs > ISDataSource Walkthroughs > Walkthrough: Modifying data using ISDataSource.NET

Glossary Item Box

This walkthrough shows you how to modifying data using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Configure Data Source.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • DataSet Component in App_Code.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To modify data using ISDataSource
  1. Drag ISDataSource control from toolbox to the designer surface.
  2. Configure Data Source for the newly created ISDataSource.
  3. Select DataSet for the SchemaType.
  4. Click Schema Name dropdown and select dsNorthWind from the list.

  5. In the next dialog, click AutoGenerate button which is located at the most bottom.

  6. Click Finish.
  7. Drag GridView / DetailsView / FormView or others data-bound controls.
  8. Set the DataSourceID (Choose Data Source) to ISDataSource1.
  9. Set the DataMember (View Name) to Categories.

  10. Enable the Inserting / Deleting / Updating from the data-bound controls.

  11. You are all set. Run the page in browser.

ISDataSourceSettings :

<ISDataSource:ISDataSource ID="ISDataSource1" runat="server" SchemaName ="dsNorthwind">
   <Tables>
      <ISDataSource:ISDataSourceTable ConflictDetection="CompareAllValues"
         DeleteMethod ="Delete" InsertMethod ="Insert"
         OldValuesParameterFormatString="Original_{0}" SelectMethod="GetData" TableName="Customers"
         TypeName="dsNorthwind.CustomersTableAdapter"
         UpdateMethod ="Update">
         <UpdateParameters>
            <asp:Parameter Name="CustomerID" Type="String" />
            <asp:Parameter Name="CompanyName" Type="String" />
            <asp:Parameter Name="ContactName" Type="String" />
            <asp:Parameter Name="ContactTitle" Type="String" />
            <asp:Parameter Name="Address" Type="String" />
            <asp:Parameter Name="City" Type="String" />
            <asp:Parameter Name="Region" Type="String" />
            < asp : Parameter Name="PostalCode" Type="String" />
            <asp:Parameter Name="Country" Type="String" />
            <asp:Parameter Name="Phone" Type="String" />
            <asp:Parameter Name="Fax" Type="String" />
            <asp:Parameter Name="Original_CustomerID" Type="String" />
            <asp:Parameter Name="Original_CompanyName" Type="String" />
            <asp:Parameter Name="Original_ContactName" Type="String" />
            <asp:Parameter Name="Original_ContactTitle" Type="String" />
            <asp:Parameter Name="Original_Address" Type="String" />
            <asp:Parameter Name="Original_City" Type="String" />
            <asp:Parameter Name="Original_Region" Type="String" />
            <asp:Parameter Name="Original_PostalCode" Type="String" />
            <asp:Parameter Name="Original_Country" Type="String" />
            <asp:Parameter Name="Original_Phone" Type="String" />
            <asp:Parameter Name="Original_Fax" Type="String" />
         </UpdateParameters>
         <InsertParameters>
            <asp:Parameter Name="CustomerID" Type="String" />
            <asp:Parameter Name="CompanyName" Type="String" />
            <asp:Parameter Name="ContactName" Type="String" />
            <asp:Parameter Name="ContactTitle" Type="String" />
            <asp:Parameter Name="Address" Type="String" />
            <asp:Parameter Name="City" Type="String" />
            <asp:Parameter Name="Region" Type="String" />
            <asp:Parameter Name="PostalCode" Type="String" />
            <asp:Parameter Name="Country" Type="String" />
            <asp:Parameter Name="Phone" Type="String" />
            <asp:Parameter Name="Fax" Type="String" />
         </ InsertParameters >
         <DeleteParameters>
            <asp:Parameter Name="Original_CustomerID" Type="String" />
            <asp:Parameter Name="Original_CompanyName" Type="String" />
            <asp:Parameter Name="Original_ContactName" Type="String" />
            <asp:Parameter Name="Original_ContactTitle" Type="String" />
            <asp:Parameter Name="Original_Address" Type="String" />
            <asp:Parameter Name="Original_City" Type="String" />
            <asp:Parameter Name="Original_Region" Type="String" />
            <asp:Parameter Name="Original_PostalCode" Type="String" />
            <asp:Parameter Name="Original_Country" Type="String" />
            <asp:Parameter Name="Original_Phone" Type="String" />
            <asp:Parameter Name="Original_Fax" Type="String" />
         </ DeleteParameters >
      </ISDataSource:ISDataSourceTable>
   </Tables>
</ISDataSource:ISDataSource >

See Also

Tasks
Walkthrough: Binding to data using ISDataSource
Walkthrough: Binding Generic Collection using ISDataSource
Walkthrough Topics
How-to Topics

Concepts
Processing data using ISDataSource

References
ISDataSource Class
SchemaType Property
SchemaName Property


Walkthrough: Binding to Hierarchical data using ISDataSource.NET

Walkthrough: Binding to Hierarchical data using ISDataSource.NET
See Also Send Feedback
ISDataSource > Getting Started > Samples and Walkthroughs > ISDataSource Walkthroughs > Walkthrough: Binding to Hierarchical data using ISDataSource.NET

Glossary Item Box

This walkthrough shows you how to perform binding to hierarchical data using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Configure Data Source.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • DataSet Component in App_Code.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To bind hierarchical data using ISDataSource

  1. Drag ISDataSource control from toolbox to the designer surface.
  2. Configure Data Source for the newly created ISDataSource.
  3. Select DataSet for the SchemaType.
  4. Click Schema Name dropdown and select dsNorthWind from the list.

  5. In the next dialog, click AutoGenerate button which is located at the most bottom.

  6. Click Finish.
  7. Drag WebGrid control from toolbox to the designer surface.
  8. Set the DataSourceID to ISDataSource1.

  9. In the Connected to DataSource dialog, select Retrieve Hierarchical Structure and click OK.

  10. You are all set. Run the page in browser.

See Also

Tasks
Walkthrough: Binding to Hierarchical CustomObject using ISDataSource
Walkthrough Topics
How-to Topics

Concepts
Hierarchical Data Retrieval

References
ISDataSource Class
SchemaType Property
SchemaName Property


Walkthrough Topics

Walkthrough Topics
See Also Send Feedback
ISDataSource > Walkthrough Topics

Glossary Item Box

The following list of walkthrough topics demonstrates how to use all features in ISDataSource.

Processing data using ISDataSource

The topics in this category provide information about using ISDataSource for binding and modifying data.

  • Walkthrough: Binding to Data using ISDataSource
  • Walkthrough: Binding Generic Collection using ISDataSource.NET
  • Walkthrough: Modifying Data using ISDataSource
  • Walkthrough: Binding to Multiple controls using ISDataSource

Hierarchical Data Retrieval

The topics in this category provide information about using ISDataSource for binding to hierarchical data.

  • Walkthrough: Binding to Hierarchical data using ISDataSource.NET
  • Walkthrough: Binding to Hierarchical CustomObject using ISDataSource.NET

Load on Demand Data Retrieval

The topics in this category provide information about creating various LoadOnDemand using ISDataSource.

  • Walkthrough: Loading child rows on demand based on the selected parent row
  • Walkthrough: Creating Self Reference LoadOnDemand WebGrid
  • How-to: Implement custom Virtual Load

See Also

Tasks
How-to Topics

Other Resources
Features and Concepts
Learning More


How-to Topics

How-to Topics
See Also Send Feedback
ISDataSource > How-to Topics

Glossary Item Box

The following list of How-to topics describes how to implement various features in ISDataSource.

Architecture

The topics in this category provide direct instructions on how to utilize basic features based on ISDataSource architecture.

  • How-to: Utilize DataObjectTypeName
  • How-to: Utilize CancelSelectOnNullParameters
  • How-to: Utilize Paging Capability

Processing data using ISDataSource

The topics in this category provide direct instructions on how to use ISDataSource with DetailView, GridView and many others.

  • How-to: Use ISDataSource.NET along with DetailsView
  • How-to: Use ISDataSource.NET along with GridView
  • How-to: Use ISDataSource.NET along with FormView
  • How-to: Use ISDataSource.NET along with DataList
  • How-to: Use ISDataSource.NET along with Repeater
  • How-to: Use ISDataSource.NET along with ListControls

Sorting and Filtering Data

The topics in this category provide direct instructions on how to use FilterExpression, FilterParameters and SortExpression.

  • How-to: Utilize FilterExpression
  • How-to: Utilize FilterParameters
  • How-to: Utilize multiple FilterParameters
  • How-to: Utilize SortExpression
  • How-to: Utilize SortParameterName

Caching Architecture

The topic in this category provides a direct instruction on how to set cache configuration.

  • How-to: Configure cache configuration

Cache Storage

The topics in this category provide direct instructions on how to use and configure file server.

  • How-to: Use file server for an instance of control
  • How-to: Configure file server to use shared network drive

Event Handlers

The topic in this category provides a direct instruction on how to use the event handlers available in ISDataSource.

  • How-to: Use ISDataSource.NET event handlers

See Also

Tasks
Walkthrough Topics

Other Resources
Features and Concepts
Learning More


Features and Concepts

Features and Concepts
See Also Send Feedback
ISDataSource > Features and Concepts

Glossary Item Box

This section summarizes key features owned by the ISDataSource.

In This Section

Architecture
Read about the ISDataSource architecture

Processing data using ISDataSource.NET
Learn how to perform data operations through ISDataSource.

Hierarchical Data Retrieval
Information about retrieving data hierarchically.

Load on Demand Data Retrieval
Read about the ISDataSource's ability to support all load on demand in WebGrid and WebCombo.

Caching Architecture
Read about data caching supported in ISDataSource.

Event Handlers
Information about the event handlers available in ISDataSource

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Learning More


Architecture

Architecture
See Also Send Feedback
ISDataSource > Features and Concepts > Architecture

Glossary Item Box

In simple way, ISDataSource can be described as a collection of tables (ISDataSourceTable) with or without pre-defined schema, which will act as proxies for working with Microsoft.NET data-bound controls and Intersoft data-bound controls.

As you have seen in figure 2.0, ISDataSource is used to describe/represent the data structure from your Business Logic Layer or Data Layer itself. Each of the ISDataSourceTable plays a part in determining how the data operations are handled, the same way how ObjectDataSource handle the data operations request.

There are two fundamental things that construct ISDataSource control:

  • Collection of Tables (ISDataSourceTable)
    Collection of ISDataSourceTable that hold information on how data is treated (Select/Update/Delete/Insert)

  • DataSourceSchema
    The DataSourceSchema holds information regarding the underlying structure of all tables in ISDataSource control. This structural information is used for hierarchical data retrieval using Intersoft WebGrid control.

The advantages of this architecture are:

  • With all tables are collected in one control, you can set a configuration settings from ISDataSource control level or ISDataSourceTable level. Therefore it is easier to manage all the configuration settings for all DataSource that will be used in a page.
  • Given the DataSourceSchema information allows the Intersoft WebGrid to perform Retrieve Structure in Design Time and most importantly allow the Intersoft WebGrid.NET to perform Hierarchical binding with no code (codeless Hierarchical data binding).

In This Section

Organize your data sources in one component

Integration with .NET data bound controls

How-to: Utilize DataObjectTypeName

How-to: Utilize CancelSelectOnNullParameters

How-to: Utilize Paging Capability

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Processing data using ISDataSource
Hierarchical Data Retrieval
Working with designer

References
ISDataSourceTable Class
SchemaName Property
SchemaType Property


Organize your data sources in one component

Organize your data sources in one component
See Also Send Feedback
ISDataSource > Features and Concepts > Architecture > Organize your data sources in one component

Glossary Item Box

Although ISDataSource is primarily used to perform hierarchical data retrieval, it also supports the standard .NET data source controls binding.

Currently the data source controls that shipped along with Visual Studio 2005 (SqlDataSource, AccessDataSource, and ObjectDataSource) only support one table definition per data source, to some extend this is not a practical approach to do. Considering a scenario where you have a huge and complex table structure and you use lots of table in a single page. You will have lots of data source instances in your designer and it will take times to manage them one by one.

ISDataSource provides a better way to manage your data sources. With only using one control you can organize which tables will be used in the page and how the tables access, retrieve, and modify the data.

With this architecture you can easily add/remove/modify any table that you will use in the page. Moreover, you will be able to control the behavior from ISDataSource level and ISDataSourceTable level more easily.

See Also

Concepts
Architecture

Related Sections
Integration with .NET data bound controls

References
ISDataSource Class
ISDataSourceTable Class


Integration with .NET data bound controls

Integration with .NET data bound controls
See Also Send Feedback
ISDataSource > Features and Concepts > Architecture > Integration with .NET data bound controls

Glossary Item Box

Another important feature that ISDataSource provides is the integration to .NET data bound controls. You can select which table to be bounded by utilizing the data member property of .NET data bound controls. If you use Typed DataSet as table definition, by default the .NET data bound controls will generate the column based on data member that you select.

See Also

Concepts
Architecture

Related Sections
Organize your data sources in one component

References
ISDataSource Class


How-to: Utilize DataObjectTypeName

How-to: Utilize DataObjectTypeName
See Also Send Feedback
ISDataSource > Features and Concepts > Architecture > How-to: Utilize DataObjectTypeName

Glossary Item Box

You can set DataObjectTypeName in ISDataSource using designer.

In this topic, you will learn how to utilize DataObjectTypeName in ISDataSource.

To utilize DataObjectTypeName in ISDataSource

  1. Right click ISDataSource instance and choose ISDataSource Designer.
  2. Choose which Tables that you want to use (e.g Products) then set the DataObjetTypeName properties to parameter name that are passed by data-bound controls (e.g DataObject.MyData).
  3. Also, set TypeName properties to type of the object(e.g DataObject.MyDataAccess).
  4. Run the Project.

See Also

Tasks
How-to: Utilize CancelSelectOnNullParameters
How-to: Utilize Paging Capability
Walkthrough Topics
How-to Topics

Concepts
Architecture

References
DataObjectTypeName Property
TypeName Property


How-to: Utilize CancelSelectOnNullParameters

How-to: Utilize CancelSelectOnNullParameters
See Also Send Feedback
ISDataSource > Features and Concepts > Architecture > How-to: Utilize CancelSelectOnNullParameters

Glossary Item Box

You can set CancelSelectOnNullParameters in ISDataSource using designer.

In this topic, you will learn how to set CancelSelectOnNullParameters in ISDataSource.

To set CancelSelectOnNullParameters in ISDataSource

  1. Right-click ISDataSource instance and choose ISDataSource Designer.
  2. Choose which Tables that you want to use (e.g Products) then set the CancelSelectOnNullParameter properties to Yes.
  3. Run the Project.

See Also

Tasks
How-to: Utilize DataObjectTypeName
How-to: Utilize Paging Capability
Walkthrough Topics
How-to Topics

Concepts
Architecture

References
CancelSelectOnNullParameter Property


How-to: Utilize Paging Capability

How-to: Utilize Paging Capability
See Also Send Feedback
ISDataSource > Features and Concepts > Architecture > How-to: Utilize Paging Capability

Glossary Item Box

You can set Paging Capability in ISDataSource using designer.

In this topic, you will learn how to set Paging Capability in ISDataSource.

To set Paging Capability in ISDataSource

  1. Right click ISDataSource instance and choose ISDataSource Designer.
  2. Choose which Tables that you want to use (e.g Products) then set the EnablePaging properties to True.
  3. Run the Project.

See Also

Tasks
How-to: Utilize DataObjectTypeName
How-to: Utilize CancelSelectOnNullParameters
Walkthrough Topics
How-to Topics

Concepts
Architecture

References
EnablePaging Property


Processing data using ISDataSource.NET

Processing data using ISDataSource.NET
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET

Glossary Item Box

ISDataSource performs data operations through its ISDataSourceTable collection. When working with a data-bound control you need to determine which ISDataSourceTable from ISDataSourceTable collection to be bounded to the data-bound control. You can do this through DataMember property.

To retrieve data from a business object, set the corresponding ISDataSourceTable's SelectMethod property with the name of the method that retrieve the data. If the method does not return an IEnumerable or DataSet object, the object is wrapped by runtime in an IEnumerable collection.

If the method signature has parameters, you can add Parameter objects to the SelectParameters collection and bind them to the values that you want to pass to the method that is specified in ISDataSourceTable's SelectMethod method. The parameter must match the names and the types of the parameters in the method signature in order for ISDataSourceTable to use the parameter.

In This Section

Walkthrough: Binding to Data using ISDataSource

Walkthrough: Binding Generic Collection using ISDataSource.NET

Walkthrough: Modifying Data using ISDataSource

Walkthrough: Binding to multiple controls using ISDataSource.NET

How-to: Use ISDataSource.NET along with DetailsView

How-to: Use ISDataSource.NET along with GridView

How-to: Use ISDataSource.NET along with FormView

How-to: Use ISDataSource.NET along with DataList

How-to: Use ISDataSource.NET along with Repeater

How-to: Use ISDataSource.NET along with ListControls

Process Diagram/Sequence

Parameter Option

Sorting and Filtering Data

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Hierarchical Data Retrieval

References
ISDataSourceTable Class
SelectMethod Property
SelectParameters Property


Walkthrough: Binding to multiple controls using ISDataSource.NET

Walkthrough: Binding to multiple controls using ISDataSource.NET
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Walkthrough: Binding to multiple controls using ISDataSource.NET

Glossary Item Box

This walkthrough shows you how to perform binding to multiple controls using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Configure Data Source.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • DataSet Component in App_Code.
  • Visual Studio 2005 Application.

Step-By-Step Instructions

To bind multiple controls using ISDataSource

  1. Drag ISDataSource control from toolbox to the WebForm.
  2. Configure Data Source for the newly created ISDataSource.
  3. Select DataSet for the SchemaType.
  4. Click Schema Name dropdown and select dsNorthWind from the list.

  5. In the next dialog, click AutoGenerate button which is located at the bottom.

  6. Click Finish.
  7. Drag GridView / DetailsView / FormView or others data-bound controls.
  8. Set the DataSourceID (Choose Data Source) to ISDataSource1.
  9. Set the DataMember (View Name) to Categories.
  10. You are all set. Run the page in browser.

See Also

Tasks
Walkthrough: Binding to data using ISDataSource
Walkthrough: Binding Generic Collection using ISDataSource
Walkthrough: Modifying data using ISDataSource
Walkthrough Topics
How-to Topics

Concepts
Processing data using ISDataSource

References
ISDataSource Class
SchemaName Property
SchemaType Property


How-to: Use ISDataSource.NET along with DetailsView

How-to: Use ISDataSource.NET along with DetailsView
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > How-to: Use ISDataSource.NET along with DetailsView

Glossary Item Box

You can use ISDataSource with DetailView from designer.

This topic will show you how to use ISDataSource along with DetailView using OverwriteChanges as the ConflictDetection.

To use ISDataSource along with DetailView

  1. Binding DataSet to ISDataSource. (Use Customers table).
  2. Set ConflictDetection to OverwriteChanges (ISDataSource property).

  3. Bind ISDataSource to DetailView and activate Enable Paging, Enable Inserting, Enable Editing and Enable Deleting.

  4. Change CustomerID column's ReadOnly property to False.

  5. The result will be like following:

See Also

Tasks
How-to: Use ISDataSource along with GridView
How-to: Use ISDataSource. along with FormView
How-to: Use ISDataSource along with DataList
How-to: Use ISDataSource along with Repeater
How-to: Use ISDataSource along with ListControls
How-to: Use ISDataSource event handlers

Concepts
Processing data using ISDataSource

References
ISDataSource Class
ConflictDetection Property
EnablePaging Property


How-to: Use ISDataSource.NET along with GridView

How-to: Use ISDataSource.NET along with GridView
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > How-to: Use ISDataSource.NET along with GridView

Glossary Item Box

You can use ISDataSource with GridView from designer.

This topic will show you how to use ISDataSource along with GridView using CompareAllValues (Optimistic concurrency) as the ConflictDetection.

To use ISDataSource along with GridView

  1. Create a DataSet. In the advanced options, select Use optimistic concurrency.

  2. Binding DataSet to ISDataSource. (Use Customers table).
  3. Set ConflictDetection to CompareAllValues (ISDataSourceNET property).

  4. Bind ISDataSource to GridView and activate Enable Paging, Enable Editing and Enable Deleting.

  5. Change CustomerID column's ReadOnly property to False.

  6. The result will look like following:

See Also

Tasks
How-to: Use ISDataSource along with DetailView
How-to: Use ISDataSource along with FormView
How-to: Use ISDataSource along with DataList
How-to: Use ISDataSource along with Repeater
How-to: Use ISDataSource along with ListControls
How-to: Use ISDataSource event handlers

Concepts
Processing data using ISDataSource

References
ISDataSource Class
ConflictDetection Property
EnablePaging Property


How-to: Use ISDataSource.NET along with FormView

How-to: Use ISDataSource.NET along with FormView
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > How-to: Use ISDataSource.NET along with FormView

Glossary Item Box

You can use ISDataSource with FormView from designer.

This topic will show you how to use ISDataSource along with FormView using OverwriteChanges as the ConflictDetection.

To use ISDataSource along with FormView

  1. Binding DataSet to ISDataSource. (Use Customers table).
  2. Set ConflictDetection to OverwriteChanges (ISDataSourceNET property).

  3. Bind ISDataSource to FormView and activate Enable Paging.

  4. In the HTML view (.aspx), change CustomerID's tag from <%# Eval("CustomerID") %> to <%# Bind("FieldName") %>.
    e.g. : <asp:TextBox ID="CustomerIDTextBox" runat="server" Text='<%# Bind("CustomerID") %>'>
  5. The result will be like following:

See Also

Tasks
How-to: Use ISDataSource along with DetailView
How-to: Use ISDataSource along with GridView
How-to: Use ISDataSource along with DataList
How-to: Use ISDataSource along with Repeater
How-to: Use ISDataSource along with ListControls
How-to: Use ISDataSource event handlers

Concepts
Processing data using ISDataSource

References
ISDataSource Class
ConflictDetection Property
EnablePaging Property


How-to: Use ISDataSource.NET along with DataList

How-to: Use ISDataSource.NET along with DataList
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > How-to: Use ISDataSource.NET along with DataList

Glossary Item Box

You can use ISDataSource with DataList from designer.

This topic will show you how to use ISDataSource along with DataList.

To use ISDataSource along with DataList

  1. Binding DataSet to ISDataSource. (Use Shippers table).
  2. Bind ISDataSource to FormView and activate Enable Paging.

  3. In the Edit Templates, insert Label and in the HTML view (.aspx) bound the Label with tag <%# Eval("ShipperID") %>.

  4. The result will be like following:

See Also

Tasks
How-to: Use ISDataSource along with DetailView
How-to: Use ISDataSource along with GridView
How-to: Use ISDataSource along with FormView
How-to: Use ISDataSource along with Repeater
How-to: Use ISDataSource along with ListControls
How-to: Use ISDataSource event handlers

Concepts
Processing data using ISDataSource

References
ISDataSource Class
EnablePaging Property


How-to: Use ISDataSource.NET along with Repeater

How-to: Use ISDataSource.NET along with Repeater
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > How-to: Use ISDataSource.NET along with Repeater

Glossary Item Box

You can use ISDataSource with Repeater from designer.

This topic will show you how to use ISDataSource along with Repeater.

To use ISDataSource along with Repeater

  1. Binding DataSet to ISDataSource. (Use Employees table).
  2. Bind ISDataSource to Repeater.

  3. Switch to view source to edit the control's template.
    <ItemTemplate>
   <table class="text">
   <tr>
      <td align="right">
         <b>Employee ID:</b>
      </td>
      <td>
         <asp:Label runat="server" ID="EmployeeID" Text='<%# Eval("EmployeeID") %>'></asp:Label>
      </td>
   </tr>
   <tr>
      <td align="right">
         <b>Last Name:</b>
      </td>
      <td>
         <asp:Label runat="server" ID="LastName" Text='<%# Eval("LastName") %>'></asp:Label>
      </td>
   </tr>
   <tr>
      <td align="right">
         <b>First Name:</b>
      </td>
      <td>
         <asp:Label runat="server" ID="FirstName" Text='<%# Eval("FirstName") %>'></asp:Label>
      </td>
   </tr>
   <tr>
      <td align="right">
         <b>Address:</b>
      </td>
      <td>
         <asp:Label runat="server" ID="Address" Text='<%# Eval("Address") %>'></asp:Label>
      </td>
   </tr>
   <tr>
      <td align="right">
         <b>Home Phone</b></td>
      <td>
         <asp:Label runat="server" ID="HomePhone" Text='<%# Eval("HomePhone") %>'>
         </asp:Label>
      </td>
   </tr>
   </table>
   <br />
</ItemTemplate>
  4. The result will be like following:

See Also

Tasks
How-to: Use ISDataSource along with DetailView
How-to: Use ISDataSource along with GridView
How-to: Use ISDataSource along with FormView
How-to: Use ISDataSource along with DataList
How-to: Use ISDataSource along with ListControls
How-to: Use ISDataSource event handlers

Concepts
Processing data using ISDataSource

References
ISDataSource Class


How-to: Use ISDataSource.NET along with ListControls

How-to: Use ISDataSource.NET along with ListControls
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > How-to: Use ISDataSource.NET along with ListControls

Glossary Item Box

You can use ISDataSource with ListControls.

This topic will show you how to use ISDataSource along with ListBox.

To use ISDataSource along with ListControls

  1. Binding DataSet to ISDataSource. (Use Customers table).
  2. Bind ISDataSource to ListBox.

  3. The result will be like following:

See Also

Tasks
How-to: Use ISDataSource along with DetailView
How-to: Use ISDataSource along with GridView
How-to: Use ISDataSource along with FormView
How-to: Use ISDataSource along with DataList
How-to: Use ISDataSource along with Repeater
How-to: Use ISDataSource event handlers

Concepts
Processing data using ISDataSource.NET

References
ISDataSource Class


Process Diagram/Sequence

Process Diagram/Sequence
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Process Diagram/Sequence

Glossary Item Box

For better understanding about how data-operations is processed take a look at figure below.

When a request is occurred, Data Web Control will provide TableName information along with the request call. ISDataSource control will access respective ISDataSourceTable through TableName property and perform the request.

For example if user requests to retrieve data for Customers data the sequence of processes will be:

DataWebControl -> Select [Customers] -> ISDataSourceControl
ISDataSourceControl -> Select [Customers] -> ISDataSourceTable [Customers]
ISDataSourceTable [Customers] -> GetCustomers -> CustomerTableAdapter / CustomerBLL

And after that processes finished the data is sent back to DataWebControl following the same sequence

CustomerTableAdapter -> GetCustomers -> ISDataSourceTable [Customers]
ISDataSourceTable [Customers] -> Select [Customers] -> ISDataSourceControl
ISDataSourceControl -> Customers Data -> DataWebControl

The same sequence of processes happens when you perform another data operation processes (insert/update/delete).

See Also

Tasks
Walkthrough Topics
How-to Topics

Related Sections
Parameter Option
Sorting and Filtering Data

References
ISDataSource Class
ISDataSourceTable Class


Parameter Option

Parameter Option
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Parameter Option

Glossary Item Box

By default in .NET data-bound controls will pass all textbox fields to DataSource control as InputParameters. In some extend this can be quite troublesome since we need to create a DataOperation method signature (Insert/Update/Delete) that match the InputParameters given.

ISDataSource provides a flag for WebGrid.NET Enterprise 5.0 called ParameterOption. This flag is used to determine whether WebGrid.NET will pass all available fields as InputParameters or merge data from available fields (updated data) and original data retrieved previously as InputParameters.

Consider following scenario:

In Schema Definition we have:
Table: Customers
Fields: CustomerID, ContactName, CompanyName, ContactTitle, Address, City, Country, Region.

By default, when we create a DataSet we will have methods with signature as follows: (OverwriteChanges applied)
Insert(CustomerID, ContactName, CompanyName, ContactTitle, Address, City, Country, Region)
Delete(OriginalCustomerID)
Update(CustomerID, ContactName, CompanyName, ContactTitle, Address, City, Country, Region, OriginalCustomerID)

Now, let say we bound this ISDataSource to GridView but we do not want to bind all the columns, let say only CustomerID, ContactName, CompanyName. At this situation we can't use the auto-generated method from DataSet to update a row since the parameters supplied from GridView will not be the same as in method signature.

Update(CustomerID, ContactName, CompanyName, OriginalCustomerID)
Vs
Update(CustomerID, ContactName, CompanyName, ContactTitle, Address, City, Country, Region, OriginalCustomerID)

This kind of issue can be resolved using ParameterOption = "FromDataSource", this flag will tell WebGrid to merge all the input parameters from given DataSource with the updated fields. Using this approach you can reuse the auto-generated method from DataSet nicely.

If you prefer the default way you can also set the ParameterOption = "FromFields" so WebGrid will only pass available fields as input parameters.

See Also

Tasks
Walkthrough Topics
How-to Topics

Related Sections
Process Diagram/Sequence
Sorting and Filtering Data

References
ParameterOption Property
InputParameters Property


Sorting and Filtering Data

Sorting and Filtering Data
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Sorting and Filtering Data

Glossary Item Box

The ISDataSourceTable can sort and filter data that is retrieved by the SelectMethod property if the data is returned as a DataSet, DataView or DataTable object.

You can set the FilterExpression property to a filtering expression using a format string syntax and bind values in the expression to parameters that are specified in the FilterParameters collection.

Furthermore you can also set the SortExpression property which will act as secondary sorting expression after data-bound control SortExpression if any.

In This Section

How-to: Utilize FilterExpression

How-to: Utilize FilterParameters

How-to: Utilize multiple FilterParameters

How-to: Utilize SortExpression

How-to: Utilize SortParameterName

See Also

Tasks
Walkthrough Topics
How-to Topics

Related Sections
Process Diagram/Sequence
Parameter Option

References
FilterExpression Property
FilterParameters Property
SortExpression Property
SelectMethod Property


How-to: Utilize FilterExpression

How-to: Utilize FilterExpression
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Sorting and Filtering Data > How-to: Utilize FilterExpression

Glossary Item Box

FilterExpression is used to filter the data retrieved when the Select method is called. The method specified in the SelectMethod property must return a DataSet, DataView or DataTable.

This sample demonstrates how to use FilterExpression and SortExpression.

To use ISDataSource along with FilterExpression

  1. Binding DataSet to ISDataSource. (Use Products table).
  2. Add a TextBox and a Server-side button.
  3. Write this function in OnButtonClick Client-side event:
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   ISDataSourceTable table = ISDataSource1.Tables.GetNamedItem("Products");
   table.FilterExpression = TextBox1.Text;
}
  4. The result will be like this.
    ISFilterExpression

See Also

References
FilterExpression Property


How-to: Utilize FilterParameters

How-to: Utilize FilterParameters
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Sorting and Filtering Data > How-to: Utilize FilterParameters

Glossary Item Box

FilterParameters is a collection of parameters that you can use to fill a placeholder in FilterExpression. (e.g : ProductName Like '{0}') .The placeholders are replaced according to the index of the parameter in the FilterParameters collection.

This sample demonstrates how to use FilterParameters (single parameter [ProductName]).

To use FilterParameters in ISDatasource

  1. Binding DataSet to ISDataSource. (Use Products table).
  2. Add FilterParameter like following:

    a
  3. Add a TextBox and a Server-side button.
  4. Right click the ISDataSource and go to the Designer >> Table Customers >> Filter Parameters collection.
  5. Add a parameter to be linked to the textbox.
  7. Write this function in OnButtonClick Client-side event :
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   GridView1.DataBind();
}
  8. The result will be like this.

See Also

References
FilterParameters Property


How-to: Utilize multiple FilterParameters

How-to: Utilize multiple FilterParameters
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Sorting and Filtering Data > How-to: Utilize multiple FilterParameters

Glossary Item Box

FilterParameters is a collection of parameters that you can use to fill a placeholder in FilterExpression. (e.g : Country Like '{0}%' AND City Like '{1}%'). The placeholders are replaced according to the index of the parameter in the FilterParameters collection.

This sample demonstrates how to use FilterParameters (multiple parameters [Country & City])

To use ISDataSource along with Multiple FilterParameters

  1. Binding DataSet to ISDataSource. (Use Customers table).
  2. Open ISDataSource designer and add Country Like '{0}%' AND City Like '{1}%' to FilterExpression property. MultipleParam

  3. Add 2 TextBoxes and a Server-side button.
  4. Right click the ISDataSource and go to the Designer >> Table Customers >> Filter Parameters collection.
  5. Add 2 parameters to be linked to the textboxes. IsDSMultipleParams2

  6. Write this function in OnButtonClick Client-side event :
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   GridView1.DataBind();
}

  7. The result will be like this.

See Also

References
FilterParameters Property
FilterExpression Property


How-to: Utilize SortExpression

How-to: Utilize SortExpression
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Sorting and Filtering Data > How-to: Utilize SortExpression

Glossary Item Box

SortingExpression is used to sort the data retrieved by ISDataSourceControl. The SortExpression in ISDataSource will always act as secondary sorting after the data-bound controls sorting mechanism.

This sample demonstrates how to use SortExpression.

To use ISDataSource along with SortExpression

  1. Binding DataSet to ISDataSource. (Use Customers table).
  2. Add a TextBox and a Server-side button.
  3. Write this function in OnButtonClick Client-side event:
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   ISDataSourceTable table = ISDataSource1.Tables.GetNamedItem("Customers")
   table.SortExpression = TextBox1.Text;
   GridView1.DataBind();
}
  4. The result will be like this.

See Also

Tasks
How-to: Filter data using FilterExpression and FilterParameters
Walkthrough Topics
How-to Topics

Concepts
Sorting and Filtering Data

References
SortExpression Property


How-to: Utilize SortParameterName

How-to: Utilize SortParameterName
See Also Send Feedback
ISDataSource > Features and Concepts > Processing data using ISDataSource.NET > Sorting and Filtering Data > How-to: Utilize SortParameterName

Glossary Item Box

Using SortParameterName will add an additional parameter in your SelectMethod. This additional parameter than will hold the value that you need to perform a manual sorting (e.g from query)

This sample demonstrates how to use SortParameterName

To use ISDataSource along with SortParameterName

  1. Binding DataSet to ISDataSource. (Use Customers table).
  2. Create SortData.cs in App_Code as following :
    C# Copy Code
    namespace SortObject
{
    [System.ComponentModel.DataObject]
    public class SortData
    {
        private OleDbConnection _connection;

        public OleDbConnection Connection
        {
            get
            {
                if (this._connection == null)
                {
                    this._connection = new OleDbConnection();
                    this._connection.ConnectionString = System.Configuration.ConfigurationManager.ConnectionStrings["NorthWindConnectionString"].ConnectionString;
                }
                return this._connection;
            }
        }

        public SortData()
        {
            //
            // TODO: Add constructor logic here
            //
        }

        [System.ComponentModel.DataObjectMethodAttribute(System.ComponentModel.DataObjectMethodType.Select, false)]
        public DataTable GetData(string sortExpression)
        {
            DataTable dt = new DataTable();

            String query = "SELECT * FROM Customers ";

            if (!String.IsNullOrEmpty(sortExpression))
                query += "ORDER BY " + sortExpression;
            OleDbDataAdapter da = new OleDbDataAdapter();
            da.SelectCommand = new OleDbCommand(query, this.Connection);
            da.Fill(dt);

            return dt;
        }
    }
}
  3. Right click the ISDataSource and choose Configure Data Source.
  4. Choose SchemaType to CustomObject, click Next.
  5. Add SortData to TableName, and choose SortObject.SortData.
  6. Choose a method GetData(String sortExpression), click Next and Finish.
    ISParam0
  7. Right click the ISDataSource and choose ISDataSource Designer.
  8. Add sortExpression to SortParameterName property.
  10. The result will be like this.

    Result

See Also

References
SortParameterName Property


Hierarchical Data Retrieval

Hierarchical Data Retrieval
See Also Send Feedback
ISDataSource > Features and Concepts > Hierarchical Data Retrieval

Glossary Item Box

In Hierarchical data retrieval ISDataSource will traverse through all child tables in specified DataSourceSchema property. Starting from the given RootTable, ISDataSource will go to each child tables and perform the data retrieval on each child tables. In the end ISDataSource will generate a DataSet that holds all the data and the hierarchical relationship.

The DataSourceSchema is only used to determine which table in the hierarchical schema to be populated. The process to populate each table is the same as Flat Data Retrieval. You need to provide SelectMethod for each ISDataSourceTable that represent the child tables.

You can also bind to a Hierarchical Custom Objects by providing a custom schema definition. You can create the custom schema definition by implementing IHierarchical and IObjectRelations interfaces.

In This Section

Walkthrough: Binding to Hierarchical data using ISDataSource.NET

Walkthrough: Binding to Hierarchical CustomObject using ISDataSource.NET

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Load on Demand Data Retrieval

References
LoadOnDemand Property
IHierarchicalList Interface
IObjectRelations Interface


Walkthrough: Binding to Hierarchical CustomObject using ISDataSource.NET

Walkthrough: Binding to Hierarchical CustomObject using ISDataSource.NET
See Also Send Feedback
ISDataSource > Features and Concepts > Hierarchical Data Retrieval > Walkthrough: Binding to Hierarchical CustomObject using ISDataSource.NET

Glossary Item Box

This walkthrough shows you how to perform binding to hierarchical CustomObject using ISDataSource.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource.
  • Configure Data Source.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To bind hierarchical CustomObject using ISDataSource

  1. Drag ISDataSource control from toolbox to the designer surface.
  2. Configure Data Source for the newly created ISDataSource.
  3. Select CustomObject for the SchemaType.
  4. Click Schema Name dropdown and select CustomObject.CustomerCollection from the list.

  5. In the next dialog, click AutoGenerate button which is located at the most bottom.

  6. Click Finish.
  7. Drag WebGrid control from toolbox to the designer surface.
  8. Set the DataSourceID to ISDataSource1.

  9. In the Connected to DataSource dialog, select Retrieve Hierarchical Structure and click OK.

  10. You are all set. Run the page in browser.

See Also

Tasks
Walkthrough: Binding to Hierarchical data using ISDataSource
Walkthrough Topics
How-to Topics

Concepts
Hierarchical Data Retrieval

References
ISDataSource Class
SchemaName Property
SchemaType Property


Load on Demand Data Retrieval

Load on Demand Data Retrieval
See Also Send Feedback
ISDataSource > Features and Concepts > Load on Demand Data Retrieval

Glossary Item Box

One of important key features in WebGrid is the ability to load data on demand. ISDataSource is also designed to support all load on demand scenarios in WebGrid and also in WebCombo.

There are three types of load on demand in general:

  1. Virtual Page load on demand (Custom VirtualLoad)
  2. Hierarchical load on demand
  3. Self-Reference load on demand

In This Section

Walkthrough: Loading child rows on demand based on the selected parent row

Walkthrough: Creating Self Reference LoadOnDemand WebGrid

How-to: Implement custom Virtual Load

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Hierarchical Data Retrieval

References
LoadOnDemand Property


Walkthrough: Loading child rows on demand based on the selected parent row

Walkthrough: Loading child rows on demand based on the selected parent row
See Also Send Feedback
ISDataSource > Features and Concepts > Load on Demand Data Retrieval > Walkthrough: Loading child rows on demand based on the selected parent row

Glossary Item Box

This walkthrough shows you how to implement LoadOnDemand in Hierarchical table.

During this walkthrough, you will learn how to do the following:

  • Use ISDataSource control.
  • Use WebGrid and ISDataSource SmartTag.
  • Implement LoadOnDemand.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and set LoadOnDemand using ISDataSource properties

  1. Bind WebGrid to ISDataSource.
  2. Add Query by double click on dsNorthWind.xsd in App_Code then right click on the Orders.
  3. In TableAdapter Query Configuration Wizard, choose Use SQL Statements, click Next.
  4. Then choose Select which returns rows, click Next.
  5. Specify this query "SELECT CustomerID, EmployeeID, Freight, OrderDate, OrderID, RequiredDate, ShipAddress, ShipCity, ShipCountry, ShipName, ShipPostalCode, ShipRegion, ShipVia, ShippedDate FROM Orders WHERE (CustomerID = ?)" then click Next.

  6. Set Fill a DataTable method name to FillBy and Return a DataTable method name to GetDataBy.

  7. Click Next - Finish.

  8. Set ISDataSource properties.

    Property | Value
    LoadOnDemand | True
    EnableCaching | Yes

  9. Open ISDataSource Designer

    Property | Value
    SelectChildRowMethod | GetDataBy

See Also

Tasks
Creating Self Reference LoadOnDemand WebGrid
How-to: Implement custom Virtual Load

Concepts
Load on Demand Data Retrieval


Creating Self Reference LoadOnDemand WebGrid

Creating Self Reference LoadOnDemand WebGrid
See Also Send Feedback
ISDataSource > Features and Concepts > Load on Demand Data Retrieval > Creating Self Reference LoadOnDemand WebGrid

Glossary Item Box

This walkthrough shows you how to create Self Reference LoadOnDemand in WebGrid.

During this walkthrough, you will learn how to do the following:

  • Setting a Self Reference Load On Demand in a WebGrid.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and specify Self Reference LoadOnDemand in WebGrid.

  1. Open WebGrid Designer >> Advanced, click See All Properties.
  2. Select RootTable.
  3. Expand SelfReferenceSettings.
  4. Set ParentDataMember to EmployeeID.
  5. Set ChildDataMember to ReportsTo.
  6. Set ExpandColumnMember to FirstName.
  7. Set Enabled to True.

    SelfRefDes

  8. Drag ISDataSource control from toolbox to the designer surface.
  9. Configure Data Source for the newly created ISDataSource.
  10. Select DataSet for the SchemaType.
  11. Click Schema Name dropdown and select dsNorthWind from the list.
  12. In the next dialog, click Add button then select Employees in the dropdown menu.
  13. In the Select Method dropdown list, select GetDataBy(Nullable<Int32> ReportsTo) method.
  14. Click Finish.

    ISDSSelfRef1

  15. Open ISDataSource Designer.
  16. Click on Employees table.
  17. Set SelectSelfReferenceRowMethod to GetDataBy.

    ISDSSElfRef2

  18. Drag WebGrid control from toolbox to the designer surface.
  19. Set the DataSourceID to ISDataSource1.

    a

  20. In the Connect to DataSource dialog, select Retrieve Structure, choose "Employees" table then click OK.
  21. Open WebGrid.NET Designer >> Advanced and click See all properties.
  22. Expand SelfReferencingSettings, set Enabled to True, set ExpandColumnMember to FirstName, set ChildDataMember to ReportsTo and ParentDataMember to EmployeeID.
  23. In SelfReferencingSettings, remember to set LoadOnDemand to True.

    SelfRefLOD

See Also

Tasks
Walkthrough: Loading child rows on demand based on the selected parent row
How-to: Implement custom Virtual Load

Concepts
Load on Demand Data Retrieval


How-to: Implement custom Virtual Load

How-to: Implement custom Virtual Load
See Also Send Feedback
ISDataSource > Features and Concepts > Load on Demand Data Retrieval > How-to: Implement custom Virtual Load

Glossary Item Box

Custom VirtualLoad is one of VirtualLoad features which allow developer to setup a grid with their own implementation and logic for fetching the data. Note that sorting, editing and all other data-aware functionalities can work in this mode, except Grouping since that Grouping requires all rows to be loaded.

In this topic, you will learn how to implement the custom virtual load in WebGrid.

To Implement custom Virtual Load in WebGrid

  1. Set the PagingMode to VirtualLoad.
  2. Set the VirtualLoadMode to Custom.
  3. Drag ISDataSource control from toolbox to the designer surface.
  4. Configure Data Source for the newly created ISDataSource.
  5. Select DataSet for the SchemaType.
  6. Click Schema Name dropdown and select dsNorthWind from the list.
  7. In the next dialog, click AutoGenerate button which is located at the most bottom. Click Finish.
  8. Drag WebGrid control from toolbox to the designer surface.
  9. Set the DataSourceID to ISDataSource1.
  10. In the Connect to DataSource dialog, select Orders table as root table and select Retrieve Structure, then click OK.
  11. Right click on ISDataSource1 and launch the designer, set the Orders table's SelectCount property to GetCount.
  12. For the WebGrid, set the PagingMode to VirtualLoad and VirtualLoadMode to Custom.
  13. Write codes that handle virtual load and the total row count in App_Code. For reference, see the codes in App_Code\dsNorthwind_Extended.cs.
  14. Run the page in browser.

See Also

Tasks
Walkthrough: Loading child rows on demand based on the selected parent row
How-to: Implement custom Virtual Load

Concepts
Load on Demand Data Retrieval


Caching Architecture

Caching Architecture
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture

Glossary Item Box

ISDataSource also support data caching. While data is cached, call to any ISDataSourceTables' Select method will retrieve the data from the cache rather than from business object that associated with it.

ISDataSource provides a more flexible caching configuration. The following are the list of settings that you can configure:

  • CacheStorage
  • CacheScope
  • CachePriority
  • StoreCachePerPage
  • CacheKeyDependency
  • CacheDuration & CacheExpirationPolicy

In This Section

How-to: Configure cache configuration

Cache Storage

Cache Scope

Store Cache per Page

Cache Key Dependency

Cache Key Pattern

Use cached on first load

See Also

Tasks
Walkthrough Topics
How-to Topics

References
CacheStorage Property
CacheScope Property
CachePriority Property
StoreCachePerPage Property
CacheKeyDependency Property
CacheDuration Property
CacheExpirationPolicy Property


How-to: Configure cache configuration

How-to: Configure cache configuration
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > How-to: Configure cache configuration

Glossary Item Box

ISDataSource also have abilities to configure its cache configuration by using Cache Storage, Cache Storage, Cache Scope, Cache Key Dependency, Store Cache per Page, Cache on First Load.

In this topic, you will learn how to configure cache configuration.

To configure cache configuration using CachedData on FirstLoad

  1. Click ISDataSource instance and press F4.
  2. Set EnableCaching to Yes.
  3. Set UseCachedDataOnFirstLoad to No (default value is Yes).

  5. Run the Project.

To configure cache configuration using CachedDuration

  1. Click ISDataSource instance and press F4.
  2. Set EnableCaching to Yes.
  3. Set CacheDuration to 5 (seconds).

    CacheDuration
  4. Run the Project.

To configure cache configuration using CacheKeyDependency

  1. Click ISDataSource instance and press F4.
  2. Set EnableCaching to Yes.
  3. Set CacheKeyDependency to key1.

  5. Run the Project.

To configure cache configuration using FileServerStorage

  1. Click ISDataSource instance and press F4.
  2. Set EnableCaching to Yes.
  3. Set CacheStorage to FileServer.
  4. Set CacheServerConnection to "path=C:\Cache".

  6. Run the Project.

To configure cache configuration using Global Cache Scope

  1. Click ISDataSource instance and press F4.
  2. Set EnableCaching to Yes.
  3. Set CacheScope to Global.

  5. Run the Project.

To configure cache configuration using PerPage Cache Scope

  1. Click ISDataSource instance and press F4.
  2. Set EnableCaching to Yes.
  3. Set StoreCachePerPage to Yes.

  5. Run the Project.

To configure cache configuration using PerUser Cache Scope

  1. Click ISDataSource instance and press F4.
  2. Set EnableCaching to Yes.
  3. Set CacheScope to PerUser.

  5. Run the Project.

See Also

Concepts
Caching Architecture


Cache storage

Cache storage
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Cache storage

Glossary Item Box

ISDataSource provides three media (PageCache, Session and FileServer) to store the Cache Data, each of them have their own unique characteristic that you might want to explore first before deciding which media you will use.

Page Cache

Page Cache stores the Cache Data in the server's memory. The cache is regulated by a combination of the CacheDuration, CacheExpirationPolicy and CachePriority setting.

The CacheDuration indicates the number of seconds that the cache storing data before the cache entry is discarded. On the other hand, the CacheExpirationPolicy describes the behavior of the cache in order to release the memory. If the CacheExpirationPolicy is set to Absolute, the cache data will be hold in memory for - at most - the amount of time that is specified by the CacheDuration. The data might be released before the duration time if the memory is needed. If the CacheExpirationPolicy is set to Sliding, the cache expires when there is no activity for a time that is equal to the CacheDuration.

One more important setting for PageCache setting is CachePriority. When the Web server hosting an ASP.NET application runs low on memory, the PageCache object selectively purges items to free system memory. When an item is added to PageCache, you can assign relative priority / CachePriority compared to other items stored in the cache. Items to which you assign higher priority values are less likely to be deleted from the cache when the server is processing a large number of requests, whereas items to which you assign lower priority values are more likely to be deleted.

Session

Session stores the Cache Data in Session Object. The cache is expired when session is timed out or Session.Abandon() method is called. In order to extend the cache time, simply increase the Session's timeout value. Session is best used for scenarios when data is scoped based per user/session and when on-demand data retrieval implementation is required.

You can also implement SqlServer mode to store the Session's data for larger applications that work in WebFarm or clustering.

File Server

File Server stores the Cache Data in a server (physical hard-disk). Using the unique-patterned key generated by ISDataSource, the data will be paired and stored in an actual server/machine. You can configure how the cached data is removed from Fileserver through ISDataSource or you can perform it manually from the Fileserver itself.

Some benefits of using Fileserver cache are:

    • Highly scalable. You can choose a network drive to store the caches which enable multiple web servers to access the state.
    • Decent performance. With more than dozen of high performances hard drives, you can choose a near-memory speed with high random access and sequential read-write hard drive to store the caches.
    • Easily extensible. Unlike memory (RAM), you can easily extend a hard drive's capacity with larger one when it becomes insufficient.

Features of Fileserver:

    • Automatic cleaning. When the cache for the viewstate has expired, the cache will be automatically deleted.
    • Easily configurable for application-wide through web.config.
    • Allow customization on cache policy and expiration duration.

To save the cached data to FileServer you need to specify the CacheServerConnection. Following is a list of parameters that can be used in CacheServerConnection:

    • path. Specify the path of file server storage
    • expireduration. Specify the time in minutes how long should a cache stay in the storage.
    • expirationpolicy. Specify the expiration policy of the cache. The valid values are Sliding, Absolute.

Each parameter should be separated using ; (semicolon) character.

In This Section

How-to: Use file server for an instance of control

How-to: Configure file server to use shared network drive

See Also

Tasks
Walkthrough Topics
How-to Topics

Related Sections
Cache Scope
Store Cache per Page
Cache Key Dependency
Cache Key Pattern
Use cached on first load

References
CacheStorage Property
CacheDuration Property
CacheExpirationPolicy Property
CachePriority Property


How-to: Use file server for an instance of control

How-to: Use file server for an instance of control
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Cache storage > How-to: Use file server for an instance of control

Glossary Item Box

The following steps demonstrate how to use file server to store the viewstate of WebCombo control:

  1. Set ViewStateStorage to FileServer.
  2. Set ViewStateServerConnection to “path=c:\CacheStorage”.

The specified path (eg. c:\CacheStorage) requires read and write permission for aspnet_wp worker process (in IIS 5.x) or iis_wpg (in IIS 6+)

See Also

Tasks
How-to: Configure file server to use shared network drive

Concepts
Cache storage


How-to: Configure file server to use shared network drive

How-to: Configure file server to use shared network drive
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Cache storage > How-to: Configure file server to use shared network drive

Glossary Item Box

The following steps demonstrate how to use a shared network drive for the file server:

  1. Set ViewStateStorage to FileServer
  2. Set ViewStateServerConnection to “path=\\CacheServer\CacheStorage”
  3. Configure the identity of the account that has an access to the server and network resources in web.config.

Sample web.config setting for identity:

<system.web>

<identity impersonate=”true” userName=”CacheServer\CacheAccount” password=”CachePassword” />

</system.web>

Parameters for ViewStateServerConnection

The following lists the parameters that can be used in ViewStateServerConnection:

  • path
    Specify the path of the file server storage.

  • expireduration
    Specify the time in minutes how long should a cache stay in the storage.

  • expirationpolicy
    Specify the expiration policy of the cache. The valid values are Sliding, Absolute.

Each parameter should be separated by using ; character.

See Also

Tasks
How-to: Use file server for an instance of control

Concepts
Cache storage


Cache Scope

Cache Scope
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Cache Scope

Glossary Item Box

Another cache configuration setting that available from ISDataSource is CacheScope. You can define the scope of the cache, whether it is available to global user or specific user (session).

Global

Global cache data allows all users that access the application share the same data. It is usually used for common data that rarely updated and used by all users.

Per User

Per User cache data will create a new instance for each user that accessing the application. The data is exclusive to each user.

See Also

Related Sections
Cache storage
Store Cache per Page
Cache Key Dependency
Cache Key Pattern
Use cached on first load

References
CacheScope Property


Store Cache per Page

Store Cache per Page
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Store Cache per Page

Glossary Item Box

StoreCachePerPage is another additional setting that available from ISDataSource. This feature allows you to decide whether to distinguish the data between pages.

See Also

Related Sections
Cache storage
Cache Scope
Cache Key Dependency
Cache Key Pattern
Use cached on first load

References
StoreCachePerPage Property


Cache Key Dependency

Cache Key Dependency
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Cache Key Dependency

Glossary Item Box

Last but not least is CacheKeyDependency, this settings is treated as a key wild card to identifies the cache if needed.

See Also

Related Sections
Cache storage
Cache Scope
Store Cache per Page
Cache Key Pattern
Use cached on first load

References
CacheKeyDependency Property


Cache Key Pattern

Cache Key Pattern
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Cache Key Pattern

Glossary Item Box

A unique cache entry is created using combination of all these configurations.

Follows are the Cache Key Pattern:
{SessionID} : {PageName} : KeyDependency : ViewName : Duration : ExpirationPolicy : TypeName : SelectMethod+ Params ++ : startRowIndex : maximumRows

The field under {} is optional.
If the CacheScope is set to Global, the key will not have {SessionID}
If the StoreCachePerPage is set to No, the key will not have {PageName}
The other information is essential to create the Cache Key to differentiate the Cache Data.

From the pattern above you can see that multiple ISDataSourceTable that share the same characteristic can share the same cached data. Therefore carefully planning the cache configuration brings a better approach to optimize the performance your application.

See Also

Related Sections
Cache storage
Cache Scope
Store Cache per Page
Cache Key Dependency
Use cached on first load

References
CacheScope Property
CacheStorage Property


Use cached on first load

Use cached on first load
See Also Send Feedback
ISDataSource > Features and Concepts > Caching Architecture > Use cached on first load

Glossary Item Box

Besides the configuration that used to determine the unique cache key above, one more vital settings that ISDataSource.NET cache architecture provide is the ability to determine whether ISDataSource.NET will use the cache data on first load or always look for actual data from database.

See Also

Related Sections
Cache storage
Cache Scope
Store Cache per Page
Cache Key Dependency
Cache Key Pattern

References
UseCachedDataOnFirstLoad Property


Event Handlers

Event Handlers
See Also Send Feedback
ISDataSource > Features and Concepts > Event Handlers

Glossary Item Box

ISDataSource.rovides the same Event Handlers as in .NET ObjectDataSource. Those event handlers are:

  • Deleted
  • Deleting
  • Filtering
  • Inserted
  • Inserting
  • Selected
  • Selecting
  • Updated
  • Updating

Any data operation from any ISDataSourceTable will call the same associated event handlers. In order to distinguish which ISDataSourceTable is actually performing the data operation, each of event arguments have is added with a property called ViewName.

In This Section

How-to: Use ISDataSource.NET event handlers

See Also

Tasks
Walkthrough Topics
How-to Topics

References
Deleted Event
Deleting Event
Filtering Event
Inserted Event
Inserting Event
Selected Event
Selecting Event
Updated Event
Updating Event


How-to: Use ISDataSource.NET event handlers

How-to: Use ISDataSource.NET event handlers
See Also Send Feedback
ISDataSource > Features and Concepts > Event Handlers > How-to: Use ISDataSource.NET event handlers

Glossary Item Box

ISDataSource also have event handlers that you can use.

In this topic, you will learn how to use ISDataSource event handlers.

To use ISDataSource event handlers

  1. Click ISDataSource instance and press F4.
  2. Add ISDataSource1_Selecting to Selecting event.
  3. Add the following code to ISDataSource1_Selecting event handlers:

    C# Copy Image Copy Code
    protected void ISDataSource1_Selecting(object sender, ISNet.WebUI.DataSource.ISDataSourceSelectingEventArgs e)
{
  ISDataSource1.Tables.GetNamedItem("Categories").SortExpression = "CategoryName DESC";
}

  4. Run the Project.

See Also

Tasks
Walkthrough Topics
How-to Topics

References
ISDataSource Class
Selecting Event


Learning More

Learning More
See Also Send Feedback
ISDataSource > Learning More

Glossary Item Box

The topics in this section provide essential information on getting familiar with ISDataSource Designer and Typed DataSet.

In This Section

Working with designer
Learn how to work with ISDataSource Wizard designer.

Working with Typed DataSet
Learn how to bind ISDataSource to data-bound controls using Typed DataSet.

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Features and Concepts


Working with designer

Working with designer
See Also Send Feedback
ISDataSource > Learning More > Working with designer

Glossary Item Box

ISDataSource package also comes with a wizard designer. The designer is adapted from ObjectDataSource wizard designer with some additional features and implementation that supports the overall architecture.

In This Section

Automatic table generation

Step by step wizard

Automatic conflict detection behavior

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Working with Typed DataSet


Automatic table generation

Automatic table generation
See Also Send Feedback
ISDataSource > Learning More > Working with designer > Automatic table generation

Glossary Item Box

One of the valuable features in ISDataSource architecture is the ability to generate / predefined all tables' definition based on the given schema (DataSet schema). Thus with only three clicks you can have a structured data source completes with all the table definition on how to process the data.

See Also

Related Sections
Step by step wizard
Automatic conflict detection behavior


Step by step wizard

Step by step wizard
See Also Send Feedback
ISDataSource > Learning More > Working with designer > Step by step wizard

Glossary Item Box

ISDataSource designer is divided into three sections:

  • Schema definition
  • Method / Table definition
  • Parameter definition

Schema definition

This section is designed to help you decide which schema will be used. When you choose the SchemaType to DataSet, all predefined Typed DataSet will be listed in the SchemaName. You can observe what tables are listed in the Schema from the Table List below it.

Method/Table definition

This section is designed to define all your table definition. You can add / delete / modify any table using this designer. If you specify a schema in Schema definition section, you can use the Generate button to automatically generate all table definitions exist in the Schema. Ultimately you need to specify the Select Method for each Table that belongs to the ISDataSource.

Parameter Definition

This section is used to define how the SelectMethod's parameter retrieves the value.

See Also

Related Sections
Automatic table generation
Automatic conflict detection behavior


Automatic conflict detection behavior

Automatic conflict detection behavior
See Also Send Feedback
ISDataSource > Learning More > Working with designer > Automatic conflict detection behavior

Glossary Item Box

When you finished configuring ISDataSource through Step by Step Wizard above, the wizard will perform one last intelligent checking to determine the conflict detection behavior.

If your ISDataSource table configuration used a table-schema definition that perform optimistic concurrency, the wizard will directly change the ISDataSourceTable's conflict detection property to CompareAllValues, or else it will use the default OverwriteChanges.

See Also

Related Sections
Automatic table generation
Step by step wizard

References
ConflictDetection Property


Working with Typed DataSet

Working with Typed DataSet
See Also Send Feedback
ISDataSource > Learning More > Working with Typed DataSet

Glossary Item Box

This section will demonstrate how to bind ISDataSource to data-bound controls using Typed-DataSet.

First of all you need to create the Typed-DataSet first using Visual Studio 2005 DataSet designer. These are the following steps:

  1. Add New Item and select DataSet templates.
  2. Specify your connection string, and create your DataSet structures in the given designer and configure how the data-operation is executed.

After you have a TypeDataSet ready, you may continue creating an ISDataSource and configure it to work in our data-bound controls.

  1. Drag and drop ISDataSource component from Visual Studio 2005 toolbox.
  2. Right-click the component and select configure data source.
  3. A wizard-designer will be opened.
  4. In Choose Schema Definition panel.
    Let the SchemaType value as default (DataSet), and select the SchemaName from the dropdown. Upon SchemaName selection you will see the list of tables that belong to that DataSet / Schema.
  5. Click Next.
  6. In Define DataMethods panel.
    Click the generate table to automatically populates all the table definitions from the given schema you specified before.
    (Note: you can also manually add/remove/manage the table definition using the same way as ObjectDataSource process)
  7. Click Finish.

Now you have an ISDataSource object, you can start binding it to data-bound controls.

  1. Drag one of data-bound controls from ToolBox. (e.g. GridView).
  2. Specify its DataSourceID property.
  3. By default it will take the first table in ISDataSource to auto-generate the GridView structure. You can change this by specifying its DataMember property.
Up until this point you have managed to bind a data-bound control with minimal code especially in UI layer.

See Also

Tasks
Walkthrough Topics
How-to Topics

Other Resources
Working with designer

References
SchemaName Property
SchemaType Property


Server-side References

Server-side References
Send Feedback
ISDataSource > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in ISDataSource.


ISNet.WebUI.DataSource Namespace

ISNet.WebUI.DataSource Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | AutoIncrementAttribute | Use this attribute to mark a property in custom object as auto increment field.
Class | CaptionAttribute | Use this attribute to set property caption's value
Class | ISDataSource | Represents a business object that provides data (flat/hierarchical) to data-bound controls in multi-tier Web application architectures. Represents a business object that provides data (flat/hierarchical) to data-bound controls in multi-tier Web application architectures.
Class | ISDataSourceCancelEventArgsBase | Provides data for other arguments that inherited from ISDataSourceCancelEventArgsBase
Class | ISDataSourceDisposingEventArgs | Provides data for the ObjectDisposing event of the ISDataSource control.
Class | ISDataSourceEventArgs | Provides data for the ObjectCreating and ObjectCreated events of the ISDataSource control.
Class | ISDataSourceEventArgsBase | Provides data for other arguments that inherited from ISDataSourceEventArgsBase
Class | ISDataSourceFilteringEventArgs | Provides data for the Filtering event of the ISDataSource control.
Class | ISDataSourceMethodEventArgs | Provides data for the Inserting, Updating, and Deleting events of the ISDataSource control.
Class | ISDataSourceObjectRelation | Represent a CustomObject relation.
Class | ISDataSourceSelectingEventArgs | Provides data for the Selecting event of the ISDataSource control.
Class | ISDataSourceStatusEventArgs | Provides data for the Selected, Inserted, Updated, and Deleted events of the ISDataSource control.
Class | ISDataSourceTable | Represents a business object that provides data to data-bound controls.
Class | ISDataSourceTableCollection | This class is intended for internal use Represents the collection of ISDataSourceTable, that is in a ISDataSource control.
Class | ISDataSourceTableSchema |
Class | ISDataSourceView | Supports the ISDataSource control and provides an interface for data-bound controls to perform data operations with business and data objects.
Class | NonRetrievableAttribute | Use this attribute to mark a property in custom object as non retrievable. When a property has this attribute, the property will not be populated during databinding.
Class | PrimaryKeyAttribute | Use this attribute to mark a property in custom object as Primary Key. This attribute is required for Hierarchical custom objects databinding.

Interfaces

 | Interface | Description
Interface | IHierarchicalList | IHierarchicalList interface, required to support hierarchical objects binding in WebGrid.NET Enterprise V5.0.++
Interface | IObjectRelations | IObjectRelations interface, required to support hierarchical objects binding in WebGrid.NET Enterprise V5.0.++

Delegates

 | Delegate | Description
Delegate | ISDataSourceDisposingEventHandler | Represents the method that will handle the ObjectDisposing event of the ISDataSource control.
Delegate | ISDataSourceFilteringEventHandler | Represents the method that will handle the Filtering event of the ISDataSource control.
Delegate | ISDataSourceMethodEventHandler | Represents the method that will handle the Selecting, Updating, Inserting, or Deleting event of the ISDataSource control.
Delegate | ISDataSourceObjectEventHandler | Represents the method that will handle the ObjectCreating and ObjectCreated events of the ISDataSource control.
Delegate | ISDataSourceSelectingEventHandler | Represents the method that will handle the Selecting event of the ISDataSource control.
Delegate | ISDataSourceStatusEventHandler | Represents the method that will handle the Selected, Updated, Inserted, and Deleted events of the ISDataSource control.

Enumerations

 | Enumeration | Description
Enumeration | CacheEnabled | Determines whether ISDataSource enables data caching or not
Enumeration | CacheExpirationPolicy | Describes the way data cached using ASP.NET caching mechanisms expires when a time-out is set.
Enumeration | CachePriority | Specifies the relative priority of items stored in the Cache object.
Enumeration | CacheScope | Determines the scope of cache when ISDataSource control cached the data
Enumeration | CacheStorage | Determines where ISDataSource control store the cached data
Enumeration | CancelSelectOnNullParameter |
Enumeration | NullToDBNull | Determines whether ISDatasource will convert null value to DBNull
Enumeration | SchemaType | Determines the type of Schema specified to ISDataSource
Enumeration | StoreCachePerPage | Determines whether the ISDataSource caching store cache data per page
Enumeration | UseCachedDataOnFirstLoad | Determines whether the ISDataSource use cached data on first load or not

See Also

Reference

ISNet.WebUI.ISDataSource Assembly


AutoIncrementAttribute Class

[image]
ISDataSource Documentation
AutoIncrementAttribute Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : AutoIncrementAttribute Class

Use this attribute to mark a property in custom object as auto increment field.

Object Model

AutoIncrementAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=True,
   Inherited=True)>
Public Class AutoIncrementAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
C#
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public class AutoIncrementAttribute : System.Attribute
Delphi
public class AutoIncrementAttribute = class(System.Attribute)
JScript
AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=,
   Inherited=)
public class AutoIncrementAttribute extends System.Attribute
Managed Extensions for C++
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public __gc class AutoIncrementAttribute : public System.Attribute
C++/CLI
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public ref class AutoIncrementAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.DataSource.AutoIncrementAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AutoIncrementAttribute Members
ISNet.WebUI.DataSource Namespace


AutoIncrementAttribute Class Members

[image]
ISDataSource Documentation
AutoIncrementAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.DataSource Namespace : AutoIncrementAttribute Class

The following tables list the members exposed by AutoIncrementAttribute.

Public Constructors

 | Name | Description
public Constructor | AutoIncrementAttribute Constructor |
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

AutoIncrementAttribute Class
ISNet.WebUI.DataSource Namespace


AutoIncrementAttribute Constructor

[image]
ISDataSource Documentation
AutoIncrementAttribute Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > AutoIncrementAttribute Class : AutoIncrementAttribute Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New AutoIncrementAttribute()
C#
public AutoIncrementAttribute()
Delphi
public AutoIncrementAttribute();
JScript
public function AutoIncrementAttribute();
Managed Extensions for C++
public: AutoIncrementAttribute();
C++/CLI
public:
AutoIncrementAttribute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


CaptionAttribute Class

[image]
ISDataSource Documentation
CaptionAttribute Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CaptionAttribute Class

Use this attribute to set property caption's value

Object Model

CaptionAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=True,
   Inherited=True)>
Public Class CaptionAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
C#
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public class CaptionAttribute : System.Attribute
Delphi
public class CaptionAttribute = class(System.Attribute)
JScript
AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=,
   Inherited=)
public class CaptionAttribute extends System.Attribute
Managed Extensions for C++
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public __gc class CaptionAttribute : public System.Attribute
C++/CLI
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public ref class CaptionAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.DataSource.CaptionAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CaptionAttribute Members
ISNet.WebUI.DataSource Namespace


CaptionAttribute Class Members

[image]
ISDataSource Documentation
CaptionAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.DataSource Namespace : CaptionAttribute Class

The following tables list the members exposed by CaptionAttribute.

Public Constructors

 | Name | Description
public Constructor | CaptionAttribute Constructor |
Top

Public Properties

 | Name | Description
public Property | Caption |
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

CaptionAttribute Class
ISNet.WebUI.DataSource Namespace


CaptionAttribute Constructor

[image]
ISDataSource Documentation
CaptionAttribute Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > CaptionAttribute Class : CaptionAttribute Constructor

caption

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal caption As String _
)
Visual Basic (Usage) Copy Code
Dim caption As String

Dim instance As New CaptionAttribute(caption)
C#
public CaptionAttribute(
   string caption
)
Delphi
public CaptionAttribute(
    caption: String
);
JScript
public function CaptionAttribute(
   caption : String
);
Managed Extensions for C++
public: CaptionAttribute(
   string* caption
)
C++/CLI
public:
CaptionAttribute(
   String^ caption
)

Parameters

caption

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


CaptionAttribute Class Properties

[image]
ISDataSource Documentation
CaptionAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CaptionAttribute Class

For a list of all members of this type, see CaptionAttribute members.

Public Properties

 | Name | Description
public Property | Caption |
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

CaptionAttribute Class
ISNet.WebUI.DataSource Namespace


Caption Property

[image]
ISDataSource Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > CaptionAttribute Class : Caption Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Caption As String
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim value As String

value = instance.Caption
C#
public string Caption {get;}
Delphi
public read-only property Caption: String;
JScript
public function get Caption : String
Managed Extensions for C++
public: __property string* get_Caption();
C++/CLI
public:
property String^ Caption {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


ISDataSource Class

[image]
ISDataSource Documentation
ISDataSource Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSource Class

Represents a business object that provides data (flat/hierarchical) to data-bound controls in multi-tier Web application architectures. Represents a business object that provides data (flat/hierarchical) to data-bound controls in multi-tier Web application architectures.

Object Model

ISDataSource Class

Syntax

Visual Basic (Declaration)
<ParseChildrenAttribute(True)>
<DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.DataSource.Design.ISDataSourceDesigner, ISNet.WebUI.Design.ISDataSourceDesigner, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")>
<PersistChildrenAttribute(Persist=False, UsesCustomPersistence=False)>
<ToolboxBitmapAttribute()>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class ISDataSource
   Inherits System.Web.UI.DataSourceControl
   Implements ISNet.ICopyable, ISNet.WebUI.IDataSourceControlOperation
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
C#
[ParseChildrenAttribute(true)]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.DataSource.Design.ISDataSourceDesigner, ISNet.WebUI.Design.ISDataSourceDesigner, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[ToolboxBitmapAttribute()]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class ISDataSource : System.Web.UI.DataSourceControl, ISNet.ICopyable, ISNet.WebUI.IDataSourceControlOperation
Delphi
public class ISDataSource = class(System.Web.UI.DataSourceControl, ISNet.ICopyable, ISNet.WebUI.IDataSourceControlOperation)
JScript
ParseChildrenAttribute()
DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.DataSource.Design.ISDataSourceDesigner, ISNet.WebUI.Design.ISDataSourceDesigner, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")
PersistChildrenAttribute(Persist=, UsesCustomPersistence=)
ToolboxBitmapAttribute()
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class ISDataSource extends System.Web.UI.DataSourceControl implements ISNet.ICopyable, ISNet.WebUI.IDataSourceControlOperation
Managed Extensions for C++
[ParseChildrenAttribute(true)]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.DataSource.Design.ISDataSourceDesigner, ISNet.WebUI.Design.ISDataSourceDesigner, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[ToolboxBitmapAttribute()]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class ISDataSource : public System.Web.UI.DataSourceControl, ISNet.ICopyable, ISNet.WebUI.IDataSourceControlOperation
C++/CLI
[ParseChildrenAttribute(true)]
[DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.DataSource.Design.ISDataSourceDesigner, ISNet.WebUI.Design.ISDataSourceDesigner, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
[PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[ToolboxBitmapAttribute()]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class ISDataSource : public System.Web.UI.DataSourceControl, ISNet.ICopyable, ISNet.WebUI.IDataSourceControlOperation

Remarks

The ISDataSource.NET is an ASP.NET data source control that represents a data-aware middle-tier object or a data-interface object to data-bound controls. You can use the ISDataSource control in conjuction with data-bound control to display, edit, and sort data on a Web page with little or no code.

ISDataSource.NET is designed to support both hierarchical data retrieval and flat data retrieval. The SchemaName and SchemaType property identifies the hierarchical structure of the datasource along with the definition of ISDataSourceTables. The role of SchemaName and SchemaType are solely to desribe the hierarchical structure, while all the data operation is handled from each ISDataSourceTable.

Note :

The flat data retrieval process follow the standard .NET ObjectDataSourceControl procedure, which mean any data-bound control that can support .NET ObjectDataSource can utilize ISDataSource.NET as well. On the other hand, the hierarchical data retrieval process can only used exclusively by Intersoft Solutions data-bound controls such as WebGrid.NET 5.0+ and WebCombo.NET 4.0+.

In general the nature of ISDataSource.NET is similiar with .NET ObjectDataSource control. Each of ISDataSourceTable definition uses reflection to create instances of business objects and to call methods on them to retrieve, update, insert and delete data. The TypeName property identifies the name of the class that ISDataSourceTable works with.

ISDataSource.NET is constructed from a single entry of ISDataSourceTable or a collection of ISDataSourceTables. Each table is associated with a data source view class, the name of this view is taken from ISDataSourceTable's TableName. The same as ObjectDataSource concept, the ISDataSourceView handles most of the operation behind the scene, you can use GetView(string viewName) method to gain access to corresponding ISDataSourceView.

The following list describes the features of ISDataSource.NET control

  • Selecting - Set the SelectMethod property (in ISDataSourceTable) to the name of business object methods that selects data and include any necessary parameters in the SelectParameters collection either programmatically or by using a data-bound control
  • Sorting - Set the SortParameterName property to the name of the parameter in SelectMethod method that carries the sort criteria. Set the SortExpression property to perform sorting when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView or a DataTable.
  • Filtering - Set the FilterExpression property to a filtering expression and optionally add any parameter to the FilterParameters collection to filter the data when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView, or DataTable.
  • Paging - Data source paging is supported, if the SelectMethod method contains parameters for the maximum number of records to retrieve and the index of the first record to retrieve. The names of those parameters must be set in the MaximumRowsParameterName and StartRowIndexParameterName properties, respectively. A data-bound control might be able to perform paging itself, even if the ISDataSource control does not support paging directly in the method specified by the SelectMethod property. The requirement for the data-bound control to be able to do this is that the method specified by the SelectMethod property return an object that implements the Icollection interface.
  • Updating - Set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameters in the UpdateParameters collection.
  • Deleting - Set the DeleteMethod property to the name of the business object method or function that deletes data, and include any necessary parameters in the DeleteParameters collection.
  • Inserting - Set the InsertMethod property to the name of the business object method or function that inserts data and include any necessary parameters in the InsertParameters collection.
  • Caching - Set the EnableCaching property to true, and configure cache settings according to the caching behavior you want for your cached data.

The ISDataSource.NET has an enhanced caching capability. Follows are the settings that you can set :

  • CacheScope (Global / PerUser)
  • CacheDuration and CacheExpirationPolicy (applicable when CacheStorage is set to PageCache)
  • CacheKeyDependency
  • CacheStorage (PageCache / Session / FileServer)
  • StoreCachePerPage

All this settings is used to create the CacheKey that used to identify the cached data that going to be stored. The CacheKey produced by ISDataSource follows following pattern:

{SessionID} : {PageName} : KeyDependency : ViewName : Duration : ExpirationPolicy : TypeName : SelectMethod + Params ++ startRowIndex : maxmumRows

The field under '{}' is optional.

If the CacheScope is set to Global, the key will not have {SessionID}.

If the StoreCachePerPage is set to No, the key will not have {PageName}.

The other information is essential to create and differentiate the cached data.

The cache configuration also can be set from Table level so you can have better flexibility which data and which configuration to be cached

The ISDataSource.NET is an ASP.NET data source control that represents a data-aware middle-tier object or a data-interface object to data-bound controls. You can use the ISDataSource control in conjuction with data-bound control to display, edit, and sort data on a Web page with little or no code.

ISDataSource.NET is designed to support both hierarchical data retrieval and flat data retrieval. The SchemaName and SchemaType property identifies the hierarchical structure of the datasource along with the definition of ISDataSourceTables. The role of SchemaName and SchemaType are solely to desribe the hierarchical structure, while all the data operation is handled from each ISDataSourceTable.

Note :

The flat data retrieval process follow the standard .NET ObjectDataSourceControl procedure, which mean any data-bound control that can support .NET ObjectDataSource can utilize ISDataSource.NET as well. On the other hand, the hierarchical data retrieval process can only used exclusively by Intersoft Solutions data-bound controls such as WebGrid.NET 5.0+ and WebCombo.NET 4.0+.

In general the nature of ISDataSource.NET is similiar with .NET ObjectDataSource control. Each of ISDataSourceTable definition uses reflection to create instances of business objects and to call methods on them to retrieve, update, insert and delete data. The TypeName property identifies the name of the class that ISDataSourceTable works with.

ISDataSource.NET is constructed from a single entry of ISDataSourceTable or a collection of ISDataSourceTables. Each table is associated with a data source view class, the name of this view is taken from ISDataSourceTable's TableName. The same as ObjectDataSource concept, the ISDataSourceView handles most of the operation behind the scene, you can use GetView(string viewName) method to gain access to corresponding ISDataSourceView.

The following list describes the features of ISDataSource.NET control

[Selecting] - Set the SelectMethod property [in ISDataSourceTable] to the name of business object methods that selects data and include any necessary parameters in the SelectParameters collection either programmatically or by using a data-bound control

[Sorting] - Set the SortParameterName property to the name of the parameter in SelectMethod method that carries the sort criteria. - Set the SortExpression property to perform sorting when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView or a DataTable.

[Filtering] - Set the FilterExpression property to a filtering expression and optionally add any parameters to the FilterParameters collection to filter the data when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView, or DataTable.

[Paging] - Data source paging is supported, if the SelectMethod method contains parameters for the maximum number of records to retrieve and the index of the first record to retrieve. The names of those parameters must be set in the MaximumRowsParameterName and StartRowIndexParameterName properties, respectively. A data-bound control might be able to perform paging itself, even if the ISDataSource control does not support paging directly in the method specified by the SelectMethod property. The requirement for the data-bound control to be able to do this is that the method specified by the SelectMethod property return an object that implements the Icollection interface.

[Updating] - Set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameters in the UpdateParameters collection.

[Deleting] - Set the DeleteMethod property to the name of the business object method or function that deletes data, and include any necessary parameters in the DeleteParameters collection.

[Inserting] - Set the InsertMethod property to the name of the business object method or function that inserts data, and include any necessary parameters in the InsertParameters collection.

[Caching] - Set the EnableCaching property to true, and the configure cache settings according to the caching behavior you want for your cached data.

The ISDataSource.NET has an enhanced caching capability. Follows are the settings that you can set :

+ CacheScope [Global / PerUser]

+ CacheDuration and CacheExpirationPolicy [applicable when CacheStorage is set to PageCache]

+ CacheKeyDependency

+ CacheStorage [PageCache / Session / FileServer]

+ StoreCachePerPage

All this settings is used to create the CacheKey that used to identify the cached data that going to be stored. The CacheKey produced by ISDataSource follows following pattern:

{SessionID} : {PageName} : KeyDependency : ViewName : Duration : ExpirationPolicy : TypeName : SelectMethod + Params ++ startRowIndex : maxmumRows

The field under '{}' is optional.

If the CacheScope is set to Global, the key will not have {SessionID}.

If the StoreCachePerPage is set to No, the key will not have {PageName}.

The other information is essential to create and differentiate the cached data.

The cache configuration also can be set from Table level so you can have better flexibility which data and which configuration to be cached.

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.DataSourceControl
ISNet.WebUI.DataSource.ISDataSource

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Members
ISNet.WebUI.DataSource Namespace

Tasks

Walkthrough: Binding to data using ISDataSource.NET
Walkthrough: Binding to Hierarchical data using ISDataSource.NET
Walkthrough: Modifying data using ISDataSource.NET
Walkthrough: Binding Generic Collection using ISDataSource.NET
Walkthrough: Binding to multiple controls using ISDataSource.NET
How-to: Use ISDataSource.NET along with GridView

Concepts

Processing data using ISDataSource.NET
Architecture
Organize your data sources in one component

Other Resources

Integration with .NET data bound controls

tasks

Walkthrough: Binding to Hierarchical CustomObject using ISDataSource.NET
How-to: Use ISDataSource.NET along with FormView
How-to: Use ISDataSource.NET along with DataList
How-to: Use ISDataSource.NET along with Repeater
How-to: Use ISDataSource.NET along with DetailView
How-to: Use ISDataSource.NET event handlers


ISDataSource Class Members

[image]
ISDataSource Documentation
ISDataSource Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSource Class

The following tables list the members exposed by ISDataSource.

Public Constructors

 | Name | Description
public Constructor | ISDataSource Constructor | Initializes a new instance of the ISDataSource class.
Top

Public Properties

 | Name | Description
public Property | CacheDuration | Gets or sets the length of time - in seconds, that the data source control caches data that is retrieved by the SelectMethod method. Gets or sets the length of time, in seconds, that the data source control caches data that is retrieved by the SelectMethod method.
public Property | CacheExpirationPolicy | Gets or sets the cache expiration behavior - when combined with the duration, which describes the behavior of the cache that the data source control uses. Gets or sets the cache expiration behavior that, when combined with the duration, describes the behavior of the cache that the data source control uses.
public Property | CacheKeyDependency | Gets or sets a user-defined key dependency that is linked to all data cache objects that are created by the data source control.
public Property | CachePriority | Gets or sets the relative priority of items stored in the Cache object.
public Property | CacheScope | Gets or sets the scope of the cached data.
public Property | CacheServerConnection | Get or sets the cache's file server connection string.
public Property | CacheStorage | Gets or sets the storage of the cached data.
public Property | CancelSelectOnNullParameter |
public Property | ConflictDetection | Gets or sets a value that determines whether only the new values are passed to the Update method or both the old and new values are passed to the Update method. Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.
public Property | ConvertNullToDBNull | Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.
public Property | EnableCaching | Gets or sets a value indicating whether the ISDataSource control has data caching enabled.
public Property | EnableViewState | (Inherited from System.Web.UI.Control)
public Property | ID | (Inherited from System.Web.UI.Control)
public Property | LoadOnDemand | Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the behavior how the Hierarchical data will be retrieved on demand Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the behavior how the Hierarchical data will be retrieve on demand
public Property | ParameterOption | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior on how the values are passed from Intersoft data-bound controls for Update, Insert and Delete operations. Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior how the values is passed from Intersoft data-bound controls for Update, Insert and Delete operations.
public Property | RootTable | Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the RootTable of ISDataSourceTables, which is used for Hierarchical Select in Intersoft WebGrid.NET 5.0+ Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the RootTable of ISDataSourceTables, which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+
public Property | RuntimeLicenseKey |
public Property | SchemaName | Gets or sets the name of the schema that represents the structure of ISDataSource. Gets or sets the name of the schema that represent the structure of ISDataSource.
public Property | SchemaType | Gets or sets the type of the schema that represents the structure of ISDataSource. Gets or sets the type of the schema that represent the structure of ISDataSource.
public Property | StoreCachePerPage | Gets or sets a value indicating whether the ISDataSource control will store the cached data separately for each page.
public Property | Tables | Gets the collection of ISDataSourceTables that belongs to ISDataSourceControl Gets collection of ISDataSourceTables that belong to ISDataSourceControl
public Property | UseCachedDataOnFirstLoad | Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled. Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled.
Top

Public Methods

 | Name | Description
public Method | ClearCache | Clear all cached related to all ISDataSourceTables in this ISDataSource control.
public Method | ClearCacheAndData |
public Method | Clone |
public Method | CopyFrom | Overloaded.
public Method | DataBind | (Inherited from System.Web.UI.Control)
public Method | Delete | Overloaded. Performs a delete operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.
public Method | Dispose | (Inherited from System.Web.UI.Control)
public Method | DoHierarchicalSelect | Overloaded. Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.
public Method | DoSelect | Overloaded. Perform flat data retrieval from ISDataSource control. The control peform data retrieval from the RootTable which determine using GetRootTable() method.
public Method | GetDataSourceSchema | Get the specified data source schema which determined from SchemaName and SchemaType properties.
public Method | GetRootTable | Get the RootTable of the ISDataSource.
public Method | Insert | Overloaded. Performs an insert operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.
public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
public Method | Select | Overloaded. Retrieves data from the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.
public Method | SetDataSourceSelectArguments | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Set the select arguments that going to be used by next select process for any table in ISDataSource control
public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
public Method | Update | Overloaded. Performs an update operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.
Top

Public Events

 | Name | Description
public Event | DataBinding | (Inherited from System.Web.UI.Control)
public Event | Deleted | Occurs when a Delete operation has completed.
public Event | Deleting | Occurs before a Delete operation.
public Event | Disposed | (Inherited from System.Web.UI.Control)
public Event | Filtering | Occurs before a filter operation.
public Event | Init | (Inherited from System.Web.UI.Control)
public Event | Inserted | Occurs when an Insert operation has completed.
public Event | Inserting | Occurs before an Insert operation.
public Event | Load | (Inherited from System.Web.UI.Control)
public Event | ObjectCreated | Occurs after the object that is identified by the ISDataSourceTable's TypeName property is created.
public Event | ObjectCreating | Occurs before the object that is identified by the TypeName property is created.
public Event | ObjectDisposing | Occurs before the object that is identified by the TypeName property is discarded.
public Event | PreRender | (Inherited from System.Web.UI.Control)
public Event | Selected | Occurs when a Select operation has completed.
public Event | Selecting | Occurs before a Select operation.
public Event | Unload | (Inherited from System.Web.UI.Control)
public Event | Updated | Occurs when an Update operation has completed.
public Event | Updating | Occurs before an Update operation.
Top

See Also

Reference

ISDataSource Class
ISNet.WebUI.DataSource Namespace


ISDataSource Constructor

[image]
ISDataSource Documentation
ISDataSource Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ISDataSource Constructor

Initializes a new instance of the ISDataSource class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSource()
C#
public ISDataSource()
Delphi
public ISDataSource();
JScript
public function ISDataSource();
Managed Extensions for C++
public: ISDataSource();
C++/CLI
public:
ISDataSource();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ISDataSource Class Methods

[image]
ISDataSource Documentation
ISDataSource Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSource Class

For a list of all members of this type, see ISDataSource members.

Public Methods

 | Name | Description
public Method | ClearCache | Clear all cached related to all ISDataSourceTables in this ISDataSource control.
public Method | ClearCacheAndData |
public Method | Clone |
public Method | CopyFrom | Overloaded.
public Method | DataBind | (Inherited from System.Web.UI.Control)
public Method | Delete | Overloaded. Performs a delete operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.
public Method | Dispose | (Inherited from System.Web.UI.Control)
public Method | DoHierarchicalSelect | Overloaded. Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.
public Method | DoSelect | Overloaded. Perform flat data retrieval from ISDataSource control. The control peform data retrieval from the RootTable which determine using GetRootTable() method.
public Method | GetDataSourceSchema | Get the specified data source schema which determined from SchemaName and SchemaType properties.
public Method | GetRootTable | Get the RootTable of the ISDataSource.
public Method | Insert | Overloaded. Performs an insert operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.
public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
public Method | Select | Overloaded. Retrieves data from the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.
public Method | SetDataSourceSelectArguments | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Set the select arguments that going to be used by next select process for any table in ISDataSource control
public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
public Method | Update | Overloaded. Performs an update operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.
Top

See Also

Reference

ISDataSource Class
ISNet.WebUI.DataSource Namespace


ClearCache Method

[image]
ISDataSource Documentation
ClearCache Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ClearCache Method

Clear all cached related to all ISDataSourceTables in this ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Sub ClearCache()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource

instance.ClearCache()
C#
public void ClearCache()
Delphi
public procedure ClearCache();
JScript
public function ClearCache();
Managed Extensions for C++
public: void ClearCache();
C++/CLI
public:
void ClearCache();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ClearCacheAndData Method

[image]
ISDataSource Documentation
ClearCacheAndData Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ClearCacheAndData Method

Syntax

Visual Basic (Declaration)
Public Sub ClearCacheAndData()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource

instance.ClearCacheAndData()
C#
public void ClearCacheAndData()
Delphi
public procedure ClearCacheAndData();
JScript
public function ClearCacheAndData();
Managed Extensions for C++
public: void ClearCacheAndData();
C++/CLI
public:
void ClearCacheAndData();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Clone Method

[image]
ISDataSource Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As Object

value = instance.Clone()
C#
public object Clone()
Delphi
public function Clone(): TObject;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: Object* Clone();
C++/CLI
public:
Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


CopyFrom Method

[image]
ISDataSource Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) |
CopyFrom(Object,Boolean) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


CopyFrom(Object) Method

[image]
ISDataSource Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > CopyFrom Method : CopyFrom(Object) Method

sourceObject

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal sourceObject As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim sourceObject As Object

instance.CopyFrom(sourceObject)
C#
public void CopyFrom(
   object sourceObject
)
Delphi
public procedure CopyFrom(
    sourceObject: TObject
);
JScript
public function CopyFrom(
   sourceObject : Object
);
Managed Extensions for C++
public: void CopyFrom(
   Object* sourceObject
)
C++/CLI
public:
void CopyFrom(
   Object^ sourceObject
)

Parameters

sourceObject

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
ISDataSource Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

sourceObject
flag

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyFrom( _
   ByVal sourceObject As Object, _
   ByVal flag As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim sourceObject As Object
Dim flag As Boolean

instance.CopyFrom(sourceObject, flag)
C#
public void CopyFrom(
   object sourceObject,
   bool flag
)
Delphi
public procedure CopyFrom(
    sourceObject: TObject;
    flag: Boolean
);
JScript
public function CopyFrom(
   sourceObject : Object,
   flag : boolean
);
Managed Extensions for C++
public: void CopyFrom(
   Object* sourceObject,
   bool flag
)
C++/CLI
public:
void CopyFrom(
   Object^ sourceObject,
   bool flag
)

Parameters

sourceObject
flag

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


Delete Method

[image]
ISDataSource Documentation
Delete Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Delete Method

Performs a delete operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.

Overload List

Overload | Description
Delete() | Performs a delete operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.
Delete(String) | Performs a delete operation to the table specified in parameter ViewName by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Delete() Method

[image]
ISDataSource Documentation
Delete() Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Delete Method : Delete() Method

Performs a delete operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Delete() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As Integer

value = instance.Delete()
C#
public int Delete()
Delphi
public function Delete(): Integer;
JScript
public function Delete() : int;
Managed Extensions for C++
public: int Delete();
C++/CLI
public:
int Delete();

Return Value

A value that represents the number of rows deleted from the underlying data storage, if the AffectedRows property of the ISDataSourceStatusEventArgs is set in the Deleted event; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


Delete(String) Method

[image]
ISDataSource Documentation
Delete(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Delete Method : Delete(String) Method

viewName
The name of the view to be deleted.
Performs a delete operation to the table specified in parameter ViewName by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Delete( _
   ByVal viewName As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim viewName As String
Dim value As Integer

value = instance.Delete(viewName)
C#
public int Delete(
   string viewName
)
Delphi
public function Delete(
    viewName: String
): Integer;
JScript
public function Delete(
   viewName : String
) : int;
Managed Extensions for C++
public: int Delete(
   string* viewName
)
C++/CLI
public:
int Delete(
   String^ viewName
)

Parameters

viewName
The name of the view to be deleted.

Return Value

A value that represents the number of rows deleted from the underlying data storage, if the AffectedRows property of the ISDataSourceStatusEventArgs is set in the Deleted event; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoHierarchicalSelect Method

[image]
ISDataSource Documentation
DoHierarchicalSelect Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : DoHierarchicalSelect Method

Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.

Overload List

Overload | Description
DoHierarchicalSelect() | Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.
DoHierarchicalSelect(Hashtable) | Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.
DoHierarchicalSelect(String) | Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from tableName which specified in the parameter
DoHierarchicalSelect(String,Hashtable) | Perform hierarchcial data retrieval from ISDataSource control. The control perform data retrieval from tableName which specified in the parameter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


DoHierarchicalSelect() Method

[image]
ISDataSource Documentation
DoHierarchicalSelect() Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoHierarchicalSelect Method : DoHierarchicalSelect() Method

Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.

Syntax

Visual Basic (Declaration)
Public Overloads Function DoHierarchicalSelect() As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As IListSource

value = instance.DoHierarchicalSelect()
C#
public IListSource DoHierarchicalSelect()
Delphi
public function DoHierarchicalSelect(): IListSource;
JScript
public function DoHierarchicalSelect() : IListSource;
Managed Extensions for C++
public: IListSource* DoHierarchicalSelect();
C++/CLI
public:
IListSource^ DoHierarchicalSelect();

Return Value

An IListSource instance, contains list of rows. (DataSet)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoHierarchicalSelect(Hashtable) Method

[image]
ISDataSource Documentation
DoHierarchicalSelect(Hashtable) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoHierarchicalSelect Method : DoHierarchicalSelect(Hashtable) Method

tablesInHierarchicalStructure
A collection of tables name that going to be fill during hierarchical data retrieval.
Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.

Syntax

Visual Basic (Declaration)
Public Overloads Function DoHierarchicalSelect( _
   ByVal tablesInHierarchicalStructure As Hashtable _
) As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim tablesInHierarchicalStructure As Hashtable
Dim value As IListSource

value = instance.DoHierarchicalSelect(tablesInHierarchicalStructure)
C#
public IListSource DoHierarchicalSelect(
   Hashtable tablesInHierarchicalStructure
)
Delphi
public function DoHierarchicalSelect(
    tablesInHierarchicalStructure: Hashtable
): IListSource;
JScript
public function DoHierarchicalSelect(
   tablesInHierarchicalStructure : Hashtable
) : IListSource;
Managed Extensions for C++
public: IListSource* DoHierarchicalSelect(
   Hashtable* tablesInHierarchicalStructure
)
C++/CLI
public:
IListSource^ DoHierarchicalSelect(
   Hashtable^ tablesInHierarchicalStructure
)

Parameters

tablesInHierarchicalStructure
A collection of tables name that going to be fill during hierarchical data retrieval.

Return Value

An IListSource instance, contains list of rows. (DataSet)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoHierarchicalSelect(String) Method

[image]
ISDataSource Documentation
DoHierarchicalSelect(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoHierarchicalSelect Method : DoHierarchicalSelect(String) Method

tableName
The name of table, that will acts as the RootTable in hierarchical data retrieval
Perform hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from tableName which specified in the parameter

Syntax

Visual Basic (Declaration)
Public Overloads Function DoHierarchicalSelect( _
   ByVal tableName As String _
) As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim tableName As String
Dim value As IListSource

value = instance.DoHierarchicalSelect(tableName)
C#
public IListSource DoHierarchicalSelect(
   string tableName
)
Delphi
public function DoHierarchicalSelect(
    tableName: String
): IListSource;
JScript
public function DoHierarchicalSelect(
   tableName : String
) : IListSource;
Managed Extensions for C++
public: IListSource* DoHierarchicalSelect(
   string* tableName
)
C++/CLI
public:
IListSource^ DoHierarchicalSelect(
   String^ tableName
)

Parameters

tableName
The name of table, that will acts as the RootTable in hierarchical data retrieval

Return Value

An IListSource instance, contains list of rows. (DataSet)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoHierarchicalSelect(String,Hashtable) Method

[image]
ISDataSource Documentation
DoHierarchicalSelect(String,Hashtable) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoHierarchicalSelect Method : DoHierarchicalSelect(String,Hashtable) Method

tableName
The name of table, that will acts as the RootTable in hierarchical data retrieval
tablesInHierarchicalStructure
A collection of tables name that going to be fill during hierarchical data retrieval.
Perform hierarchcial data retrieval from ISDataSource control. The control perform data retrieval from tableName which specified in the parameter

Syntax

Visual Basic (Declaration)
Public Overloads Function DoHierarchicalSelect( _
   ByVal tableName As String, _
   ByVal tablesInHierarchicalStructure As Hashtable _
) As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim tableName As String
Dim tablesInHierarchicalStructure As Hashtable
Dim value As IListSource

value = instance.DoHierarchicalSelect(tableName, tablesInHierarchicalStructure)
C#
public IListSource DoHierarchicalSelect(
   string tableName,
   Hashtable tablesInHierarchicalStructure
)
Delphi
public function DoHierarchicalSelect(
    tableName: String;
    tablesInHierarchicalStructure: Hashtable
): IListSource;
JScript
public function DoHierarchicalSelect(
   tableName : String,
   tablesInHierarchicalStructure : Hashtable
) : IListSource;
Managed Extensions for C++
public: IListSource* DoHierarchicalSelect(
   string* tableName,
   Hashtable* tablesInHierarchicalStructure
)
C++/CLI
public:
IListSource^ DoHierarchicalSelect(
   String^ tableName,
   Hashtable^ tablesInHierarchicalStructure
)

Parameters

tableName
The name of table, that will acts as the RootTable in hierarchical data retrieval
tablesInHierarchicalStructure
A collection of tables name that going to be fill during hierarchical data retrieval.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoSelect Method

[image]
ISDataSource Documentation
DoSelect Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : DoSelect Method

Perform flat data retrieval from ISDataSource control. The control peform data retrieval from the RootTable which determine using GetRootTable() method.

Overload List

Overload | Description
DoSelect() | Perform flat data retrieval from ISDataSource control. The control peform data retrieval from the RootTable which determine using GetRootTable() method.
DoSelect(Boolean) | Perform either flat data retrieval / hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.
DoSelect(Boolean,Hashtable) | Perform either flat data retrieval / hierarchical data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.
DoSelect(String) | Perform flat data retrieval from ISDataSource control. The control peform data retrieval from the tableName specified in the parameter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


DoSelect() Method

[image]
ISDataSource Documentation
DoSelect() Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoSelect Method : DoSelect() Method

Perform flat data retrieval from ISDataSource control. The control peform data retrieval from the RootTable which determine using GetRootTable() method.

Syntax

Visual Basic (Declaration)
Public Overloads Function DoSelect() As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As IListSource

value = instance.DoSelect()
C#
public IListSource DoSelect()
Delphi
public function DoSelect(): IListSource;
JScript
public function DoSelect() : IListSource;
Managed Extensions for C++
public: IListSource* DoSelect();
C++/CLI
public:
IListSource^ DoSelect();

Return Value

An IListSource instance, contains list of rows. (DataTable)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoSelect(Boolean) Method

[image]
ISDataSource Documentation
DoSelect(Boolean) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoSelect Method : DoSelect(Boolean) Method

retrieveHierarchical
A flag to determine whether the method perform flat data retrieval / hierarchical data retrieval. true = perform hierarchical data retrieval false = perform flat data retrieval
Perform either flat data retrieval / hierarchcial data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.

Syntax

Visual Basic (Declaration)
Public Overloads Function DoSelect( _
   ByVal retrieveHierarchical As Boolean _
) As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim retrieveHierarchical As Boolean
Dim value As IListSource

value = instance.DoSelect(retrieveHierarchical)
C#
public IListSource DoSelect(
   bool retrieveHierarchical
)
Delphi
public function DoSelect(
    retrieveHierarchical: Boolean
): IListSource;
JScript
public function DoSelect(
   retrieveHierarchical : boolean
) : IListSource;
Managed Extensions for C++
public: IListSource* DoSelect(
   bool retrieveHierarchical
)
C++/CLI
public:
IListSource^ DoSelect(
   bool retrieveHierarchical
)

Parameters

retrieveHierarchical
A flag to determine whether the method perform flat data retrieval / hierarchical data retrieval. true = perform hierarchical data retrieval false = perform flat data retrieval

Return Value

An IListSource instance, contains list of rows. (DataSet or DataTable)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoSelect(Boolean,Hashtable) Method

[image]
ISDataSource Documentation
DoSelect(Boolean,Hashtable) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoSelect Method : DoSelect(Boolean,Hashtable) Method

retrieveHierarchical
A flag to determine whether the method perform flat data retrieval / hierarchical data retrieval. true = perform hierarchical data retrieval false = perform flat data retrieval
tablesInHierarchicalStructure
A collection of tables name that going to be fill during hierarchical data retrieval.
Perform either flat data retrieval / hierarchical data retrieval from ISDataSource control. The control perfrom data retrieval from RootTable which determine using GetRootTable() method.

Syntax

Visual Basic (Declaration)
Public Overloads Function DoSelect( _
   ByVal retrieveHierarchical As Boolean, _
   ByVal tablesInHierarchicalStructure As Hashtable _
) As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim retrieveHierarchical As Boolean
Dim tablesInHierarchicalStructure As Hashtable
Dim value As IListSource

value = instance.DoSelect(retrieveHierarchical, tablesInHierarchicalStructure)
C#
public IListSource DoSelect(
   bool retrieveHierarchical,
   Hashtable tablesInHierarchicalStructure
)
Delphi
public function DoSelect(
    retrieveHierarchical: Boolean;
    tablesInHierarchicalStructure: Hashtable
): IListSource;
JScript
public function DoSelect(
   retrieveHierarchical : boolean,
   tablesInHierarchicalStructure : Hashtable
) : IListSource;
Managed Extensions for C++
public: IListSource* DoSelect(
   bool retrieveHierarchical,
   Hashtable* tablesInHierarchicalStructure
)
C++/CLI
public:
IListSource^ DoSelect(
   bool retrieveHierarchical,
   Hashtable^ tablesInHierarchicalStructure
)

Parameters

retrieveHierarchical
A flag to determine whether the method perform flat data retrieval / hierarchical data retrieval. true = perform hierarchical data retrieval false = perform flat data retrieval
tablesInHierarchicalStructure
A collection of tables name that going to be fill during hierarchical data retrieval.

Return Value

An IListSource instance, contains list of rows. (DataSet or DataTable)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


DoSelect(String) Method

[image]
ISDataSource Documentation
DoSelect(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > DoSelect Method : DoSelect(String) Method

tableName
The name of table, which hold the data that going to be retrieved.
Perform flat data retrieval from ISDataSource control. The control peform data retrieval from the tableName specified in the parameter

Syntax

Visual Basic (Declaration)
Public Overloads Function DoSelect( _
   ByVal tableName As String _
) As IListSource
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim tableName As String
Dim value As IListSource

value = instance.DoSelect(tableName)
C#
public IListSource DoSelect(
   string tableName
)
Delphi
public function DoSelect(
    tableName: String
): IListSource;
JScript
public function DoSelect(
   tableName : String
) : IListSource;
Managed Extensions for C++
public: IListSource* DoSelect(
   string* tableName
)
C++/CLI
public:
IListSource^ DoSelect(
   String^ tableName
)

Parameters

tableName
The name of table, which hold the data that going to be retrieved.

Return Value

An IListSource instance, contains list of rows. (DataTable)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


GetDataSourceSchema Method

[image]
ISDataSource Documentation
GetDataSourceSchema Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : GetDataSourceSchema Method

Get the specified data source schema which determined from SchemaName and SchemaType properties.

Syntax

Visual Basic (Declaration)
Public Function GetDataSourceSchema() As DataSet
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As DataSet

value = instance.GetDataSourceSchema()
C#
public DataSet GetDataSourceSchema()
Delphi
public function GetDataSourceSchema(): DataSet;
JScript
public function GetDataSourceSchema() : DataSet;
Managed Extensions for C++
public: DataSet* GetDataSourceSchema();
C++/CLI
public:
DataSet^ GetDataSourceSchema();

Return Value

A DataSet instance that holds all the schema definition.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


GetRootTable Method

[image]
ISDataSource Documentation
GetRootTable Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : GetRootTable Method

Get the RootTable of the ISDataSource.

Syntax

Visual Basic (Declaration)
Public Function GetRootTable() As ISDataSourceTable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As ISDataSourceTable

value = instance.GetRootTable()
C#
public ISDataSourceTable GetRootTable()
Delphi
public function GetRootTable(): ISDataSourceTable;
JScript
public function GetRootTable() : ISDataSourceTable;
Managed Extensions for C++
public: ISDataSourceTable* GetRootTable();
C++/CLI
public:
ISDataSourceTable^ GetRootTable();

Return Value

An ISDataSourceTable instance that act as the RootTable of ISDataSource control.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Insert Method

[image]
ISDataSource Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Insert Method

Performs an insert operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.

Overload List

Overload | Description
Insert() | Performs an insert operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.
Insert(String) | Performs an insert operation to the table specified in parameter ViewName by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Insert() Method

[image]
ISDataSource Documentation
Insert() Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Insert Method : Insert() Method

Performs an insert operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As Integer

value = instance.Insert()
C#
public int Insert()
Delphi
public function Insert(): Integer;
JScript
public function Insert() : int;
Managed Extensions for C++
public: int Insert();
C++/CLI
public:
int Insert();

Return Value

A value that represents the number of rows inserted into the underlying data storage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


Insert(String) Method

[image]
ISDataSource Documentation
Insert(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Insert Method : Insert(String) Method

viewName
The name of the view to be deleted.
Performs an insert operation to the table specified in parameter ViewName by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal viewName As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim viewName As String
Dim value As Integer

value = instance.Insert(viewName)
C#
public int Insert(
   string viewName
)
Delphi
public function Insert(
    viewName: String
): Integer;
JScript
public function Insert(
   viewName : String
) : int;
Managed Extensions for C++
public: int Insert(
   string* viewName
)
C++/CLI
public:
int Insert(
   String^ viewName
)

Parameters

viewName
The name of the view to be deleted.

Return Value

A value that represents the number of rows deleted from the underlying data storage, if the AffectedRows property of the ISDataSourceStatusEventArgs is set in the Deleted event; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


Select Method

[image]
ISDataSource Documentation
Select Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Select Method

Retrieves data from the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Overload List

Overload | Description
Select() | Retrieves data from the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.
Select(String) | Retrieves data from the table specified in parameter ViewName by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.
Select(String,DataSourceSelectArguments) | Retrieves data from the table specified in parameter ViewName by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Select() Method

[image]
ISDataSource Documentation
Select() Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Select Method : Select() Method

Retrieves data from the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Select() As IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As IEnumerable

value = instance.Select()
C#
public IEnumerable Select()
Delphi
public function Select(): IEnumerable;
JScript
public function Select() : IEnumerable;
Managed Extensions for C++
public: IEnumerable* Select();
C++/CLI
public:
IEnumerable^ Select();

Return Value

An IEnumerable list of data rows.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


Select(String) Method

[image]
ISDataSource Documentation
Select(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Select Method : Select(String) Method

viewName
The name of view, which hold the data that going to be retrieved.
Retrieves data from the table specified in parameter ViewName by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Select( _
   ByVal viewName As String _
) As IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim viewName As String
Dim value As IEnumerable

value = instance.Select(viewName)
C#
public IEnumerable Select(
   string viewName
)
Delphi
public function Select(
    viewName: String
): IEnumerable;
JScript
public function Select(
   viewName : String
) : IEnumerable;
Managed Extensions for C++
public: IEnumerable* Select(
   string* viewName
)
C++/CLI
public:
IEnumerable^ Select(
   String^ viewName
)

Parameters

viewName
The name of view, which hold the data that going to be retrieved.

Return Value

An IEnumerable list of data rows.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


Select(String,DataSourceSelectArguments) Method

[image]
ISDataSource Documentation
Select(String,DataSourceSelectArguments) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Select Method : Select(String,DataSourceSelectArguments) Method

viewName
The name of view, which hold the data that going to be retrieved.
args
A DataSourceSelectArguments used to request operations on the data beyond basic data retrieval.
Retrieves data from the table specified in parameter ViewName by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Select( _
   ByVal viewName As String, _
   ByVal args As DataSourceSelectArguments _
) As IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim viewName As String
Dim args As DataSourceSelectArguments
Dim value As IEnumerable

value = instance.Select(viewName, args)
C#
public IEnumerable Select(
   string viewName,
   DataSourceSelectArguments args
)
Delphi
public function Select(
    viewName: String;
    args: DataSourceSelectArguments
): IEnumerable;
JScript
public function Select(
   viewName : String,
   args : DataSourceSelectArguments
) : IEnumerable;
Managed Extensions for C++
public: IEnumerable* Select(
   string* viewName,
   DataSourceSelectArguments* args
)
C++/CLI
public:
IEnumerable^ Select(
   String^ viewName,
   DataSourceSelectArguments^ args
)

Parameters

viewName
The name of view, which hold the data that going to be retrieved.
args
A DataSourceSelectArguments used to request operations on the data beyond basic data retrieval.

Return Value

An IEnumerable list of data rows.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


SetDataSourceSelectArguments Method

[image]
ISDataSource Documentation
SetDataSourceSelectArguments Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : SetDataSourceSelectArguments Method

selectArguments
Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Set the select arguments that going to be used by next select process for any table in ISDataSource control

Syntax

Visual Basic (Declaration)
Public Sub SetDataSourceSelectArguments( _
   ByVal selectArguments As DataSourceSelectArguments _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim selectArguments As DataSourceSelectArguments

instance.SetDataSourceSelectArguments(selectArguments)
C#
public void SetDataSourceSelectArguments(
   DataSourceSelectArguments selectArguments
)
Delphi
public procedure SetDataSourceSelectArguments(
    selectArguments: DataSourceSelectArguments
);
JScript
public function SetDataSourceSelectArguments(
   selectArguments : DataSourceSelectArguments
);
Managed Extensions for C++
public: void SetDataSourceSelectArguments(
   DataSourceSelectArguments* selectArguments
)
C++/CLI
public:
void SetDataSourceSelectArguments(
   DataSourceSelectArguments^ selectArguments
)

Parameters

selectArguments

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Update Method

[image]
ISDataSource Documentation
Update Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Update Method

Performs an update operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.

Overload List

Overload | Description
Update() | Performs an update operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.
Update(String) | Performs an update operation to to the table specified in parameter ViewName by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Update() Method

[image]
ISDataSource Documentation
Update() Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Update Method : Update() Method

Performs an update operation to the first table specified in ISDataSourceTableCollection or specified in RootTable by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Update() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As Integer

value = instance.Update()
C#
public int Update()
Delphi
public function Update(): Integer;
JScript
public function Update() : int;
Managed Extensions for C++
public: int Update();
C++/CLI
public:
int Update();

Return Value

A value that represents the number of rows updated in the underlying data storage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


Update(String) Method

[image]
ISDataSource Documentation
Update(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class > Update Method : Update(String) Method

viewName
The name of the view to be updated.
Performs an update operation to to the table specified in parameter ViewName by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Update( _
   ByVal viewName As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim viewName As String
Dim value As Integer

value = instance.Update(viewName)
C#
public int Update(
   string viewName
)
Delphi
public function Update(
    viewName: String
): Integer;
JScript
public function Update(
   viewName : String
) : int;
Managed Extensions for C++
public: int Update(
   string* viewName
)
C++/CLI
public:
int Update(
   String^ viewName
)

Parameters

viewName
The name of the view to be updated.

Return Value

A value that represents the number of rows updated in the underlying data storage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members
Overload List


ISDataSource Class Properties

[image]
ISDataSource Documentation
ISDataSource Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSource Class

For a list of all members of this type, see ISDataSource members.

Public Properties

 | Name | Description
public Property | CacheDuration | Gets or sets the length of time - in seconds, that the data source control caches data that is retrieved by the SelectMethod method. Gets or sets the length of time, in seconds, that the data source control caches data that is retrieved by the SelectMethod method.
public Property | CacheExpirationPolicy | Gets or sets the cache expiration behavior - when combined with the duration, which describes the behavior of the cache that the data source control uses. Gets or sets the cache expiration behavior that, when combined with the duration, describes the behavior of the cache that the data source control uses.
public Property | CacheKeyDependency | Gets or sets a user-defined key dependency that is linked to all data cache objects that are created by the data source control.
public Property | CachePriority | Gets or sets the relative priority of items stored in the Cache object.
public Property | CacheScope | Gets or sets the scope of the cached data.
public Property | CacheServerConnection | Get or sets the cache's file server connection string.
public Property | CacheStorage | Gets or sets the storage of the cached data.
public Property | CancelSelectOnNullParameter |
public Property | ConflictDetection | Gets or sets a value that determines whether only the new values are passed to the Update method or both the old and new values are passed to the Update method. Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.
public Property | ConvertNullToDBNull | Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.
public Property | EnableCaching | Gets or sets a value indicating whether the ISDataSource control has data caching enabled.
public Property | EnableViewState | (Inherited from System.Web.UI.Control)
public Property | ID | (Inherited from System.Web.UI.Control)
public Property | LoadOnDemand | Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the behavior how the Hierarchical data will be retrieved on demand Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the behavior how the Hierarchical data will be retrieve on demand
public Property | ParameterOption | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior on how the values are passed from Intersoft data-bound controls for Update, Insert and Delete operations. Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior how the values is passed from Intersoft data-bound controls for Update, Insert and Delete operations.
public Property | RootTable | Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the RootTable of ISDataSourceTables, which is used for Hierarchical Select in Intersoft WebGrid.NET 5.0+ Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the RootTable of ISDataSourceTables, which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+
public Property | RuntimeLicenseKey |
public Property | SchemaName | Gets or sets the name of the schema that represents the structure of ISDataSource. Gets or sets the name of the schema that represent the structure of ISDataSource.
public Property | SchemaType | Gets or sets the type of the schema that represents the structure of ISDataSource. Gets or sets the type of the schema that represent the structure of ISDataSource.
public Property | StoreCachePerPage | Gets or sets a value indicating whether the ISDataSource control will store the cached data separately for each page.
public Property | Tables | Gets the collection of ISDataSourceTables that belongs to ISDataSourceControl Gets collection of ISDataSourceTables that belong to ISDataSourceControl
public Property | UseCachedDataOnFirstLoad | Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled. Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled.
Top

See Also

Reference

ISDataSource Class
ISNet.WebUI.DataSource Namespace


CacheDuration Property

[image]
ISDataSource Documentation
CacheDuration Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CacheDuration Property

Gets or sets the length of time - in seconds, that the data source control caches data that is retrieved by the SelectMethod method. Gets or sets the length of time, in seconds, that the data source control caches data that is retrieved by the SelectMethod method.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Cache")>
<DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")>
<TypeConverterAttribute("System.Web.UI.DataSourceCacheDurationConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
Public Overridable Property CacheDuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As Integer

instance.CacheDuration = value

value = instance.CacheDuration
C#
[CategoryAttribute("Cache")]
[DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")]
[TypeConverterAttribute("System.Web.UI.DataSourceCacheDurationConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public virtual int CacheDuration {get; set;}
Delphi
public read-write property CacheDuration: Integer; virtual;
JScript
CategoryAttribute("Cache")
DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")
TypeConverterAttribute("System.Web.UI.DataSourceCacheDurationConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
public function get,set CacheDuration : int
Managed Extensions for C++
[CategoryAttribute("Cache")]
[DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")]
[TypeConverterAttribute("System.Web.UI.DataSourceCacheDurationConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public: __property virtual int get_CacheDuration();
public: __property virtual void set_CacheDuration(
   int value
);
C++/CLI
[CategoryAttribute("Cache")]
[DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")]
[TypeConverterAttribute("System.Web.UI.DataSourceCacheDurationConverter, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
public:
virtual property int CacheDuration {
   int get();
   void set (    int value);
}

Property Value

The number of seconds that the ISDataSource caches the results of each ISDataSourceTable's SelectMethod property invocation. The default is 0. The value cannot be negative.

Remarks

The CacheDuration indicates the number of seconds that the cache storing data before the cache entry is discarded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Cache storage

Tasks

How-to: Configure cache configuration


CacheExpirationPolicy Property

[image]
ISDataSource Documentation
CacheExpirationPolicy Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CacheExpirationPolicy Property

Gets or sets the cache expiration behavior - when combined with the duration, which describes the behavior of the cache that the data source control uses. Gets or sets the cache expiration behavior that, when combined with the duration, describes the behavior of the cache that the data source control uses.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Cache")>
<DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")>
<DefaultValueAttribute()>
Public Overridable Property CacheExpirationPolicy As CacheExpirationPolicy
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As CacheExpirationPolicy

instance.CacheExpirationPolicy = value

value = instance.CacheExpirationPolicy
C#
[CategoryAttribute("Cache")]
[DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")]
[DefaultValueAttribute()]
public virtual CacheExpirationPolicy CacheExpirationPolicy {get; set;}
Delphi
public read-write property CacheExpirationPolicy: CacheExpirationPolicy; virtual;
JScript
CategoryAttribute("Cache")
DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")
DefaultValueAttribute()
public function get,set CacheExpirationPolicy : CacheExpirationPolicy
Managed Extensions for C++
[CategoryAttribute("Cache")]
[DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")]
[DefaultValueAttribute()]
public: __property virtual CacheExpirationPolicy get_CacheExpirationPolicy();
public: __property virtual void set_CacheExpirationPolicy(
   CacheExpirationPolicy value
);
C++/CLI
[CategoryAttribute("Cache")]
[DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")]
[DefaultValueAttribute()]
public:
virtual property CacheExpirationPolicy CacheExpirationPolicy {
   CacheExpirationPolicy get();
   void set (    CacheExpirationPolicy value);
}

Property Value

One of the CacheExpirationPolicy values. The default is CacheExpirationPolicy.Absolute.

Remarks

This property can be configured when users store Cached Data in Page Cache. If the CacheExpirationPolicy is set to Absolute, the cache data will be hold in memory for - at most - the amount of time that is specified by the CacheDuration. The data might be released before the duration time if the memory is needed. If the CacheExpirationPolicy is set to Sliding, the cache expires when there is no activity for a time that is equal to the CacheDuration.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Cache storage


CacheKeyDependency Property

[image]
ISDataSource Documentation
CacheKeyDependency Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CacheKeyDependency Property

Gets or sets a user-defined key dependency that is linked to all data cache objects that are created by the data source control.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Cache")>
<DefaultValueAttribute()>
<DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")>
Public Overridable Property CacheKeyDependency As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As String

instance.CacheKeyDependency = value

value = instance.CacheKeyDependency
C#
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")]
public virtual string CacheKeyDependency {get; set;}
Delphi
public read-write property CacheKeyDependency: String; virtual;
JScript
CategoryAttribute("Cache")
DefaultValueAttribute()
DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")
public function get,set CacheKeyDependency : String
Managed Extensions for C++
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")]
public: __property virtual string* get_CacheKeyDependency();
public: __property virtual void set_CacheKeyDependency(
   string* value
);
C++/CLI
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")]
public:
virtual property String^ CacheKeyDependency {
   String^ get();
   void set (    String^ value);
}

Property Value

A key that identifies all cache objects created by the ISDataSource.

Remarks

This property is treated as a key wild card to identifies the cache if needed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


CachePriority Property

[image]
ISDataSource Documentation
CachePriority Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CachePriority Property

Gets or sets the relative priority of items stored in the Cache object.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")>
<CategoryAttribute("Cache")>
<DefaultValueAttribute()>
Public Overridable Property CachePriority As CachePriority
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As CachePriority

instance.CachePriority = value

value = instance.CachePriority
C#
[DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
public virtual CachePriority CachePriority {get; set;}
Delphi
public read-write property CachePriority: CachePriority; virtual;
JScript
DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")
CategoryAttribute("Cache")
DefaultValueAttribute()
public function get,set CachePriority : CachePriority
Managed Extensions for C++
[DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
public: __property virtual CachePriority get_CachePriority();
public: __property virtual void set_CachePriority(
   CachePriority value
);
C++/CLI
[DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
public:
virtual property CachePriority CachePriority {
   CachePriority get();
   void set (    CachePriority value);
}

Property Value

The relative priority of items stored in the Cache object.

Remarks

Using this property you can assign relative priority compared to other items stored in the cache. Items to which you assign higher priority values are less likely to be deleted from the cache when the server is processing a large number of requests, whereas items to which you assign lower priority values are more likely to be deleted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Cache storage


CacheScope Property

[image]
ISDataSource Documentation
CacheScope Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CacheScope Property

Gets or sets the scope of the cached data.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Cache")>
<DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")>
<DefaultValueAttribute()>
Public Overridable Property CacheScope As CacheScope
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As CacheScope

instance.CacheScope = value

value = instance.CacheScope
C#
[CategoryAttribute("Cache")]
[DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")]
[DefaultValueAttribute()]
public virtual CacheScope CacheScope {get; set;}
Delphi
public read-write property CacheScope: CacheScope; virtual;
JScript
CategoryAttribute("Cache")
DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")
DefaultValueAttribute()
public function get,set CacheScope : CacheScope
Managed Extensions for C++
[CategoryAttribute("Cache")]
[DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")]
[DefaultValueAttribute()]
public: __property virtual CacheScope get_CacheScope();
public: __property virtual void set_CacheScope(
   CacheScope value
);
C++/CLI
[CategoryAttribute("Cache")]
[DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")]
[DefaultValueAttribute()]
public:
virtual property CacheScope CacheScope {
   CacheScope get();
   void set (    CacheScope value);
}

Property Value

One of the CacheScope values. The default is CacheScope.Global.

Remarks

You can define the scope of the cache, whether it is available to global user or specific user (session).

  • Global. Global cache data allows all users that access the application share the same data. It is usually used for common data that rarely updated and used by all users.
  • Per User. Per User cache data will create a new instance for each user that accessing the application. The data is exclusive to each user.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Cache Scope
Cache Key Pattern


CacheServerConnection Property

[image]
ISDataSource Documentation
CacheServerConnection Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CacheServerConnection Property

Get or sets the cache's file server connection string.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Cache")>
<DescriptionAttribute("File Server's connection string")>
Public Overridable Property CacheServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As String

instance.CacheServerConnection = value

value = instance.CacheServerConnection
C#
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("File Server's connection string")]
public virtual string CacheServerConnection {get; set;}
Delphi
public read-write property CacheServerConnection: String; virtual;
JScript
DefaultValueAttribute()
CategoryAttribute("Cache")
DescriptionAttribute("File Server's connection string")
public function get,set CacheServerConnection : String
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("File Server's connection string")]
public: __property virtual string* get_CacheServerConnection();
public: __property virtual void set_CacheServerConnection(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("File Server's connection string")]
public:
virtual property String^ CacheServerConnection {
   String^ get();
   void set (    String^ value);
}

Property Value

The File server connection string that the ISDataSource control uses to connect to a FileServer.

Remarks

To save the cached data to FileServer you need to specify the CacheServerConnection. Following is a list of parameters that can be used in CacheServerConnection:

  • path. Specify the path of file server storage
  • expireduration. Specify the time in minutes how long should a cache stay in the storage.
  • expirationpolicy. Specify the expiration policy of the cache. The valid values are Sliding, Absolute.

Each parameter should be separated using ";" (semicolon) character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Tasks

How-to: Use file server for an instance of control
How-to: Configure file server to use shared network drive


CacheStorage Property

[image]
ISDataSource Documentation
CacheStorage Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CacheStorage Property

Gets or sets the storage of the cached data.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies how the cache is stored.")>
<DefaultValueAttribute()>
<CategoryAttribute("Cache")>
Public Overridable Property CacheStorage As CacheStorage
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As CacheStorage

instance.CacheStorage = value

value = instance.CacheStorage
C#
[DescriptionAttribute("Specifies how the cache is stored.")]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public virtual CacheStorage CacheStorage {get; set;}
Delphi
public read-write property CacheStorage: CacheStorage; virtual;
JScript
DescriptionAttribute("Specifies how the cache is stored.")
DefaultValueAttribute()
CategoryAttribute("Cache")
public function get,set CacheStorage : CacheStorage
Managed Extensions for C++
[DescriptionAttribute("Specifies how the cache is stored.")]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public: __property virtual CacheStorage get_CacheStorage();
public: __property virtual void set_CacheStorage(
   CacheStorage value
);
C++/CLI
[DescriptionAttribute("Specifies how the cache is stored.")]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public:
virtual property CacheStorage CacheStorage {
   CacheStorage get();
   void set (    CacheStorage value);
}

Property Value

One of the CacheStorage values. The default is CacheStorage.PageCache.

Remarks

In ISDataSource.NET you have three options to store the Cache Data.

  • Page Cache
    Page Cache stores the Cache Data in the server's memory. In order to use Page Cache you need to configure the settings on CacheDuration, CacheExpirationPolicy and CachePriority. The CacheDuration indicates the number of seconds the cache storing data before the cache entry is discarded. On the other hand, the CacheExpirationPolicy describes the behavior of the cache in order to release the memory. If the CacheExpirationPolicy is set to Absolute, the cache data will be hold in memory for - at most - the amount of time that is specified by the CacheDuration. The data might be released before the duration time if the memory is needed. If the CacheExpirationPolicy is set to Sliding, the cache expires when there is no activity for a time that is equal to the CacheDuration.
    The CachePriority setting takes affect when When the Web server hosting an ASP.NET application runs low on memory. the PageCache object selectively purges items to free system memory. When an item is added to PageCache, you can assign relative priority / CachePriority compared to other items stored in the cache. Items to which you assign higher priority values are less likely to be deleted from the cache when the server is processing a large number of requests, whereas items to which you assign lower priority values are more likely to be deleted.
  • Session
    Session stores the Cache Data in Session Object. The cache is expired when session is timed out or Session.Abandon() method is called. In order to extend the cache time, simply increase the Session’s timeout value. Session is best used for scenarios when data is scoped based per user/session and when on-demand data retrieval implementation is required.
  • File Server
    File Server stores the Cache Data in a server (physical hard-disk). Using the unique-patterned key generated by ISDataSource.NET the data will be paired and stored in an actual server/machine. You can configure how the cached data is removed from Fileserver through ISDataSource or you can perform it manually from the Fileserver itself. For more information please read Cache Storage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Cache Storage

Tasks

How-to: Use file server for an instance of control
How-to: Configure file server to use shared network drive

Other Resources

Cache Key Pattern


CancelSelectOnNullParameter Property

[image]
ISDataSource Documentation
CancelSelectOnNullParameter Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : CancelSelectOnNullParameter Property

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")>
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
Public Property CancelSelectOnNullParameter As CancelSelectOnNullParameter
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As CancelSelectOnNullParameter

instance.CancelSelectOnNullParameter = value

value = instance.CancelSelectOnNullParameter
C#
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
public CancelSelectOnNullParameter CancelSelectOnNullParameter {get; set;}
Delphi
public read-write property CancelSelectOnNullParameter: CancelSelectOnNullParameter;
JScript
NotifyParentPropertyAttribute()
DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")
DefaultValueAttribute()
CategoryAttribute("Data")
public function get,set CancelSelectOnNullParameter : CancelSelectOnNullParameter
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
public: __property CancelSelectOnNullParameter get_CancelSelectOnNullParameter();
public: __property void set_CancelSelectOnNullParameter(
   CancelSelectOnNullParameter value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
public:
property CancelSelectOnNullParameter CancelSelectOnNullParameter {
   CancelSelectOnNullParameter get();
   void set (    CancelSelectOnNullParameter value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ConflictDetection Property

[image]
ISDataSource Documentation
ConflictDetection Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ConflictDetection Property

Gets or sets a value that determines whether only the new values are passed to the Update method or both the old and new values are passed to the Update method. Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Specifies how data conflicts are resolved.")>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
Public Property ConflictDetection As ISNet.WebUI.ConflictOptions
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As ISNet.WebUI.ConflictOptions

instance.ConflictDetection = value

value = instance.ConflictDetection
C#
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies how data conflicts are resolved.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public ISNet.WebUI.ConflictOptions ConflictDetection {get; set;}
Delphi
public read-write property ConflictDetection: ISNet.WebUI.ConflictOptions;
JScript
NotifyParentPropertyAttribute()
DescriptionAttribute("Specifies how data conflicts are resolved.")
CategoryAttribute("Data")
DefaultValueAttribute()
public function get,set ConflictDetection : ISNet.WebUI.ConflictOptions
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies how data conflicts are resolved.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public: __property ISNet.WebUI.ConflictOptions get_ConflictDetection();
public: __property void set_ConflictDetection(
   ISNet.WebUI.ConflictOptions value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Specifies how data conflicts are resolved.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public:
property ISNet.WebUI.ConflictOptions ConflictDetection {
   ISNet.WebUI.ConflictOptions get();
   void set (    ISNet.WebUI.ConflictOptions value);
}

Property Value

One of the ConflictOptions values. The default is ConflictOptions.OverwriteChanges.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Automatic conflict detection behavior


ConvertNullToDBNull Property

[image]
ISDataSource Documentation
ConvertNullToDBNull Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ConvertNullToDBNull Property

Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
Public Property ConvertNullToDBNull As NullToDBNull
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As NullToDBNull

instance.ConvertNullToDBNull = value

value = instance.ConvertNullToDBNull
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public NullToDBNull ConvertNullToDBNull {get; set;}
Delphi
public read-write property ConvertNullToDBNull: NullToDBNull;
JScript
CategoryAttribute("Data")
DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")
NotifyParentPropertyAttribute()
DefaultValueAttribute()
public function get,set ConvertNullToDBNull : NullToDBNull
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public: __property NullToDBNull get_ConvertNullToDBNull();
public: __property void set_ConvertNullToDBNull(
   NullToDBNull value
);
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
public:
property NullToDBNull ConvertNullToDBNull {
   NullToDBNull get();
   void set (    NullToDBNull value);
}

Property Value

NullToDBNull.No, if any a null reference (Nothing in Visual Basic) values in Parameter objects passed to the ISDataSource control are automatically converted to System.DbNull.Value values; otherwise, NullToDBNull.Yes. The default is NullToDBNull.No.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


EnableCaching Property

[image]
ISDataSource Documentation
EnableCaching Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : EnableCaching Property

Gets or sets a value indicating whether the ISDataSource control has data caching enabled.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Whether caching is enabled for this data source.")>
<DefaultValueAttribute()>
<CategoryAttribute("Cache")>
Public Overridable Property EnableCaching As CacheEnabled
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As CacheEnabled

instance.EnableCaching = value

value = instance.EnableCaching
C#
[DescriptionAttribute("Whether caching is enabled for this data source.")]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public virtual CacheEnabled EnableCaching {get; set;}
Delphi
public read-write property EnableCaching: CacheEnabled; virtual;
JScript
DescriptionAttribute("Whether caching is enabled for this data source.")
DefaultValueAttribute()
CategoryAttribute("Cache")
public function get,set EnableCaching : CacheEnabled
Managed Extensions for C++
[DescriptionAttribute("Whether caching is enabled for this data source.")]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public: __property virtual CacheEnabled get_EnableCaching();
public: __property virtual void set_EnableCaching(
   CacheEnabled value
);
C++/CLI
[DescriptionAttribute("Whether caching is enabled for this data source.")]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public:
virtual property CacheEnabled EnableCaching {
   CacheEnabled get();
   void set (    CacheEnabled value);
}

Property Value

CacheEnabled.Yes if data caching is enabled for the data source control; otherwise, CacheEnabled.No. The default is CacheEnabled.No.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


LoadOnDemand Property

[image]
ISDataSource Documentation
LoadOnDemand Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : LoadOnDemand Property

Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the behavior how the Hierarchical data will be retrieved on demand Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the behavior how the Hierarchical data will be retrieve on demand

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Specifies whether the Hierarchical data will be retrieve on demand. This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Property LoadOnDemand As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As Boolean

instance.LoadOnDemand = value

value = instance.LoadOnDemand
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the Hierarchical data will be retrieve on demand. This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public bool LoadOnDemand {get; set;}
Delphi
public read-write property LoadOnDemand: Boolean;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Specifies whether the Hierarchical data will be retrieve on demand. This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
CategoryAttribute("Behavior")
public function get,set LoadOnDemand : boolean
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the Hierarchical data will be retrieve on demand. This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property bool get_LoadOnDemand();
public: __property void set_LoadOnDemand(
   bool value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies whether the Hierarchical data will be retrieve on demand. This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
property bool LoadOnDemand {
   bool get();
   void set (    bool value);
}

Property Value

true to let ISDataSource perform LoadOnDemand automatically; otherwise, false. The default is false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Load on Demand Data Retrieval

Tasks

Walkthrough: Creating Hierarchical LoadOnDemand using ISDataSource.NET
Walkthrough: Creating SelfReference LoadOnDemand using ISDataSource.NET

Other Resources

Hierarchical Data Retrieval


ParameterOption Property

[image]
ISDataSource Documentation
ParameterOption Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ParameterOption Property

Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior on how the values are passed from Intersoft data-bound controls for Update, Insert and Delete operations. Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior how the values is passed from Intersoft data-bound controls for Update, Insert and Delete operations.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable when ISDataSource is bound to Intersoft data-bound controls.")>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
Public Property ParameterOption As ISNet.WebUI.ParameterOptions
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As ISNet.WebUI.ParameterOptions

instance.ParameterOption = value

value = instance.ParameterOption
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable when ISDataSource is bound to Intersoft data-bound controls.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public ISNet.WebUI.ParameterOptions ParameterOption {get; set;}
Delphi
public read-write property ParameterOption: ISNet.WebUI.ParameterOptions;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable when ISDataSource is bound to Intersoft data-bound controls.")
DefaultValueAttribute()
CategoryAttribute("Behavior")
public function get,set ParameterOption : ISNet.WebUI.ParameterOptions
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable when ISDataSource is bound to Intersoft data-bound controls.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public: __property ISNet.WebUI.ParameterOptions get_ParameterOption();
public: __property void set_ParameterOption(
   ISNet.WebUI.ParameterOptions value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable when ISDataSource is bound to Intersoft data-bound controls.")]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
public:
property ISNet.WebUI.ParameterOptions ParameterOption {
   ISNet.WebUI.ParameterOptions get();
   void set (    ISNet.WebUI.ParameterOptions value);
}

Property Value

One of the ParameterOptions values. The default is ParameterOptions.FromDataSource

Remarks

By default in .NET data-bound controls will pass all textbox fields to DataSource control as InputParameters. This might cause problems since we need to create a DataOperation method signature (Insert/Update/Delete) that match the InputParameters given. ParameterOption can be used determine whether WebGrid.NET will pass all available fields as InputParameters or merge data from available fields (updated data) and original data retrieved previously as InputParameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Parameter Option


RootTable Property

[image]
ISDataSource Documentation
RootTable Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : RootTable Property

Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the RootTable of ISDataSourceTables, which is used for Hierarchical Select in Intersoft WebGrid.NET 5.0+ Note : This feature only useable when ISDataSource is bound to Intersoft WebGrid.NET 5.0+. Gets or sets the RootTable of ISDataSourceTables, which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<DescriptionAttribute("RootTable of ISDataSourceTables. Which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+.")>
<CategoryAttribute("Data")>
Public Property RootTable As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As String

instance.RootTable = value

value = instance.RootTable
C#
[DefaultValueAttribute()]
[DescriptionAttribute("RootTable of ISDataSourceTables. Which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+.")]
[CategoryAttribute("Data")]
public string RootTable {get; set;}
Delphi
public read-write property RootTable: String;
JScript
DefaultValueAttribute()
DescriptionAttribute("RootTable of ISDataSourceTables. Which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+.")
CategoryAttribute("Data")
public function get,set RootTable : String
Managed Extensions for C++
[DefaultValueAttribute()]
[DescriptionAttribute("RootTable of ISDataSourceTables. Which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+.")]
[CategoryAttribute("Data")]
public: __property string* get_RootTable();
public: __property void set_RootTable(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[DescriptionAttribute("RootTable of ISDataSourceTables. Which used for Hierarchical Select in Intersoft WebGrid.NET 5.0+.")]
[CategoryAttribute("Data")]
public:
property String^ RootTable {
   String^ get();
   void set (    String^ value);
}

Property Value

A TableName that identifies the RootTable of ISDataSource control. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Tasks

Walkthrough: Binding to Hierarchical data using ISDataSource.NET

Concepts

Hierarchical Data Retrieval

Other Resources

Load on Demand Data Retrieval


RuntimeLicenseKey Property

[image]
ISDataSource Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : RuntimeLicenseKey Property

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ISNet.PersistLayoutAttribute(False)>
<DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
<NotifyParentPropertyAttribute(True)>
Public Property RuntimeLicenseKey As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[NotifyParentPropertyAttribute(true)]
public string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: String;
JScript
DefaultValueAttribute()
ISNet.PersistLayoutAttribute()
DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
NotifyParentPropertyAttribute()
public function get,set RuntimeLicenseKey : String
Managed Extensions for C++
[DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_RuntimeLicenseKey();
public: __property void set_RuntimeLicenseKey(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
[DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
[NotifyParentPropertyAttribute(true)]
public:
property String^ RuntimeLicenseKey {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


SchemaName Property

[image]
ISDataSource Documentation
SchemaName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : SchemaName Property

Gets or sets the name of the schema that represents the structure of ISDataSource. Gets or sets the name of the schema that represent the structure of ISDataSource.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies where the data-source schema is defined. The schema definition can be from DataSet or CustomObjects which specified in SchemaType property")>
<CategoryAttribute("Schema")>
<DefaultValueAttribute()>
Public Property SchemaName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As String

instance.SchemaName = value

value = instance.SchemaName
C#
[DescriptionAttribute("Specifies where the data-source schema is defined. The schema definition can be from DataSet or CustomObjects which specified in SchemaType property")]
[CategoryAttribute("Schema")]
[DefaultValueAttribute()]
public string SchemaName {get; set;}
Delphi
public read-write property SchemaName: String;
JScript
DescriptionAttribute("Specifies where the data-source schema is defined. The schema definition can be from DataSet or CustomObjects which specified in SchemaType property")
CategoryAttribute("Schema")
DefaultValueAttribute()
public function get,set SchemaName : String
Managed Extensions for C++
[DescriptionAttribute("Specifies where the data-source schema is defined. The schema definition can be from DataSet or CustomObjects which specified in SchemaType property")]
[CategoryAttribute("Schema")]
[DefaultValueAttribute()]
public: __property string* get_SchemaName();
public: __property void set_SchemaName(
   string* value
);
C++/CLI
[DescriptionAttribute("Specifies where the data-source schema is defined. The schema definition can be from DataSet or CustomObjects which specified in SchemaType property")]
[CategoryAttribute("Schema")]
[DefaultValueAttribute()]
public:
property String^ SchemaName {
   String^ get();
   void set (    String^ value);
}

Property Value

A partially or fully qualified class name that identifies the type of the ISDataSource's structure. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Automatic table generation
Step by step wizard


SchemaType Property

[image]
ISDataSource Documentation
SchemaType Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : SchemaType Property

Gets or sets the type of the schema that represents the structure of ISDataSource. Gets or sets the type of the schema that represent the structure of ISDataSource.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the type of schema for the data-source. It can be from DataSet or CustomObjects.")>
<DefaultValueAttribute()>
<CategoryAttribute("Schema")>
Public Property SchemaType As SchemaType
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As SchemaType

instance.SchemaType = value

value = instance.SchemaType
C#
[DescriptionAttribute("Specifies the type of schema for the data-source. It can be from DataSet or CustomObjects.")]
[DefaultValueAttribute()]
[CategoryAttribute("Schema")]
public SchemaType SchemaType {get; set;}
Delphi
public read-write property SchemaType: SchemaType;
JScript
DescriptionAttribute("Specifies the type of schema for the data-source. It can be from DataSet or CustomObjects.")
DefaultValueAttribute()
CategoryAttribute("Schema")
public function get,set SchemaType : SchemaType
Managed Extensions for C++
[DescriptionAttribute("Specifies the type of schema for the data-source. It can be from DataSet or CustomObjects.")]
[DefaultValueAttribute()]
[CategoryAttribute("Schema")]
public: __property SchemaType get_SchemaType();
public: __property void set_SchemaType(
   SchemaType value
);
C++/CLI
[DescriptionAttribute("Specifies the type of schema for the data-source. It can be from DataSet or CustomObjects.")]
[DefaultValueAttribute()]
[CategoryAttribute("Schema")]
public:
property SchemaType SchemaType {
   SchemaType get();
   void set (    SchemaType value);
}

Property Value

One of the SchemaType values. The default is SchemaType.DataSet.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Automatic table generation
Step by step wizard


StoreCachePerPage Property

[image]
ISDataSource Documentation
StoreCachePerPage Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : StoreCachePerPage Property

Gets or sets a value indicating whether the ISDataSource control will store the cached data separately for each page.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Cache")>
<DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")>
<DefaultValueAttribute()>
Public Overridable Property StoreCachePerPage As StoreCachePerPage
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As StoreCachePerPage

instance.StoreCachePerPage = value

value = instance.StoreCachePerPage
C#
[CategoryAttribute("Cache")]
[DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")]
[DefaultValueAttribute()]
public virtual StoreCachePerPage StoreCachePerPage {get; set;}
Delphi
public read-write property StoreCachePerPage: StoreCachePerPage; virtual;
JScript
CategoryAttribute("Cache")
DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")
DefaultValueAttribute()
public function get,set StoreCachePerPage : StoreCachePerPage
Managed Extensions for C++
[CategoryAttribute("Cache")]
[DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")]
[DefaultValueAttribute()]
public: __property virtual StoreCachePerPage get_StoreCachePerPage();
public: __property virtual void set_StoreCachePerPage(
   StoreCachePerPage value
);
C++/CLI
[CategoryAttribute("Cache")]
[DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")]
[DefaultValueAttribute()]
public:
virtual property StoreCachePerPage StoreCachePerPage {
   StoreCachePerPage get();
   void set (    StoreCachePerPage value);
}

Property Value

StoreCachePerPage.Yes if cached data is stored per page; otherwise, StoreCachePerPage.No. The default is StoreCachePerPage.No.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Store Cache per Page


Tables Property

[image]
ISDataSource Documentation
Tables Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Tables Property

Gets the collection of ISDataSourceTables that belongs to ISDataSourceControl Gets collection of ISDataSourceTables that belong to ISDataSourceControl

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Collection of ISDataSourceTables.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public ReadOnly Property Tables As ISDataSourceTableCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As ISDataSourceTableCollection

value = instance.Tables
C#
[CategoryAttribute("Data")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of ISDataSourceTables.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
public ISDataSourceTableCollection Tables {get;}
Delphi
public read-only property Tables: ISDataSourceTableCollection;
JScript
CategoryAttribute("Data")
PersistenceModeAttribute(PersistenceMode.InnerProperty)
NotifyParentPropertyAttribute()
DescriptionAttribute("Collection of ISDataSourceTables.")
ISNet.Serialization.BinarySerializableAttribute()
DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
public function get Tables : ISDataSourceTableCollection
Managed Extensions for C++
[CategoryAttribute("Data")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of ISDataSourceTables.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ISDataSourceTableCollection* get_Tables();
C++/CLI
[CategoryAttribute("Data")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of ISDataSourceTables.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ISDataSourceTableCollection^ Tables {
   ISDataSourceTableCollection^ get();
}

Property Value

Collection of ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


UseCachedDataOnFirstLoad Property

[image]
ISDataSource Documentation
UseCachedDataOnFirstLoad Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : UseCachedDataOnFirstLoad Property

Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled. Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Cache")>
<DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")>
<DefaultValueAttribute()>
Public Overridable Property UseCachedDataOnFirstLoad As UseCachedDataOnFirstLoad
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As UseCachedDataOnFirstLoad

instance.UseCachedDataOnFirstLoad = value

value = instance.UseCachedDataOnFirstLoad
C#
[CategoryAttribute("Cache")]
[DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")]
[DefaultValueAttribute()]
public virtual UseCachedDataOnFirstLoad UseCachedDataOnFirstLoad {get; set;}
Delphi
public read-write property UseCachedDataOnFirstLoad: UseCachedDataOnFirstLoad; virtual;
JScript
CategoryAttribute("Cache")
DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")
DefaultValueAttribute()
public function get,set UseCachedDataOnFirstLoad : UseCachedDataOnFirstLoad
Managed Extensions for C++
[CategoryAttribute("Cache")]
[DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")]
[DefaultValueAttribute()]
public: __property virtual UseCachedDataOnFirstLoad get_UseCachedDataOnFirstLoad();
public: __property virtual void set_UseCachedDataOnFirstLoad(
   UseCachedDataOnFirstLoad value
);
C++/CLI
[CategoryAttribute("Cache")]
[DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")]
[DefaultValueAttribute()]
public:
virtual property UseCachedDataOnFirstLoad UseCachedDataOnFirstLoad {
   UseCachedDataOnFirstLoad get();
   void set (    UseCachedDataOnFirstLoad value);
}

Property Value

UseCachedDataOnFirstLoad.Yes if cached data gonna be used on first load; otherwise, UseCachedDataOnFirstLoad.No. The default is UseCachedDataOnFirstLoad.Yes.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Concepts

Use cached on first load

Tasks

How-to: Configure cache configuration


ISDataSource Class Events

[image]
ISDataSource Documentation
ISDataSource Class Events
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSource Class

For a list of all members of this type, see ISDataSource members.

Public Events

 | Name | Description
public Event | DataBinding | (Inherited from System.Web.UI.Control)
public Event | Deleted | Occurs when a Delete operation has completed.
public Event | Deleting | Occurs before a Delete operation.
public Event | Disposed | (Inherited from System.Web.UI.Control)
public Event | Filtering | Occurs before a filter operation.
public Event | Init | (Inherited from System.Web.UI.Control)
public Event | Inserted | Occurs when an Insert operation has completed.
public Event | Inserting | Occurs before an Insert operation.
public Event | Load | (Inherited from System.Web.UI.Control)
public Event | ObjectCreated | Occurs after the object that is identified by the ISDataSourceTable's TypeName property is created.
public Event | ObjectCreating | Occurs before the object that is identified by the TypeName property is created.
public Event | ObjectDisposing | Occurs before the object that is identified by the TypeName property is discarded.
public Event | PreRender | (Inherited from System.Web.UI.Control)
public Event | Selected | Occurs when a Select operation has completed.
public Event | Selecting | Occurs before a Select operation.
public Event | Unload | (Inherited from System.Web.UI.Control)
public Event | Updated | Occurs when an Update operation has completed.
public Event | Updating | Occurs before an Update operation.
Top

See Also

Reference

ISDataSource Class
ISNet.WebUI.DataSource Namespace


Deleted Event

[image]
ISDataSource Documentation
Deleted Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Deleted Event

Occurs when a Delete operation has completed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Fires when a Delete operation has completed.")>
Public Event Deleted As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Deleted, handler
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires when a Delete operation has completed.")]
public event ISDataSourceStatusEventHandler Deleted
Delphi
public event Deleted: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires when a Delete operation has completed.")]
public: __event ISDataSourceStatusEventHandler* Deleted
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires when a Delete operation has completed.")]
public:
event ISDataSourceStatusEventHandler^ Deleted

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

This event handles the Deleted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Delete operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. The following are important properties available in ISDataSourceStatusEventArgs:

  • AffectedRows. You can use this property to return the number of rows that were deleted from the Delete method
  • ReturnValue. If you return the number of deleted rows from the method that is specified by the DeleteMethod property the value is available from this property.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguished it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Deleted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Delete operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Follows are important properties available in ISDataSourceStatusEventArgs: + AffectedRows You can use this property to return the number of rows that were deleted from the Delete method + ReturnValue If you return the number of deleted rows from the method that is specified by the DeleteMethod property the value is available from this property. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Deleting Event

[image]
ISDataSource Documentation
Deleting Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Deleting Event

Occurs before a Delete operation.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Fires before a Delete operation. ")>
Public Event Deleting As ISDataSourceMethodEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceMethodEventHandler

AddHandler instance.Deleting, handler
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a Delete operation. ")]
public event ISDataSourceMethodEventHandler Deleting
Delphi
public event Deleting: ISDataSourceMethodEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a Delete operation. ")]
public: __event ISDataSourceMethodEventHandler* Deleting
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a Delete operation. ")]
public:
event ISDataSourceMethodEventHandler^ Deleting

Event Data

The event handler receives an argument of type ISDataSourceMethodEventArgs containing data related to this event. The following ISDataSourceMethodEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
InputParameters | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

This event handles the Deleting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the delete operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. You can cancel the delete operation by setting the Cancel property of the ISDataSourceMethodEventArgs to true.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Deleting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the delete operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. You can cancel the delete operation by setting the Cancel property of the ISDataSourceMethodEventArgs to true. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Filtering Event

[image]
ISDataSource Documentation
Filtering Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Filtering Event

Occurs before a filter operation.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Fires before a filter operation. ")>
Public Event Filtering As ISDataSourceFilteringEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceFilteringEventHandler

AddHandler instance.Filtering, handler
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a filter operation. ")]
public event ISDataSourceFilteringEventHandler Filtering
Delphi
public event Filtering: ISDataSourceFilteringEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a filter operation. ")]
public: __event ISDataSourceFilteringEventHandler* Filtering
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a filter operation. ")]
public:
event ISDataSourceFilteringEventHandler^ Filtering

Event Data

The event handler receives an argument of type ISDataSourceFilteringEventArgs containing data related to this event. The following ISDataSourceFilteringEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
ParameterValues | Gets an IOrderedDictionary interface that provides access to the Parameter objects of the ISDataSourceTable class.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Filtering event to perform validation operations on filter parameter values before any ISDataSourceTable of ISDataSource control performs a filter operation. You can cancel the select operation by setting the Cancel property of the ISDataSourceFilteringEventArgs to true. The event is raised only if the FilterExpression property is set. The ISDataSource.Filtering event delegates to the ISDataSourceView.Filtering event of the ISDataSourceView that is associated with the ISDataSourceTable.
Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.
Security Note : You should validate any filter parameter value that you receive from the client. The runtime simply substitutes the parameter value into the filter expression and applies it to the DataView object that is returned by the Select method. If you are using the FilterExpression property as a security measure to limit the number of items that are returned, you must validate the parameter values before the filtering occurs.
Handle the Filtering event to perform validation operations on filter parameter values before any ISDataSourceTable of ISDataSource control performs a filter operation. You can cancel the select operation by setting the Cancel property of the ISDataSourceFilteringEventArgs to true. The event is raised only if the FilterExpression property is set. The ISDataSource.Filtering event delegates to the ISDataSourceView.Filtering event of the ISDataSourceView that is associated with the ISDataSourceTable. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property. Security Note : You should validate any filter parameter value that you receive from the client. The runtime simply substitutes the parameter value into the filter expression and applies it to the DataView object that is returned by the Select method. If you are using the FilterExpression property as a security measure to limit the number of items that are returned, you must validate the parameter values before the filtering occurs.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Inserted Event

[image]
ISDataSource Documentation
Inserted Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Inserted Event

Occurs when an Insert operation has completed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Fires when an Insert operation has completed. ")>
<CategoryAttribute("Data")>
Public Event Inserted As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Inserted, handler
C#
[DescriptionAttribute("Fires when an Insert operation has completed. ")]
[CategoryAttribute("Data")]
public event ISDataSourceStatusEventHandler Inserted
Delphi
public event Inserted: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute("Fires when an Insert operation has completed. ")]
[CategoryAttribute("Data")]
public: __event ISDataSourceStatusEventHandler* Inserted
C++/CLI
[DescriptionAttribute("Fires when an Insert operation has completed. ")]
[CategoryAttribute("Data")]
public:
event ISDataSourceStatusEventHandler^ Inserted

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the Inserted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Insert operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Inserted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Insert operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Inserting Event

[image]
ISDataSource Documentation
Inserting Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Inserting Event

Occurs before an Insert operation.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Fires before an Insert operation. ")>
Public Event Inserting As ISDataSourceMethodEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceMethodEventHandler

AddHandler instance.Inserting, handler
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before an Insert operation. ")]
public event ISDataSourceMethodEventHandler Inserting
Delphi
public event Inserting: ISDataSourceMethodEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before an Insert operation. ")]
public: __event ISDataSourceMethodEventHandler* Inserting
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before an Insert operation. ")]
public:
event ISDataSourceMethodEventHandler^ Inserting

Event Data

The event handler receives an argument of type ISDataSourceMethodEventArgs containing data related to this event. The following ISDataSourceMethodEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
InputParameters | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Inserting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the insert operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object.
Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.
Handle the Inserting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the insert operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ObjectCreated Event

[image]
ISDataSource Documentation
ObjectCreated Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ObjectCreated Event

Occurs after the object that is identified by the ISDataSourceTable's TypeName property is created.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Fires after the object that is identified by the ISDataSourceTable's TypeName property is created. ")>
<CategoryAttribute("Data")>
Public Event ObjectCreated As ISDataSourceObjectEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceObjectEventHandler

AddHandler instance.ObjectCreated, handler
C#
[DescriptionAttribute("Fires after the object that is identified by the ISDataSourceTable's TypeName property is created. ")]
[CategoryAttribute("Data")]
public event ISDataSourceObjectEventHandler ObjectCreated
Delphi
public event ObjectCreated: ISDataSourceObjectEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute("Fires after the object that is identified by the ISDataSourceTable's TypeName property is created. ")]
[CategoryAttribute("Data")]
public: __event ISDataSourceObjectEventHandler* ObjectCreated
C++/CLI
[DescriptionAttribute("Fires after the object that is identified by the ISDataSourceTable's TypeName property is created. ")]
[CategoryAttribute("Data")]
public:
event ISDataSourceObjectEventHandler^ ObjectCreated

Event Data

The event handler receives an argument of type ISDataSourceEventArgs containing data related to this event. The following ISDataSourceEventArgs properties provide information specific to this event.

Property | Description
ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the ObjectCreated event to call other methods on the business object, set properties, or perform other initialization that is specific to the business object before any ISDataSourceTable of ISDataSource control object calls the business object data method to perform a data operation. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object. If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the ObjectCreated event to call other methods on the business object, set properties, or perform other initialization that is specific to the business object before any ISDataSourceTable of ISDataSource control object calls the business object data method to perform a data operation. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object. If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ObjectCreating Event

[image]
ISDataSource Documentation
ObjectCreating Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ObjectCreating Event

Occurs before the object that is identified by the TypeName property is created.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Fires before the object that is identified by the TypeName property is created. ")>
<CategoryAttribute("Data")>
Public Event ObjectCreating As ISDataSourceObjectEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceObjectEventHandler

AddHandler instance.ObjectCreating, handler
C#
[DescriptionAttribute("Fires before the object that is identified by the TypeName property is created. ")]
[CategoryAttribute("Data")]
public event ISDataSourceObjectEventHandler ObjectCreating
Delphi
public event ObjectCreating: ISDataSourceObjectEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute("Fires before the object that is identified by the TypeName property is created. ")]
[CategoryAttribute("Data")]
public: __event ISDataSourceObjectEventHandler* ObjectCreating
C++/CLI
[DescriptionAttribute("Fires before the object that is identified by the TypeName property is created. ")]
[CategoryAttribute("Data")]
public:
event ISDataSourceObjectEventHandler^ ObjectCreating

Event Data

The event handler receives an argument of type ISDataSourceEventArgs containing data related to this event. The following ISDataSourceEventArgs properties provide information specific to this event.

Property | Description
ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised. The corresponding ISDataSourceTable automatically calls the default constructor of a business object to create and instance of it using reflection. Handle the ObjectCreating event to explicitly call another constructor, and set the instance of the object that result to the ObjectInstance property of the associated ISDataSourceEventArgs object.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised. The corresponding ISDataSourceTable automatically calls the default constructor of a business object to create and instance of it using reflection. Handle the ObjectCreating event to explicitly call another constructor, and set the instance of the object that results to the ObjectInstance property of the associated ISDataSourceEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ObjectDisposing Event

[image]
ISDataSource Documentation
ObjectDisposing Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ObjectDisposing Event

Occurs before the object that is identified by the TypeName property is discarded.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Fires before the object that is identified by the TypeName property is discarded. ")>
Public Event ObjectDisposing As ISDataSourceDisposingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceDisposingEventHandler

AddHandler instance.ObjectDisposing, handler
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before the object that is identified by the TypeName property is discarded. ")]
public event ISDataSourceDisposingEventHandler ObjectDisposing
Delphi
public event ObjectDisposing: ISDataSourceDisposingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before the object that is identified by the TypeName property is discarded. ")]
public: __event ISDataSourceDisposingEventHandler* ObjectDisposing
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before the object that is identified by the TypeName property is discarded. ")]
public:
event ISDataSourceDisposingEventHandler^ ObjectDisposing

Event Data

The event handler receives an argument of type ISDataSourceDisposingEventArgs containing data related to this event. The following ISDataSourceDisposingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

The ObjectDisposing event is always raised before the instance of the business object is discarded. If the business object implements the IDisposable interface, the Dispose method is called after this event is raised. Handle the ObjectDisposing event to call other methods on the object, set properties, or perform clean-up that is specific to the object before the object is destroyed. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object.
Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.
The ObjectDisposing event is always raised before the instance of the business object is discarded. If the business object implements the IDisposable interface, the Dispose method is called after this event is raised. Handle the ObjectDisposing event to call other methods on the object, set properties, or perform clean-up that is specific to the object before the object is destroyed. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Selected Event

[image]
ISDataSource Documentation
Selected Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Selected Event

Occurs when a Select operation has completed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Fires when a Select operation has completed. ")>
<CategoryAttribute("Data")>
Public Event Selected As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Selected, handler
C#
[DescriptionAttribute("Fires when a Select operation has completed. ")]
[CategoryAttribute("Data")]
public event ISDataSourceStatusEventHandler Selected
Delphi
public event Selected: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute("Fires when a Select operation has completed. ")]
[CategoryAttribute("Data")]
public: __event ISDataSourceStatusEventHandler* Selected
C++/CLI
[DescriptionAttribute("Fires when a Select operation has completed. ")]
[CategoryAttribute("Data")]
public:
event ISDataSourceStatusEventHandler^ Selected

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the Selected event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Select operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Selected event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Select operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Selecting Event

[image]
ISDataSource Documentation
Selecting Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Selecting Event

Occurs before a Select operation.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Fires before a Select operation. ")>
Public Event Selecting As ISDataSourceSelectingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceSelectingEventHandler

AddHandler instance.Selecting, handler
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a Select operation. ")]
public event ISDataSourceSelectingEventHandler Selecting
Delphi
public event Selecting: ISDataSourceSelectingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a Select operation. ")]
public: __event ISDataSourceSelectingEventHandler* Selecting
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before a Select operation. ")]
public:
event ISDataSourceSelectingEventHandler^ Selecting

Event Data

The event handler receives an argument of type ISDataSourceSelectingEventArgs containing data related to this event. The following ISDataSourceSelectingEventArgs properties provide information specific to this event.

Property | Description
Arguments | Provides a mechanism that the ISDataSourceTable object can use to request data-related operations when data is retrieved.
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
ExecutingSelectCount | Gets a value indicating whether the ISDataSourceTable is retrieving a row count during a data retrieval operation.
InputParameters (Inherited from ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs) | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Selecting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the data retrieval operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. This event can be fired twice for a single call to the Select method, if the SelectCountMethod property is set. The ExecutingSelectCount property of the ISDataSourceSelectingEventArgs object is used to determine if select was called to retrieve data or retrieve the count.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Selecting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the data retrieval operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. This event can be fired twice for a single call to the Select method, if the SelectCountMethod property is set. The ExecutingSelectCount property of the ISDataSourceSelectingEventArgs object is used to determine if select was called to retrieve data or retrieve the count. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members

Tasks

How-to: Use ISDataSource.NET event handlers


Updated Event

[image]
ISDataSource Documentation
Updated Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Updated Event

Occurs when an Update operation has completed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Fires when an Update operation has completed.")>
<CategoryAttribute("Data")>
Public Event Updated As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Updated, handler
C#
[DescriptionAttribute("Fires when an Update operation has completed.")]
[CategoryAttribute("Data")]
public event ISDataSourceStatusEventHandler Updated
Delphi
public event Updated: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[DescriptionAttribute("Fires when an Update operation has completed.")]
[CategoryAttribute("Data")]
public: __event ISDataSourceStatusEventHandler* Updated
C++/CLI
[DescriptionAttribute("Fires when an Update operation has completed.")]
[CategoryAttribute("Data")]
public:
event ISDataSourceStatusEventHandler^ Updated

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the Updated event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Update operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Updated event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Update operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Updating Event

[image]
ISDataSource Documentation
Updating Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Updating Event

Occurs before an Update operation.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Data")>
<DescriptionAttribute("Fires before an Update operation. ")>
Public Event Updating As ISDataSourceMethodEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As ISDataSourceMethodEventHandler

AddHandler instance.Updating, handler
C#
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before an Update operation. ")]
public event ISDataSourceMethodEventHandler Updating
Delphi
public event Updating: ISDataSourceMethodEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before an Update operation. ")]
public: __event ISDataSourceMethodEventHandler* Updating
C++/CLI
[CategoryAttribute("Data")]
[DescriptionAttribute("Fires before an Update operation. ")]
public:
event ISDataSourceMethodEventHandler^ Updating

Event Data

The event handler receives an argument of type ISDataSourceMethodEventArgs containing data related to this event. The following ISDataSourceMethodEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
InputParameters | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Updating event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the update operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Updating event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the update operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ISDataSourceCancelEventArgsBase Class

[image]
ISDataSource Documentation
ISDataSourceCancelEventArgsBase Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceCancelEventArgsBase Class

Provides data for other arguments that inherited from ISDataSourceCancelEventArgsBase

Object Model

ISDataSourceCancelEventArgsBase Class

Syntax

Visual Basic (Declaration)
Public Class ISDataSourceCancelEventArgsBase
   Inherits System.ComponentModel.CancelEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceCancelEventArgsBase
C#
public class ISDataSourceCancelEventArgsBase : System.ComponentModel.CancelEventArgs
Delphi
public class ISDataSourceCancelEventArgsBase = class(System.ComponentModel.CancelEventArgs)
JScript
public class ISDataSourceCancelEventArgsBase extends System.ComponentModel.CancelEventArgs
Managed Extensions for C++
public __gc class ISDataSourceCancelEventArgsBase : public System.ComponentModel.CancelEventArgs
C++/CLI
public ref class ISDataSourceCancelEventArgsBase : public System.ComponentModel.CancelEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceDisposingEventArgs
ISNet.WebUI.DataSource.ISDataSourceFilteringEventArgs
ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceCancelEventArgsBase Members
ISNet.WebUI.DataSource Namespace


ISDataSourceCancelEventArgsBase Class Members

[image]
ISDataSource Documentation
ISDataSourceCancelEventArgsBase Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceCancelEventArgsBase Class

The following tables list the members exposed by ISDataSourceCancelEventArgsBase.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceCancelEventArgsBase Constructor | Provides data for ISDataSource cancelable event.
Top

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations.
Top

See Also

Reference

ISDataSourceCancelEventArgsBase Class
ISNet.WebUI.DataSource Namespace


ISDataSourceCancelEventArgsBase Constructor

[image]
ISDataSource Documentation
ISDataSourceCancelEventArgsBase Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceCancelEventArgsBase Class : ISDataSourceCancelEventArgsBase Constructor

viewName
A value that represents the ISDataSourceTable
Provides data for ISDataSource cancelable event.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal viewName As String _
)
Visual Basic (Usage) Copy Code
Dim viewName As String

Dim instance As New ISDataSourceCancelEventArgsBase(viewName)
C#
public ISDataSourceCancelEventArgsBase(
   string viewName
)
Delphi
public ISDataSourceCancelEventArgsBase(
    viewName: String
);
JScript
public function ISDataSourceCancelEventArgsBase(
   viewName : String
);
Managed Extensions for C++
public: ISDataSourceCancelEventArgsBase(
   string* viewName
)
C++/CLI
public:
ISDataSourceCancelEventArgsBase(
   String^ viewName
)

Parameters

viewName
A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceCancelEventArgsBase Class
ISDataSourceCancelEventArgsBase Members


ISDataSourceCancelEventArgsBase Class Properties

[image]
ISDataSource Documentation
ISDataSourceCancelEventArgsBase Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceCancelEventArgsBase Class

For a list of all members of this type, see ISDataSourceCancelEventArgsBase members.

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations.
Top

See Also

Reference

ISDataSourceCancelEventArgsBase Class
ISNet.WebUI.DataSource Namespace


ViewName Property

[image]
ISDataSource Documentation
ViewName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceCancelEventArgsBase Class : ViewName Property

Gets an value that represents the ISDataSourceTable which performs data operations.

Syntax

Visual Basic (Declaration)
Public Property ViewName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceCancelEventArgsBase
Dim value As String

instance.ViewName = value

value = instance.ViewName
C#
public string ViewName {get; set;}
Delphi
public read-write property ViewName: String;
JScript
public function get,set ViewName : String
Managed Extensions for C++
public: __property string* get_ViewName();
public: __property void set_ViewName(
   string* value
);
C++/CLI
public:
property String^ ViewName {
   String^ get();
   void set (    String^ value);
}

Property Value

A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceCancelEventArgsBase Class
ISDataSourceCancelEventArgsBase Members


ISDataSourceDisposingEventArgs Class

[image]
ISDataSource Documentation
ISDataSourceDisposingEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceDisposingEventArgs Class

Provides data for the ObjectDisposing event of the ISDataSource control.

Object Model

ISDataSourceDisposingEventArgs Class

Syntax

Visual Basic (Declaration)
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class ISDataSourceDisposingEventArgs
   Inherits ISDataSourceCancelEventArgsBase
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceDisposingEventArgs
C#
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class ISDataSourceDisposingEventArgs : ISDataSourceCancelEventArgsBase
Delphi
public class ISDataSourceDisposingEventArgs = class(ISDataSourceCancelEventArgsBase)
JScript
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class ISDataSourceDisposingEventArgs extends ISDataSourceCancelEventArgsBase
Managed Extensions for C++
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class ISDataSourceDisposingEventArgs : public ISDataSourceCancelEventArgsBase
C++/CLI
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class ISDataSourceDisposingEventArgs : public ISDataSourceCancelEventArgsBase

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceDisposingEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceDisposingEventArgs Members
ISNet.WebUI.DataSource Namespace


ISDataSourceDisposingEventArgs Class Members

[image]
ISDataSource Documentation
ISDataSourceDisposingEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceDisposingEventArgs Class

The following tables list the members exposed by ISDataSourceDisposingEventArgs.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceDisposingEventArgs Constructor | Provides data for the ObjectDisposing event of the ISDataSource control.
Top

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceDisposingEventArgs Class
ISNet.WebUI.DataSource Namespace


ISDataSourceDisposingEventArgs Constructor

[image]
ISDataSource Documentation
ISDataSourceDisposingEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceDisposingEventArgs Class : ISDataSourceDisposingEventArgs Constructor

objectInstance
The business object the ISDataSourceTable uses to data operations; otherwise, a null reference (Nothing in Visual Basic), if a null reference (Nothing in Visual Basic) is passed to the ISDataSourceEventArgs
viewName
A value that represents the ISDataSourceTable
Provides data for the ObjectDisposing event of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objectInstance As Object, _
   ByVal viewName As String _
)
Visual Basic (Usage) Copy Code
Dim objectInstance As Object
Dim viewName As String

Dim instance As New ISDataSourceDisposingEventArgs(objectInstance, viewName)
C#
public ISDataSourceDisposingEventArgs(
   object objectInstance,
   string viewName
)
Delphi
public ISDataSourceDisposingEventArgs(
    objectInstance: TObject;
    viewName: String
);
JScript
public function ISDataSourceDisposingEventArgs(
   objectInstance : Object,
   viewName : String
);
Managed Extensions for C++
public: ISDataSourceDisposingEventArgs(
   Object* objectInstance,
   string* viewName
)
C++/CLI
public:
ISDataSourceDisposingEventArgs(
   Object^ objectInstance,
   String^ viewName
)

Parameters

objectInstance
The business object the ISDataSourceTable uses to data operations; otherwise, a null reference (Nothing in Visual Basic), if a null reference (Nothing in Visual Basic) is passed to the ISDataSourceEventArgs
viewName
A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceDisposingEventArgs Class
ISDataSourceDisposingEventArgs Members


ISDataSourceDisposingEventArgs Class Properties

[image]
ISDataSource Documentation
ISDataSourceDisposingEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceDisposingEventArgs Class

For a list of all members of this type, see ISDataSourceDisposingEventArgs members.

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceDisposingEventArgs Class
ISNet.WebUI.DataSource Namespace


ObjectInstance Property

[image]
ISDataSource Documentation
ObjectInstance Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceDisposingEventArgs Class : ObjectInstance Property

Gets an object that represents the business object with which the ISDataSourceTable performs data operations.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ObjectInstance As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceDisposingEventArgs
Dim value As Object

value = instance.ObjectInstance
C#
public object ObjectInstance {get;}
Delphi
public read-only property ObjectInstance: TObject;
JScript
public function get ObjectInstance : Object
Managed Extensions for C++
public: __property Object* get_ObjectInstance();
C++/CLI
public:
property Object^ ObjectInstance {
   Object^ get();
}

Property Value

The business object the ISDataSourceTable uses to data operations; otherwise, a null reference (Nothing in Visual Basic), if a null reference (Nothing in Visual Basic) is passed to the ISDataSourceEventArgs.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceDisposingEventArgs Class
ISDataSourceDisposingEventArgs Members


ISDataSourceEventArgs Class

[image]
ISDataSource Documentation
ISDataSourceEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceEventArgs Class

Provides data for the ObjectCreating and ObjectCreated events of the ISDataSource control.

Object Model

ISDataSourceEventArgs Class

Syntax

Visual Basic (Declaration)
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class ISDataSourceEventArgs
   Inherits ISDataSourceEventArgsBase
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceEventArgs
C#
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class ISDataSourceEventArgs : ISDataSourceEventArgsBase
Delphi
public class ISDataSourceEventArgs = class(ISDataSourceEventArgsBase)
JScript
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class ISDataSourceEventArgs extends ISDataSourceEventArgsBase
Managed Extensions for C++
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class ISDataSourceEventArgs : public ISDataSourceEventArgsBase
C++/CLI
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class ISDataSourceEventArgs : public ISDataSourceEventArgsBase

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.DataSource.ISDataSourceEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceEventArgs Members
ISNet.WebUI.DataSource Namespace


ISDataSourceEventArgs Class Members

[image]
ISDataSource Documentation
ISDataSourceEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceEventArgs Class

The following tables list the members exposed by ISDataSourceEventArgs.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceEventArgs Constructor | Initializes a new instance of the ISDataSourceEventArgs class using the specified object.
Top

Public Properties

 | Name | Description
public Property | ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
public Property | ViewName | Gets an value that represents the ViewName which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase)
Top

See Also

Reference

ISDataSourceEventArgs Class
ISNet.WebUI.DataSource Namespace


ISDataSourceEventArgs Constructor

[image]
ISDataSource Documentation
ISDataSourceEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceEventArgs Class : ISDataSourceEventArgs Constructor

objectInstance
The business object with which the ISDataSource interacts to perform data operations.
viewName
A value that represents the ISDataSourceTable
Initializes a new instance of the ISDataSourceEventArgs class using the specified object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal objectInstance As Object, _
   ByVal viewName As String _
)
Visual Basic (Usage) Copy Code
Dim objectInstance As Object
Dim viewName As String

Dim instance As New ISDataSourceEventArgs(objectInstance, viewName)
C#
public ISDataSourceEventArgs(
   object objectInstance,
   string viewName
)
Delphi
public ISDataSourceEventArgs(
    objectInstance: TObject;
    viewName: String
);
JScript
public function ISDataSourceEventArgs(
   objectInstance : Object,
   viewName : String
);
Managed Extensions for C++
public: ISDataSourceEventArgs(
   Object* objectInstance,
   string* viewName
)
C++/CLI
public:
ISDataSourceEventArgs(
   Object^ objectInstance,
   String^ viewName
)

Parameters

objectInstance
The business object with which the ISDataSource interacts to perform data operations.
viewName
A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceEventArgs Class
ISDataSourceEventArgs Members


ISDataSourceEventArgs Class Properties

[image]
ISDataSource Documentation
ISDataSourceEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceEventArgs Class

For a list of all members of this type, see ISDataSourceEventArgs members.

Public Properties

 | Name | Description
public Property | ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
public Property | ViewName | Gets an value that represents the ViewName which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase)
Top

See Also

Reference

ISDataSourceEventArgs Class
ISNet.WebUI.DataSource Namespace


ObjectInstance Property

[image]
ISDataSource Documentation
ObjectInstance Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceEventArgs Class : ObjectInstance Property

Gets an object that represents the business object with which the ISDataSourceTable performs data operations.

Syntax

Visual Basic (Declaration)
Public Property ObjectInstance As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceEventArgs
Dim value As Object

instance.ObjectInstance = value

value = instance.ObjectInstance
C#
public object ObjectInstance {get; set;}
Delphi
public read-write property ObjectInstance: TObject;
JScript
public function get,set ObjectInstance : Object
Managed Extensions for C++
public: __property Object* get_ObjectInstance();
public: __property void set_ObjectInstance(
   Object* value
);
C++/CLI
public:
property Object^ ObjectInstance {
   Object^ get();
   void set (    Object^ value);
}

Property Value

The business object the ISDataSourceTable uses to data operations; otherwise, a null reference (Nothing in Visual Basic), ] if a null reference (Nothing in Visual Basic) is passed to the ISDataSourceEventArgs.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceEventArgs Class
ISDataSourceEventArgs Members


ISDataSourceEventArgsBase Class

[image]
ISDataSource Documentation
ISDataSourceEventArgsBase Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceEventArgsBase Class

Provides data for other arguments that inherited from ISDataSourceEventArgsBase

Object Model

ISDataSourceEventArgsBase Class

Syntax

Visual Basic (Declaration)
Public Class ISDataSourceEventArgsBase
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceEventArgsBase
C#
public class ISDataSourceEventArgsBase : System.EventArgs
Delphi
public class ISDataSourceEventArgsBase = class(System.EventArgs)
JScript
public class ISDataSourceEventArgsBase extends System.EventArgs
Managed Extensions for C++
public __gc class ISDataSourceEventArgsBase : public System.EventArgs
C++/CLI
public ref class ISDataSourceEventArgsBase : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.DataSource.ISDataSourceEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceEventArgs
ISNet.WebUI.DataSource.ISDataSourceStatusEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceEventArgsBase Members
ISNet.WebUI.DataSource Namespace


ISDataSourceEventArgsBase Class Members

[image]
ISDataSource Documentation
ISDataSourceEventArgsBase Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceEventArgsBase Class

The following tables list the members exposed by ISDataSourceEventArgsBase.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceEventArgsBase Constructor | Initializes a new instance of the ISDataSourceEventArgs class using the specified object.
Top

Public Properties

 | Name | Description
public Property | ViewName | Gets an value that represents the ViewName which performs data operations.
Top

See Also

Reference

ISDataSourceEventArgsBase Class
ISNet.WebUI.DataSource Namespace


ISDataSourceEventArgsBase Constructor

[image]
ISDataSource Documentation
ISDataSourceEventArgsBase Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceEventArgsBase Class : ISDataSourceEventArgsBase Constructor

viewName
A value that represents the ISDataSourceTable
Initializes a new instance of the ISDataSourceEventArgs class using the specified object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal viewName As String _
)
Visual Basic (Usage) Copy Code
Dim viewName As String

Dim instance As New ISDataSourceEventArgsBase(viewName)
C#
public ISDataSourceEventArgsBase(
   string viewName
)
Delphi
public ISDataSourceEventArgsBase(
    viewName: String
);
JScript
public function ISDataSourceEventArgsBase(
   viewName : String
);
Managed Extensions for C++
public: ISDataSourceEventArgsBase(
   string* viewName
)
C++/CLI
public:
ISDataSourceEventArgsBase(
   String^ viewName
)

Parameters

viewName
A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceEventArgsBase Class
ISDataSourceEventArgsBase Members


ISDataSourceEventArgsBase Class Properties

[image]
ISDataSource Documentation
ISDataSourceEventArgsBase Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceEventArgsBase Class

For a list of all members of this type, see ISDataSourceEventArgsBase members.

Public Properties

 | Name | Description
public Property | ViewName | Gets an value that represents the ViewName which performs data operations.
Top

See Also

Reference

ISDataSourceEventArgsBase Class
ISNet.WebUI.DataSource Namespace


ViewName Property

[image]
ISDataSource Documentation
ViewName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceEventArgsBase Class : ViewName Property

Gets an value that represents the ViewName which performs data operations.

Syntax

Visual Basic (Declaration)
Public Property ViewName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceEventArgsBase
Dim value As String

instance.ViewName = value

value = instance.ViewName
C#
public string ViewName {get; set;}
Delphi
public read-write property ViewName: String;
JScript
public function get,set ViewName : String
Managed Extensions for C++
public: __property string* get_ViewName();
public: __property void set_ViewName(
   string* value
);
C++/CLI
public:
property String^ ViewName {
   String^ get();
   void set (    String^ value);
}

Property Value

A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceEventArgsBase Class
ISDataSourceEventArgsBase Members


ISDataSourceFilteringEventArgs Class

[image]
ISDataSource Documentation
ISDataSourceFilteringEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceFilteringEventArgs Class

Provides data for the Filtering event of the ISDataSource control.

Object Model

ISDataSourceFilteringEventArgs Class

Syntax

Visual Basic (Declaration)
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class ISDataSourceFilteringEventArgs
   Inherits ISDataSourceCancelEventArgsBase
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceFilteringEventArgs
C#
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class ISDataSourceFilteringEventArgs : ISDataSourceCancelEventArgsBase
Delphi
public class ISDataSourceFilteringEventArgs = class(ISDataSourceCancelEventArgsBase)
JScript
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class ISDataSourceFilteringEventArgs extends ISDataSourceCancelEventArgsBase
Managed Extensions for C++
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class ISDataSourceFilteringEventArgs : public ISDataSourceCancelEventArgsBase
C++/CLI
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class ISDataSourceFilteringEventArgs : public ISDataSourceCancelEventArgsBase

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceFilteringEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceFilteringEventArgs Members
ISNet.WebUI.DataSource Namespace


ISDataSourceFilteringEventArgs Class Members

[image]
ISDataSource Documentation
ISDataSourceFilteringEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceFilteringEventArgs Class

The following tables list the members exposed by ISDataSourceFilteringEventArgs.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceFilteringEventArgs Constructor | Initializes a new instance of the ISDataSourceFilteringEventArgs class using the specified object.
Top

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ParameterValues | Gets an IOrderedDictionary interface that provides access to the Parameter objects of the ISDataSourceTable class.
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceFilteringEventArgs Class
ISNet.WebUI.DataSource Namespace


ISDataSourceFilteringEventArgs Constructor

[image]
ISDataSource Documentation
ISDataSourceFilteringEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceFilteringEventArgs Class : ISDataSourceFilteringEventArgs Constructor

parameterValues
An IOrderedDictionary of Parameter objects.
viewName
A value that represents the ISDataSourceTable
Initializes a new instance of the ISDataSourceFilteringEventArgs class using the specified object.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parameterValues As IOrderedDictionary, _
   ByVal viewName As String _
)
Visual Basic (Usage) Copy Code
Dim parameterValues As IOrderedDictionary
Dim viewName As String

Dim instance As New ISDataSourceFilteringEventArgs(parameterValues, viewName)
C#
public ISDataSourceFilteringEventArgs(
   IOrderedDictionary parameterValues,
   string viewName
)
Delphi
public ISDataSourceFilteringEventArgs(
    parameterValues: IOrderedDictionary;
    viewName: String
);
JScript
public function ISDataSourceFilteringEventArgs(
   parameterValues : IOrderedDictionary,
   viewName : String
);
Managed Extensions for C++
public: ISDataSourceFilteringEventArgs(
   IOrderedDictionary* parameterValues,
   string* viewName
)
C++/CLI
public:
ISDataSourceFilteringEventArgs(
   IOrderedDictionary^ parameterValues,
   String^ viewName
)

Parameters

parameterValues
An IOrderedDictionary of Parameter objects.
viewName
A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceFilteringEventArgs Class
ISDataSourceFilteringEventArgs Members


ISDataSourceFilteringEventArgs Class Properties

[image]
ISDataSource Documentation
ISDataSourceFilteringEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceFilteringEventArgs Class

For a list of all members of this type, see ISDataSourceFilteringEventArgs members.

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ParameterValues | Gets an IOrderedDictionary interface that provides access to the Parameter objects of the ISDataSourceTable class.
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceFilteringEventArgs Class
ISNet.WebUI.DataSource Namespace


ParameterValues Property

[image]
ISDataSource Documentation
ParameterValues Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceFilteringEventArgs Class : ParameterValues Property

Gets an IOrderedDictionary interface that provides access to the Parameter objects of the ISDataSourceTable class.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ParameterValues As IOrderedDictionary
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceFilteringEventArgs
Dim value As IOrderedDictionary

value = instance.ParameterValues
C#
public IOrderedDictionary ParameterValues {get;}
Delphi
public read-only property ParameterValues: IOrderedDictionary;
JScript
public function get ParameterValues : IOrderedDictionary
Managed Extensions for C++
public: __property IOrderedDictionary* get_ParameterValues();
C++/CLI
public:
property IOrderedDictionary^ ParameterValues {
   IOrderedDictionary^ get();
}

Property Value

An IOrderedDictionary of Parameter objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceFilteringEventArgs Class
ISDataSourceFilteringEventArgs Members


ISDataSourceMethodEventArgs Class

[image]
ISDataSource Documentation
ISDataSourceMethodEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceMethodEventArgs Class

Provides data for the Inserting, Updating, and Deleting events of the ISDataSource control.

Object Model

ISDataSourceMethodEventArgs Class

Syntax

Visual Basic (Declaration)
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class ISDataSourceMethodEventArgs
   Inherits ISDataSourceCancelEventArgsBase
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceMethodEventArgs
C#
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class ISDataSourceMethodEventArgs : ISDataSourceCancelEventArgsBase
Delphi
public class ISDataSourceMethodEventArgs = class(ISDataSourceCancelEventArgsBase)
JScript
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class ISDataSourceMethodEventArgs extends ISDataSourceCancelEventArgsBase
Managed Extensions for C++
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class ISDataSourceMethodEventArgs : public ISDataSourceCancelEventArgsBase
C++/CLI
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class ISDataSourceMethodEventArgs : public ISDataSourceCancelEventArgsBase

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs
ISNet.WebUI.DataSource.ISDataSourceSelectingEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceMethodEventArgs Members
ISNet.WebUI.DataSource Namespace


ISDataSourceMethodEventArgs Class Members

[image]
ISDataSource Documentation
ISDataSourceMethodEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceMethodEventArgs Class

The following tables list the members exposed by ISDataSourceMethodEventArgs.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceMethodEventArgs Constructor | Provides data for the Inserting, Updating, and Deleting events of the ISDataSource control.
Top

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | InputParameters | Gets a collection that contains business object method parameters and their values.
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceMethodEventArgs Class
ISNet.WebUI.DataSource Namespace


ISDataSourceMethodEventArgs Constructor

[image]
ISDataSource Documentation
ISDataSourceMethodEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceMethodEventArgs Class : ISDataSourceMethodEventArgs Constructor

inputParameters
An IDictionary of name/value pairs that represent the business object method parameters and their corresponding values.
viewName
A value that represents the ISDataSourceTable
Provides data for the Inserting, Updating, and Deleting events of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inputParameters As IOrderedDictionary, _
   ByVal viewName As String _
)
Visual Basic (Usage) Copy Code
Dim inputParameters As IOrderedDictionary
Dim viewName As String

Dim instance As New ISDataSourceMethodEventArgs(inputParameters, viewName)
C#
public ISDataSourceMethodEventArgs(
   IOrderedDictionary inputParameters,
   string viewName
)
Delphi
public ISDataSourceMethodEventArgs(
    inputParameters: IOrderedDictionary;
    viewName: String
);
JScript
public function ISDataSourceMethodEventArgs(
   inputParameters : IOrderedDictionary,
   viewName : String
);
Managed Extensions for C++
public: ISDataSourceMethodEventArgs(
   IOrderedDictionary* inputParameters,
   string* viewName
)
C++/CLI
public:
ISDataSourceMethodEventArgs(
   IOrderedDictionary^ inputParameters,
   String^ viewName
)

Parameters

inputParameters
An IDictionary of name/value pairs that represent the business object method parameters and their corresponding values.
viewName
A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceMethodEventArgs Class
ISDataSourceMethodEventArgs Members


ISDataSourceMethodEventArgs Class Properties

[image]
ISDataSource Documentation
ISDataSourceMethodEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceMethodEventArgs Class

For a list of all members of this type, see ISDataSourceMethodEventArgs members.

Public Properties

 | Name | Description
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | InputParameters | Gets a collection that contains business object method parameters and their values.
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceMethodEventArgs Class
ISNet.WebUI.DataSource Namespace


InputParameters Property

[image]
ISDataSource Documentation
InputParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceMethodEventArgs Class : InputParameters Property

Gets a collection that contains business object method parameters and their values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InputParameters As IOrderedDictionary
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceMethodEventArgs
Dim value As IOrderedDictionary

value = instance.InputParameters
C#
public IOrderedDictionary InputParameters {get;}
Delphi
public read-only property InputParameters: IOrderedDictionary;
JScript
public function get InputParameters : IOrderedDictionary
Managed Extensions for C++
public: __property IOrderedDictionary* get_InputParameters();
C++/CLI
public:
property IOrderedDictionary^ InputParameters {
   IOrderedDictionary^ get();
}

Property Value

An IDictionary of name/value pairs that represent the business object method parameters and their corresponding values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceMethodEventArgs Class
ISDataSourceMethodEventArgs Members


ISDataSourceObjectRelation Class

[image]
ISDataSource Documentation
ISDataSourceObjectRelation Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceObjectRelation Class

Represent a CustomObject relation.

Object Model

ISDataSourceObjectRelation Class

Syntax

Visual Basic (Declaration)
Public Class ISDataSourceObjectRelation
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceObjectRelation
C#
public class ISDataSourceObjectRelation
Delphi
public class ISDataSourceObjectRelation
JScript
public class ISDataSourceObjectRelation
Managed Extensions for C++
public __gc class ISDataSourceObjectRelation
C++/CLI
public ref class ISDataSourceObjectRelation

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSource.ISDataSourceObjectRelation

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceObjectRelation Members
ISNet.WebUI.DataSource Namespace


ISDataSourceObjectRelation Class Members

[image]
ISDataSource Documentation
ISDataSourceObjectRelation Class Members
See Also Methods Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceObjectRelation Class

The following tables list the members exposed by ISDataSourceObjectRelation.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceObjectRelation Constructor | Overloaded.
Top

Public Methods

 | Name | Description
public Method | SetParentObjectType | Set the parent object type for this relation.
Top

See Also

Reference

ISDataSourceObjectRelation Class
ISNet.WebUI.DataSource Namespace


ISDataSourceObjectRelation Constructor

[image]
ISDataSource Documentation
ISDataSourceObjectRelation Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceObjectRelation Class : ISDataSourceObjectRelation Constructor

Overload List

Overload | Description
ISDataSourceObjectRelation Constructor(Type,String,String,Type,String) | Initialize new instance of ISDataSourceObjectRelation class
ISDataSourceObjectRelation Constructor(Type,String[],String,Type,String[]) | Initialize new instance of ISDataSourceObjectRelation class

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceObjectRelation Class
ISDataSourceObjectRelation Members


ISDataSourceObjectRelation Constructor(Type,String,String,Type,String)

[image]
ISDataSource Documentation
ISDataSourceObjectRelation Constructor(Type,String,String,Type,String)
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceObjectRelation Class > ISDataSourceObjectRelation Constructor : ISDataSourceObjectRelation Constructor(Type,String,String,Type,String)

parentObjectType
the type of parent object class
parentMember
parent member name(must be one of public property from parent object)
childCollectionProperty
the name of child collection property
childObjectType
the type of child object class
childMember
child member name(must be one of public property from child object)
Initialize new instance of ISDataSourceObjectRelation class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentObjectType As Type, _
   ByVal parentMember As String, _
   ByVal childCollectionProperty As String, _
   ByVal childObjectType As Type, _
   ByVal childMember As String _
)
Visual Basic (Usage) Copy Code
Dim parentObjectType As Type
Dim parentMember As String
Dim childCollectionProperty As String
Dim childObjectType As Type
Dim childMember As String

Dim instance As New ISDataSourceObjectRelation(parentObjectType, parentMember, childCollectionProperty, childObjectType, childMember)
C#
public ISDataSourceObjectRelation(
   Type parentObjectType,
   string parentMember,
   string childCollectionProperty,
   Type childObjectType,
   string childMember
)
Delphi
public ISDataSourceObjectRelation(
    parentObjectType: Type;
    parentMember: String;
    childCollectionProperty: String;
    childObjectType: Type;
    childMember: String
);
JScript
public function ISDataSourceObjectRelation(
   parentObjectType : Type,
   parentMember : String,
   childCollectionProperty : String,
   childObjectType : Type,
   childMember : String
);
Managed Extensions for C++
public: ISDataSourceObjectRelation(
   Type* parentObjectType,
   string* parentMember,
   string* childCollectionProperty,
   Type* childObjectType,
   string* childMember
)
C++/CLI
public:
ISDataSourceObjectRelation(
   Type^ parentObjectType,
   String^ parentMember,
   String^ childCollectionProperty,
   Type^ childObjectType,
   String^ childMember
)

Parameters

parentObjectType
the type of parent object class
parentMember
parent member name(must be one of public property from parent object)
childCollectionProperty
the name of child collection property
childObjectType
the type of child object class
childMember
child member name(must be one of public property from child object)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceObjectRelation Class
ISDataSourceObjectRelation Members
Overload List


ISDataSourceObjectRelation Constructor(Type,String[],String,Type,String[])

[image]
ISDataSource Documentation
ISDataSourceObjectRelation Constructor(Type,String[],String,Type,String[])
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceObjectRelation Class > ISDataSourceObjectRelation Constructor : ISDataSourceObjectRelation Constructor(Type,String[],String,Type,String[])

parentObjectType
the type of parent object class
parentMembers
collection of parent member name
childCollectionProperty
the name of child collection property
childObjectType
the type of child object class
childMembers
collection of parent child name
Initialize new instance of ISDataSourceObjectRelation class

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal parentObjectType As Type, _
   ByVal parentMembers() As String, _
   ByVal childCollectionProperty As String, _
   ByVal childObjectType As Type, _
   ByVal childMembers() As String _
)
Visual Basic (Usage) Copy Code
Dim parentObjectType As Type
Dim parentMembers() As String
Dim childCollectionProperty As String
Dim childObjectType As Type
Dim childMembers() As String

Dim instance As New ISDataSourceObjectRelation(parentObjectType, parentMembers, childCollectionProperty, childObjectType, childMembers)
C#
public ISDataSourceObjectRelation(
   Type parentObjectType,
   string[] parentMembers,
   string childCollectionProperty,
   Type childObjectType,
   string[] childMembers
)
Delphi
public ISDataSourceObjectRelation(
    parentObjectType: Type;
    parentMembers: Stringarray of;
    childCollectionProperty: String;
    childObjectType: Type;
    childMembers: Stringarray of
);
JScript
public function ISDataSourceObjectRelation(
   parentObjectType : Type,
   parentMembers : String[],
   childCollectionProperty : String,
   childObjectType : Type,
   childMembers : String[]
);
Managed Extensions for C++
public: ISDataSourceObjectRelation(
   Type* parentObjectType,
   string*[]* parentMembers,
   string* childCollectionProperty,
   Type* childObjectType,
   string*[]* childMembers
)
C++/CLI
public:
ISDataSourceObjectRelation(
   Type^ parentObjectType,
   array<String^>^ parentMembers,
   String^ childCollectionProperty,
   Type^ childObjectType,
   array<String^>^ childMembers
)

Parameters

parentObjectType
the type of parent object class
parentMembers
collection of parent member name
childCollectionProperty
the name of child collection property
childObjectType
the type of child object class
childMembers
collection of parent child name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceObjectRelation Class
ISDataSourceObjectRelation Members
Overload List


ISDataSourceObjectRelation Class Methods

[image]
ISDataSource Documentation
ISDataSourceObjectRelation Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceObjectRelation Class

For a list of all members of this type, see ISDataSourceObjectRelation members.

Public Methods

 | Name | Description
public Method | SetParentObjectType | Set the parent object type for this relation.
Top

See Also

Reference

ISDataSourceObjectRelation Class
ISNet.WebUI.DataSource Namespace


SetParentObjectType Method

[image]
ISDataSource Documentation
SetParentObjectType Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceObjectRelation Class : SetParentObjectType Method

parentObjectType
Set the parent object type for this relation.

Syntax

Visual Basic (Declaration)
Public Sub SetParentObjectType( _
   ByVal parentObjectType As Type _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceObjectRelation
Dim parentObjectType As Type

instance.SetParentObjectType(parentObjectType)
C#
public void SetParentObjectType(
   Type parentObjectType
)
Delphi
public procedure SetParentObjectType(
    parentObjectType: Type
);
JScript
public function SetParentObjectType(
   parentObjectType : Type
);
Managed Extensions for C++
public: void SetParentObjectType(
   Type* parentObjectType
)
C++/CLI
public:
void SetParentObjectType(
   Type^ parentObjectType
)

Parameters

parentObjectType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceObjectRelation Class
ISDataSourceObjectRelation Members


ISDataSourceSelectingEventArgs Class

[image]
ISDataSource Documentation
ISDataSourceSelectingEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceSelectingEventArgs Class

Provides data for the Selecting event of the ISDataSource control.

Object Model

ISDataSourceSelectingEventArgs Class

Syntax

Visual Basic (Declaration)
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class ISDataSourceSelectingEventArgs
   Inherits ISDataSourceMethodEventArgs
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceSelectingEventArgs
C#
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class ISDataSourceSelectingEventArgs : ISDataSourceMethodEventArgs
Delphi
public class ISDataSourceSelectingEventArgs = class(ISDataSourceMethodEventArgs)
JScript
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class ISDataSourceSelectingEventArgs extends ISDataSourceMethodEventArgs
Managed Extensions for C++
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class ISDataSourceSelectingEventArgs : public ISDataSourceMethodEventArgs
C++/CLI
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class ISDataSourceSelectingEventArgs : public ISDataSourceMethodEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
System.ComponentModel.CancelEventArgs
ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs
ISNet.WebUI.DataSource.ISDataSourceSelectingEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceSelectingEventArgs Members
ISNet.WebUI.DataSource Namespace


ISDataSourceSelectingEventArgs Class Members

[image]
ISDataSource Documentation
ISDataSourceSelectingEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceSelectingEventArgs Class

The following tables list the members exposed by ISDataSourceSelectingEventArgs.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceSelectingEventArgs Constructor | Provides data for the Selecting event of the ISDataSource control.
Top

Public Properties

 | Name | Description
public Property | Arguments | Provides a mechanism that the ISDataSourceTable object can use to request data-related operations when data is retrieved.
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ExecutingSelectCount | Gets a value indicating whether the ISDataSourceTable is retrieving a row count during a data retrieval operation.
public Property | InputParameters | Gets a collection that contains business object method parameters and their values. (Inherited from ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs)
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceSelectingEventArgs Class
ISNet.WebUI.DataSource Namespace


ISDataSourceSelectingEventArgs Constructor

[image]
ISDataSource Documentation
ISDataSourceSelectingEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceSelectingEventArgs Class : ISDataSourceSelectingEventArgs Constructor

inputParameters
An IDictionary of name/value pairs that represent the business object method parameters and their corresponding values.
arguments
A DataSourceSelectArguments that specifies which additional data-related operations the ISDataSource should perform on a results set.
executingSelectCount
Gets a value indicating whether the ISDataSourceTable is retrieving a row count during a data retrieval operation.
viewName
A value that represents the ISDataSourceTable
Provides data for the Selecting event of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inputParameters As IOrderedDictionary, _
   ByVal arguments As DataSourceSelectArguments, _
   ByVal executingSelectCount As Boolean, _
   ByVal viewName As String _
)
Visual Basic (Usage) Copy Code
Dim inputParameters As IOrderedDictionary
Dim arguments As DataSourceSelectArguments
Dim executingSelectCount As Boolean
Dim viewName As String

Dim instance As New ISDataSourceSelectingEventArgs(inputParameters, arguments, executingSelectCount, viewName)
C#
public ISDataSourceSelectingEventArgs(
   IOrderedDictionary inputParameters,
   DataSourceSelectArguments arguments,
   bool executingSelectCount,
   string viewName
)
Delphi
public ISDataSourceSelectingEventArgs(
    inputParameters: IOrderedDictionary;
    arguments: DataSourceSelectArguments;
    executingSelectCount: Boolean;
    viewName: String
);
JScript
public function ISDataSourceSelectingEventArgs(
   inputParameters : IOrderedDictionary,
   arguments : DataSourceSelectArguments,
   executingSelectCount : boolean,
   viewName : String
);
Managed Extensions for C++
public: ISDataSourceSelectingEventArgs(
   IOrderedDictionary* inputParameters,
   DataSourceSelectArguments* arguments,
   bool executingSelectCount,
   string* viewName
)
C++/CLI
public:
ISDataSourceSelectingEventArgs(
   IOrderedDictionary^ inputParameters,
   DataSourceSelectArguments^ arguments,
   bool executingSelectCount,
   String^ viewName
)

Parameters

inputParameters
An IDictionary of name/value pairs that represent the business object method parameters and their corresponding values.
arguments
A DataSourceSelectArguments that specifies which additional data-related operations the ISDataSource should perform on a results set.
executingSelectCount
Gets a value indicating whether the ISDataSourceTable is retrieving a row count during a data retrieval operation.
viewName
A value that represents the ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceSelectingEventArgs Class
ISDataSourceSelectingEventArgs Members


ISDataSourceSelectingEventArgs Class Properties

[image]
ISDataSource Documentation
ISDataSourceSelectingEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceSelectingEventArgs Class

For a list of all members of this type, see ISDataSourceSelectingEventArgs members.

Public Properties

 | Name | Description
public Property | Arguments | Provides a mechanism that the ISDataSourceTable object can use to request data-related operations when data is retrieved.
public Property | Cancel | (Inherited from System.ComponentModel.CancelEventArgs)
public Property | ExecutingSelectCount | Gets a value indicating whether the ISDataSourceTable is retrieving a row count during a data retrieval operation.
public Property | InputParameters | Gets a collection that contains business object method parameters and their values. (Inherited from ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs)
public Property | ViewName | Gets an value that represents the ISDataSourceTable which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase)
Top

See Also

Reference

ISDataSourceSelectingEventArgs Class
ISNet.WebUI.DataSource Namespace


Arguments Property

[image]
ISDataSource Documentation
Arguments Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceSelectingEventArgs Class : Arguments Property

Provides a mechanism that the ISDataSourceTable object can use to request data-related operations when data is retrieved.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Arguments As DataSourceSelectArguments
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceSelectingEventArgs
Dim value As DataSourceSelectArguments

value = instance.Arguments
C#
public DataSourceSelectArguments Arguments {get;}
Delphi
public read-only property Arguments: DataSourceSelectArguments;
JScript
public function get Arguments : DataSourceSelectArguments
Managed Extensions for C++
public: __property DataSourceSelectArguments* get_Arguments();
C++/CLI
public:
property DataSourceSelectArguments^ Arguments {
   DataSourceSelectArguments^ get();
}

Property Value

A DataSourceSelectArguments that specifies which additional data-related operations the ISDataSource should perform on a results set.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceSelectingEventArgs Class
ISDataSourceSelectingEventArgs Members


ExecutingSelectCount Property

[image]
ISDataSource Documentation
ExecutingSelectCount Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceSelectingEventArgs Class : ExecutingSelectCount Property

Gets a value indicating whether the ISDataSourceTable is retrieving a row count during a data retrieval operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExecutingSelectCount As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceSelectingEventArgs
Dim value As Boolean

value = instance.ExecutingSelectCount
C#
public bool ExecutingSelectCount {get;}
Delphi
public read-only property ExecutingSelectCount: Boolean;
JScript
public function get ExecutingSelectCount : boolean
Managed Extensions for C++
public: __property bool get_ExecutingSelectCount();
C++/CLI
public:
property bool ExecutingSelectCount {
   bool get();
}

Property Value

true, if data source paging is enabled and the ISDataSourceTable is retrieving a row count; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceSelectingEventArgs Class
ISDataSourceSelectingEventArgs Members


ISDataSourceStatusEventArgs Class

[image]
ISDataSource Documentation
ISDataSourceStatusEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceStatusEventArgs Class

Provides data for the Selected, Inserted, Updated, and Deleted events of the ISDataSource control.

Object Model

ISDataSourceStatusEventArgs Class

Syntax

Visual Basic (Declaration)
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class ISDataSourceStatusEventArgs
   Inherits ISDataSourceEventArgsBase
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceStatusEventArgs
C#
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class ISDataSourceStatusEventArgs : ISDataSourceEventArgsBase
Delphi
public class ISDataSourceStatusEventArgs = class(ISDataSourceEventArgsBase)
JScript
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class ISDataSourceStatusEventArgs extends ISDataSourceEventArgsBase
Managed Extensions for C++
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class ISDataSourceStatusEventArgs : public ISDataSourceEventArgsBase
C++/CLI
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class ISDataSourceStatusEventArgs : public ISDataSourceEventArgsBase

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.DataSource.ISDataSourceEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceStatusEventArgs

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Members
ISNet.WebUI.DataSource Namespace


ISDataSourceStatusEventArgs Class Members

[image]
ISDataSource Documentation
ISDataSourceStatusEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceStatusEventArgs Class

The following tables list the members exposed by ISDataSourceStatusEventArgs.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceStatusEventArgs Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AffectedRows | Gets or sets the number of rows that are affected by the data operation.
public Property | Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
public Property | ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
public Property | OperationType |
public Property | OutputParameters | Gets a collection that contains business object method parameters and their values.
public Property | ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
public Property | ViewName | Gets an value that represents the ViewName which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase)
Top

See Also

Reference

ISDataSourceStatusEventArgs Class
ISNet.WebUI.DataSource Namespace


ISDataSourceStatusEventArgs Constructor

[image]
ISDataSource Documentation
ISDataSourceStatusEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class : ISDataSourceStatusEventArgs Constructor

Overload List

Overload | Description
ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary) | Initializes a new instance of the ISDataSourceStatusEventArgs class using the specified output parameters and return value.
ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary,Exception) | Initializes a new instance of the ISDataSourceStatusEventArgs class using the specified output parameters and return value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members


ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary)

[image]
ISDataSource Documentation
ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary)
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class > ISDataSourceStatusEventArgs Constructor : ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary)

viewName
A value that represents the ISDataSourceTable
returnValue
An object that represents a return value for the completed database operation.
outputParameters
An IDictionary of name/value pairs of parameter objects.
Initializes a new instance of the ISDataSourceStatusEventArgs class using the specified output parameters and return value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal viewName As String, _
   ByVal returnValue As Object, _
   ByVal outputParameters As IDictionary _
)
Visual Basic (Usage) Copy Code
Dim viewName As String
Dim returnValue As Object
Dim outputParameters As IDictionary

Dim instance As New ISDataSourceStatusEventArgs(viewName, returnValue, outputParameters)
C#
public ISDataSourceStatusEventArgs(
   string viewName,
   object returnValue,
   IDictionary outputParameters
)
Delphi
public ISDataSourceStatusEventArgs(
    viewName: String;
    returnValue: TObject;
    outputParameters: IDictionary
);
JScript
public function ISDataSourceStatusEventArgs(
   viewName : String,
   returnValue : Object,
   outputParameters : IDictionary
);
Managed Extensions for C++
public: ISDataSourceStatusEventArgs(
   string* viewName,
   Object* returnValue,
   IDictionary* outputParameters
)
C++/CLI
public:
ISDataSourceStatusEventArgs(
   String^ viewName,
   Object^ returnValue,
   IDictionary^ outputParameters
)

Parameters

viewName
A value that represents the ISDataSourceTable
returnValue
An object that represents a return value for the completed database operation.
outputParameters
An IDictionary of name/value pairs of parameter objects.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members
Overload List


ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary,Exception)

[image]
ISDataSource Documentation
ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary,Exception)
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class > ISDataSourceStatusEventArgs Constructor : ISDataSourceStatusEventArgs Constructor(String,Object,IDictionary,Exception)

viewName
A value that represents the ISDataSourceTable
returnValue
An object that represents a return value for the completed database operation.
outputParameters
An IDictionary of name/value pairs of parameter objects.
exception
An Exception that wraps any internal exceptions thrown during the method call.
Initializes a new instance of the ISDataSourceStatusEventArgs class using the specified output parameters and return value.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal viewName As String, _
   ByVal returnValue As Object, _
   ByVal outputParameters As IDictionary, _
   ByVal exception As Exception _
)
Visual Basic (Usage) Copy Code
Dim viewName As String
Dim returnValue As Object
Dim outputParameters As IDictionary
Dim exception As Exception

Dim instance As New ISDataSourceStatusEventArgs(viewName, returnValue, outputParameters, exception)
C#
public ISDataSourceStatusEventArgs(
   string viewName,
   object returnValue,
   IDictionary outputParameters,
   Exception exception
)
Delphi
public ISDataSourceStatusEventArgs(
    viewName: String;
    returnValue: TObject;
    outputParameters: IDictionary;
    exception: Exception
);
JScript
public function ISDataSourceStatusEventArgs(
   viewName : String,
   returnValue : Object,
   outputParameters : IDictionary,
   exception : Exception
);
Managed Extensions for C++
public: ISDataSourceStatusEventArgs(
   string* viewName,
   Object* returnValue,
   IDictionary* outputParameters,
   Exception* exception
)
C++/CLI
public:
ISDataSourceStatusEventArgs(
   String^ viewName,
   Object^ returnValue,
   IDictionary^ outputParameters,
   Exception^ exception
)

Parameters

viewName
A value that represents the ISDataSourceTable
returnValue
An object that represents a return value for the completed database operation.
outputParameters
An IDictionary of name/value pairs of parameter objects.
exception
An Exception that wraps any internal exceptions thrown during the method call.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members
Overload List


ISDataSourceStatusEventArgs Class Properties

[image]
ISDataSource Documentation
ISDataSourceStatusEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceStatusEventArgs Class

For a list of all members of this type, see ISDataSourceStatusEventArgs members.

Public Properties

 | Name | Description
public Property | AffectedRows | Gets or sets the number of rows that are affected by the data operation.
public Property | Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
public Property | ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
public Property | OperationType |
public Property | OutputParameters | Gets a collection that contains business object method parameters and their values.
public Property | ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
public Property | ViewName | Gets an value that represents the ViewName which performs data operations. (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase)
Top

See Also

Reference

ISDataSourceStatusEventArgs Class
ISNet.WebUI.DataSource Namespace


AffectedRows Property

[image]
ISDataSource Documentation
AffectedRows Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class : AffectedRows Property

Gets or sets the number of rows that are affected by the data operation.

Syntax

Visual Basic (Declaration)
Public Property AffectedRows As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceStatusEventArgs
Dim value As Integer

instance.AffectedRows = value

value = instance.AffectedRows
C#
public int AffectedRows {get; set;}
Delphi
public read-write property AffectedRows: Integer;
JScript
public function get,set AffectedRows : int
Managed Extensions for C++
public: __property int get_AffectedRows();
public: __property void set_AffectedRows(
   int value
);
C++/CLI
public:
property int AffectedRows {
   int get();
   void set (    int value);
}

Property Value

The number of rows affected by the data operation.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members


Exception Property

[image]
ISDataSource Documentation
Exception Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class : Exception Property

Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceStatusEventArgs
Dim value As Exception

value = instance.Exception
C#
public Exception Exception {get;}
Delphi
public read-only property Exception: Exception;
JScript
public function get Exception : Exception
Managed Extensions for C++
public: __property Exception* get_Exception();
C++/CLI
public:
property Exception^ Exception {
   Exception^ get();
}

Property Value

An Exception that wraps any exceptions thrown by the business object in its InnerException.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members


ExceptionHandled Property

[image]
ISDataSource Documentation
ExceptionHandled Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class : ExceptionHandled Property

Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.

Syntax

Visual Basic (Declaration)
Public Property ExceptionHandled As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceStatusEventArgs
Dim value As Boolean

instance.ExceptionHandled = value

value = instance.ExceptionHandled
C#
public bool ExceptionHandled {get; set;}
Delphi
public read-write property ExceptionHandled: Boolean;
JScript
public function get,set ExceptionHandled : boolean
Managed Extensions for C++
public: __property bool get_ExceptionHandled();
public: __property void set_ExceptionHandled(
   bool value
);
C++/CLI
public:
property bool ExceptionHandled {
   bool get();
   void set (    bool value);
}

Property Value

true if an exception thrown by the business object has been handled and should not be thrown by the ISDataSource; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members


OperationType Property

[image]
ISDataSource Documentation
OperationType Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class : OperationType Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OperationType As DataSourceOperation
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceStatusEventArgs
Dim value As DataSourceOperation

value = instance.OperationType
C#
public DataSourceOperation OperationType {get;}
Delphi
public read-only property OperationType: DataSourceOperation;
JScript
public function get OperationType : DataSourceOperation
Managed Extensions for C++
public: __property DataSourceOperation get_OperationType();
C++/CLI
public:
property DataSourceOperation OperationType {
   DataSourceOperation get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members


OutputParameters Property

[image]
ISDataSource Documentation
OutputParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class : OutputParameters Property

Gets a collection that contains business object method parameters and their values.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OutputParameters As IDictionary
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceStatusEventArgs
Dim value As IDictionary

value = instance.OutputParameters
C#
public IDictionary OutputParameters {get;}
Delphi
public read-only property OutputParameters: IDictionary;
JScript
public function get OutputParameters : IDictionary
Managed Extensions for C++
public: __property IDictionary* get_OutputParameters();
C++/CLI
public:
property IDictionary^ OutputParameters {
   IDictionary^ get();
}

Property Value

An IDictionary of name/value pairs that represent the business object method parameters and their corresponding values.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members


ReturnValue Property

[image]
ISDataSource Documentation
ReturnValue Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceStatusEventArgs Class : ReturnValue Property

Gets the return value that is returned by the business object method, if any, as an object.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ReturnValue As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceStatusEventArgs
Dim value As Object

value = instance.ReturnValue
C#
public object ReturnValue {get;}
Delphi
public read-only property ReturnValue: TObject;
JScript
public function get ReturnValue : Object
Managed Extensions for C++
public: __property Object* get_ReturnValue();
C++/CLI
public:
property Object^ ReturnValue {
   Object^ get();
}

Property Value

An object that represents the return value returned by the business object method; otherwise, a null reference (Nothing in Visual Basic), if the business object method returns no value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventArgs Class
ISDataSourceStatusEventArgs Members


ISDataSourceTable Class

[image]
ISDataSource Documentation
ISDataSourceTable Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTable Class

Represents a business object that provides data to data-bound controls.

Object Model

ISDataSourceTable Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<SerializableAttribute()>
Public Class ISDataSourceTable
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IDataSourceTable, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[SerializableAttribute()]
public class ISDataSourceTable : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IDataSourceTable, ISNet.WebUI.INamedObject
Delphi
public class ISDataSourceTable = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IDataSourceTable, ISNet.WebUI.INamedObject)
JScript
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
SerializableAttribute()
public class ISDataSourceTable extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IDataSourceTable, ISNet.WebUI.INamedObject
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[SerializableAttribute()]
public __gc class ISDataSourceTable : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IDataSourceTable, ISNet.WebUI.INamedObject
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[SerializableAttribute()]
public ref class ISDataSourceTable : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.IDataSourceTable, ISNet.WebUI.INamedObject

Remarks

Each DataSourceTable is associated with a data source view class, the name of this view is taken from ISDataSourceTable's TableName. The same as ObjectDataSource concept, the ISDataSourceView handles most of the operation behind the scene, you can use GetView(string viewName) method to gain access to corresponding ISDataSourceView.

The following list describes the capability of ISDataSourceTable class:

  • Selecting - Set the SelectMethod property (in ISDataSourceTable) to the name of business object methods that selects data and include any necessary parameters in the SelectParameters collection either programmatically or by using a data-bound control
  • Sorting - Set the SortParameterName property to the name of the parameter in SelectMethod method that carries the sort criteria. Set the SortExpression property to perform sorting when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView or a DataTable.
  • Filtering - Set the FilterExpression property to a filtering expression and optionally add any parameter to the FilterParameters collection to filter the data when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView, or DataTable.
  • Paging - Data source paging is supported, if the SelectMethod method contains parameters for the maximum number of records to retrieve and the index of the first record to retrieve. The names of those parameters must be set in the MaximumRowsParameterName and StartRowIndexParameterName properties, respectively. A data-bound control might be able to perform paging itself, even if the ISDataSource control does not support paging directly in the method specified by the SelectMethod property. The requirement for the data-bound control to be able to do this is that the method specified by the SelectMethod property return an object that implements the Icollection interface.
  • Updating - Set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameters in the UpdateParameters collection.
  • Deleting - Set the DeleteMethod property to the name of the business object method or function that deletes data, and include any necessary parameters in the DeleteParameters collection.
  • Inserting - Set the InsertMethod property to the name of the business object method or function that inserts data and include any necessary parameters in the InsertParameters collection.
  • Caching - Set the EnableCaching property to true, and configure cache settings according to the caching behavior you want for your cached data.

The ISDataSource.NET has an enhanced caching capability. Follows are the settings that you can set :

  • CacheScope (Global / PerUser)
  • CacheDuration and CacheExpirationPolicy (applicable when CacheStorage is set to PageCache)
  • CacheKeyDependency
  • CacheStorage (PageCache / Session / FileServer)
  • StoreCachePerPage

All this settings is used to create the CacheKey that used to identify the cached data that going to be stored. The CacheKey produced by ISDataSource follows following pattern:

{SessionID} : {PageName} : KeyDependency : ViewName : Duration : ExpirationPolicy : TypeName : SelectMethod + Params ++ startRowIndex : maxmumRows

The field under '{}' is optional.

If the CacheScope is set to Global, the key will not have {SessionID}.

If the StoreCachePerPage is set to No, the key will not have {PageName}.

The other information is essential to create and differentiate the cached data.

The cache configuration also can be set from Table level so you can have better flexibility which data and which configuration to be cached

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.DataSource.ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Members
ISNet.WebUI.DataSource Namespace

Concepts

Automatic table generation
Step by step wizard
Automatic conflict detection behavior
Processing data using ISDataSource.NET


ISDataSourceTable Class Members

[image]
ISDataSource Documentation
ISDataSourceTable Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTable Class

The following tables list the members exposed by ISDataSourceTable.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceTable Constructor | Initializes a new instance of ISDataSourceTable class.
Top

Public Properties

 | Name | Description
public Property | CacheDuration | Gets or sets the length of time - in seconds, that the data source control caches data that is retrieved by the SelectMethod method. Gets or sets the length of time, in seconds, that the data source control caches data that is retrieved by the SelectMethod method.
public Property | CacheExpirationPolicy | Gets or sets the cache expiration behavior - when combined with the duration, which describes the behavior of the cache that the data source control uses. Gets or sets the cache expiration behavior that, when combined with the duration, describes the behavior of the cache that the data source control uses.
public Property | CacheKeyDependency | Gets or sets a user-defined key dependency that is linked to all data cache objects that are created by the data source control.
public Property | CachePriority | Gets or sets the relative priority of items stored in the Cache object.
public Property | CacheScope | Gets or sets the scope of the cached data.
public Property | CacheServerConnection | Get or sets the cache's file server connection string.
public Property | CacheStorage | Gets or sets the storage of the cached data.
public Property | CancelSelectOnNullParameter |
public Property | ConflictDetection | Gets or sets a value that determines whether only the new values are passed to the Update method or both the old and new values are passed to the Update method. Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.
public Property | ConvertNullToDBNull | Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.
public Property | DataObjectTypeName | Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control. Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control.
public Property | DeleteMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data.
public Property | DeleteParameters | Gets the parameters collection that contains the parameters that are used by the DeleteMethod method. Gets the parameters collection that contains the parameters that are used by the DeleteMethod method.
public Property | EnableCaching | Gets or sets a value indicating whether the ISDataSource control has data caching enabled.
public Property | EnablePaging | Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves. Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves.
public Property | FilterExpression | Gets or sets a filtering expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a filtering expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | FilterParameters | Gets a collection of parameters that are associated with any parameter placeholder in the FilterExpression string. Gets a collection of parameters that are associated with any parameter placeholders in the FilterExpression string.
public Property | InsertMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to insert data.
public Property | InsertParameters | Gets the parameters collection that contains the parameters that are used by the InsertMethod method.
public Property | MaximumRowsParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the number of records to retrieve for data source paging support.
public Property | OldValuesParameterFormatString | Gets or sets a format string to apply to the names of the parameters for original values that are passed to the Delete or Update methods.
public Property | ParameterOption | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior how the values is passed from Intersoft data-bound controls for Update, Insert and Delete operations.
public Property | SelectChildRowMethod | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve child rows data. Used for performing load on demand in Hierachical WebGrid 5.0+ .
public Property | SelectCountMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve a row count.
public Property | SelectMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve data.
public Property | SelectParameters | Gets the parameters collection that contains the parameters that are used by the SelectMethod method.
public Property | SelectSelfReferenceRowMethod | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve self reference rows data. Used for performing load on demand in SelfReferenced WebGrid 5.0+ .
public Property | SortExpression | Gets or sets a sorting expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a sorting expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | SortParameterName | Gets or sets the name of the business object that the SelectMethod parameter uses to specify a sort expression for data source sorting support. Gets or sets the name of the business object that the SelectMethod parameter used to specify a sort expression for data source sorting support.
public Property | StartRowIndexParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the integer index of the first record to retrieve from the results set for data source paging support.
public Property | StoreCachePerPage | Gets or sets a value indicating whether the ISDataSource control will store the cached data separately for each page.
public Property | TableName | Gets or sets a unique value that indicates the ISDataSourceTable's Name
public Property | TypeName | Gets or sets the name of the class that the ISDataSourceTable object represents.
public Property | UpdateMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data.
public Property | UpdateParameters | Gets the parameters collection that contains parameters that are used by the method that is specified by the UpdateMethod property. Gets the parameters collection that contains the parameters that are used by the method that is specified by the UpdateMethod property.
public Property | UseCachedDataOnFirstLoad | Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled. Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled.
Top

Public Methods

 | Name | Description
public Method | ClearCache | Clear all cache related to this table
public Method | ClearCacheAndData |
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. Overridden.
public Method | Delete | Performs a delete operation by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetTableSchema | Gets the schema for this datasource table.
public Method | GetView | Gets the ISDataSourceView associated with the ISDataSourceTable.
public Method | Insert | Performs an insert operation by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.
public Method | IsCachingEnabled |
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Select | Overloaded. Retrieves data from the underlying data storage by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Update | Performs an update operation by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.
Top

See Also

Reference

ISDataSourceTable Class
ISNet.WebUI.DataSource Namespace


ISDataSourceTable Constructor

[image]
ISDataSource Documentation
ISDataSourceTable Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : ISDataSourceTable Constructor

Initializes a new instance of ISDataSourceTable class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceTable()
C#
public ISDataSourceTable()
Delphi
public ISDataSourceTable();
JScript
public function ISDataSourceTable();
Managed Extensions for C++
public: ISDataSourceTable();
C++/CLI
public:
ISDataSourceTable();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


ISDataSourceTable Class Methods

[image]
ISDataSource Documentation
ISDataSourceTable Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTable Class

For a list of all members of this type, see ISDataSourceTable members.

Public Methods

 | Name | Description
public Method | ClearCache | Clear all cache related to this table
public Method | ClearCacheAndData |
public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | CopyFrom | Overloaded. Overridden.
public Method | Delete | Performs a delete operation by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.
public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | GetTableSchema | Gets the schema for this datasource table.
public Method | GetView | Gets the ISDataSourceView associated with the ISDataSourceTable.
public Method | Insert | Performs an insert operation by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.
public Method | IsCachingEnabled |
public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Select | Overloaded. Retrieves data from the underlying data storage by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.
public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
public Method | Update | Performs an update operation by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.
Top

See Also

Reference

ISDataSourceTable Class
ISNet.WebUI.DataSource Namespace


ClearCache Method

[image]
ISDataSource Documentation
ClearCache Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : ClearCache Method

Clear all cache related to this table

Syntax

Visual Basic (Declaration)
Public Sub ClearCache()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable

instance.ClearCache()
C#
public void ClearCache()
Delphi
public procedure ClearCache();
JScript
public function ClearCache();
Managed Extensions for C++
public: void ClearCache();
C++/CLI
public:
void ClearCache();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


ClearCacheAndData Method

[image]
ISDataSource Documentation
ClearCacheAndData Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : ClearCacheAndData Method

Syntax

Visual Basic (Declaration)
Public Sub ClearCacheAndData()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable

instance.ClearCacheAndData()
C#
public void ClearCacheAndData()
Delphi
public procedure ClearCacheAndData();
JScript
public function ClearCacheAndData();
Managed Extensions for C++
public: void ClearCacheAndData();
C++/CLI
public:
void ClearCacheAndData();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


CopyFrom Method

[image]
ISDataSource Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CopyFrom Method

Overload List

Overload | Description
CopyFrom(Object) |
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


CopyFrom(Object) Method

[image]
ISDataSource Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class > CopyFrom Method : CopyFrom(Object) Method

obj

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub CopyFrom( _
   ByVal obj As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim obj As Object

instance.CopyFrom(obj)
C#
public override void CopyFrom(
   object obj
)
Delphi
public procedure CopyFrom(
    obj: TObject
); override;
JScript
public override function CopyFrom(
   obj : Object
);
Managed Extensions for C++
public: void CopyFrom(
   Object* obj
) override
C++/CLI
public:
void CopyFrom(
   Object^ obj
) override

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members
Overload List


Delete Method

[image]
ISDataSource Documentation
Delete Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : Delete Method

Performs a delete operation by calling the method that is identified by the DeleteMethod property with any parameters that are in the DeleteParameters collection.

Syntax

Visual Basic (Declaration)
Public Function Delete() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Integer

value = instance.Delete()
C#
public int Delete()
Delphi
public function Delete(): Integer;
JScript
public function Delete() : int;
Managed Extensions for C++
public: int Delete();
C++/CLI
public:
int Delete();

Return Value

A value that represents the number of rows deleted from the underlying data storage, if the AffectedRows property of the ISDataSourceStatusEventArgs is set in the Deleted event; otherwise, -1.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


GetTableSchema Method

[image]
ISDataSource Documentation
GetTableSchema Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : GetTableSchema Method

dataSource
The datasource which schema to be retrieved.
Gets the schema for this datasource table.

Syntax

Visual Basic (Declaration)
Public Function GetTableSchema( _
   ByVal dataSource As IEnumerable _
) As ISNet.WebUI.IDataSourceTableSchema
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim dataSource As IEnumerable
Dim value As ISNet.WebUI.IDataSourceTableSchema

value = instance.GetTableSchema(dataSource)
C#
public ISNet.WebUI.IDataSourceTableSchema GetTableSchema(
   IEnumerable dataSource
)
Delphi
public function GetTableSchema(
    dataSource: IEnumerable
): ISNet.WebUI.IDataSourceTableSchema;
JScript
public function GetTableSchema(
   dataSource : IEnumerable
) : ISNet.WebUI.IDataSourceTableSchema;
Managed Extensions for C++
public: ISNet.WebUI.IDataSourceTableSchema* GetTableSchema(
   IEnumerable* dataSource
)
C++/CLI
public:
ISNet.WebUI.IDataSourceTableSchema^ GetTableSchema(
   IEnumerable^ dataSource
)

Parameters

dataSource
The datasource which schema to be retrieved.

Return Value

An object instance that implement IDataSourceTableSchema interface.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


GetView Method

[image]
ISDataSource Documentation
GetView Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : GetView Method

Gets the ISDataSourceView associated with the ISDataSourceTable.

Syntax

Visual Basic (Declaration)
Public Function GetView() As ISDataSourceView
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ISDataSourceView

value = instance.GetView()
C#
public ISDataSourceView GetView()
Delphi
public function GetView(): ISDataSourceView;
JScript
public function GetView() : ISDataSourceView;
Managed Extensions for C++
public: ISDataSourceView* GetView();
C++/CLI
public:
ISDataSourceView^ GetView();

Return Value

Returns the ISDataSourceView associated with the ISDataSourceTable.

Remarks

Users can use GetView method (string viewName) to get the access to the ISDataSourceView which handles the data operation of ISDataSourceTable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Other Resources

Event Handlers


Insert Method

[image]
ISDataSource Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : Insert Method

Performs an insert operation by calling the method that is identified by the InsertMethod property and any parameters in the InsertParameters collection.

Syntax

Visual Basic (Declaration)
Public Function Insert() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Integer

value = instance.Insert()
C#
public int Insert()
Delphi
public function Insert(): Integer;
JScript
public function Insert() : int;
Managed Extensions for C++
public: int Insert();
C++/CLI
public:
int Insert();

Return Value

A value that represents the number of rows inserted into the underlying data storage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


IsCachingEnabled Method

[image]
ISDataSource Documentation
IsCachingEnabled Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : IsCachingEnabled Method

Syntax

Visual Basic (Declaration)
Public Function IsCachingEnabled() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Boolean

value = instance.IsCachingEnabled()
C#
public bool IsCachingEnabled()
Delphi
public function IsCachingEnabled(): Boolean;
JScript
public function IsCachingEnabled() : boolean;
Managed Extensions for C++
public: bool IsCachingEnabled();
C++/CLI
public:
bool IsCachingEnabled();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


Select Method

[image]
ISDataSource Documentation
Select Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : Select Method

Retrieves data from the underlying data storage by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Overload List

Overload | Description
Select() | Retrieves data from the underlying data storage by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.
Select(DataSourceSelectArguments) | Retrieves data from the underlying data storage by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


Select() Method

[image]
ISDataSource Documentation
Select() Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class > Select Method : Select() Method

Retrieves data from the underlying data storage by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Select() As IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As IEnumerable

value = instance.Select()
C#
public IEnumerable Select()
Delphi
public function Select(): IEnumerable;
JScript
public function Select() : IEnumerable;
Managed Extensions for C++
public: IEnumerable* Select();
C++/CLI
public:
IEnumerable^ Select();

Return Value

An IEnumerable list of data rows.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members
Overload List


Select(DataSourceSelectArguments) Method

[image]
ISDataSource Documentation
Select(DataSourceSelectArguments) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class > Select Method : Select(DataSourceSelectArguments) Method

args
A DataSourceSelectArguments used to request operations on the data beyond basic data retrieval.
Retrieves data from the underlying data storage by calling the method that is identified by the SelectMethod property with the parameters in the SelectParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Select( _
   ByVal args As DataSourceSelectArguments _
) As IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim args As DataSourceSelectArguments
Dim value As IEnumerable

value = instance.Select(args)
C#
public IEnumerable Select(
   DataSourceSelectArguments args
)
Delphi
public function Select(
    args: DataSourceSelectArguments
): IEnumerable;
JScript
public function Select(
   args : DataSourceSelectArguments
) : IEnumerable;
Managed Extensions for C++
public: IEnumerable* Select(
   DataSourceSelectArguments* args
)
C++/CLI
public:
IEnumerable^ Select(
   DataSourceSelectArguments^ args
)

Parameters

args
A DataSourceSelectArguments used to request operations on the data beyond basic data retrieval.

Return Value

An IEnumerable list of data rows.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members
Overload List


Update Method

[image]
ISDataSource Documentation
Update Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : Update Method

Performs an update operation by calling the method that is identified by the UpdateMethod property and any parameters that are in the UpdateParameters collection.

Syntax

Visual Basic (Declaration)
Public Function Update() As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Integer

value = instance.Update()
C#
public int Update()
Delphi
public function Update(): Integer;
JScript
public function Update() : int;
Managed Extensions for C++
public: int Update();
C++/CLI
public:
int Update();

Return Value

A value that represents the number of rows updated in the underlying data storage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


ISDataSourceTable Class Properties

[image]
ISDataSource Documentation
ISDataSourceTable Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTable Class

For a list of all members of this type, see ISDataSourceTable members.

Public Properties

 | Name | Description
public Property | CacheDuration | Gets or sets the length of time - in seconds, that the data source control caches data that is retrieved by the SelectMethod method. Gets or sets the length of time, in seconds, that the data source control caches data that is retrieved by the SelectMethod method.
public Property | CacheExpirationPolicy | Gets or sets the cache expiration behavior - when combined with the duration, which describes the behavior of the cache that the data source control uses. Gets or sets the cache expiration behavior that, when combined with the duration, describes the behavior of the cache that the data source control uses.
public Property | CacheKeyDependency | Gets or sets a user-defined key dependency that is linked to all data cache objects that are created by the data source control.
public Property | CachePriority | Gets or sets the relative priority of items stored in the Cache object.
public Property | CacheScope | Gets or sets the scope of the cached data.
public Property | CacheServerConnection | Get or sets the cache's file server connection string.
public Property | CacheStorage | Gets or sets the storage of the cached data.
public Property | CancelSelectOnNullParameter |
public Property | ConflictDetection | Gets or sets a value that determines whether only the new values are passed to the Update method or both the old and new values are passed to the Update method. Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.
public Property | ConvertNullToDBNull | Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.
public Property | DataObjectTypeName | Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control. Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control.
public Property | DeleteMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data.
public Property | DeleteParameters | Gets the parameters collection that contains the parameters that are used by the DeleteMethod method. Gets the parameters collection that contains the parameters that are used by the DeleteMethod method.
public Property | EnableCaching | Gets or sets a value indicating whether the ISDataSource control has data caching enabled.
public Property | EnablePaging | Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves. Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves.
public Property | FilterExpression | Gets or sets a filtering expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a filtering expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | FilterParameters | Gets a collection of parameters that are associated with any parameter placeholder in the FilterExpression string. Gets a collection of parameters that are associated with any parameter placeholders in the FilterExpression string.
public Property | InsertMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to insert data.
public Property | InsertParameters | Gets the parameters collection that contains the parameters that are used by the InsertMethod method.
public Property | MaximumRowsParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the number of records to retrieve for data source paging support.
public Property | OldValuesParameterFormatString | Gets or sets a format string to apply to the names of the parameters for original values that are passed to the Delete or Update methods.
public Property | ParameterOption | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior how the values is passed from Intersoft data-bound controls for Update, Insert and Delete operations.
public Property | SelectChildRowMethod | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve child rows data. Used for performing load on demand in Hierachical WebGrid 5.0+ .
public Property | SelectCountMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve a row count.
public Property | SelectMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve data.
public Property | SelectParameters | Gets the parameters collection that contains the parameters that are used by the SelectMethod method.
public Property | SelectSelfReferenceRowMethod | Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve self reference rows data. Used for performing load on demand in SelfReferenced WebGrid 5.0+ .
public Property | SortExpression | Gets or sets a sorting expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a sorting expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | SortParameterName | Gets or sets the name of the business object that the SelectMethod parameter uses to specify a sort expression for data source sorting support. Gets or sets the name of the business object that the SelectMethod parameter used to specify a sort expression for data source sorting support.
public Property | StartRowIndexParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the integer index of the first record to retrieve from the results set for data source paging support.
public Property | StoreCachePerPage | Gets or sets a value indicating whether the ISDataSource control will store the cached data separately for each page.
public Property | TableName | Gets or sets a unique value that indicates the ISDataSourceTable's Name
public Property | TypeName | Gets or sets the name of the class that the ISDataSourceTable object represents.
public Property | UpdateMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data.
public Property | UpdateParameters | Gets the parameters collection that contains parameters that are used by the method that is specified by the UpdateMethod property. Gets the parameters collection that contains the parameters that are used by the method that is specified by the UpdateMethod property.
public Property | UseCachedDataOnFirstLoad | Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled. Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled.
Top

See Also

Reference

ISDataSourceTable Class
ISNet.WebUI.DataSource Namespace


CacheDuration Property

[image]
ISDataSource Documentation
CacheDuration Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CacheDuration Property

Gets or sets the length of time - in seconds, that the data source control caches data that is retrieved by the SelectMethod method. Gets or sets the length of time, in seconds, that the data source control caches data that is retrieved by the SelectMethod method.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Cache")>
<DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")>
<TypeConverterAttribute("#bi.#ai, ISNet.WebUI.ISDataSource, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")>
Public Overridable Property CacheDuration As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Integer

instance.CacheDuration = value

value = instance.CacheDuration
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")]
[TypeConverterAttribute("#bi.#ai, ISNet.WebUI.ISDataSource, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
public virtual int CacheDuration {get; set;}
Delphi
public read-write property CacheDuration: Integer; virtual;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
CategoryAttribute("Cache")
DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")
TypeConverterAttribute("#bi.#ai, ISNet.WebUI.ISDataSource, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")
public function get,set CacheDuration : int
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")]
[TypeConverterAttribute("#bi.#ai, ISNet.WebUI.ISDataSource, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
public: __property virtual int get_CacheDuration();
public: __property virtual void set_CacheDuration(
   int value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("The duration, in seconds, of the expiration. The expiration policy is specified by the ExpirationPolicy property.")]
[TypeConverterAttribute("#bi.#ai, ISNet.WebUI.ISDataSource, Version=1.0.1500.1, Culture=neutral, PublicKeyToken=c4184ef0d326354b")]
public:
virtual property int CacheDuration {
   int get();
   void set (    int value);
}

Property Value

The number of seconds that the ISDataSource caches the results of each ISDataSourceTable's SelectMethod property invocation. The default is 0. The value cannot be negative.

Remarks

The CacheDuration indicates the number of seconds that the cache storing data before the cache entry is discarded.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Cache Storage

Tasks

How-to: Configure cache configuration


CacheExpirationPolicy Property

[image]
ISDataSource Documentation
CacheExpirationPolicy Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CacheExpirationPolicy Property

Gets or sets the cache expiration behavior - when combined with the duration, which describes the behavior of the cache that the data source control uses. Gets or sets the cache expiration behavior that, when combined with the duration, describes the behavior of the cache that the data source control uses.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Cache")>
Public Overridable Property CacheExpirationPolicy As CacheExpirationPolicy
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As CacheExpirationPolicy

instance.CacheExpirationPolicy = value

value = instance.CacheExpirationPolicy
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public virtual CacheExpirationPolicy CacheExpirationPolicy {get; set;}
Delphi
public read-write property CacheExpirationPolicy: CacheExpirationPolicy; virtual;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
CategoryAttribute("Cache")
public function get,set CacheExpirationPolicy : CacheExpirationPolicy
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public: __property virtual CacheExpirationPolicy get_CacheExpirationPolicy();
public: __property virtual void set_CacheExpirationPolicy(
   CacheExpirationPolicy value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("The expiration policy of the cache. The duration for the expiration is specified by the Duration property.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
public:
virtual property CacheExpirationPolicy CacheExpirationPolicy {
   CacheExpirationPolicy get();
   void set (    CacheExpirationPolicy value);
}

Property Value

One of the CacheExpirationPolicy values. The default is CacheExpirationPolicy.Default.

Remarks

This property can be configured when users store Cached Data in Page Cache. If the CacheExpirationPolicy is set to Absolute, the cache data will be hold in memory for - at most - the amount of time that is specified by the CacheDuration. The data might be released before the duration time if the memory is needed. If the CacheExpirationPolicy is set to Sliding, the cache expires when there is no activity for a time that is equal to the CacheDuration.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Cache Storage


CacheKeyDependency Property

[image]
ISDataSource Documentation
CacheKeyDependency Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CacheKeyDependency Property

Gets or sets a user-defined key dependency that is linked to all data cache objects that are created by the data source control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")>
<CategoryAttribute("Cache")>
Public Overridable Property CacheKeyDependency As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.CacheKeyDependency = value

value = instance.CacheKeyDependency
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")]
[CategoryAttribute("Cache")]
public virtual string CacheKeyDependency {get; set;}
Delphi
public read-write property CacheKeyDependency: String; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")
CategoryAttribute("Cache")
public function get,set CacheKeyDependency : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")]
[CategoryAttribute("Cache")]
public: __property virtual string* get_CacheKeyDependency();
public: __property virtual void set_CacheKeyDependency(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates an arbitrary cache key to make this cache entry depend on.")]
[CategoryAttribute("Cache")]
public:
virtual property String^ CacheKeyDependency {
   String^ get();
   void set (    String^ value);
}

Property Value

A key that identifies all cache objects created by the ISDataSource.

Remarks

This property is treated as a key wild card to identifies the cache if needed.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


CachePriority Property

[image]
ISDataSource Documentation
CachePriority Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CachePriority Property

Gets or sets the relative priority of items stored in the Cache object.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("Cache")>
<DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")>
Public Overridable Property CachePriority As CachePriority
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As CachePriority

instance.CachePriority = value

value = instance.CachePriority
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")]
public virtual CachePriority CachePriority {get; set;}
Delphi
public read-write property CachePriority: CachePriority; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
CategoryAttribute("Cache")
DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")
public function get,set CachePriority : CachePriority
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")]
public: __property virtual CachePriority get_CachePriority();
public: __property virtual void set_CachePriority(
   CachePriority value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[DescriptionAttribute("Specifies the relative priority of items stored in the Cache object. ")]
public:
virtual property CachePriority CachePriority {
   CachePriority get();
   void set (    CachePriority value);
}

Property Value

The relative priority of items stored in the Cache object.

Remarks

Using this property you can assign relative priority compared to other items stored in the cache. Items to which you assign higher priority values are less likely to be deleted from the cache when the server is processing a large number of requests, whereas items to which you assign lower priority values are more likely to be deleted.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Cache storage


CacheScope Property

[image]
ISDataSource Documentation
CacheScope Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CacheScope Property

Gets or sets the scope of the cached data.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Cache")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
Public Overridable Property CacheScope As CacheScope
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As CacheScope

instance.CacheScope = value

value = instance.CacheScope
C#
[DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Cache")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
public virtual CacheScope CacheScope {get; set;}
Delphi
public read-write property CacheScope: CacheScope; virtual;
JScript
DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")
NotifyParentPropertyAttribute()
CategoryAttribute("Cache")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
public function get,set CacheScope : CacheScope
Managed Extensions for C++
[DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Cache")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
public: __property virtual CacheScope get_CacheScope();
public: __property virtual void set_CacheScope(
   CacheScope value
);
C++/CLI
[DescriptionAttribute("Specifies the scope of the cache.
Note : Need to add Global.asax when CacheScope is set to PerUser")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Cache")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
public:
virtual property CacheScope CacheScope {
   CacheScope get();
   void set (    CacheScope value);
}

Property Value

One of the CacheScope values. The default is CacheScope.Default.

Remarks

You can configure the cache scope if it is available to global user or specific user (session).

  • Global. Global cache data allows all users that access the application share the same data. It is usually used for common data that rarely updated and used by all users.
  • Per User. Per User cache data will create a new instance for each user that accessing the application. The data is exclusive to each user.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Cache Scope
Cache Key Pattern


CacheServerConnection Property

[image]
ISDataSource Documentation
CacheServerConnection Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CacheServerConnection Property

Get or sets the cache's file server connection string.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("File Server's connection string")>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Cache")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property CacheServerConnection As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.CacheServerConnection = value

value = instance.CacheServerConnection
C#
[DescriptionAttribute("File Server's connection string")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual string CacheServerConnection {get; set;}
Delphi
public read-write property CacheServerConnection: String; virtual;
JScript
DescriptionAttribute("File Server's connection string")
NotifyParentPropertyAttribute()
CategoryAttribute("Cache")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CacheServerConnection : String
Managed Extensions for C++
[DescriptionAttribute("File Server's connection string")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual string* get_CacheServerConnection();
public: __property virtual void set_CacheServerConnection(
   string* value
);
C++/CLI
[DescriptionAttribute("File Server's connection string")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property String^ CacheServerConnection {
   String^ get();
   void set (    String^ value);
}

Property Value

The File server connection string that the ISDataSource control uses to connect to a FileServer.

Remarks

To save the cached data to FileServer you need to specify the CacheServerConnection. Following is a list of parameters that can be used in CacheServerConnection:

  • path. Specify the path of file server storage
  • expireduration. Specify the time in minutes how long should a cache stay in the storage.
  • expirationpolicy. Specify the expiration policy of the cache. The valid values are Sliding, Absolute.

Each parameter should be separated using ";" (semicolon) character.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Tasks

How-to: Use file server for an instance of control
How-to: Configure file server to use shared network drive


CacheStorage Property

[image]
ISDataSource Documentation
CacheStorage Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CacheStorage Property

Gets or sets the storage of the cached data.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Specifies how the cache is stored.")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Cache")>
Public Overridable Property CacheStorage As CacheStorage
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As CacheStorage

instance.CacheStorage = value

value = instance.CacheStorage
C#
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies how the cache is stored.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Cache")]
public virtual CacheStorage CacheStorage {get; set;}
Delphi
public read-write property CacheStorage: CacheStorage; virtual;
JScript
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Specifies how the cache is stored.")
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Cache")
public function get,set CacheStorage : CacheStorage
Managed Extensions for C++
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies how the cache is stored.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Cache")]
public: __property virtual CacheStorage get_CacheStorage();
public: __property virtual void set_CacheStorage(
   CacheStorage value
);
C++/CLI
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Specifies how the cache is stored.")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Cache")]
public:
virtual property CacheStorage CacheStorage {
   CacheStorage get();
   void set (    CacheStorage value);
}

Property Value

One of the CacheStorage values. The default is CacheStorage.Default.

Remarks

In ISDataSource.NET you have three options to store the Cache Data.

  • Page Cache
    Page Cache stores the Cache Data in the server's memory. In order to use Page Cache you need to configure the settings on CacheDuration, CacheExpirationPolicy and CachePriority. The CacheDuration indicates the number of seconds the cache storing data before the cache entry is discarded. On the other hand, the CacheExpirationPolicy describes the behavior of the cache in order to release the memory. If the CacheExpirationPolicy is set to Absolute, the cache data will be hold in memory for - at most - the amount of time that is specified by the CacheDuration. The data might be released before the duration time if the memory is needed. If the CacheExpirationPolicy is set to Sliding, the cache expires when there is no activity for a time that is equal to the CacheDuration.
    The CachePriority setting takes affect when When the Web server hosting an ASP.NET application runs low on memory. the PageCache object selectively purges items to free system memory. When an item is added to PageCache, you can assign relative priority / CachePriority compared to other items stored in the cache. Items to which you assign higher priority values are less likely to be deleted from the cache when the server is processing a large number of requests, whereas items to which you assign lower priority values are more likely to be deleted.
  • Session
    Session stores the Cache Data in Session Object. The cache is expired when session is timed out or Session.Abandon() method is called. In order to extend the cache time, simply increase the Session’s timeout value. Session is best used for scenarios when data is scoped based per user/session and when on-demand data retrieval implementation is required.
  • File Server
    File Server stores the Cache Data in a server (physical hard-disk). Using the unique-patterned key generated by ISDataSource.NET the data will be paired and stored in an actual server/machine. You can configure how the cached data is removed from Fileserver through ISDataSource or you can perform it manually from the Fileserver itself.

For further information regarding this property please read Cache Storage.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Tasks

How-to: Use file server for an instance of control
How-to: Configure file server to use shared network drive

Concepts

Cache storage

Other Resources

Cache Key Pattern


CancelSelectOnNullParameter Property

[image]
ISDataSource Documentation
CancelSelectOnNullParameter Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : CancelSelectOnNullParameter Property

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
Public Property CancelSelectOnNullParameter As CancelSelectOnNullParameter
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As CancelSelectOnNullParameter

instance.CancelSelectOnNullParameter = value

value = instance.CancelSelectOnNullParameter
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public CancelSelectOnNullParameter CancelSelectOnNullParameter {get; set;}
Delphi
public read-write property CancelSelectOnNullParameter: CancelSelectOnNullParameter;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")
CategoryAttribute("Data")
DefaultValueAttribute()
public function get,set CancelSelectOnNullParameter : CancelSelectOnNullParameter
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public: __property CancelSelectOnNullParameter get_CancelSelectOnNullParameter();
public: __property void set_CancelSelectOnNullParameter(
   CancelSelectOnNullParameter value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Indicates whether the Select operation will be cancelled if the value of any of the SelectParameters is null")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public:
property CancelSelectOnNullParameter CancelSelectOnNullParameter {
   CancelSelectOnNullParameter get();
   void set (    CancelSelectOnNullParameter value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Tasks

How-to: Utilize CancelSelectOnNullParameters


ConflictDetection Property

[image]
ISDataSource Documentation
ConflictDetection Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : ConflictDetection Property

Gets or sets a value that determines whether only the new values are passed to the Update method or both the old and new values are passed to the Update method. Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies how data conflicts are resolved.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Data")>
Public Property ConflictDetection As ISNet.WebUI.ConflictOptions
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ISNet.WebUI.ConflictOptions

instance.ConflictDetection = value

value = instance.ConflictDetection
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies how data conflicts are resolved.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
public ISNet.WebUI.ConflictOptions ConflictDetection {get; set;}
Delphi
public read-write property ConflictDetection: ISNet.WebUI.ConflictOptions;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies how data conflicts are resolved.")
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Data")
public function get,set ConflictDetection : ISNet.WebUI.ConflictOptions
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies how data conflicts are resolved.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
public: __property ISNet.WebUI.ConflictOptions get_ConflictDetection();
public: __property void set_ConflictDetection(
   ISNet.WebUI.ConflictOptions value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies how data conflicts are resolved.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Data")]
public:
property ISNet.WebUI.ConflictOptions ConflictDetection {
   ISNet.WebUI.ConflictOptions get();
   void set (    ISNet.WebUI.ConflictOptions value);
}

Property Value

One of the ConflictOptions values. The default is ConflictOptions.Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Automatic conflict detection behavior


ConvertNullToDBNull Property

[image]
ISDataSource Documentation
ConvertNullToDBNull Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : ConvertNullToDBNull Property

Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
<DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")>
Public Property ConvertNullToDBNull As NullToDBNull
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As NullToDBNull

instance.ConvertNullToDBNull = value

value = instance.ConvertNullToDBNull
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")]
public NullToDBNull ConvertNullToDBNull {get; set;}
Delphi
public read-write property ConvertNullToDBNull: NullToDBNull;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
CategoryAttribute("Data")
DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")
public function get,set ConvertNullToDBNull : NullToDBNull
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")]
public: __property NullToDBNull get_ConvertNullToDBNull();
public: __property void set_ConvertNullToDBNull(
   NullToDBNull value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[DescriptionAttribute("Specifies whether null parameter values passed into methods will be converted to System.DBNull.")]
public:
property NullToDBNull ConvertNullToDBNull {
   NullToDBNull get();
   void set (    NullToDBNull value);
}

Property Value

NullToDBNull.No, if any a null reference (Nothing in Visual Basic) values in Parameter objects passed to the ISDataSource control are automatically converted to System.DbNull.Value values; otherwise, NullToDBNull.Yes. The default is NullToDBNull.Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


DataObjectTypeName Property

[image]
ISDataSource Documentation
DataObjectTypeName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : DataObjectTypeName Property

Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control. Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Specifies a type that can be constructed for Update, Insert, and Delete operations when the method takes this type rather than having one parameter for each property.")>
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DataObjectTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.DataObjectTypeName = value

value = instance.DataObjectTypeName
C#
[DescriptionAttribute("Specifies a type that can be constructed for Update, Insert, and Delete operations when the method takes this type rather than having one parameter for each property.")]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public string DataObjectTypeName {get; set;}
Delphi
public read-write property DataObjectTypeName: String;
JScript
DescriptionAttribute("Specifies a type that can be constructed for Update, Insert, and Delete operations when the method takes this type rather than having one parameter for each property.")
DefaultValueAttribute()
CategoryAttribute("Data")
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DataObjectTypeName : String
Managed Extensions for C++
[DescriptionAttribute("Specifies a type that can be constructed for Update, Insert, and Delete operations when the method takes this type rather than having one parameter for each property.")]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_DataObjectTypeName();
public: __property void set_DataObjectTypeName(
   string* value
);
C++/CLI
[DescriptionAttribute("Specifies a type that can be constructed for Update, Insert, and Delete operations when the method takes this type rather than having one parameter for each property.")]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ DataObjectTypeName {
   String^ get();
   void set (    String^ value);
}

Property Value

A partially or fully qualified class name that identifies the type of the object that the ISDataSourceTable can use as a parameter for an Insert, Update, or a Delete operation. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Tasks

How-to: Utilize DataObjectTypeName

Concepts

Architecture


DeleteMethod Property

[image]
ISDataSource Documentation
DeleteMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : DeleteMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Data")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("The method to execute when Delete() is called.")>
Public Property DeleteMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.DeleteMethod = value

value = instance.DeleteMethod
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The method to execute when Delete() is called.")]
public string DeleteMethod {get; set;}
Delphi
public read-write property DeleteMethod: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Data")
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("The method to execute when Delete() is called.")
public function get,set DeleteMethod : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The method to execute when Delete() is called.")]
public: __property string* get_DeleteMethod();
public: __property void set_DeleteMethod(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("The method to execute when Delete() is called.")]
public:
property String^ DeleteMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to delete data. The default is an empty string ("").

Remarks

Using DeleteMethod property you can set the name of the business object method or function that deletes data, and include any necessary parameter in the DeleteParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


DeleteParameters Property

[image]
ISDataSource Documentation
DeleteParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : DeleteParameters Property

Gets the parameters collection that contains the parameters that are used by the DeleteMethod method. Gets the parameters collection that contains the parameters that are used by the DeleteMethod method.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Collection of parameters used when calling the DeleteMethod. These parameters are merged with parameters provided by data-bound controls.")>
<CategoryAttribute("Data")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<MergablePropertyAttribute(False)>
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public ReadOnly Property DeleteParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ParameterCollection

value = instance.DeleteParameters
C#
[DescriptionAttribute("Collection of parameters used when calling the DeleteMethod. These parameters are merged with parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[MergablePropertyAttribute(false)]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ParameterCollection DeleteParameters {get;}
Delphi
public read-only property DeleteParameters: ParameterCollection;
JScript
DescriptionAttribute("Collection of parameters used when calling the DeleteMethod. These parameters are merged with parameters provided by data-bound controls.")
CategoryAttribute("Data")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
MergablePropertyAttribute()
DefaultValueAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get DeleteParameters : ParameterCollection
Managed Extensions for C++
[DescriptionAttribute("Collection of parameters used when calling the DeleteMethod. These parameters are merged with parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[MergablePropertyAttribute(false)]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property ParameterCollection* get_DeleteParameters();
C++/CLI
[DescriptionAttribute("Collection of parameters used when calling the DeleteMethod. These parameters are merged with parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[MergablePropertyAttribute(false)]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
property ParameterCollection^ DeleteParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the DeleteMethod method.

Remarks

Using DeleteMethod property you can set the name of the business object method or function that deletes data, and include any necessary parameters in the DeleteParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


EnableCaching Property

[image]
ISDataSource Documentation
EnableCaching Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : EnableCaching Property

Gets or sets a value indicating whether the ISDataSource control has data caching enabled.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Cache")>
<DescriptionAttribute("Whether caching is enabled for this data source.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property EnableCaching As CacheEnabled
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As CacheEnabled

instance.EnableCaching = value

value = instance.EnableCaching
C#
[CategoryAttribute("Cache")]
[DescriptionAttribute("Whether caching is enabled for this data source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual CacheEnabled EnableCaching {get; set;}
Delphi
public read-write property EnableCaching: CacheEnabled; virtual;
JScript
CategoryAttribute("Cache")
DescriptionAttribute("Whether caching is enabled for this data source.")
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableCaching : CacheEnabled
Managed Extensions for C++
[CategoryAttribute("Cache")]
[DescriptionAttribute("Whether caching is enabled for this data source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual CacheEnabled get_EnableCaching();
public: __property virtual void set_EnableCaching(
   CacheEnabled value
);
C++/CLI
[CategoryAttribute("Cache")]
[DescriptionAttribute("Whether caching is enabled for this data source.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property CacheEnabled EnableCaching {
   CacheEnabled get();
   void set (    CacheEnabled value);
}

Property Value

CacheEnabled.Yes if data caching is enabled for the data source control; otherwise, CacheEnabled.No. The default is CacheEnabled.Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


EnablePaging Property

[image]
ISDataSource Documentation
EnablePaging Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : EnablePaging Property

Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves. Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Paging")>
<DescriptionAttribute("ISDataSource_EnablePaging")>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnablePaging As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Boolean

instance.EnablePaging = value

value = instance.EnablePaging
C#
[CategoryAttribute("Paging")]
[DescriptionAttribute("ISDataSource_EnablePaging")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public bool EnablePaging {get; set;}
Delphi
public read-write property EnablePaging: Boolean;
JScript
CategoryAttribute("Paging")
DescriptionAttribute("ISDataSource_EnablePaging")
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnablePaging : boolean
Managed Extensions for C++
[CategoryAttribute("Paging")]
[DescriptionAttribute("ISDataSource_EnablePaging")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property bool get_EnablePaging();
public: __property void set_EnablePaging(
   bool value
);
C++/CLI
[CategoryAttribute("Paging")]
[DescriptionAttribute("ISDataSource_EnablePaging")]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property bool EnablePaging {
   bool get();
   void set (    bool value);
}

Property Value

true, if the data source control supports paging through the data it retrieves; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Tasks

How-to: Utilize Paging Capability


FilterExpression Property

[image]
ISDataSource Documentation
FilterExpression Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : FilterExpression Property

Gets or sets a filtering expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a filtering expression that is applied when the method that is specified by the SelectMethod property is called.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Data")>
<DescriptionAttribute("Filter expression used when Select() is called. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")>
Public Property FilterExpression As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.FilterExpression = value

value = instance.FilterExpression
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("Filter expression used when Select() is called. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")]
public string FilterExpression {get; set;}
Delphi
public read-write property FilterExpression: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("Data")
DescriptionAttribute("Filter expression used when Select() is called. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")
public function get,set FilterExpression : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("Filter expression used when Select() is called. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")]
public: __property string* get_FilterExpression();
public: __property void set_FilterExpression(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("Filter expression used when Select() is called. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")]
public:
property String^ FilterExpression {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents a filtering expression applied when data is retrieved using the method or function identified by the SelectMethod property.

Remarks

The ISDataSourceTable can sort and filter data that is retrieved by the SelectMethod property if the data is returned as a DataSet, DataView or DataTable object.

You can set the FilterExpression property to a filtering expression using a format string syntax and bind values in the expression to parameters that are specified in the FilterParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Sorting and Filtering Data

Tasks

How-to: Utilize FilterExpression


FilterParameters Property

[image]
ISDataSource Documentation
FilterParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : FilterParameters Property

Gets a collection of parameters that are associated with any parameter placeholder in the FilterExpression string. Gets a collection of parameters that are associated with any parameter placeholders in the FilterExpression string.

Syntax

Visual Basic (Declaration)
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Collection of parameters used in FilterExpression property. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")>
<MergablePropertyAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public ReadOnly Property FilterParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ParameterCollection

value = instance.FilterParameters
C#
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of parameters used in FilterExpression property. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")]
[MergablePropertyAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ParameterCollection FilterParameters {get;}
Delphi
public read-only property FilterParameters: ParameterCollection;
JScript
PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
CategoryAttribute("Data")
NotifyParentPropertyAttribute()
DescriptionAttribute("Collection of parameters used in FilterExpression property. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")
MergablePropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get FilterParameters : ParameterCollection
Managed Extensions for C++
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of parameters used in FilterExpression property. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")]
[MergablePropertyAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property ParameterCollection* get_FilterParameters();
C++/CLI
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of parameters used in FilterExpression property. Filtering is only available when the SelectMethod returns a DataSet or a DataTable.")]
[MergablePropertyAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
property ParameterCollection^ FilterParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains a set of parameters associated with any parameter placeholders found in the FilterExpression property.

Remarks

The ISDataSourceTable can sort and filter data that is retrieved by the SelectMethod property if the data is returned as a DataSet, DataView or DataTable object.

You can set the FilterExpression property to a filtering expression using a format string syntax and bind values in the expression to parameters that are specified in the FilterParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Sorting and Filtering Data

tasks

How-to: Utilize FilterParameters
How-to: Utilize multiple FilterParameters


InsertMethod Property

[image]
ISDataSource Documentation
InsertMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : InsertMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to insert data.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Data")>
<DescriptionAttribute("The method to execute when Insert() is called.")>
Public Property InsertMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.InsertMethod = value

value = instance.InsertMethod
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("The method to execute when Insert() is called.")]
public string InsertMethod {get; set;}
Delphi
public read-write property InsertMethod: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("Data")
DescriptionAttribute("The method to execute when Insert() is called.")
public function get,set InsertMethod : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("The method to execute when Insert() is called.")]
public: __property string* get_InsertMethod();
public: __property void set_InsertMethod(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("The method to execute when Insert() is called.")]
public:
property String^ InsertMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to insert data. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


InsertParameters Property

[image]
ISDataSource Documentation
InsertParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : InsertParameters Property

Gets the parameters collection that contains the parameters that are used by the InsertMethod method.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Collection of values used when calling the InsertMethod. These parameters are merged with the parameters provided by data-bound controls.")>
<CategoryAttribute("Data")>
<ISNet.Serialization.XmlSerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<MergablePropertyAttribute(False)>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public ReadOnly Property InsertParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ParameterCollection

value = instance.InsertParameters
C#
[DescriptionAttribute("Collection of values used when calling the InsertMethod. These parameters are merged with the parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[MergablePropertyAttribute(false)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ParameterCollection InsertParameters {get;}
Delphi
public read-only property InsertParameters: ParameterCollection;
JScript
DescriptionAttribute("Collection of values used when calling the InsertMethod. These parameters are merged with the parameters provided by data-bound controls.")
CategoryAttribute("Data")
ISNet.Serialization.XmlSerializableAttribute()
NotifyParentPropertyAttribute()
DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
MergablePropertyAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get InsertParameters : ParameterCollection
Managed Extensions for C++
[DescriptionAttribute("Collection of values used when calling the InsertMethod. These parameters are merged with the parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[MergablePropertyAttribute(false)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property ParameterCollection* get_InsertParameters();
C++/CLI
[DescriptionAttribute("Collection of values used when calling the InsertMethod. These parameters are merged with the parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[MergablePropertyAttribute(false)]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
property ParameterCollection^ InsertParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the method identified by the InsertMethod property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


MaximumRowsParameterName Property

[image]
ISDataSource Documentation
MaximumRowsParameterName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : MaximumRowsParameterName Property

Gets or sets the name of the data retrieval method parameter that is used to indicate the number of records to retrieve for data source paging support.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Paging")>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("ISDataSource_MaximumRowsParameterName")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MaximumRowsParameterName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.MaximumRowsParameterName = value

value = instance.MaximumRowsParameterName
C#
[CategoryAttribute("Paging")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("ISDataSource_MaximumRowsParameterName")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public string MaximumRowsParameterName {get; set;}
Delphi
public read-write property MaximumRowsParameterName: String;
JScript
CategoryAttribute("Paging")
DefaultValueAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("ISDataSource_MaximumRowsParameterName")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MaximumRowsParameterName : String
Managed Extensions for C++
[CategoryAttribute("Paging")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("ISDataSource_MaximumRowsParameterName")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_MaximumRowsParameterName();
public: __property void set_MaximumRowsParameterName(
   string* value
);
C++/CLI
[CategoryAttribute("Paging")]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("ISDataSource_MaximumRowsParameterName")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ MaximumRowsParameterName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the method parameter used to indicate the number of records to retrieve. The default is "maximumRows".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


OldValuesParameterFormatString Property

[image]
ISDataSource Documentation
OldValuesParameterFormatString Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : OldValuesParameterFormatString Property

Gets or sets a format string to apply to the names of the parameters for original values that are passed to the Delete or Update methods.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Data")>
<DescriptionAttribute("The format string applied to the parameter names of the old values passed in an update command when old data values are being compared for conflicts. For example, "Original_{0}". To remove the prefix, specify "{0}" for the value of this property.")>
Public Property OldValuesParameterFormatString As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.OldValuesParameterFormatString = value

value = instance.OldValuesParameterFormatString
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("The format string applied to the parameter names of the old values passed in an update command when old data values are being compared for conflicts. For example, "Original_{0}". To remove the prefix, specify "{0}" for the value of this property.")]
public string OldValuesParameterFormatString {get; set;}
Delphi
public read-write property OldValuesParameterFormatString: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("Data")
DescriptionAttribute("The format string applied to the parameter names of the old values passed in an update command when old data values are being compared for conflicts. For example, "Original_{0}". To remove the prefix, specify "{0}" for the value of this property.")
public function get,set OldValuesParameterFormatString : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("The format string applied to the parameter names of the old values passed in an update command when old data values are being compared for conflicts. For example, "Original_{0}". To remove the prefix, specify "{0}" for the value of this property.")]
public: __property string* get_OldValuesParameterFormatString();
public: __property void set_OldValuesParameterFormatString(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DescriptionAttribute("The format string applied to the parameter names of the old values passed in an update command when old data values are being compared for conflicts. For example, "Original_{0}". To remove the prefix, specify "{0}" for the value of this property.")]
public:
property String^ OldValuesParameterFormatString {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents a format string applied to the names of any oldValues or key parameters passed to the Delete or Update methods. The default is the "{0}", which means the parameter name is the field name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


ParameterOption Property

[image]
ISDataSource Documentation
ParameterOption Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : ParameterOption Property

Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the behavior how the values is passed from Intersoft data-bound controls for Update, Insert and Delete operations.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DefaultValueAttribute()>
<DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable for when ISDataSource is bound to Intersoft data-bound controls.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Behavior")>
Public Property ParameterOption As ISNet.WebUI.ParameterOptions
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ISNet.WebUI.ParameterOptions

instance.ParameterOption = value

value = instance.ParameterOption
C#
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable for when ISDataSource is bound to Intersoft data-bound controls.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
public ISNet.WebUI.ParameterOptions ParameterOption {get; set;}
Delphi
public read-write property ParameterOption: ISNet.WebUI.ParameterOptions;
JScript
NotifyParentPropertyAttribute()
DefaultValueAttribute()
DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable for when ISDataSource is bound to Intersoft data-bound controls.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Behavior")
public function get,set ParameterOption : ISNet.WebUI.ParameterOptions
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable for when ISDataSource is bound to Intersoft data-bound controls.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
public: __property ISNet.WebUI.ParameterOptions get_ParameterOption();
public: __property void set_ParameterOption(
   ISNet.WebUI.ParameterOptions value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DefaultValueAttribute()]
[DescriptionAttribute("Specifies how the values is passed from Intersoft data-bound control for Update, Insert and Delete operations. This feature only useable for when ISDataSource is bound to Intersoft data-bound controls.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Behavior")]
public:
property ISNet.WebUI.ParameterOptions ParameterOption {
   ISNet.WebUI.ParameterOptions get();
   void set (    ISNet.WebUI.ParameterOptions value);
}

Property Value

One of the ParameterOptions values. The default is ParameterOptions.Default.

Remarks

By default in .NET data-bound controls will pass all textbox fields to DataSource control as InputParameters. This might cause problems since we need to create a DataOperation method signature (Insert/Update/Delete) that match the InputParameters given. ParameterOption can be used determine whether WebGrid.NET will pass all available fields as InputParameters or merge data from available fields (updated data) and original data retrieved previously as InputParameters.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Parameter Option


SelectChildRowMethod Property

[image]
ISDataSource Documentation
SelectChildRowMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SelectChildRowMethod Property

Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve child rows data. Used for performing load on demand in Hierachical WebGrid 5.0+ .

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Behavior")>
<DescriptionAttribute("The method to execute when performing load on demand in Hierarchical WebGrid 5.0+ .")>
Public Property SelectChildRowMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.SelectChildRowMethod = value

value = instance.SelectChildRowMethod
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("The method to execute when performing load on demand in Hierarchical WebGrid 5.0+ .")]
public string SelectChildRowMethod {get; set;}
Delphi
public read-write property SelectChildRowMethod: String;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
CategoryAttribute("Behavior")
DescriptionAttribute("The method to execute when performing load on demand in Hierarchical WebGrid 5.0+ .")
public function get,set SelectChildRowMethod : String
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("The method to execute when performing load on demand in Hierarchical WebGrid 5.0+ .")]
public: __property string* get_SelectChildRowMethod();
public: __property void set_SelectChildRowMethod(
   string* value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Behavior")]
[DescriptionAttribute("The method to execute when performing load on demand in Hierarchical WebGrid 5.0+ .")]
public:
property String^ SelectChildRowMethod {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


SelectCountMethod Property

[image]
ISDataSource Documentation
SelectCountMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SelectCountMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve a row count.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultValueAttribute()>
<DescriptionAttribute("ISDataSource_SelectCountMethod")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<CategoryAttribute("Paging")>
Public Property SelectCountMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.SelectCountMethod = value

value = instance.SelectCountMethod
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("ISDataSource_SelectCountMethod")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Paging")]
public string SelectCountMethod {get; set;}
Delphi
public read-write property SelectCountMethod: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
DefaultValueAttribute()
DescriptionAttribute("ISDataSource_SelectCountMethod")
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
CategoryAttribute("Paging")
public function get,set SelectCountMethod : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("ISDataSource_SelectCountMethod")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Paging")]
public: __property string* get_SelectCountMethod();
public: __property void set_SelectCountMethod(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultValueAttribute()]
[DescriptionAttribute("ISDataSource_SelectCountMethod")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[CategoryAttribute("Paging")]
public:
property String^ SelectCountMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceView uses to retrieve a row count. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


SelectMethod Property

[image]
ISDataSource Documentation
SelectMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SelectMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve data.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("The method to execute when Select() is called.")>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SelectMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.SelectMethod = value

value = instance.SelectMethod
C#
[DescriptionAttribute("The method to execute when Select() is called.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public string SelectMethod {get; set;}
Delphi
public read-write property SelectMethod: String;
JScript
DescriptionAttribute("The method to execute when Select() is called.")
NotifyParentPropertyAttribute()
CategoryAttribute("Data")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SelectMethod : String
Managed Extensions for C++
[DescriptionAttribute("The method to execute when Select() is called.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property string* get_SelectMethod();
public: __property void set_SelectMethod(
   string* value
);
C++/CLI
[DescriptionAttribute("The method to execute when Select() is called.")]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property String^ SelectMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to retrieve data. The default is an empty string ("").

Remarks

ISDataSource.NET performs data operations through its ISDataSourceTable collection. When working with a data-bound control you can use DataMember property to determine which ISDataSourceTable from ISDataSourceTable collection to be bounded to the data-bound control.

In order to retrieve data from a business object, you need to set the corresponding ISDataSourceTable’s SelectMethod property with the name of the method that retrieve the data. If the method does not return an IEnumerable or DataSet object, the object is wrapped by runtime in an IEnumerable collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Processing data using ISDataSource.NET


SelectParameters Property

[image]
ISDataSource Documentation
SelectParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SelectParameters Property

Gets the parameters collection that contains the parameters that are used by the SelectMethod method.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("Collection of parameters used when calling the SelectMethod.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Data")>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<MergablePropertyAttribute(False)>
<DefaultValueAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public ReadOnly Property SelectParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ParameterCollection

value = instance.SelectParameters
C#
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of parameters used when calling the SelectMethod.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[MergablePropertyAttribute(false)]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ParameterCollection SelectParameters {get;}
Delphi
public read-only property SelectParameters: ParameterCollection;
JScript
NotifyParentPropertyAttribute()
DescriptionAttribute("Collection of parameters used when calling the SelectMethod.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Data")
PersistenceModeAttribute(PersistenceMode.InnerProperty)
MergablePropertyAttribute()
DefaultValueAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get SelectParameters : ParameterCollection
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of parameters used when calling the SelectMethod.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[MergablePropertyAttribute(false)]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property ParameterCollection* get_SelectParameters();
C++/CLI
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("Collection of parameters used when calling the SelectMethod.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Data")]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[MergablePropertyAttribute(false)]
[DefaultValueAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
property ParameterCollection^ SelectParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the SelectMethod method.

Remarks

ISDataSource.NET performs data operations through its ISDataSourceTable collection. When working with a data-bound control you can use DataMember property to determine which ISDataSourceTable from ISDataSourceTable collection to be bounded to the data-bound control.

In order to retrieve data from a business object, you need to set the corresponding ISDataSourceTable’s SelectMethod property with the name of the method that retrieve the data. If the method signature has parameters, you can add Parameter objects to the SelectParameters collection and bind them to the values that you want to pass to the method that is specified in ISDataSourceTable’s SelectMethod method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Processing data using ISDataSource.NET


SelectSelfReferenceRowMethod Property

[image]
ISDataSource Documentation
SelectSelfReferenceRowMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SelectSelfReferenceRowMethod Property

Note : This feature only useable when ISDataSource is bound to Intersoft data-bound controls. Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve self reference rows data. Used for performing load on demand in SelfReferenced WebGrid 5.0+ .

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Behavior")>
<DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("The method to execute when performing load on demand in SelfReferenced WebGrid 5.0+ .")>
<NotifyParentPropertyAttribute(True)>
Public Property SelectSelfReferenceRowMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.SelectSelfReferenceRowMethod = value

value = instance.SelectSelfReferenceRowMethod
C#
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("The method to execute when performing load on demand in SelfReferenced WebGrid 5.0+ .")]
[NotifyParentPropertyAttribute(true)]
public string SelectSelfReferenceRowMethod {get; set;}
Delphi
public read-write property SelectSelfReferenceRowMethod: String;
JScript
CategoryAttribute("Behavior")
DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("The method to execute when performing load on demand in SelfReferenced WebGrid 5.0+ .")
NotifyParentPropertyAttribute()
public function get,set SelectSelfReferenceRowMethod : String
Managed Extensions for C++
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("The method to execute when performing load on demand in SelfReferenced WebGrid 5.0+ .")]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_SelectSelfReferenceRowMethod();
public: __property void set_SelectSelfReferenceRowMethod(
   string* value
);
C++/CLI
[CategoryAttribute("Behavior")]
[DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("The method to execute when performing load on demand in SelfReferenced WebGrid 5.0+ .")]
[NotifyParentPropertyAttribute(true)]
public:
property String^ SelectSelfReferenceRowMethod {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


SortExpression Property

[image]
ISDataSource Documentation
SortExpression Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SortExpression Property

Gets or sets a sorting expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a sorting expression that is applied when the method that is specified by the SelectMethod property is called.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("ISDataSourceTable_SortExpression")>
<ISNet.Serialization.BinarySerializableAttribute()>
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
<NotifyParentPropertyAttribute(True)>
Public Property SortExpression As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.SortExpression = value

value = instance.SortExpression
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("ISDataSourceTable_SortExpression")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
public string SortExpression {get; set;}
Delphi
public read-write property SortExpression: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("ISDataSourceTable_SortExpression")
ISNet.Serialization.BinarySerializableAttribute()
DefaultValueAttribute()
CategoryAttribute("Data")
NotifyParentPropertyAttribute()
public function get,set SortExpression : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("ISDataSourceTable_SortExpression")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_SortExpression();
public: __property void set_SortExpression(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("ISDataSourceTable_SortExpression")]
[ISNet.Serialization.BinarySerializableAttribute()]
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[NotifyParentPropertyAttribute(true)]
public:
property String^ SortExpression {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents a sorting expression applied when data is retrieved using the method or function identified by the SelectMethod property.

Remarks

Sorting Expression is used to sort the data retrieved by ISDataSourceControl. The SortExpression in ISDataSource will always act as secondary sorting after the data-bound controls sorting mechanism.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Sorting and Filtering Data

Tasks

How-to: Utilize SortExpression


SortParameterName Property

[image]
ISDataSource Documentation
SortParameterName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SortParameterName Property

Gets or sets the name of the business object that the SelectMethod parameter uses to specify a sort expression for data source sorting support. Gets or sets the name of the business object that the SelectMethod parameter used to specify a sort expression for data source sorting support.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("The name of parameter on the Select Method that accepts a sort expression, if any.")>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
Public Property SortParameterName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.SortParameterName = value

value = instance.SortParameterName
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The name of parameter on the Select Method that accepts a sort expression, if any.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public string SortParameterName {get; set;}
Delphi
public read-write property SortParameterName: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("The name of parameter on the Select Method that accepts a sort expression, if any.")
CategoryAttribute("Data")
DefaultValueAttribute()
public function get,set SortParameterName : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The name of parameter on the Select Method that accepts a sort expression, if any.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public: __property string* get_SortParameterName();
public: __property void set_SortParameterName(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The name of parameter on the Select Method that accepts a sort expression, if any.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public:
property String^ SortParameterName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the method parameter used to indicate the parameter that accepts this sort expression value. The default is an empty string ("").

Remarks

You can set the SortParameterName property to the name of the parameter in SelectMethod method that carries the sort criteria. Then, you can set the SortExpression property to perform sorting when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView or a DataTable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Tasks

How-to: Utilize SortParameterName


StartRowIndexParameterName Property

[image]
ISDataSource Documentation
StartRowIndexParameterName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : StartRowIndexParameterName Property

Gets or sets the name of the data retrieval method parameter that is used to indicate the integer index of the first record to retrieve from the results set for data source paging support.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<NotifyParentPropertyAttribute(True)>
<CategoryAttribute("Paging")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("ISDataSource_StartRowIndexParameterName")>
Public Property StartRowIndexParameterName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.StartRowIndexParameterName = value

value = instance.StartRowIndexParameterName
C#
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Paging")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("ISDataSource_StartRowIndexParameterName")]
public string StartRowIndexParameterName {get; set;}
Delphi
public read-write property StartRowIndexParameterName: String;
JScript
DefaultValueAttribute()
NotifyParentPropertyAttribute()
CategoryAttribute("Paging")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("ISDataSource_StartRowIndexParameterName")
public function get,set StartRowIndexParameterName : String
Managed Extensions for C++
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Paging")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("ISDataSource_StartRowIndexParameterName")]
public: __property string* get_StartRowIndexParameterName();
public: __property void set_StartRowIndexParameterName(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[NotifyParentPropertyAttribute(true)]
[CategoryAttribute("Paging")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("ISDataSource_StartRowIndexParameterName")]
public:
property String^ StartRowIndexParameterName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the business object method parameter used to indicate the first record to retrieve. The default is "startRowIndex".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


StoreCachePerPage Property

[image]
ISDataSource Documentation
StoreCachePerPage Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : StoreCachePerPage Property

Gets or sets a value indicating whether the ISDataSource control will store the cached data separately for each page.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Cache")>
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")>
Public Overridable Property StoreCachePerPage As StoreCachePerPage
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As StoreCachePerPage

instance.StoreCachePerPage = value

value = instance.StoreCachePerPage
C#
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")]
public virtual StoreCachePerPage StoreCachePerPage {get; set;}
Delphi
public read-write property StoreCachePerPage: StoreCachePerPage; virtual;
JScript
DefaultValueAttribute()
CategoryAttribute("Cache")
NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")
public function get,set StoreCachePerPage : StoreCachePerPage
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")]
public: __property virtual StoreCachePerPage get_StoreCachePerPage();
public: __property virtual void set_StoreCachePerPage(
   StoreCachePerPage value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Cache")]
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[DescriptionAttribute("Determine whether ISDataSource use separate cached data for each page")]
public:
virtual property StoreCachePerPage StoreCachePerPage {
   StoreCachePerPage get();
   void set (    StoreCachePerPage value);
}

Property Value

StoreCachePerPage.Yes if cached data is stored per page; otherwise, StoreCachePerPage.No. The default is StoreCachePerPage.Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


TableName Property

[image]
ISDataSource Documentation
TableName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : TableName Property

Gets or sets a unique value that indicates the ISDataSourceTable's Name

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Name")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("ISDataSourceTable_Name")>
<NotifyParentPropertyAttribute(True)>
Public Property TableName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.TableName = value

value = instance.TableName
C#
[DefaultValueAttribute()]
[CategoryAttribute("Name")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("ISDataSourceTable_Name")]
[NotifyParentPropertyAttribute(true)]
public string TableName {get; set;}
Delphi
public read-write property TableName: String;
JScript
DefaultValueAttribute()
CategoryAttribute("Name")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("ISDataSourceTable_Name")
NotifyParentPropertyAttribute()
public function get,set TableName : String
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Name")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("ISDataSourceTable_Name")]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_TableName();
public: __property void set_TableName(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Name")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("ISDataSourceTable_Name")]
[NotifyParentPropertyAttribute(true)]
public:
property String^ TableName {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


TypeName Property

[image]
ISDataSource Documentation
TypeName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : TypeName Property

Gets or sets the name of the class that the ISDataSourceTable object represents.

Syntax

Visual Basic (Declaration)
<DefaultValueAttribute()>
<CategoryAttribute("Data")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<DescriptionAttribute("The type that contains the methods specified in this control.")>
<NotifyParentPropertyAttribute(True)>
Public Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.TypeName = value

value = instance.TypeName
C#
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("The type that contains the methods specified in this control.")]
[NotifyParentPropertyAttribute(true)]
public string TypeName {get; set;}
Delphi
public read-write property TypeName: String;
JScript
DefaultValueAttribute()
CategoryAttribute("Data")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
DescriptionAttribute("The type that contains the methods specified in this control.")
NotifyParentPropertyAttribute()
public function get,set TypeName : String
Managed Extensions for C++
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("The type that contains the methods specified in this control.")]
[NotifyParentPropertyAttribute(true)]
public: __property string* get_TypeName();
public: __property void set_TypeName(
   string* value
);
C++/CLI
[DefaultValueAttribute()]
[CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[DescriptionAttribute("The type that contains the methods specified in this control.")]
[NotifyParentPropertyAttribute(true)]
public:
property String^ TypeName {
   String^ get();
   void set (    String^ value);
}

Property Value

A partially or fully qualified class name that identifies the type of the object that the ISDataSourceTable represents. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


UpdateMethod Property

[image]
ISDataSource Documentation
UpdateMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : UpdateMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<DescriptionAttribute("The method to execute when Update() is called.")>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
Public Property UpdateMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As String

instance.UpdateMethod = value

value = instance.UpdateMethod
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The method to execute when Update() is called.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public string UpdateMethod {get; set;}
Delphi
public read-write property UpdateMethod: String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
DescriptionAttribute("The method to execute when Update() is called.")
CategoryAttribute("Data")
DefaultValueAttribute()
public function get,set UpdateMethod : String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The method to execute when Update() is called.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public: __property string* get_UpdateMethod();
public: __property void set_UpdateMethod(
   string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[DescriptionAttribute("The method to execute when Update() is called.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
public:
property String^ UpdateMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to update data. The default is an empty string.

Remarks

You can set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameter in the UpdateParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


UpdateParameters Property

[image]
ISDataSource Documentation
UpdateParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : UpdateParameters Property

Gets the parameters collection that contains parameters that are used by the method that is specified by the UpdateMethod property. Gets the parameters collection that contains the parameters that are used by the method that is specified by the UpdateMethod property.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Collection of parameters and values used when calling the UpdateMethod. These parameters are merged with parameters provided by data-bound controls.")>
<CategoryAttribute("Data")>
<DefaultValueAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<NotifyParentPropertyAttribute(True)>
<MergablePropertyAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute()>
<EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
Public ReadOnly Property UpdateParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As ParameterCollection

value = instance.UpdateParameters
C#
[DescriptionAttribute("Collection of parameters and values used when calling the UpdateMethod. These parameters are merged with parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[MergablePropertyAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public ParameterCollection UpdateParameters {get;}
Delphi
public read-only property UpdateParameters: ParameterCollection;
JScript
DescriptionAttribute("Collection of parameters and values used when calling the UpdateMethod. These parameters are merged with parameters provided by data-bound controls.")
CategoryAttribute("Data")
DefaultValueAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
NotifyParentPropertyAttribute()
MergablePropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
public function get UpdateParameters : ParameterCollection
Managed Extensions for C++
[DescriptionAttribute("Collection of parameters and values used when calling the UpdateMethod. These parameters are merged with parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[MergablePropertyAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public: __property ParameterCollection* get_UpdateParameters();
C++/CLI
[DescriptionAttribute("Collection of parameters and values used when calling the UpdateMethod. These parameters are merged with parameters provided by data-bound controls.")]
[CategoryAttribute("Data")]
[DefaultValueAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[NotifyParentPropertyAttribute(true)]
[MergablePropertyAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="System.Web.UI.Design.WebControls.ParameterCollectionEditor, System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
public:
property ParameterCollection^ UpdateParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the method that is specified by the UpdateMethod property.

Remarks

You can set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameter in the UpdateParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


UseCachedDataOnFirstLoad Property

[image]
ISDataSource Documentation
UseCachedDataOnFirstLoad Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : UseCachedDataOnFirstLoad Property

Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled. Gets or sets a value indicating whether the ISDataSource control will use cached data on first load when caching is enabled.

Syntax

Visual Basic (Declaration)
<NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<CategoryAttribute("Cache")>
<DefaultValueAttribute()>
<DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property UseCachedDataOnFirstLoad As UseCachedDataOnFirstLoad
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As UseCachedDataOnFirstLoad

instance.UseCachedDataOnFirstLoad = value

value = instance.UseCachedDataOnFirstLoad
C#
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual UseCachedDataOnFirstLoad UseCachedDataOnFirstLoad {get; set;}
Delphi
public read-write property UseCachedDataOnFirstLoad: UseCachedDataOnFirstLoad; virtual;
JScript
NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
CategoryAttribute("Cache")
DefaultValueAttribute()
DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UseCachedDataOnFirstLoad : UseCachedDataOnFirstLoad
Managed Extensions for C++
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual UseCachedDataOnFirstLoad get_UseCachedDataOnFirstLoad();
public: __property virtual void set_UseCachedDataOnFirstLoad(
   UseCachedDataOnFirstLoad value
);
C++/CLI
[NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[CategoryAttribute("Cache")]
[DefaultValueAttribute()]
[DescriptionAttribute("Determine whether ISDataSource use the cached data if available on first load")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property UseCachedDataOnFirstLoad UseCachedDataOnFirstLoad {
   UseCachedDataOnFirstLoad get();
   void set (    UseCachedDataOnFirstLoad value);
}

Property Value

UseCachedDataOnFirstLoad.Yes if cached data gonna be used on first load; otherwise, UseCachedDataOnFirstLoad.No. The default is UseCachedDataOnFirstLoad.Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members

Concepts

Use cached on first load

Tasks

How-to: Configure cache configuration


ISDataSourceTableCollection Class

[image]
ISDataSource Documentation
ISDataSourceTableCollection Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTableCollection Class

This class is intended for internal use Represents the collection of ISDataSourceTable, that is in a ISDataSource control.

Object Model

ISDataSourceTableCollection Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<DefaultMemberAttribute("Item")>
<SerializableAttribute()>
Public Class ISDataSourceTableCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public class ISDataSourceTableCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class ISDataSourceTableCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
ISNet.Serialization.BinarySerializableAttribute()
PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
DefaultMemberAttribute("Item")
SerializableAttribute()
public class ISDataSourceTableCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public __gc class ISDataSourceTableCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public ref class ISDataSourceTableCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.DataSource.ISDataSourceTableCollection

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Members
ISNet.WebUI.DataSource Namespace


ISDataSourceTableCollection Class Members

[image]
ISDataSource Documentation
ISDataSourceTableCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTableCollection Class

The following tables list the members exposed by ISDataSourceTableCollection.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceTableCollection Constructor | Initializes a new instance of the ISDataSourceTableCollection class.
Top

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Gets a value indicating whether the collection is read-only.
public Property | Item |
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add an ISDataSourceTable object into the ISDataSourceTable collection.
public Method | Clear | Removes all ISDataSourceTable objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom | Copy collection of ISDataSourceTable from another ISDataSourceTableCollection
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetEnumerator | Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an ISDataSourceTable object.
public Method | GetObjectData |
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Insert | Inserts an ISDataSourceTable object into the ISDataSourceTable collection at a specified index.
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Remove | Removes the specified ISDataSourceTable object from the collection.
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ISDataSourceTableCollection Class
ISNet.WebUI.DataSource Namespace


ISDataSourceTableCollection Constructor

[image]
ISDataSource Documentation
ISDataSourceTableCollection Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : ISDataSourceTableCollection Constructor

Initializes a new instance of the ISDataSourceTableCollection class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceTableCollection()
C#
public ISDataSourceTableCollection()
Delphi
public ISDataSourceTableCollection();
JScript
public function ISDataSourceTableCollection();
Managed Extensions for C++
public: ISDataSourceTableCollection();
C++/CLI
public:
ISDataSourceTableCollection();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


ISDataSourceTableCollection Class Methods

[image]
ISDataSource Documentation
ISDataSourceTableCollection Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTableCollection Class

For a list of all members of this type, see ISDataSourceTableCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Add an ISDataSourceTable object into the ISDataSourceTable collection.
public Method | Clear | Removes all ISDataSourceTable objects from the collection.
public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | CopyFrom | Copy collection of ISDataSourceTable from another ISDataSourceTableCollection
public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetEnumerator | Returns an enumerator object for the collection.
public Method | GetItem | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an ISDataSourceTable object.
public Method | GetObjectData |
public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Insert | Inserts an ISDataSourceTable object into the ISDataSourceTable collection at a specified index.
public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
public Method | Remove | Removes the specified ISDataSourceTable object from the collection.
public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ISDataSourceTableCollection Class
ISNet.WebUI.DataSource Namespace


Add Method

[image]
ISDataSource Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Add Method

Add an ISDataSourceTable object into the ISDataSourceTable collection.

Overload List

Overload | Description
Add(ISDataSourceTable) | Add an ISDataSourceTable object into the ISDataSourceTable collection.
Add(String) | Creates a new ISDataSourceTable object in the collection and initializes its Name value.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Add(ISDataSourceTable) Method

[image]
ISDataSource Documentation
Add(ISDataSourceTable) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class > Add Method : Add(ISDataSourceTable) Method

table
The ISDataSourceTable object to be added.
Add an ISDataSourceTable object into the ISDataSourceTable collection.

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function Add( _
   ByVal table As ISDataSourceTable _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim table As ISDataSourceTable
Dim value As Integer

value = instance.Add(table)
C#
public virtual int Add(
   ISDataSourceTable table
)
Delphi
public function Add(
    table: ISDataSourceTable
): Integer; virtual;
JScript
public function Add(
   table : ISDataSourceTable
) : int;
Managed Extensions for C++
public: virtual int Add(
   ISDataSourceTable* table
)
C++/CLI
public:
virtual int Add(
   ISDataSourceTable^ table
)

Parameters

table
The ISDataSourceTable object to be added.

Return Value

The index of the newly added ISDataSourceTable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members
Overload List


Add(String) Method

[image]
ISDataSource Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class > Add Method : Add(String) Method

name
The unique Name value.
Creates a new ISDataSourceTable object in the collection and initializes its Name value.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim name As String
Dim value As Integer

value = instance.Add(name)
C#
public int Add(
   string name
)
Delphi
public function Add(
    name: String
): Integer;
JScript
public function Add(
   name : String
) : int;
Managed Extensions for C++
public: int Add(
   string* name
)
C++/CLI
public:
int Add(
   String^ name
)

Parameters

name
The unique Name value.

Return Value

The index of the newly-added ISDataSourceTable object within the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members
Overload List


Clear Method

[image]
ISDataSource Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Clear Method

Removes all ISDataSourceTable objects from the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection

instance.Clear()
C#
public new void Clear()
Delphi
public procedure Clear();
JScript
public hide function Clear();
Managed Extensions for C++
public: new void Clear();
C++/CLI
public:
new void Clear();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


CopyFrom Method

[image]
ISDataSource Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : CopyFrom Method

passIn
collection that going to be copied
Copy collection of ISDataSourceTable from another ISDataSourceTableCollection

Syntax

Visual Basic (Declaration)
Public Function CopyFrom( _
   ByVal passIn As ISDataSourceTableCollection _
) As ISDataSourceTableCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim passIn As ISDataSourceTableCollection
Dim value As ISDataSourceTableCollection

value = instance.CopyFrom(passIn)
C#
public ISDataSourceTableCollection CopyFrom(
   ISDataSourceTableCollection passIn
)
Delphi
public function CopyFrom(
    passIn: ISDataSourceTableCollection
): ISDataSourceTableCollection;
JScript
public function CopyFrom(
   passIn : ISDataSourceTableCollection
) : ISDataSourceTableCollection;
Managed Extensions for C++
public: ISDataSourceTableCollection* CopyFrom(
   ISDataSourceTableCollection* passIn
)
C++/CLI
public:
ISDataSourceTableCollection^ CopyFrom(
   ISDataSourceTableCollection^ passIn
)

Parameters

passIn
collection that going to be copied

Return Value

colection of copied ISDataSourceTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


GetEnumerator Method

[image]
ISDataSource Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : GetEnumerator Method

Returns an enumerator object for the collection.

Syntax

Visual Basic (Declaration)
Public Shadows Function GetEnumerator() As IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
C#
public new IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public hide function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: new IEnumerator* GetEnumerator();
C++/CLI
public:
new IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


GetNamedItem Method

[image]
ISDataSource Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : GetNamedItem Method

name
Property indexer for the collection. Uses the Name string to return an ISDataSourceTable object.

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As String _
) As ISDataSourceTable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim name As String
Dim value As ISDataSourceTable

value = instance.GetNamedItem(name)
C#
public ISDataSourceTable GetNamedItem(
   string name
)
Delphi
public function GetNamedItem(
    name: String
): ISDataSourceTable;
JScript
public function GetNamedItem(
   name : String
) : ISDataSourceTable;
Managed Extensions for C++
public: ISDataSourceTable* GetNamedItem(
   string* name
)
C++/CLI
public:
ISDataSourceTable^ GetNamedItem(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


GetObjectData Method

[image]
ISDataSource Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Insert Method

[image]
ISDataSource Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Insert Method

index
The position in the collection for the new ISDataSourceTable.
table
The ISDataSourceTable object to be inserted into the collection.
Inserts an ISDataSourceTable object into the ISDataSourceTable collection at a specified index.

Syntax

Visual Basic (Declaration)
Public Sub Insert( _
   ByVal index As Integer, _
   ByVal table As ISDataSourceTable _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim index As Integer
Dim table As ISDataSourceTable

instance.Insert(index, table)
C#
public void Insert(
   int index,
   ISDataSourceTable table
)
Delphi
public procedure Insert(
    index: Integer;
    table: ISDataSourceTable
);
JScript
public function Insert(
   index : int,
   table : ISDataSourceTable
);
Managed Extensions for C++
public: void Insert(
   int index,
   ISDataSourceTable* table
)
C++/CLI
public:
void Insert(
   int index,
   ISDataSourceTable^ table
)

Parameters

index
The position in the collection for the new ISDataSourceTable.
table
The ISDataSourceTable object to be inserted into the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Remove Method

[image]
ISDataSource Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Remove Method

table
The ISDataSourceTable object to be removed from the collection.
Removes the specified ISDataSourceTable object from the collection.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal table As ISDataSourceTable _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim table As ISDataSourceTable

instance.Remove(table)
C#
public void Remove(
   ISDataSourceTable table
)
Delphi
public procedure Remove(
    table: ISDataSourceTable
);
JScript
public function Remove(
   table : ISDataSourceTable
);
Managed Extensions for C++
public: void Remove(
   ISDataSourceTable* table
)
C++/CLI
public:
void Remove(
   ISDataSourceTable^ table
)

Parameters

table
The ISDataSourceTable object to be removed from the collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


ISDataSourceTableCollection Class Properties

[image]
ISDataSource Documentation
ISDataSourceTableCollection Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTableCollection Class

For a list of all members of this type, see ISDataSourceTableCollection members.

Public Properties

 | Name | Description
public Property | Capacity | (Inherited from System.Collections.CollectionBase)
public Property | Count | (Inherited from System.Collections.CollectionBase)
public Property | IsReadOnly | Overridden. Gets a value indicating whether the collection is read-only.
public Property | Item |
public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

See Also

Reference

ISDataSourceTableCollection Class
ISNet.WebUI.DataSource Namespace


IsReadOnly Property

[image]
ISDataSource Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public override bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean; override;
JScript
public override function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly() override;
C++/CLI
public:
property bool IsReadOnly {
   bool get() override;
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Item Property

[image]
ISDataSource Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Item Property

index

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As ISDataSourceTable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim index As Integer
Dim value As ISDataSourceTable

instance.Item(index) = value

value = instance.Item(index)
C#
public ISDataSourceTable this(
   int index
) {get; set;}
Delphi
public  this: : ISDataSourceTable;(
    index: Integer
); read-write
JScript
public  this(
   index : int
) get,set : ISDataSourceTable
Managed Extensions for C++
public: __property ISDataSourceTable* get_Item(
   int index
);
public: __property void set_Item(
   int index,
   ISDataSourceTable* value
);
C++/CLI
public:
property ISDataSourceTable^ default [int] {
   ISDataSourceTable^ get(int index);
   void set (int index, ISDataSourceTable^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


ISDataSourceTableSchema Class

[image]
ISDataSource Documentation
ISDataSourceTableSchema Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTableSchema Class

Object Model

ISDataSourceTableSchema Class

Syntax

Visual Basic (Declaration)
Public Class ISDataSourceTableSchema
   Implements ISNet.WebUI.IDataSourceTableSchema
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableSchema
C#
public class ISDataSourceTableSchema : ISNet.WebUI.IDataSourceTableSchema
Delphi
public class ISDataSourceTableSchema = class(ISNet.WebUI.IDataSourceTableSchema)
JScript
public class ISDataSourceTableSchema implements ISNet.WebUI.IDataSourceTableSchema
Managed Extensions for C++
public __gc class ISDataSourceTableSchema : public ISNet.WebUI.IDataSourceTableSchema
C++/CLI
public ref class ISDataSourceTableSchema : public ISNet.WebUI.IDataSourceTableSchema

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSource.ISDataSourceTableSchema

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Members
ISNet.WebUI.DataSource Namespace


ISDataSourceTableSchema Class Members

[image]
ISDataSource Documentation
ISDataSourceTableSchema Class Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTableSchema Class

The following tables list the members exposed by ISDataSourceTableSchema.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceTableSchema Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | AutoGeneratedFields |
public Property | Columns |
public Property | DataKeyFields |
public Property | IgnoredFields |
public Property | TableName |
Top

See Also

Reference

ISDataSourceTableSchema Class
ISNet.WebUI.DataSource Namespace


ISDataSourceTableSchema Constructor

[image]
ISDataSource Documentation
ISDataSourceTableSchema Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class : ISDataSourceTableSchema Constructor

Overload List

Overload | Description
ISDataSourceTableSchema Constructor(DataTable) |
ISDataSourceTableSchema Constructor(String,DataSet) |

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members


ISDataSourceTableSchema Constructor(DataTable)

[image]
ISDataSource Documentation
ISDataSourceTableSchema Constructor(DataTable)
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class > ISDataSourceTableSchema Constructor : ISDataSourceTableSchema Constructor(DataTable)

dataTable

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal dataTable As DataTable _
)
Visual Basic (Usage) Copy Code
Dim dataTable As DataTable

Dim instance As New ISDataSourceTableSchema(dataTable)
C#
public ISDataSourceTableSchema(
   DataTable dataTable
)
Delphi
public ISDataSourceTableSchema(
    dataTable: DataTable
);
JScript
public function ISDataSourceTableSchema(
   dataTable : DataTable
);
Managed Extensions for C++
public: ISDataSourceTableSchema(
   DataTable* dataTable
)
C++/CLI
public:
ISDataSourceTableSchema(
   DataTable^ dataTable
)

Parameters

dataTable

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members
Overload List


ISDataSourceTableSchema Constructor(String,DataSet)

[image]
ISDataSource Documentation
ISDataSourceTableSchema Constructor(String,DataSet)
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class > ISDataSourceTableSchema Constructor : ISDataSourceTableSchema Constructor(String,DataSet)

tableName
dataSet

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal tableName As String, _
   ByVal dataSet As DataSet _
)
Visual Basic (Usage) Copy Code
Dim tableName As String
Dim dataSet As DataSet

Dim instance As New ISDataSourceTableSchema(tableName, dataSet)
C#
public ISDataSourceTableSchema(
   string tableName,
   DataSet dataSet
)
Delphi
public ISDataSourceTableSchema(
    tableName: String;
    dataSet: DataSet
);
JScript
public function ISDataSourceTableSchema(
   tableName : String,
   dataSet : DataSet
);
Managed Extensions for C++
public: ISDataSourceTableSchema(
   string* tableName,
   DataSet* dataSet
)
C++/CLI
public:
ISDataSourceTableSchema(
   String^ tableName,
   DataSet^ dataSet
)

Parameters

tableName
dataSet

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members
Overload List


ISDataSourceTableSchema Class Properties

[image]
ISDataSource Documentation
ISDataSourceTableSchema Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceTableSchema Class

For a list of all members of this type, see ISDataSourceTableSchema members.

Public Properties

 | Name | Description
public Property | AutoGeneratedFields |
public Property | Columns |
public Property | DataKeyFields |
public Property | IgnoredFields |
public Property | TableName |
Top

See Also

Reference

ISDataSourceTableSchema Class
ISNet.WebUI.DataSource Namespace


AutoGeneratedFields Property

[image]
ISDataSource Documentation
AutoGeneratedFields Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class : AutoGeneratedFields Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AutoGeneratedFields As Collection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableSchema
Dim value As Collection(Of String)

value = instance.AutoGeneratedFields
C#
public Collection<string> AutoGeneratedFields {get;}
Delphi
public read-only property AutoGeneratedFields: Collection;
JScript
public function get AutoGeneratedFields : Collection
Managed Extensions for C++
public: __property Collection<string*>* get_AutoGeneratedFields();
C++/CLI
public:
property Collection<String^>^ AutoGeneratedFields {
   Collection<String^>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members


Columns Property

[image]
ISDataSource Documentation
Columns Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class : Columns Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Columns As Collection(Of DataColumn)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableSchema
Dim value As Collection(Of DataColumn)

value = instance.Columns
C#
public Collection<DataColumn> Columns {get;}
Delphi
public read-only property Columns: Collection;
JScript
public function get Columns : Collection
Managed Extensions for C++
public: __property Collection<DataColumn*>* get_Columns();
C++/CLI
public:
property Collection<DataColumn^>^ Columns {
   Collection<DataColumn^>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members


DataKeyFields Property

[image]
ISDataSource Documentation
DataKeyFields Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class : DataKeyFields Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DataKeyFields As Collection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableSchema
Dim value As Collection(Of String)

value = instance.DataKeyFields
C#
public Collection<string> DataKeyFields {get;}
Delphi
public read-only property DataKeyFields: Collection;
JScript
public function get DataKeyFields : Collection
Managed Extensions for C++
public: __property Collection<string*>* get_DataKeyFields();
C++/CLI
public:
property Collection<String^>^ DataKeyFields {
   Collection<String^>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members


IgnoredFields Property

[image]
ISDataSource Documentation
IgnoredFields Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class : IgnoredFields Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IgnoredFields As Collection(Of String)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableSchema
Dim value As Collection(Of String)

value = instance.IgnoredFields
C#
public Collection<string> IgnoredFields {get;}
Delphi
public read-only property IgnoredFields: Collection;
JScript
public function get IgnoredFields : Collection
Managed Extensions for C++
public: __property Collection<string*>* get_IgnoredFields();
C++/CLI
public:
property Collection<String^>^ IgnoredFields {
   Collection<String^>^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members


TableName Property

[image]
ISDataSource Documentation
TableName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableSchema Class : TableName Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TableName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableSchema
Dim value As String

value = instance.TableName
C#
public string TableName {get;}
Delphi
public read-only property TableName: String;
JScript
public function get TableName : String
Managed Extensions for C++
public: __property string* get_TableName();
C++/CLI
public:
property String^ TableName {
   String^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableSchema Class
ISDataSourceTableSchema Members


ISDataSourceView Class

[image]
ISDataSource Documentation
ISDataSourceView Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceView Class

Supports the ISDataSource control and provides an interface for data-bound controls to perform data operations with business and data objects.

Object Model

ISDataSourceView Class

Syntax

Visual Basic (Declaration)
Public Class ISDataSourceView
   Inherits System.Web.UI.DataSourceView
   Implements ISNet.WebUI.IDataSourceView
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
C#
public class ISDataSourceView : System.Web.UI.DataSourceView, ISNet.WebUI.IDataSourceView
Delphi
public class ISDataSourceView = class(System.Web.UI.DataSourceView, ISNet.WebUI.IDataSourceView)
JScript
public class ISDataSourceView extends System.Web.UI.DataSourceView implements ISNet.WebUI.IDataSourceView
Managed Extensions for C++
public __gc class ISDataSourceView : public System.Web.UI.DataSourceView, ISNet.WebUI.IDataSourceView
C++/CLI
public ref class ISDataSourceView : public System.Web.UI.DataSourceView, ISNet.WebUI.IDataSourceView

Remarks

The ISDataSourceView handles most of the operation behind the scene of ISDataSourceTable. You can use GetView(string viewName) method to gain access to corresponding ISDataSourceView.

The following list describes the capabilities of ISDataSourceTable class that are handled by ISDataSourvrView:

  • Selecting - Set the SelectMethod property (in ISDataSourceTable) to the name of business object methods that selects data and include any necessary parameters in the SelectParameters collection either programmatically or by using a data-bound control
  • Sorting - Set the SortParameterName property to the name of the parameter in SelectMethod method that carries the sort criteria. Set the SortExpression property to perform sorting when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView or a DataTable.
  • Filtering - Set the FilterExpression property to a filtering expression and optionally add any parameter to the FilterParameters collection to filter the data when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView, or DataTable.
  • Paging - Data source paging is supported, if the SelectMethod method contains parameters for the maximum number of records to retrieve and the index of the first record to retrieve. The names of those parameters must be set in the MaximumRowsParameterName and StartRowIndexParameterName properties, respectively. A data-bound control might be able to perform paging itself, even if the ISDataSource control does not support paging directly in the method specified by the SelectMethod property. The requirement for the data-bound control to be able to do this is that the method specified by the SelectMethod property return an object that implements the Icollection interface.
  • Updating - Set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameters in the UpdateParameters collection.
  • Deleting - Set the DeleteMethod property to the name of the business object method or function that deletes data, and include any necessary parameters in the DeleteParameters collection.
  • Inserting - Set the InsertMethod property to the name of the business object method or function that inserts data and include any necessary parameters in the InsertParameters collection.
  • Caching - Set the EnableCaching property to true, and configure cache settings according to the caching behavior you want for your cached data.

Inheritance Hierarchy

System.Object
System.Web.UI.DataSourceView
ISNet.WebUI.DataSource.ISDataSourceView

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Members
ISNet.WebUI.DataSource Namespace


ISDataSourceView Class Members

[image]
ISDataSource Documentation
ISDataSourceView Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceView Class

The following tables list the members exposed by ISDataSourceView.

Public Constructors

 | Name | Description
public Constructor | ISDataSourceView Constructor | Initializes a new instance of the ISDataSourceView class.
Top

Public Properties

 | Name | Description
public Property | CancelSelectOnNullParameter |
public Property | CanDelete | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the delete operation.
public Property | CanInsert | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the insert operation.
public Property | CanPage | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports paging through the retrieved data.
public Property | CanRetrieveTotalRowCount | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports retrieving the total number of data rows, in addition to the set of data.
public Property | CanSort | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports a sorted view on the underlying data source.
public Property | CanUpdate | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the update operation.
public Property | ConflictDetection | Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.
public Property | ConvertNullToDBNull | Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.
public Property | DataObjectTypeName | Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control.
public Property | DeleteMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data.
public Property | DeleteParameters | Gets the parameters collection that contains the parameters that are used by the DeleteMethod method. Gets the parameters collection that contains the parameters that are used by the DeleteMethod method.
public Property | EnablePaging | Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves.
public Property | FilterExpression | Gets or sets a filtering expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a filtering expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | FilterParameters | Gets a collection of parameters that are associated with any parameter placeholder in the FilterExpression string. Gets a collection of parameters that are associated with any parameter placeholders in the FilterExpression string.
public Property | InsertMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to insert data.
public Property | InsertParameters | Gets the parameters collection that contains the parameters that are used by the InsertMethod method.
public Property | MaximumRowsParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the number of records to retrieve for data source paging support.
public Property | Name | Gets or sets a value indicating the ISDataSourceView's name
public Property | OldValuesParameterFormatString | Gets or sets a format string to apply to the names of the parameters for original values that are passed to the Delete or Update methods.
public Property | SelectChildRowMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve self reference rows data. Used for performing load on demand in SelfReferenced WebGrid 5.0+ .
public Property | SelectCountMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve a row count.
public Property | SelectMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve data.
public Property | SelectOperation | Gets or sets a value indicating the type of ISDataSourceView's select operation
public Property | SelectParameters | Gets the parameters collection that contains the parameters that are used by the SelectMethod method.
public Property | SelectSelfReferenceRowMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve child rows data. Used for performing load on demand in Hierachical WebGrid 5.0+ .
public Property | SortExpression | Gets or sets a sorting expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a sorting expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | SortParameterName | Gets or sets the name of the business object that the SelectMethod parameter uses to specify a sort expression for data source sorting support. Gets or sets the name of the business object that the SelectMethod parameter used to specify a sort expression for data source sorting support.
public Property | StartRowIndexParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the integer index of the first record to retrieve from the results set for data source paging support.
public Property | TypeName | Gets or sets the name of the class that the ISDataSourceTable object represents.
public Property | UpdateMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data.
public Property | UpdateParameters | Gets the parameters collection that contains parameters that are used by the method that is specified by the UpdateMethod property. Gets the parameters collection that contains the parameters that are used by the method that is specified by the UpdateMethod property.
Top

Public Methods

 | Name | Description
public Method | Delete | Overloaded. Performs a delete operation by calling the business object method that is identified by the DeleteMethod property using the specified keys and oldValues collections.
public Method | GetLastReturnValue |
public Method | Insert | Overloaded. Performs an insert operation by calling the business object method that is identified by the InsertMethod property using the specified values collection.
public Method | LoadViewState | Restores previously saved view state for the data source view.
public Method | SaveViewState | Saves the changes to the view state for the ISDataSourceView object since the time when the page was posted back to the server.
public Method | Select | Overloaded. Retrieves data from the object that is identified by the TypeName property by calling the method that is identified by the SelectMethod property and passing any values in the SelectParameters collection.
public Method | TrackViewState | Causes the ISDataSourceView object to track changes to its view state so that the changes can be stored in the ViewState object for the control and persisted across requests for the same page.
public Method | Update | Overloaded. Performs an update operation by calling the method that is identified by the UpdateMethod property and using any parameters that are supplied in the keys, values, or oldValues collections.
Top

Public Events

 | Name | Description
public Event | DataSourceViewChanged | (Inherited from System.Web.UI.DataSourceView)
public Event | Deleted | Occurs when a Delete operation has completed.
public Event | Deleting | Occurs before a Delete operation.
public Event | Filtering | Occurs before a filter operation.
public Event | Inserted | Occurs when an Insert operation has completed.
public Event | Inserting | Occurs before an Insert operation.
public Event | ObjectCreated | Occurs after the object that is identified by the ISDataSourceTable's TypeName property is created.
public Event | ObjectCreating | Occurs before the object that is identified by the TypeName property is created.
public Event | ObjectDisposing | Occurs before the object that is identified by the TypeName property is discarded.
public Event | Selected | Occurs when a Select operation has completed.
public Event | Selecting | Occurs before a Select operation.
public Event | Updated | Occurs when an Update operation has completed.
public Event | Updating | Occurs before an Update operation.
Top

See Also

Reference

ISDataSourceView Class
ISNet.WebUI.DataSource Namespace


ISDataSourceView Constructor

[image]
ISDataSource Documentation
ISDataSourceView Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : ISDataSourceView Constructor

owner
The ISDataSource that the ISDataSourceView is associated with.
name
A unique name for the data source view, within the scope of the data source control that owns it.
context
The current HttpContext.
Initializes a new instance of the ISDataSourceView class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal owner As ISDataSource, _
   ByVal name As String, _
   ByVal context As HttpContext _
)
Visual Basic (Usage) Copy Code
Dim owner As ISDataSource
Dim name As String
Dim context As HttpContext

Dim instance As New ISDataSourceView(owner, name, context)
C#
public ISDataSourceView(
   ISDataSource owner,
   string name,
   HttpContext context
)
Delphi
public ISDataSourceView(
    owner: ISDataSource;
    name: String;
    context: HttpContext
);
JScript
public function ISDataSourceView(
   owner : ISDataSource,
   name : String,
   context : HttpContext
);
Managed Extensions for C++
public: ISDataSourceView(
   ISDataSource* owner,
   string* name,
   HttpContext* context
)
C++/CLI
public:
ISDataSourceView(
   ISDataSource^ owner,
   String^ name,
   HttpContext^ context
)

Parameters

owner
The ISDataSource that the ISDataSourceView is associated with.
name
A unique name for the data source view, within the scope of the data source control that owns it.
context
The current HttpContext.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


ISDataSourceView Class Methods

[image]
ISDataSource Documentation
ISDataSourceView Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceView Class

For a list of all members of this type, see ISDataSourceView members.

Public Methods

 | Name | Description
public Method | Delete | Overloaded. Performs a delete operation by calling the business object method that is identified by the DeleteMethod property using the specified keys and oldValues collections.
public Method | GetLastReturnValue |
public Method | Insert | Overloaded. Performs an insert operation by calling the business object method that is identified by the InsertMethod property using the specified values collection.
public Method | LoadViewState | Restores previously saved view state for the data source view.
public Method | SaveViewState | Saves the changes to the view state for the ISDataSourceView object since the time when the page was posted back to the server.
public Method | Select | Overloaded. Retrieves data from the object that is identified by the TypeName property by calling the method that is identified by the SelectMethod property and passing any values in the SelectParameters collection.
public Method | TrackViewState | Causes the ISDataSourceView object to track changes to its view state so that the changes can be stored in the ViewState object for the control and persisted across requests for the same page.
public Method | Update | Overloaded. Performs an update operation by calling the method that is identified by the UpdateMethod property and using any parameters that are supplied in the keys, values, or oldValues collections.
Top

See Also

Reference

ISDataSourceView Class
ISNet.WebUI.DataSource Namespace


Delete Method

[image]
ISDataSource Documentation
Delete Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Delete Method

Performs a delete operation by calling the business object method that is identified by the DeleteMethod property using the specified keys and oldValues collections.

Overload List

Overload | Description
Delete(IDictionary,IDictionary) | Performs a delete operation by calling the business object method that is identified by the DeleteMethod property using the specified keys and oldValues collections.
Delete(IDictionary,IDictionary,DataSourceViewOperationCallback) | (Inherited from System.Web.UI.DataSourceView)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Delete(IDictionary,IDictionary) Method

[image]
ISDataSource Documentation
Delete(IDictionary,IDictionary) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Delete Method : Delete(IDictionary,IDictionary) Method

keys
A IDictionary of the key values used to identify the item to delete. These parameters are used with the DeleteMethod property to perform the delete operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).
oldValues
A IDictionary that contains the additional non-key values used to match the item in the data source. Row values are passed to the method only if the ConflictDetection property is set to the CompareAllValues field.
Performs a delete operation by calling the business object method that is identified by the DeleteMethod property using the specified keys and oldValues collections.

Syntax

Visual Basic (Declaration)
Public Overloads Function Delete( _
   ByVal keys As IDictionary, _
   ByVal oldValues As IDictionary _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim keys As IDictionary
Dim oldValues As IDictionary
Dim value As Integer

value = instance.Delete(keys, oldValues)
C#
public int Delete(
   IDictionary keys,
   IDictionary oldValues
)
Delphi
public function Delete(
    keys: IDictionary;
    oldValues: IDictionary
): Integer;
JScript
public function Delete(
   keys : IDictionary,
   oldValues : IDictionary
) : int;
Managed Extensions for C++
public: int Delete(
   IDictionary* keys,
   IDictionary* oldValues
)
C++/CLI
public:
int Delete(
   IDictionary^ keys,
   IDictionary^ oldValues
)

Parameters

keys
A IDictionary of the key values used to identify the item to delete. These parameters are used with the DeleteMethod property to perform the delete operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).
oldValues
A IDictionary that contains the additional non-key values used to match the item in the data source. Row values are passed to the method only if the ConflictDetection property is set to the CompareAllValues field.

Return Value

The number of rows deleted; otherwise, -1, if the number is not known.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


GetLastReturnValue Method

[image]
ISDataSource Documentation
GetLastReturnValue Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : GetLastReturnValue Method

Syntax

Visual Basic (Declaration)
Public Function GetLastReturnValue() As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Object

value = instance.GetLastReturnValue()
C#
public object GetLastReturnValue()
Delphi
public function GetLastReturnValue(): TObject;
JScript
public function GetLastReturnValue() : Object;
Managed Extensions for C++
public: Object* GetLastReturnValue();
C++/CLI
public:
Object^ GetLastReturnValue();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Insert Method

[image]
ISDataSource Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Insert Method

Performs an insert operation by calling the business object method that is identified by the InsertMethod property using the specified values collection.

Overload List

Overload | Description
Insert(IDictionary) | Performs an insert operation by calling the business object method that is identified by the InsertMethod property using the specified values collection.
Insert(IDictionary,DataSourceViewOperationCallback) | (Inherited from System.Web.UI.DataSourceView)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Insert(IDictionary) Method

[image]
ISDataSource Documentation
Insert(IDictionary) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Insert Method : Insert(IDictionary) Method

values
A IDictionary collection of parameters used with the InsertMethod property to perform the insert operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).
Performs an insert operation by calling the business object method that is identified by the InsertMethod property using the specified values collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Insert( _
   ByVal values As IDictionary _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim values As IDictionary
Dim value As Integer

value = instance.Insert(values)
C#
public int Insert(
   IDictionary values
)
Delphi
public function Insert(
    values: IDictionary
): Integer;
JScript
public function Insert(
   values : IDictionary
) : int;
Managed Extensions for C++
public: int Insert(
   IDictionary* values
)
C++/CLI
public:
int Insert(
   IDictionary^ values
)

Parameters

values
A IDictionary collection of parameters used with the InsertMethod property to perform the insert operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).

Return Value

The number of rows inserted; otherwise, -1, if the number is not known.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


LoadViewState Method

[image]
ISDataSource Documentation
LoadViewState Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : LoadViewState Method

state
An object that represents the ISDataSourceView state to restore.
Restores previously saved view state for the data source view.

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadViewState( _
   ByVal state As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim state As Object

instance.LoadViewState(state)
C#
public virtual void LoadViewState(
   object state
)
Delphi
public procedure LoadViewState(
    state: TObject
); virtual;
JScript
public function LoadViewState(
   state : Object
);
Managed Extensions for C++
public: virtual void LoadViewState(
   Object* state
)
C++/CLI
public:
virtual void LoadViewState(
   Object^ state
)

Parameters

state
An object that represents the ISDataSourceView state to restore.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


SaveViewState Method

[image]
ISDataSource Documentation
SaveViewState Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SaveViewState Method

Saves the changes to the view state for the ISDataSourceView object since the time when the page was posted back to the server.

Syntax

Visual Basic (Declaration)
Public Overridable Function SaveViewState() As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Object

value = instance.SaveViewState()
C#
public virtual object SaveViewState()
Delphi
public function SaveViewState(): TObject; virtual;
JScript
public function SaveViewState() : Object;
Managed Extensions for C++
public: virtual Object* SaveViewState();
C++/CLI
public:
virtual Object^ SaveViewState();

Return Value

The object that contains the changes to the ISDataSourceView view state; otherwise a null reference (Nothing in Visual Basic), if there is no view state associated with the object.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Select Method

[image]
ISDataSource Documentation
Select Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Select Method

Retrieves data from the object that is identified by the TypeName property by calling the method that is identified by the SelectMethod property and passing any values in the SelectParameters collection.

Overload List

Overload | Description
Select(DataSourceSelectArguments) | Retrieves data from the object that is identified by the TypeName property by calling the method that is identified by the SelectMethod property and passing any values in the SelectParameters collection.
Select(DataSourceSelectArguments,DataSourceViewSelectCallback) | (Inherited from System.Web.UI.DataSourceView)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Select(DataSourceSelectArguments) Method

[image]
ISDataSource Documentation
Select(DataSourceSelectArguments) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Select Method : Select(DataSourceSelectArguments) Method

arguments
A DataSourceSelectArguments used to request operations on the data beyond basic data retrieval.
Retrieves data from the object that is identified by the TypeName property by calling the method that is identified by the SelectMethod property and passing any values in the SelectParameters collection.

Syntax

Visual Basic (Declaration)
Public Overloads Function Select( _
   ByVal arguments As DataSourceSelectArguments _
) As IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim arguments As DataSourceSelectArguments
Dim value As IEnumerable

value = instance.Select(arguments)
C#
public IEnumerable Select(
   DataSourceSelectArguments arguments
)
Delphi
public function Select(
    arguments: DataSourceSelectArguments
): IEnumerable;
JScript
public function Select(
   arguments : DataSourceSelectArguments
) : IEnumerable;
Managed Extensions for C++
public: IEnumerable* Select(
   DataSourceSelectArguments* arguments
)
C++/CLI
public:
IEnumerable^ Select(
   DataSourceSelectArguments^ arguments
)

Parameters

arguments
A DataSourceSelectArguments used to request operations on the data beyond basic data retrieval.

Return Value

An IEnumerable list of data rows.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


TrackViewState Method

[image]
ISDataSource Documentation
TrackViewState Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : TrackViewState Method

Causes the ISDataSourceView object to track changes to its view state so that the changes can be stored in the ViewState object for the control and persisted across requests for the same page.

Syntax

Visual Basic (Declaration)
Public Overridable Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView

instance.TrackViewState()
C#
public virtual void TrackViewState()
Delphi
public procedure TrackViewState(); virtual;
JScript
public function TrackViewState();
Managed Extensions for C++
public: virtual void TrackViewState();
C++/CLI
public:
virtual void TrackViewState();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Update Method

[image]
ISDataSource Documentation
Update Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Update Method

Performs an update operation by calling the method that is identified by the UpdateMethod property and using any parameters that are supplied in the keys, values, or oldValues collections.

Overload List

Overload | Description
Update(IDictionary,IDictionary,IDictionary) | Performs an update operation by calling the method that is identified by the UpdateMethod property and using any parameters that are supplied in the keys, values, or oldValues collections.
Update(IDictionary,IDictionary,IDictionary,DataSourceViewOperationCallback) | (Inherited from System.Web.UI.DataSourceView)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Update(IDictionary,IDictionary,IDictionary) Method

[image]
ISDataSource Documentation
Update(IDictionary,IDictionary,IDictionary) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Update Method : Update(IDictionary,IDictionary,IDictionary) Method

keys
A IDictionary of the key values used to identify the item to update. These parameters are used with the method specified by the UpdateMethod property to perform the update operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).
values
A IDictionary of new values to apply to the data source. These parameters are used with the method specified by the UpdateMethod property to perform the update database operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).
oldValues
A IDictionary that contains the additional non-key values used to match the item in the data source. Row values are passed to the delete method, only if the ConflictDetection property is set to the CompareAllValues field.
Performs an update operation by calling the method that is identified by the UpdateMethod property and using any parameters that are supplied in the keys, values, or oldValues collections.

Syntax

Visual Basic (Declaration)
Public Overloads Function Update( _
   ByVal keys As IDictionary, _
   ByVal values As IDictionary, _
   ByVal oldValues As IDictionary _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim keys As IDictionary
Dim values As IDictionary
Dim oldValues As IDictionary
Dim value As Integer

value = instance.Update(keys, values, oldValues)
C#
public int Update(
   IDictionary keys,
   IDictionary values,
   IDictionary oldValues
)
Delphi
public function Update(
    keys: IDictionary;
    values: IDictionary;
    oldValues: IDictionary
): Integer;
JScript
public function Update(
   keys : IDictionary,
   values : IDictionary,
   oldValues : IDictionary
) : int;
Managed Extensions for C++
public: int Update(
   IDictionary* keys,
   IDictionary* values,
   IDictionary* oldValues
)
C++/CLI
public:
int Update(
   IDictionary^ keys,
   IDictionary^ values,
   IDictionary^ oldValues
)

Parameters

keys
A IDictionary of the key values used to identify the item to update. These parameters are used with the method specified by the UpdateMethod property to perform the update operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).
values
A IDictionary of new values to apply to the data source. These parameters are used with the method specified by the UpdateMethod property to perform the update database operation. If there are no parameters associated with the method, pass a null reference (Nothing in Visual Basic).
oldValues
A IDictionary that contains the additional non-key values used to match the item in the data source. Row values are passed to the delete method, only if the ConflictDetection property is set to the CompareAllValues field.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


ISDataSourceView Class Properties

[image]
ISDataSource Documentation
ISDataSourceView Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceView Class

For a list of all members of this type, see ISDataSourceView members.

Public Properties

 | Name | Description
public Property | CancelSelectOnNullParameter |
public Property | CanDelete | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the delete operation.
public Property | CanInsert | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the insert operation.
public Property | CanPage | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports paging through the retrieved data.
public Property | CanRetrieveTotalRowCount | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports retrieving the total number of data rows, in addition to the set of data.
public Property | CanSort | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports a sorted view on the underlying data source.
public Property | CanUpdate | Overridden. Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the update operation.
public Property | ConflictDetection | Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.
public Property | ConvertNullToDBNull | Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.
public Property | DataObjectTypeName | Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control.
public Property | DeleteMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data.
public Property | DeleteParameters | Gets the parameters collection that contains the parameters that are used by the DeleteMethod method. Gets the parameters collection that contains the parameters that are used by the DeleteMethod method.
public Property | EnablePaging | Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves.
public Property | FilterExpression | Gets or sets a filtering expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a filtering expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | FilterParameters | Gets a collection of parameters that are associated with any parameter placeholder in the FilterExpression string. Gets a collection of parameters that are associated with any parameter placeholders in the FilterExpression string.
public Property | InsertMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to insert data.
public Property | InsertParameters | Gets the parameters collection that contains the parameters that are used by the InsertMethod method.
public Property | MaximumRowsParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the number of records to retrieve for data source paging support.
public Property | Name | Gets or sets a value indicating the ISDataSourceView's name
public Property | OldValuesParameterFormatString | Gets or sets a format string to apply to the names of the parameters for original values that are passed to the Delete or Update methods.
public Property | SelectChildRowMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve self reference rows data. Used for performing load on demand in SelfReferenced WebGrid 5.0+ .
public Property | SelectCountMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve a row count.
public Property | SelectMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve data.
public Property | SelectOperation | Gets or sets a value indicating the type of ISDataSourceView's select operation
public Property | SelectParameters | Gets the parameters collection that contains the parameters that are used by the SelectMethod method.
public Property | SelectSelfReferenceRowMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve child rows data. Used for performing load on demand in Hierachical WebGrid 5.0+ .
public Property | SortExpression | Gets or sets a sorting expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a sorting expression that is applied when the method that is specified by the SelectMethod property is called.
public Property | SortParameterName | Gets or sets the name of the business object that the SelectMethod parameter uses to specify a sort expression for data source sorting support. Gets or sets the name of the business object that the SelectMethod parameter used to specify a sort expression for data source sorting support.
public Property | StartRowIndexParameterName | Gets or sets the name of the data retrieval method parameter that is used to indicate the integer index of the first record to retrieve from the results set for data source paging support.
public Property | TypeName | Gets or sets the name of the class that the ISDataSourceTable object represents.
public Property | UpdateMethod | Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data.
public Property | UpdateParameters | Gets the parameters collection that contains parameters that are used by the method that is specified by the UpdateMethod property. Gets the parameters collection that contains the parameters that are used by the method that is specified by the UpdateMethod property.
Top

See Also

Reference

ISDataSourceView Class
ISNet.WebUI.DataSource Namespace


CancelSelectOnNullParameter Property

[image]
ISDataSource Documentation
CancelSelectOnNullParameter Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : CancelSelectOnNullParameter Property

Syntax

Visual Basic (Declaration)
Public Property CancelSelectOnNullParameter As CancelSelectOnNullParameter
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As CancelSelectOnNullParameter

instance.CancelSelectOnNullParameter = value

value = instance.CancelSelectOnNullParameter
C#
public CancelSelectOnNullParameter CancelSelectOnNullParameter {get; set;}
Delphi
public read-write property CancelSelectOnNullParameter: CancelSelectOnNullParameter;
JScript
public function get,set CancelSelectOnNullParameter : CancelSelectOnNullParameter
Managed Extensions for C++
public: __property CancelSelectOnNullParameter get_CancelSelectOnNullParameter();
public: __property void set_CancelSelectOnNullParameter(
   CancelSelectOnNullParameter value
);
C++/CLI
public:
property CancelSelectOnNullParameter CancelSelectOnNullParameter {
   CancelSelectOnNullParameter get();
   void set (    CancelSelectOnNullParameter value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


CanDelete Property

[image]
ISDataSource Documentation
CanDelete Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : CanDelete Property

Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the delete operation.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanDelete As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Boolean

value = instance.CanDelete
C#
public override bool CanDelete {get;}
Delphi
public read-only property CanDelete: Boolean; override;
JScript
public override function get CanDelete : boolean
Managed Extensions for C++
public: __property bool get_CanDelete() override;
C++/CLI
public:
property bool CanDelete {
   bool get() override;
}

Property Value

true, if the operation is supported; otherwise, false. Deletion is not supported, if the DeleteMethod property is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


CanInsert Property

[image]
ISDataSource Documentation
CanInsert Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : CanInsert Property

Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the insert operation.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanInsert As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Boolean

value = instance.CanInsert
C#
public override bool CanInsert {get;}
Delphi
public read-only property CanInsert: Boolean; override;
JScript
public override function get CanInsert : boolean
Managed Extensions for C++
public: __property bool get_CanInsert() override;
C++/CLI
public:
property bool CanInsert {
   bool get() override;
}

Property Value

true, if the operation is supported; otherwise, false. Insertion is not supported, if the InsertMethod property is an empty string.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


CanPage Property

[image]
ISDataSource Documentation
CanPage Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : CanPage Property

Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports paging through the retrieved data.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanPage As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Boolean

value = instance.CanPage
C#
public override bool CanPage {get;}
Delphi
public read-only property CanPage: Boolean; override;
JScript
public override function get CanPage : boolean
Managed Extensions for C++
public: __property bool get_CanPage() override;
C++/CLI
public:
property bool CanPage {
   bool get() override;
}

Property Value

true, if the EnablePaging value is set to true; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


CanRetrieveTotalRowCount Property

[image]
ISDataSource Documentation
CanRetrieveTotalRowCount Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : CanRetrieveTotalRowCount Property

Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports retrieving the total number of data rows, in addition to the set of data.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRetrieveTotalRowCount As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Boolean

value = instance.CanRetrieveTotalRowCount
C#
public override bool CanRetrieveTotalRowCount {get;}
Delphi
public read-only property CanRetrieveTotalRowCount: Boolean; override;
JScript
public override function get CanRetrieveTotalRowCount : boolean
Managed Extensions for C++
public: __property bool get_CanRetrieveTotalRowCount() override;
C++/CLI
public:
property bool CanRetrieveTotalRowCount {
   bool get() override;
}

Property Value

true, if the operation is supported; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


CanSort Property

[image]
ISDataSource Documentation
CanSort Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : CanSort Property

Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports a sorted view on the underlying data source.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSort As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Boolean

value = instance.CanSort
C#
public override bool CanSort {get;}
Delphi
public read-only property CanSort: Boolean; override;
JScript
public override function get CanSort : boolean
Managed Extensions for C++
public: __property bool get_CanSort() override;
C++/CLI
public:
property bool CanSort {
   bool get() override;
}

Property Value

true.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


CanUpdate Property

[image]
ISDataSource Documentation
CanUpdate Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : CanUpdate Property

Gets a value indicating whether the ISDataSourceView object that is associated with the current ISDataSourceTable supports the update operation.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanUpdate As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Boolean

value = instance.CanUpdate
C#
public override bool CanUpdate {get;}
Delphi
public read-only property CanUpdate: Boolean; override;
JScript
public override function get CanUpdate : boolean
Managed Extensions for C++
public: __property bool get_CanUpdate() override;
C++/CLI
public:
property bool CanUpdate {
   bool get() override;
}

Property Value

true, if the operation is supported; otherwise, false. Updating is not supported if the UpdateMethod property is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


ConflictDetection Property

[image]
ISDataSource Documentation
ConflictDetection Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : ConflictDetection Property

Gets or sets a value that determines whether or not just the new values are passed to the Update method or both the old and new values are passed to the Update method.

Syntax

Visual Basic (Declaration)
Public Property ConflictDetection As ISNet.WebUI.ConflictOptions
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As ISNet.WebUI.ConflictOptions

instance.ConflictDetection = value

value = instance.ConflictDetection
C#
public ISNet.WebUI.ConflictOptions ConflictDetection {get; set;}
Delphi
public read-write property ConflictDetection: ISNet.WebUI.ConflictOptions;
JScript
public function get,set ConflictDetection : ISNet.WebUI.ConflictOptions
Managed Extensions for C++
public: __property ISNet.WebUI.ConflictOptions get_ConflictDetection();
public: __property void set_ConflictDetection(
   ISNet.WebUI.ConflictOptions value
);
C++/CLI
public:
property ISNet.WebUI.ConflictOptions ConflictDetection {
   ISNet.WebUI.ConflictOptions get();
   void set (    ISNet.WebUI.ConflictOptions value);
}

Property Value

One of the ConflictOptions values. The default is ConflictOptions.Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Automatic conflict detection behavior


ConvertNullToDBNull Property

[image]
ISDataSource Documentation
ConvertNullToDBNull Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : ConvertNullToDBNull Property

Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the value by the ISDataSource control. Gets or sets a value indicating whether the Parameter values that are passed to an update, insert, or delete operation are automatically converted from a null reference (Nothing in Visual Basic) to the Value value by the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Property ConvertNullToDBNull As NullToDBNull
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As NullToDBNull

instance.ConvertNullToDBNull = value

value = instance.ConvertNullToDBNull
C#
public NullToDBNull ConvertNullToDBNull {get; set;}
Delphi
public read-write property ConvertNullToDBNull: NullToDBNull;
JScript
public function get,set ConvertNullToDBNull : NullToDBNull
Managed Extensions for C++
public: __property NullToDBNull get_ConvertNullToDBNull();
public: __property void set_ConvertNullToDBNull(
   NullToDBNull value
);
C++/CLI
public:
property NullToDBNull ConvertNullToDBNull {
   NullToDBNull get();
   void set (    NullToDBNull value);
}

Property Value

NullToDBNull.No, if any a null reference (Nothing in Visual Basic) values in Parameter objects passed to the ISDataSource control are automatically converted to System.DbNull.Value values; otherwise, NullToDBNull.Yes. The default is NullToDBNull.Default.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


DataObjectTypeName Property

[image]
ISDataSource Documentation
DataObjectTypeName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : DataObjectTypeName Property

Gets or sets the name of a class that the ISDataSourceTable uses for a parameter in an update, insert, or delete data operation, instead of passing individual values from the data-bound control.

Syntax

Visual Basic (Declaration)
Public Property DataObjectTypeName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.DataObjectTypeName = value

value = instance.DataObjectTypeName
C#
public string DataObjectTypeName {get; set;}
Delphi
public read-write property DataObjectTypeName: String;
JScript
public function get,set DataObjectTypeName : String
Managed Extensions for C++
public: __property string* get_DataObjectTypeName();
public: __property void set_DataObjectTypeName(
   string* value
);
C++/CLI
public:
property String^ DataObjectTypeName {
   String^ get();
   void set (    String^ value);
}

Property Value

A partially or fully qualified class name that identifies the type of the object that the ISDataSourceTable can use as a parameter for an Insert, Update, or a Delete operation. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


DeleteMethod Property

[image]
ISDataSource Documentation
DeleteMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : DeleteMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to delete data.

Syntax

Visual Basic (Declaration)
Public Property DeleteMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.DeleteMethod = value

value = instance.DeleteMethod
C#
public string DeleteMethod {get; set;}
Delphi
public read-write property DeleteMethod: String;
JScript
public function get,set DeleteMethod : String
Managed Extensions for C++
public: __property string* get_DeleteMethod();
public: __property void set_DeleteMethod(
   string* value
);
C++/CLI
public:
property String^ DeleteMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to delete data. The default is an empty string ("").

Remarks

Using DeleteMethod property you can set the name of the business object method or function that deletes data, and include any necessary parameter in the DeleteParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


DeleteParameters Property

[image]
ISDataSource Documentation
DeleteParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : DeleteParameters Property

Gets the parameters collection that contains the parameters that are used by the DeleteMethod method. Gets the parameters collection that contains the parameters that are used by the DeleteMethod method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DeleteParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As ParameterCollection

value = instance.DeleteParameters
C#
public ParameterCollection DeleteParameters {get;}
Delphi
public read-only property DeleteParameters: ParameterCollection;
JScript
public function get DeleteParameters : ParameterCollection
Managed Extensions for C++
public: __property ParameterCollection* get_DeleteParameters();
C++/CLI
public:
property ParameterCollection^ DeleteParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the DeleteMethod method.

Remarks

Using DeleteMethod property you can set the name of the business object method or function that deletes data, and include any necessary parameters in the DeleteParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


EnablePaging Property

[image]
ISDataSource Documentation
EnablePaging Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : EnablePaging Property

Gets or sets a value indicating whether the ISDataSourceTable supports paging through the set of data that it retrieves.

Syntax

Visual Basic (Declaration)
Public Property EnablePaging As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As Boolean

instance.EnablePaging = value

value = instance.EnablePaging
C#
public bool EnablePaging {get; set;}
Delphi
public read-write property EnablePaging: Boolean;
JScript
public function get,set EnablePaging : boolean
Managed Extensions for C++
public: __property bool get_EnablePaging();
public: __property void set_EnablePaging(
   bool value
);
C++/CLI
public:
property bool EnablePaging {
   bool get();
   void set (    bool value);
}

Property Value

true, if the data source control supports paging through the data it retrieves; otherwise, false.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Tasks

How-to: Utilize Paging Capability


FilterExpression Property

[image]
ISDataSource Documentation
FilterExpression Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : FilterExpression Property

Gets or sets a filtering expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a filtering expression that is applied when the method that is specified by the SelectMethod property is called.

Syntax

Visual Basic (Declaration)
Public Property FilterExpression As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.FilterExpression = value

value = instance.FilterExpression
C#
public string FilterExpression {get; set;}
Delphi
public read-write property FilterExpression: String;
JScript
public function get,set FilterExpression : String
Managed Extensions for C++
public: __property string* get_FilterExpression();
public: __property void set_FilterExpression(
   string* value
);
C++/CLI
public:
property String^ FilterExpression {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents a filtering expression applied when data is retrieved using the method or function identified by the SelectMethod property.

Remarks

The ISDataSourceTable can sort and filter data that is retrieved by the SelectMethod property if the data is returned as a DataSet, DataView or DataTable object.

You can set the FilterExpression property to a filtering expression using a format string syntax and bind values in the expression to parameters that are specified in the FilterParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Tasks

How-to: Utilize FilterExpression

Concepts

Sorting and Filtering Data


FilterParameters Property

[image]
ISDataSource Documentation
FilterParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : FilterParameters Property

Gets a collection of parameters that are associated with any parameter placeholder in the FilterExpression string. Gets a collection of parameters that are associated with any parameter placeholders in the FilterExpression string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilterParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As ParameterCollection

value = instance.FilterParameters
C#
public ParameterCollection FilterParameters {get;}
Delphi
public read-only property FilterParameters: ParameterCollection;
JScript
public function get FilterParameters : ParameterCollection
Managed Extensions for C++
public: __property ParameterCollection* get_FilterParameters();
C++/CLI
public:
property ParameterCollection^ FilterParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains a set of parameters associated with any parameter placeholders found in the FilterExpression property.

Remarks

The ISDataSourceTable can sort and filter data that is retrieved by the SelectMethod property if the data is returned as a DataSet, DataView or DataTable object.

You can set the FilterExpression property to a filtering expression using a format string syntax and bind values in the expression to parameters that are specified in the FilterParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Tasks

How-to: Utilize FilterParameters
How-to: Utilize multiple FilterParameters

Concepts

Sorting and Filtering Data


InsertMethod Property

[image]
ISDataSource Documentation
InsertMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : InsertMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to insert data.

Syntax

Visual Basic (Declaration)
Public Property InsertMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.InsertMethod = value

value = instance.InsertMethod
C#
public string InsertMethod {get; set;}
Delphi
public read-write property InsertMethod: String;
JScript
public function get,set InsertMethod : String
Managed Extensions for C++
public: __property string* get_InsertMethod();
public: __property void set_InsertMethod(
   string* value
);
C++/CLI
public:
property String^ InsertMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to insert data. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


InsertParameters Property

[image]
ISDataSource Documentation
InsertParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : InsertParameters Property

Gets the parameters collection that contains the parameters that are used by the InsertMethod method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InsertParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As ParameterCollection

value = instance.InsertParameters
C#
public ParameterCollection InsertParameters {get;}
Delphi
public read-only property InsertParameters: ParameterCollection;
JScript
public function get InsertParameters : ParameterCollection
Managed Extensions for C++
public: __property ParameterCollection* get_InsertParameters();
C++/CLI
public:
property ParameterCollection^ InsertParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the method identified by the InsertMethod property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


MaximumRowsParameterName Property

[image]
ISDataSource Documentation
MaximumRowsParameterName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : MaximumRowsParameterName Property

Gets or sets the name of the data retrieval method parameter that is used to indicate the number of records to retrieve for data source paging support.

Syntax

Visual Basic (Declaration)
Public Property MaximumRowsParameterName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.MaximumRowsParameterName = value

value = instance.MaximumRowsParameterName
C#
public string MaximumRowsParameterName {get; set;}
Delphi
public read-write property MaximumRowsParameterName: String;
JScript
public function get,set MaximumRowsParameterName : String
Managed Extensions for C++
public: __property string* get_MaximumRowsParameterName();
public: __property void set_MaximumRowsParameterName(
   string* value
);
C++/CLI
public:
property String^ MaximumRowsParameterName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the method parameter used to indicate the number of records to retrieve. The default is "maximumRows".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Name Property

[image]
ISDataSource Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Name Property

Gets or sets a value indicating the ISDataSourceView's name

Syntax

Visual Basic (Declaration)
Public Shadows Property Name As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.Name = value

value = instance.Name
C#
public new string Name {get; set;}
Delphi
public read-write property Name: String;
JScript
public hide function get,set Name : String
Managed Extensions for C++
public: __property new string* get_Name();
public: __property new void set_Name(
   string* value
);
C++/CLI
public:
new property String^ Name {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


OldValuesParameterFormatString Property

[image]
ISDataSource Documentation
OldValuesParameterFormatString Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : OldValuesParameterFormatString Property

Gets or sets a format string to apply to the names of the parameters for original values that are passed to the Delete or Update methods.

Syntax

Visual Basic (Declaration)
Public Property OldValuesParameterFormatString As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.OldValuesParameterFormatString = value

value = instance.OldValuesParameterFormatString
C#
public string OldValuesParameterFormatString {get; set;}
Delphi
public read-write property OldValuesParameterFormatString: String;
JScript
public function get,set OldValuesParameterFormatString : String
Managed Extensions for C++
public: __property string* get_OldValuesParameterFormatString();
public: __property void set_OldValuesParameterFormatString(
   string* value
);
C++/CLI
public:
property String^ OldValuesParameterFormatString {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents a format string applied to the names of any oldValues or key parameters passed to the Delete or Update methods. The default is the "{0}", which means the parameter name is the field name.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


SelectChildRowMethod Property

[image]
ISDataSource Documentation
SelectChildRowMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SelectChildRowMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve self reference rows data. Used for performing load on demand in SelfReferenced WebGrid 5.0+ .

Syntax

Visual Basic (Declaration)
Public Property SelectChildRowMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.SelectChildRowMethod = value

value = instance.SelectChildRowMethod
C#
public string SelectChildRowMethod {get; set;}
Delphi
public read-write property SelectChildRowMethod: String;
JScript
public function get,set SelectChildRowMethod : String
Managed Extensions for C++
public: __property string* get_SelectChildRowMethod();
public: __property void set_SelectChildRowMethod(
   string* value
);
C++/CLI
public:
property String^ SelectChildRowMethod {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


SelectCountMethod Property

[image]
ISDataSource Documentation
SelectCountMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SelectCountMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve a row count.

Syntax

Visual Basic (Declaration)
Public Property SelectCountMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.SelectCountMethod = value

value = instance.SelectCountMethod
C#
public string SelectCountMethod {get; set;}
Delphi
public read-write property SelectCountMethod: String;
JScript
public function get,set SelectCountMethod : String
Managed Extensions for C++
public: __property string* get_SelectCountMethod();
public: __property void set_SelectCountMethod(
   string* value
);
C++/CLI
public:
property String^ SelectCountMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceView uses to retrieve a row count. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


SelectMethod Property

[image]
ISDataSource Documentation
SelectMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SelectMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve data.

Syntax

Visual Basic (Declaration)
Public Property SelectMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.SelectMethod = value

value = instance.SelectMethod
C#
public string SelectMethod {get; set;}
Delphi
public read-write property SelectMethod: String;
JScript
public function get,set SelectMethod : String
Managed Extensions for C++
public: __property string* get_SelectMethod();
public: __property void set_SelectMethod(
   string* value
);
C++/CLI
public:
property String^ SelectMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to retrieve data. The default is an empty string ("").

Remarks

ISDataSource.NET performs data operations through its ISDataSourceTable collection. When working with a data-bound control you can use DataMember property to determine which ISDataSourceTable from ISDataSourceTable collection to be bounded to the data-bound control.

In order to retrieve data from a business object, you need to set the corresponding ISDataSourceTable’s SelectMethod property with the name of the method that retrieve the data. If the method does not return an IEnumerable or DataSet object, the object is wrapped by runtime in an IEnumerable collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Processing data using ISDataSource.NET


SelectOperation Property

[image]
ISDataSource Documentation
SelectOperation Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SelectOperation Property

Gets or sets a value indicating the type of ISDataSourceView's select operation

Syntax

Visual Basic (Declaration)
Public Property SelectOperation As ISNet.WebUI.SelectOptions
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As ISNet.WebUI.SelectOptions

instance.SelectOperation = value

value = instance.SelectOperation
C#
public ISNet.WebUI.SelectOptions SelectOperation {get; set;}
Delphi
public read-write property SelectOperation: ISNet.WebUI.SelectOptions;
JScript
public function get,set SelectOperation : ISNet.WebUI.SelectOptions
Managed Extensions for C++
public: __property ISNet.WebUI.SelectOptions get_SelectOperation();
public: __property void set_SelectOperation(
   ISNet.WebUI.SelectOptions value
);
C++/CLI
public:
property ISNet.WebUI.SelectOptions SelectOperation {
   ISNet.WebUI.SelectOptions get();
   void set (    ISNet.WebUI.SelectOptions value);
}

Remarks

SelectChildRow: Perform child rows selection using method specified in SelectChildRowMethod property. Used for performing LoadOnDemand in Hierachical WebGrid 5.0+ .

SelectVirtualRow: Perform virtual rows selection using method specified in SelectVirtualRowMethod property. Used for performing CustomVirtualLoad in WebGrid 5.0+ .

SelectSelfReferenceRow: Perform self reference rows selection using method specified in SelectSelfReferenceRowMethod property. Used for performing LoadOnDemand in Self Reference WebGrid 5.0+ .

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


SelectParameters Property

[image]
ISDataSource Documentation
SelectParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SelectParameters Property

Gets the parameters collection that contains the parameters that are used by the SelectMethod method.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As ParameterCollection

value = instance.SelectParameters
C#
public ParameterCollection SelectParameters {get;}
Delphi
public read-only property SelectParameters: ParameterCollection;
JScript
public function get SelectParameters : ParameterCollection
Managed Extensions for C++
public: __property ParameterCollection* get_SelectParameters();
C++/CLI
public:
property ParameterCollection^ SelectParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the SelectMethod method.

Remarks

ISDataSource.NET performs data operations through its ISDataSourceTable collection. When working with a data-bound control you can use DataMember property to determine which ISDataSourceTable from ISDataSourceTable collection to be bounded to the data-bound control.

In order to retrieve data from a business object, you need to set the corresponding ISDataSourceTable’s SelectMethod property with the name of the method that retrieve the data. If the method signature has parameters, you can add Parameter objects to the SelectParameters collection and bind them to the values that you want to pass to the method that is specified in ISDataSourceTable’s SelectMethod method.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Processing data using ISDataSource.NET


SelectSelfReferenceRowMethod Property

[image]
ISDataSource Documentation
SelectSelfReferenceRowMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SelectSelfReferenceRowMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to retrieve child rows data. Used for performing load on demand in Hierachical WebGrid 5.0+ .

Syntax

Visual Basic (Declaration)
Public Property SelectSelfReferenceRowMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.SelectSelfReferenceRowMethod = value

value = instance.SelectSelfReferenceRowMethod
C#
public string SelectSelfReferenceRowMethod {get; set;}
Delphi
public read-write property SelectSelfReferenceRowMethod: String;
JScript
public function get,set SelectSelfReferenceRowMethod : String
Managed Extensions for C++
public: __property string* get_SelectSelfReferenceRowMethod();
public: __property void set_SelectSelfReferenceRowMethod(
   string* value
);
C++/CLI
public:
property String^ SelectSelfReferenceRowMethod {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


SortExpression Property

[image]
ISDataSource Documentation
SortExpression Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SortExpression Property

Gets or sets a sorting expression that is applied when the method specified by the SelectMethod property is called. Gets or sets a sorting expression that is applied when the method that is specified by the SelectMethod property is called.

Syntax

Visual Basic (Declaration)
Public Property SortExpression As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.SortExpression = value

value = instance.SortExpression
C#
public string SortExpression {get; set;}
Delphi
public read-write property SortExpression: String;
JScript
public function get,set SortExpression : String
Managed Extensions for C++
public: __property string* get_SortExpression();
public: __property void set_SortExpression(
   string* value
);
C++/CLI
public:
property String^ SortExpression {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents a sorting expression applied when data is retrieved using the method or function identified by the SelectMethod property.

Remarks

Sorting Expression is used to sort the data retrieved by ISDataSourceControl. The SortExpression in ISDataSource will always act as secondary sorting after the data-bound controls sorting mechanism.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Tasks

How-to: Utilize SortExpression

Concepts

Sorting and Filtering Data


SortParameterName Property

[image]
ISDataSource Documentation
SortParameterName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : SortParameterName Property

Gets or sets the name of the business object that the SelectMethod parameter uses to specify a sort expression for data source sorting support. Gets or sets the name of the business object that the SelectMethod parameter used to specify a sort expression for data source sorting support.

Syntax

Visual Basic (Declaration)
Public Property SortParameterName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.SortParameterName = value

value = instance.SortParameterName
C#
public string SortParameterName {get; set;}
Delphi
public read-write property SortParameterName: String;
JScript
public function get,set SortParameterName : String
Managed Extensions for C++
public: __property string* get_SortParameterName();
public: __property void set_SortParameterName(
   string* value
);
C++/CLI
public:
property String^ SortParameterName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the method parameter used to indicate the parameter that accepts this sort expression value. The default is an empty string ("").

Remarks

You can set the SortParameterName property to the name of the parameter in SelectMethod method that carries the sort criteria. Then, you can set the SortExpression property to perform sorting when the Select method is called. The method specified by the SelectMethod property must return a DataSet, DataView or a DataTable.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Tasks

How-to: Utilize SortParameterName


StartRowIndexParameterName Property

[image]
ISDataSource Documentation
StartRowIndexParameterName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : StartRowIndexParameterName Property

Gets or sets the name of the data retrieval method parameter that is used to indicate the integer index of the first record to retrieve from the results set for data source paging support.

Syntax

Visual Basic (Declaration)
Public Property StartRowIndexParameterName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.StartRowIndexParameterName = value

value = instance.StartRowIndexParameterName
C#
public string StartRowIndexParameterName {get; set;}
Delphi
public read-write property StartRowIndexParameterName: String;
JScript
public function get,set StartRowIndexParameterName : String
Managed Extensions for C++
public: __property string* get_StartRowIndexParameterName();
public: __property void set_StartRowIndexParameterName(
   string* value
);
C++/CLI
public:
property String^ StartRowIndexParameterName {
   String^ get();
   void set (    String^ value);
}

Property Value

The name of the business object method parameter used to indicate the first record to retrieve. The default is "startRowIndex".

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


TypeName Property

[image]
ISDataSource Documentation
TypeName Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : TypeName Property

Gets or sets the name of the class that the ISDataSourceTable object represents.

Syntax

Visual Basic (Declaration)
Public Property TypeName As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.TypeName = value

value = instance.TypeName
C#
public string TypeName {get; set;}
Delphi
public read-write property TypeName: String;
JScript
public function get,set TypeName : String
Managed Extensions for C++
public: __property string* get_TypeName();
public: __property void set_TypeName(
   string* value
);
C++/CLI
public:
property String^ TypeName {
   String^ get();
   void set (    String^ value);
}

Property Value

A partially or fully qualified class name that identifies the type of the object that the ISDataSourceTable represents. The default is an empty string ("").

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


UpdateMethod Property

[image]
ISDataSource Documentation
UpdateMethod Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : UpdateMethod Property

Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data. Gets or sets the name of the method or function that the ISDataSourceTable invokes to update data.

Syntax

Visual Basic (Declaration)
Public Property UpdateMethod As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As String

instance.UpdateMethod = value

value = instance.UpdateMethod
C#
public string UpdateMethod {get; set;}
Delphi
public read-write property UpdateMethod: String;
JScript
public function get,set UpdateMethod : String
Managed Extensions for C++
public: __property string* get_UpdateMethod();
public: __property void set_UpdateMethod(
   string* value
);
C++/CLI
public:
property String^ UpdateMethod {
   String^ get();
   void set (    String^ value);
}

Property Value

A string that represents the name of the method or function that the ISDataSourceTable uses to update data. The default is an empty string.

Remarks

You can set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameter in the UpdateParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


UpdateParameters Property

[image]
ISDataSource Documentation
UpdateParameters Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : UpdateParameters Property

Gets the parameters collection that contains parameters that are used by the method that is specified by the UpdateMethod property. Gets the parameters collection that contains the parameters that are used by the method that is specified by the UpdateMethod property.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property UpdateParameters As ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim value As ParameterCollection

value = instance.UpdateParameters
C#
public ParameterCollection UpdateParameters {get;}
Delphi
public read-only property UpdateParameters: ParameterCollection;
JScript
public function get UpdateParameters : ParameterCollection
Managed Extensions for C++
public: __property ParameterCollection* get_UpdateParameters();
C++/CLI
public:
property ParameterCollection^ UpdateParameters {
   ParameterCollection^ get();
}

Property Value

A ParameterCollection that contains the parameters used by the method that is specified by the UpdateMethod property.

Remarks

You can set the UpdateMethod property to the name of the business object method that updates data, and include any necessary parameter in the UpdateParameters collection.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


ISDataSourceView Class Events

[image]
ISDataSource Documentation
ISDataSourceView Class Events
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceView Class

For a list of all members of this type, see ISDataSourceView members.

Public Events

 | Name | Description
public Event | DataSourceViewChanged | (Inherited from System.Web.UI.DataSourceView)
public Event | Deleted | Occurs when a Delete operation has completed.
public Event | Deleting | Occurs before a Delete operation.
public Event | Filtering | Occurs before a filter operation.
public Event | Inserted | Occurs when an Insert operation has completed.
public Event | Inserting | Occurs before an Insert operation.
public Event | ObjectCreated | Occurs after the object that is identified by the ISDataSourceTable's TypeName property is created.
public Event | ObjectCreating | Occurs before the object that is identified by the TypeName property is created.
public Event | ObjectDisposing | Occurs before the object that is identified by the TypeName property is discarded.
public Event | Selected | Occurs when a Select operation has completed.
public Event | Selecting | Occurs before a Select operation.
public Event | Updated | Occurs when an Update operation has completed.
public Event | Updating | Occurs before an Update operation.
Top

See Also

Reference

ISDataSourceView Class
ISNet.WebUI.DataSource Namespace


Deleted Event

[image]
ISDataSource Documentation
Deleted Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Deleted Event

Occurs when a Delete operation has completed.

Syntax

Visual Basic (Declaration)
Public Event Deleted As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Deleted, handler
C#
public event ISDataSourceStatusEventHandler Deleted
Delphi
public event Deleted: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceStatusEventHandler* Deleted
C++/CLI
public:
event ISDataSourceStatusEventHandler^ Deleted

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

This event handles the Deleted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Delete operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. The following are important properties available in ISDataSourceStatusEventArgs:

  • AffectedRows. You can use this property to return the number of rows that were deleted from the Delete method
  • ReturnValue. If you return the number of deleted rows from the method that is specified by the DeleteMethod property the value is available from this property.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguished it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Deleted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Delete operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Follows are important properties available in ISDataSourceStatusEventArgs: + AffectedRows You can use this property to return the number of rows that were deleted from the Delete method + ReturnValue If you return the number of deleted rows from the method that is specified by the DeleteMethod property the value is available from this property. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


Deleting Event

[image]
ISDataSource Documentation
Deleting Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Deleting Event

Occurs before a Delete operation.

Syntax

Visual Basic (Declaration)
Public Event Deleting As ISDataSourceMethodEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceMethodEventHandler

AddHandler instance.Deleting, handler
C#
public event ISDataSourceMethodEventHandler Deleting
Delphi
public event Deleting: ISDataSourceMethodEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceMethodEventHandler* Deleting
C++/CLI
public:
event ISDataSourceMethodEventHandler^ Deleting

Event Data

The event handler receives an argument of type ISDataSourceMethodEventArgs containing data related to this event. The following ISDataSourceMethodEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
InputParameters | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

This event handles the Deleting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the delete operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. You can cancel the delete operation by setting the Cancel property of the ISDataSourceMethodEventArgs to true.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Deleting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the delete operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. You can cancel the delete operation by setting the Cancel property of the ISDataSourceMethodEventArgs to true. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


Filtering Event

[image]
ISDataSource Documentation
Filtering Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Filtering Event

Occurs before a filter operation.

Syntax

Visual Basic (Declaration)
Public Event Filtering As ISDataSourceFilteringEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceFilteringEventHandler

AddHandler instance.Filtering, handler
C#
public event ISDataSourceFilteringEventHandler Filtering
Delphi
public event Filtering: ISDataSourceFilteringEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceFilteringEventHandler* Filtering
C++/CLI
public:
event ISDataSourceFilteringEventHandler^ Filtering

Event Data

The event handler receives an argument of type ISDataSourceFilteringEventArgs containing data related to this event. The following ISDataSourceFilteringEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
ParameterValues | Gets an IOrderedDictionary interface that provides access to the Parameter objects of the ISDataSourceTable class.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Filtering event to perform validation operations on filter parameter values before any ISDataSourceTable of ISDataSource control performs a filter operation. You can cancel the select operation by setting the Cancel property of the ISDataSourceFilteringEventArgs to true. The event is raised only if the FilterExpression property is set. The ISDataSource.Filtering event delegates to the ISDataSourceView.Filtering event of the ISDataSourceView that is associated with the ISDataSourceTable.
Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.
Security Note : You should validate any filter parameter value that you receive from the client. The runtime simply substitutes the parameter value into the filter expression and applies it to the DataView object that is returned by the Select method. If you are using the FilterExpression property as a security measure to limit the number of items that are returned, you must validate the parameter values before the filtering occurs.
Handle the Filtering event to perform validation operations on filter parameter values before any ISDataSourceTable of ISDataSource control performs a filter operation. You can cancel the select operation by setting the Cancel property of the ISDataSourceFilteringEventArgs to true. The event is raised only if the FilterExpression property is set. The ISDataSource.Filtering event delegates to the ISDataSourceView.Filtering event of the ISDataSourceView that is associated with the ISDataSourceTable. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property. Security Note : You should validate any filter parameter value that you receive from the client. The runtime simply substitutes the parameter value into the filter expression and applies it to the DataView object that is returned by the Select method. If you are using the FilterExpression property as a security measure to limit the number of items that are returned, you must validate the parameter values before the filtering occurs.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


Inserted Event

[image]
ISDataSource Documentation
Inserted Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Inserted Event

Occurs when an Insert operation has completed.

Syntax

Visual Basic (Declaration)
Public Event Inserted As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Inserted, handler
C#
public event ISDataSourceStatusEventHandler Inserted
Delphi
public event Inserted: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceStatusEventHandler* Inserted
C++/CLI
public:
event ISDataSourceStatusEventHandler^ Inserted

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the Inserted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Insert operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Inserted event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Insert operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


Inserting Event

[image]
ISDataSource Documentation
Inserting Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Inserting Event

Occurs before an Insert operation.

Syntax

Visual Basic (Declaration)
Public Event Inserting As ISDataSourceMethodEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceMethodEventHandler

AddHandler instance.Inserting, handler
C#
public event ISDataSourceMethodEventHandler Inserting
Delphi
public event Inserting: ISDataSourceMethodEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceMethodEventHandler* Inserting
C++/CLI
public:
event ISDataSourceMethodEventHandler^ Inserting

Event Data

The event handler receives an argument of type ISDataSourceMethodEventArgs containing data related to this event. The following ISDataSourceMethodEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
InputParameters | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Inserting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the insert operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object.
Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.
Handle the Inserting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the insert operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


ObjectCreated Event

[image]
ISDataSource Documentation
ObjectCreated Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : ObjectCreated Event

Occurs after the object that is identified by the ISDataSourceTable's TypeName property is created.

Syntax

Visual Basic (Declaration)
Public Event ObjectCreated As ISDataSourceObjectEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceObjectEventHandler

AddHandler instance.ObjectCreated, handler
C#
public event ISDataSourceObjectEventHandler ObjectCreated
Delphi
public event ObjectCreated: ISDataSourceObjectEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceObjectEventHandler* ObjectCreated
C++/CLI
public:
event ISDataSourceObjectEventHandler^ ObjectCreated

Event Data

The event handler receives an argument of type ISDataSourceEventArgs containing data related to this event. The following ISDataSourceEventArgs properties provide information specific to this event.

Property | Description
ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the ObjectCreated event to call other methods on the business object, set properties, or perform other initialization that is specific to the business object before any ISDataSourceTable of ISDataSource control object calls the business object data method to perform a data operation. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object. If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. You can distinguish it by using ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the ObjectCreated event to call other methods on the business object, set properties, or perform other initialization that is specific to the business object before any ISDataSourceTable of ISDataSource control object calls the business object data method to perform a data operation. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object. If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


ObjectCreating Event

[image]
ISDataSource Documentation
ObjectCreating Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : ObjectCreating Event

Occurs before the object that is identified by the TypeName property is created.

Syntax

Visual Basic (Declaration)
Public Event ObjectCreating As ISDataSourceObjectEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceObjectEventHandler

AddHandler instance.ObjectCreating, handler
C#
public event ISDataSourceObjectEventHandler ObjectCreating
Delphi
public event ObjectCreating: ISDataSourceObjectEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceObjectEventHandler* ObjectCreating
C++/CLI
public:
event ISDataSourceObjectEventHandler^ ObjectCreating

Event Data

The event handler receives an argument of type ISDataSourceEventArgs containing data related to this event. The following ISDataSourceEventArgs properties provide information specific to this event.

Property | Description
ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised. The corresponding ISDataSourceTable automatically calls the default constructor of a business object to create and instance of it using reflection. Handle the ObjectCreating event to explicitly call another constructor, and set the instance of the object that result to the ObjectInstance property of the associated ISDataSourceEventArgs object.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

If the method that is identified to perform the data operation is static (Shared in Visual Basic), the ObjectCreating and ObjectCreated events are never raised. The corresponding ISDataSourceTable automatically calls the default constructor of a business object to create and instance of it using reflection. Handle the ObjectCreating event to explicitly call another constructor, and set the instance of the object that results to the ObjectInstance property of the associated ISDataSourceEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


ObjectDisposing Event

[image]
ISDataSource Documentation
ObjectDisposing Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : ObjectDisposing Event

Occurs before the object that is identified by the TypeName property is discarded.

Syntax

Visual Basic (Declaration)
Public Event ObjectDisposing As ISDataSourceDisposingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceDisposingEventHandler

AddHandler instance.ObjectDisposing, handler
C#
public event ISDataSourceDisposingEventHandler ObjectDisposing
Delphi
public event ObjectDisposing: ISDataSourceDisposingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceDisposingEventHandler* ObjectDisposing
C++/CLI
public:
event ISDataSourceDisposingEventHandler^ ObjectDisposing

Event Data

The event handler receives an argument of type ISDataSourceDisposingEventArgs containing data related to this event. The following ISDataSourceDisposingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
ObjectInstance | Gets an object that represents the business object with which the ISDataSourceTable performs data operations.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

The ObjectDisposing event is always raised before the instance of the business object is discarded. If the business object implements the IDisposable interface, the Dispose method is called after this event is raised. Handle the ObjectDisposing event to call other methods on the object, set properties, or perform clean-up that is specific to the object before the object is destroyed. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object.
Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.
The ObjectDisposing event is always raised before the instance of the business object is discarded. If the business object implements the IDisposable interface, the Dispose method is called after this event is raised. Handle the ObjectDisposing event to call other methods on the object, set properties, or perform clean-up that is specific to the object before the object is destroyed. A reference to the object is accessed by the ObjectInstance property, which is exposed by the ISDataSourceEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Selected Event

[image]
ISDataSource Documentation
Selected Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Selected Event

Occurs when a Select operation has completed.

Syntax

Visual Basic (Declaration)
Public Event Selected As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Selected, handler
C#
public event ISDataSourceStatusEventHandler Selected
Delphi
public event Selected: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceStatusEventHandler* Selected
C++/CLI
public:
event ISDataSourceStatusEventHandler^ Selected

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the Selected event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Select operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Selected event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after a Select operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


Selecting Event

[image]
ISDataSource Documentation
Selecting Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Selecting Event

Occurs before a Select operation.

Syntax

Visual Basic (Declaration)
Public Event Selecting As ISDataSourceSelectingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceSelectingEventHandler

AddHandler instance.Selecting, handler
C#
public event ISDataSourceSelectingEventHandler Selecting
Delphi
public event Selecting: ISDataSourceSelectingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceSelectingEventHandler* Selecting
C++/CLI
public:
event ISDataSourceSelectingEventHandler^ Selecting

Event Data

The event handler receives an argument of type ISDataSourceSelectingEventArgs containing data related to this event. The following ISDataSourceSelectingEventArgs properties provide information specific to this event.

Property | Description
Arguments | Provides a mechanism that the ISDataSourceTable object can use to request data-related operations when data is retrieved.
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
ExecutingSelectCount | Gets a value indicating whether the ISDataSourceTable is retrieving a row count during a data retrieval operation.
InputParameters (Inherited from ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs) | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Selecting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the data retrieval operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. This event can be fired twice for a single call to the Select method, if the SelectCountMethod property is set. The ExecutingSelectCount property of the ISDataSourceSelectingEventArgs object is used to determine if select was called to retrieve data or retrieve the count.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Selecting event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the data retrieval operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. This event can be fired twice for a single call to the Select method, if the SelectCountMethod property is set. The ExecutingSelectCount property of the ISDataSourceSelectingEventArgs object is used to determine if select was called to retrieve data or retrieve the count. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


Updated Event

[image]
ISDataSource Documentation
Updated Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Updated Event

Occurs when an Update operation has completed.

Syntax

Visual Basic (Declaration)
Public Event Updated As ISDataSourceStatusEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceStatusEventHandler

AddHandler instance.Updated, handler
C#
public event ISDataSourceStatusEventHandler Updated
Delphi
public event Updated: ISDataSourceStatusEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceStatusEventHandler* Updated
C++/CLI
public:
event ISDataSourceStatusEventHandler^ Updated

Event Data

The event handler receives an argument of type ISDataSourceStatusEventArgs containing data related to this event. The following ISDataSourceStatusEventArgs properties provide information specific to this event.

Property | Description
AffectedRows | Gets or sets the number of rows that are affected by the data operation.
Exception | Gets a wrapper for any exceptions that are thrown by the method that is called by the ISDataSourceTable during a data operation.
ExceptionHandled | Gets or sets a value indicating whether an exception that was thrown by the business object has been handled.
OperationType |
OutputParameters | Gets a collection that contains business object method parameters and their values.
ReturnValue | Gets the return value that is returned by the business object method, if any, as an object.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceEventArgsBase) | Gets an value that represents the ViewName which performs data operations.

Remarks

Handle the Updated event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Update operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Updated event to examine the values of a return value or output parameters, or to determine whether an exception was thrown after an Update operation has completed. The return value, output parameters, and exception handling properties are available from the ISDataSourceStatusEventArgs object that is associated with the event. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


Updating Event

[image]
ISDataSource Documentation
Updating Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : Updating Event

Occurs before an Update operation.

Syntax

Visual Basic (Declaration)
Public Event Updating As ISDataSourceMethodEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As ISDataSourceMethodEventHandler

AddHandler instance.Updating, handler
C#
public event ISDataSourceMethodEventHandler Updating
Delphi
public event Updating: ISDataSourceMethodEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event ISDataSourceMethodEventHandler* Updating
C++/CLI
public:
event ISDataSourceMethodEventHandler^ Updating

Event Data

The event handler receives an argument of type ISDataSourceMethodEventArgs containing data related to this event. The following ISDataSourceMethodEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
InputParameters | Gets a collection that contains business object method parameters and their values.
ViewName (Inherited from ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase) | Gets an value that represents the ISDataSourceTable which performs data operations.

Remarks

Handle the Updating event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the update operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object.

Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguish it you can use ViewName property which can be accessed from event argument. ViewName value is the same as ISDataSource's TableName property.

Handle the Updating event to perform additional initialization that is specific to your application, to validate the values of parameters, or to change the parameter values before any ISDataSourceTable of ISDataSource control performs the update operation. The parameters are available as an IDictionary collection that is accessed by the InputParameters property, which is exposed by the ISDataSourceMethodEventArgs object. Note : Each ISDataSourceTable in ISDataSource will trigger the same data operation event when a data operation is executed. To distinguished it use ViewName property which can be accessed from ViewName property. ViewName value is the same as ISDataSource's TableName property.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members

Concepts

Event Handlers


NonRetrievableAttribute Class

[image]
ISDataSource Documentation
NonRetrievableAttribute Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : NonRetrievableAttribute Class

Use this attribute to mark a property in custom object as non retrievable. When a property has this attribute, the property will not be populated during databinding.

Object Model

NonRetrievableAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=True,
   Inherited=True)>
Public Class NonRetrievableAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
C#
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public class NonRetrievableAttribute : System.Attribute
Delphi
public class NonRetrievableAttribute = class(System.Attribute)
JScript
AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=,
   Inherited=)
public class NonRetrievableAttribute extends System.Attribute
Managed Extensions for C++
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public __gc class NonRetrievableAttribute : public System.Attribute
C++/CLI
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public ref class NonRetrievableAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.DataSource.NonRetrievableAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NonRetrievableAttribute Members
ISNet.WebUI.DataSource Namespace


NonRetrievableAttribute Class Members

[image]
ISDataSource Documentation
NonRetrievableAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.DataSource Namespace : NonRetrievableAttribute Class

The following tables list the members exposed by NonRetrievableAttribute.

Public Constructors

 | Name | Description
public Constructor | NonRetrievableAttribute Constructor |
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

NonRetrievableAttribute Class
ISNet.WebUI.DataSource Namespace


NonRetrievableAttribute Constructor

[image]
ISDataSource Documentation
NonRetrievableAttribute Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > NonRetrievableAttribute Class : NonRetrievableAttribute Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New NonRetrievableAttribute()
C#
public NonRetrievableAttribute()
Delphi
public NonRetrievableAttribute();
JScript
public function NonRetrievableAttribute();
Managed Extensions for C++
public: NonRetrievableAttribute();
C++/CLI
public:
NonRetrievableAttribute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


PrimaryKeyAttribute Class

[image]
ISDataSource Documentation
PrimaryKeyAttribute Class
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : PrimaryKeyAttribute Class

Use this attribute to mark a property in custom object as Primary Key. This attribute is required for Hierarchical custom objects databinding.

Object Model

PrimaryKeyAttribute Class

Syntax

Visual Basic (Declaration)
<AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=True,
   Inherited=True)>
Public Class PrimaryKeyAttribute
   Inherits System.Attribute
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
C#
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public class PrimaryKeyAttribute : System.Attribute
Delphi
public class PrimaryKeyAttribute = class(System.Attribute)
JScript
AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=,
   Inherited=)
public class PrimaryKeyAttribute extends System.Attribute
Managed Extensions for C++
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public __gc class PrimaryKeyAttribute : public System.Attribute
C++/CLI
[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=true,
   Inherited=true)]
public ref class PrimaryKeyAttribute : public System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
ISNet.WebUI.DataSource.PrimaryKeyAttribute

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PrimaryKeyAttribute Members
ISNet.WebUI.DataSource Namespace


PrimaryKeyAttribute Class Members

[image]
ISDataSource Documentation
PrimaryKeyAttribute Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.DataSource Namespace : PrimaryKeyAttribute Class

The following tables list the members exposed by PrimaryKeyAttribute.

Public Constructors

 | Name | Description
public Constructor | PrimaryKeyAttribute Constructor |
Top

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

PrimaryKeyAttribute Class
ISNet.WebUI.DataSource Namespace


PrimaryKeyAttribute Constructor

[image]
ISDataSource Documentation
PrimaryKeyAttribute Constructor
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > PrimaryKeyAttribute Class : PrimaryKeyAttribute Constructor

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New PrimaryKeyAttribute()
C#
public PrimaryKeyAttribute()
Delphi
public PrimaryKeyAttribute();
JScript
public function PrimaryKeyAttribute();
Managed Extensions for C++
public: PrimaryKeyAttribute();
C++/CLI
public:
PrimaryKeyAttribute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


CacheEnabled Enumeration

[image]
ISDataSource Documentation
CacheEnabled Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CacheEnabled Enumeration

Determines whether ISDataSource enables data caching or not

Syntax

Visual Basic (Declaration)
Public Enum CacheEnabled
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CacheEnabled
C#
public enum CacheEnabled : System.Enum
Delphi
public enum CacheEnabled = class(System.Enum)
JScript
public enum CacheEnabled extends System.Enum
Managed Extensions for C++
__value public enum CacheEnabled : public System.Enum
C++/CLI
public enum class CacheEnabled : public System.Enum

Members

Member | Description
Default | Caching enabled follows the setting in ISDataSource control
No | Disable caching
Yes | Enable caching

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.CacheEnabled

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


CacheExpirationPolicy Enumeration

[image]
ISDataSource Documentation
CacheExpirationPolicy Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CacheExpirationPolicy Enumeration

Describes the way data cached using ASP.NET caching mechanisms expires when a time-out is set.

Syntax

Visual Basic (Declaration)
Public Enum CacheExpirationPolicy
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CacheExpirationPolicy
C#
public enum CacheExpirationPolicy : System.Enum
Delphi
public enum CacheExpirationPolicy = class(System.Enum)
JScript
public enum CacheExpirationPolicy extends System.Enum
Managed Extensions for C++
__value public enum CacheExpirationPolicy : public System.Enum
C++/CLI
public enum class CacheExpirationPolicy : public System.Enum

Members

Member | Description
Absolute | Cached data expires when the amount of time specified by the CacheDuration property has passed since the data was first cached.
Default | Cache Expiration Policy follows the setting in ISDataSource control
Sliding | Cached data expires only when the cache entry has not been used for the amount of time specified by the CacheDuration property.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.CacheExpirationPolicy

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


CachePriority Enumeration

[image]
ISDataSource Documentation
CachePriority Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CachePriority Enumeration

Specifies the relative priority of items stored in the Cache object.

Syntax

Visual Basic (Declaration)
Public Enum CachePriority
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CachePriority
C#
public enum CachePriority : System.Enum
Delphi
public enum CachePriority = class(System.Enum)
JScript
public enum CachePriority extends System.Enum
Managed Extensions for C++
__value public enum CachePriority : public System.Enum
C++/CLI
public enum class CachePriority : public System.Enum

Members

Member | Description
AboveNormal | Cache items with this priority level are less likely to be deleted as the server frees system memory than those assigned a Normal priority.
BelowNormal | Cache items with this priority level are more likely to be deleted from the cache as the server frees system memory than items assigned a Normal priority.
Default | The cache priority of thecache data follows the setting in ISDataSource control
High | Cache items with this priority level are the least likely to be deleted from the cache as the server frees system memory.
Low | Cache items with this priority level are the most likely to be deleted from the cache as the server frees system memory.
Normal | Cache items with this priority level are likely to be deleted from the cache as the server frees system memory only after those items with Low or BelowNormal priority. This is the default.
NotRemovable | The cache items with this priority level will not be automatically deleted from the cache as the server frees system memory. However, items with this priority level are removed along with other items according to the item's absolute or sliding expiration time.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.CachePriority

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


CacheScope Enumeration

[image]
ISDataSource Documentation
CacheScope Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CacheScope Enumeration

Determines the scope of cache when ISDataSource control cached the data

Syntax

Visual Basic (Declaration)
Public Enum CacheScope
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CacheScope
C#
public enum CacheScope : System.Enum
Delphi
public enum CacheScope = class(System.Enum)
JScript
public enum CacheScope extends System.Enum
Managed Extensions for C++
__value public enum CacheScope : public System.Enum
C++/CLI
public enum class CacheScope : public System.Enum

Members

Member | Description
Default | The scope of cache data follows the setting in ISDataSource control
Global | Global cache data allows all users that access the application share the same data. It is usually used for common data that rarely updated and used by all users.
PerUser | Per User cache data will create a new instance for each user that accessing the application. The data is exclusive to each user.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.CacheScope

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


CacheStorage Enumeration

[image]
ISDataSource Documentation
CacheStorage Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CacheStorage Enumeration

Determines where ISDataSource control store the cached data

Syntax

Visual Basic (Declaration)
Public Enum CacheStorage
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CacheStorage
C#
public enum CacheStorage : System.Enum
Delphi
public enum CacheStorage = class(System.Enum)
JScript
public enum CacheStorage extends System.Enum
Managed Extensions for C++
__value public enum CacheStorage : public System.Enum
C++/CLI
public enum class CacheStorage : public System.Enum

Members

Member | Description
Default | The storage where the cache data will be stored follows the setting in ISDataSource control
FileServer | Cache data will be stored in FileServer
PageCache | Cache data will be stored in PageCache
Session | Cache data will be stored in Session Object

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.CacheStorage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


CancelSelectOnNullParameter Enumeration

[image]
ISDataSource Documentation
CancelSelectOnNullParameter Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CancelSelectOnNullParameter Enumeration

Syntax

Visual Basic (Declaration)
Public Enum CancelSelectOnNullParameter
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CancelSelectOnNullParameter
C#
public enum CancelSelectOnNullParameter : System.Enum
Delphi
public enum CancelSelectOnNullParameter = class(System.Enum)
JScript
public enum CancelSelectOnNullParameter extends System.Enum
Managed Extensions for C++
__value public enum CancelSelectOnNullParameter : public System.Enum
C++/CLI
public enum class CancelSelectOnNullParameter : public System.Enum

Members

Member | Description
Default |
No |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.CancelSelectOnNullParameter

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


NullToDBNull Enumeration

[image]
ISDataSource Documentation
NullToDBNull Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : NullToDBNull Enumeration

Determines whether ISDatasource will convert null value to DBNull

Syntax

Visual Basic (Declaration)
Public Enum NullToDBNull
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NullToDBNull
C#
public enum NullToDBNull : System.Enum
Delphi
public enum NullToDBNull = class(System.Enum)
JScript
public enum NullToDBNull extends System.Enum
Managed Extensions for C++
__value public enum NullToDBNull : public System.Enum
C++/CLI
public enum class NullToDBNull : public System.Enum

Members

Member | Description
Default | Behavior to convert null to DBNull follows the setting in ISDataSource control
No | Don't convert null value to DBNull
Yes | Convert null value to DBNull

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.NullToDBNull

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


SchemaType Enumeration

[image]
ISDataSource Documentation
SchemaType Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : SchemaType Enumeration

Determines the type of Schema specified to ISDataSource

Syntax

Visual Basic (Declaration)
Public Enum SchemaType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SchemaType
C#
public enum SchemaType : System.Enum
Delphi
public enum SchemaType = class(System.Enum)
JScript
public enum SchemaType extends System.Enum
Managed Extensions for C++
__value public enum SchemaType : public System.Enum
C++/CLI
public enum class SchemaType : public System.Enum

Members

Member | Description
CustomObject | Schema will be retrieved from a Custom object
DataSet | Schema will be retrieved from a DataSet object

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.SchemaType

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


StoreCachePerPage Enumeration

[image]
ISDataSource Documentation
StoreCachePerPage Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : StoreCachePerPage Enumeration

Determines whether the ISDataSource caching store cache data per page

Syntax

Visual Basic (Declaration)
Public Enum StoreCachePerPage
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As StoreCachePerPage
C#
public enum StoreCachePerPage : System.Enum
Delphi
public enum StoreCachePerPage = class(System.Enum)
JScript
public enum StoreCachePerPage extends System.Enum
Managed Extensions for C++
__value public enum StoreCachePerPage : public System.Enum
C++/CLI
public enum class StoreCachePerPage : public System.Enum

Members

Member | Description
Default | Behavior to store the cached data follows the setting in ISDataSource control
No | Disable store cached data per page
Yes | Enable store cached data per page

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.StoreCachePerPage

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


UseCachedDataOnFirstLoad Enumeration

[image]
ISDataSource Documentation
UseCachedDataOnFirstLoad Enumeration
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : UseCachedDataOnFirstLoad Enumeration

Determines whether the ISDataSource use cached data on first load or not

Syntax

Visual Basic (Declaration)
Public Enum UseCachedDataOnFirstLoad
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As UseCachedDataOnFirstLoad
C#
public enum UseCachedDataOnFirstLoad : System.Enum
Delphi
public enum UseCachedDataOnFirstLoad = class(System.Enum)
JScript
public enum UseCachedDataOnFirstLoad extends System.Enum
Managed Extensions for C++
__value public enum UseCachedDataOnFirstLoad : public System.Enum
C++/CLI
public enum class UseCachedDataOnFirstLoad : public System.Enum

Members

Member | Description
Default | Behavior to use cached data on first load follows the setting in ISDataSource control
No | Don't use cached data on first load
Yes | Use cached data on first load

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.DataSource.UseCachedDataOnFirstLoad

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISNet.WebUI.DataSource Namespace


IHierarchicalList Interface

[image]
ISDataSource Documentation
IHierarchicalList Interface
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : IHierarchicalList Interface

IHierarchicalList interface, required to support hierarchical objects binding in WebGrid.NET Enterprise V5.0.++

Syntax

Visual Basic (Declaration)
Public Interface IHierarchicalList
Visual Basic (Usage) Copy Code
Dim instance As IHierarchicalList
C#
public interface IHierarchicalList
Delphi
public interface IHierarchicalList
JScript
public interface IHierarchicalList
Managed Extensions for C++
public __gc __interface IHierarchicalList
C++/CLI
public interface class IHierarchicalList

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IHierarchicalList Members
ISNet.WebUI.DataSource Namespace


IHierarchicalList Interface Members

[image]
ISDataSource Documentation
IHierarchicalList Interface Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : IHierarchicalList Interface

The following tables list the members exposed by IHierarchicalList.

Public Properties

 | Name | Description
Property | ItemType | Represent the type of object stored in the collection
Top

See Also

Reference

IHierarchicalList Interface
ISNet.WebUI.DataSource Namespace


IHierarchicalList Interface Properties

[image]
ISDataSource Documentation
IHierarchicalList Interface Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : IHierarchicalList Interface

For a list of all members of this type, see IHierarchicalList members.

Public Properties

 | Name | Description
Property | ItemType | Represent the type of object stored in the collection
Top

See Also

Reference

IHierarchicalList Interface
ISNet.WebUI.DataSource Namespace


ItemType Property

[image]
ISDataSource Documentation
ItemType Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > IHierarchicalList Interface : ItemType Property

Represent the type of object stored in the collection

Syntax

Visual Basic (Declaration)
ReadOnly Property ItemType As Type
Visual Basic (Usage) Copy Code
Dim instance As IHierarchicalList
Dim value As Type

value = instance.ItemType
C#
Type ItemType {get;}
Delphi
read-only property ItemType: Type;
JScript
function get ItemType : Type
Managed Extensions for C++
__property Type* get_ItemType();
C++/CLI
property Type^ ItemType {
   Type^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IHierarchicalList Interface
IHierarchicalList Members


IObjectRelations Interface

[image]
ISDataSource Documentation
IObjectRelations Interface
Members See Also Send Feedback
ISNet.WebUI.DataSource Namespace : IObjectRelations Interface

IObjectRelations interface, required to support hierarchical objects binding in WebGrid.NET Enterprise V5.0.++

Syntax

Visual Basic (Declaration)
Public Interface IObjectRelations
Visual Basic (Usage) Copy Code
Dim instance As IObjectRelations
C#
public interface IObjectRelations
Delphi
public interface IObjectRelations
JScript
public interface IObjectRelations
Managed Extensions for C++
public __gc __interface IObjectRelations
C++/CLI
public interface class IObjectRelations

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObjectRelations Members
ISNet.WebUI.DataSource Namespace


IObjectRelations Interface Members

[image]
ISDataSource Documentation
IObjectRelations Interface Members
See Also Properties Send Feedback
ISNet.WebUI.DataSource Namespace : IObjectRelations Interface

The following tables list the members exposed by IObjectRelations.

Public Properties

 | Name | Description
Property | Relations | Collection of custom object relations
Top

See Also

Reference

IObjectRelations Interface
ISNet.WebUI.DataSource Namespace


IObjectRelations Interface Properties

[image]
ISDataSource Documentation
IObjectRelations Interface Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : IObjectRelations Interface

For a list of all members of this type, see IObjectRelations members.

Public Properties

 | Name | Description
Property | Relations | Collection of custom object relations
Top

See Also

Reference

IObjectRelations Interface
ISNet.WebUI.DataSource Namespace


Relations Property

[image]
ISDataSource Documentation
Relations Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > IObjectRelations Interface : Relations Property

Collection of custom object relations

Syntax

Visual Basic (Declaration)
ReadOnly Property Relations As ArrayList
Visual Basic (Usage) Copy Code
Dim instance As IObjectRelations
Dim value As ArrayList

value = instance.Relations
C#
ArrayList Relations {get;}
Delphi
read-only property Relations: ArrayList;
JScript
function get Relations : ArrayList
Managed Extensions for C++
__property ArrayList* get_Relations();
C++/CLI
property ArrayList^ Relations {
   ArrayList^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

IObjectRelations Interface
IObjectRelations Members


ISDataSourceDisposingEventHandler Delegate

[image]
ISDataSource Documentation
ISDataSourceDisposingEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceDisposingEventHandler Delegate

sender
The source of the event.
e
An ISDataSourceDisposingEventArgs that contains the event data.
Represents the method that will handle the ObjectDisposing event of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ISDataSourceDisposingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ISDataSourceDisposingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceDisposingEventHandler(AddressOf HandlerMethod)
C#
public delegate void ISDataSourceDisposingEventHandler(
   object sender,
   ISDataSourceDisposingEventArgs e
)
Delphi
public delegate ISDataSourceDisposingEventHandler(
    sender: TObject;
    e: ISDataSourceDisposingEventArgs
);
JScript
public delegate ISDataSourceDisposingEventHandler(
   sender : Object,
   e : ISDataSourceDisposingEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ISDataSourceDisposingEventHandler(
   Object* sender,
   ISDataSourceDisposingEventArgs* e
)
C++/CLI
public delegate void ISDataSourceDisposingEventHandler(
   Object^ sender,
   ISDataSourceDisposingEventArgs^ e
)

Parameters

sender
The source of the event.
e
An ISDataSourceDisposingEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceDisposingEventHandler Members
ISNet.WebUI.DataSource Namespace


ISDataSourceFilteringEventHandler Delegate

[image]
ISDataSource Documentation
ISDataSourceFilteringEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceFilteringEventHandler Delegate

sender
The source of the event.
e
An ISDataSourceFilteringEventArgs that contains the event data.
Represents the method that will handle the Filtering event of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ISDataSourceFilteringEventHandler( _
   ByVal sender As Object, _
   ByVal e As ISDataSourceFilteringEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceFilteringEventHandler(AddressOf HandlerMethod)
C#
public delegate void ISDataSourceFilteringEventHandler(
   object sender,
   ISDataSourceFilteringEventArgs e
)
Delphi
public delegate ISDataSourceFilteringEventHandler(
    sender: TObject;
    e: ISDataSourceFilteringEventArgs
);
JScript
public delegate ISDataSourceFilteringEventHandler(
   sender : Object,
   e : ISDataSourceFilteringEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ISDataSourceFilteringEventHandler(
   Object* sender,
   ISDataSourceFilteringEventArgs* e
)
C++/CLI
public delegate void ISDataSourceFilteringEventHandler(
   Object^ sender,
   ISDataSourceFilteringEventArgs^ e
)

Parameters

sender
The source of the event.
e
An ISDataSourceFilteringEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceFilteringEventHandler Members
ISNet.WebUI.DataSource Namespace


ISDataSourceMethodEventHandler Delegate

[image]
ISDataSource Documentation
ISDataSourceMethodEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceMethodEventHandler Delegate

sender
The source of the event.
e
An ISDataSourceMethodEventArgs that contains the event data.
Represents the method that will handle the Selecting, Updating, Inserting, or Deleting event of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ISDataSourceMethodEventHandler( _
   ByVal sender As Object, _
   ByVal e As ISDataSourceMethodEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceMethodEventHandler(AddressOf HandlerMethod)
C#
public delegate void ISDataSourceMethodEventHandler(
   object sender,
   ISDataSourceMethodEventArgs e
)
Delphi
public delegate ISDataSourceMethodEventHandler(
    sender: TObject;
    e: ISDataSourceMethodEventArgs
);
JScript
public delegate ISDataSourceMethodEventHandler(
   sender : Object,
   e : ISDataSourceMethodEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ISDataSourceMethodEventHandler(
   Object* sender,
   ISDataSourceMethodEventArgs* e
)
C++/CLI
public delegate void ISDataSourceMethodEventHandler(
   Object^ sender,
   ISDataSourceMethodEventArgs^ e
)

Parameters

sender
The source of the event.
e
An ISDataSourceMethodEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceMethodEventHandler Members
ISNet.WebUI.DataSource Namespace


ISDataSourceObjectEventHandler Delegate

[image]
ISDataSource Documentation
ISDataSourceObjectEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceObjectEventHandler Delegate

sender
The source of the event.
e
An ISDataSourceEventArgs that contains the event data.
Represents the method that will handle the ObjectCreating and ObjectCreated events of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ISDataSourceObjectEventHandler( _
   ByVal sender As Object, _
   ByVal e As ISDataSourceEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceObjectEventHandler(AddressOf HandlerMethod)
C#
public delegate void ISDataSourceObjectEventHandler(
   object sender,
   ISDataSourceEventArgs e
)
Delphi
public delegate ISDataSourceObjectEventHandler(
    sender: TObject;
    e: ISDataSourceEventArgs
);
JScript
public delegate ISDataSourceObjectEventHandler(
   sender : Object,
   e : ISDataSourceEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ISDataSourceObjectEventHandler(
   Object* sender,
   ISDataSourceEventArgs* e
)
C++/CLI
public delegate void ISDataSourceObjectEventHandler(
   Object^ sender,
   ISDataSourceEventArgs^ e
)

Parameters

sender
The source of the event.
e
An ISDataSourceEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceObjectEventHandler Members
ISNet.WebUI.DataSource Namespace


ISDataSourceSelectingEventHandler Delegate

[image]
ISDataSource Documentation
ISDataSourceSelectingEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceSelectingEventHandler Delegate

sender
The source of the event.
e
An ISDataSourceSelectingEventArgs that contains the event data.
Represents the method that will handle the Selecting event of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ISDataSourceSelectingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ISDataSourceSelectingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceSelectingEventHandler(AddressOf HandlerMethod)
C#
public delegate void ISDataSourceSelectingEventHandler(
   object sender,
   ISDataSourceSelectingEventArgs e
)
Delphi
public delegate ISDataSourceSelectingEventHandler(
    sender: TObject;
    e: ISDataSourceSelectingEventArgs
);
JScript
public delegate ISDataSourceSelectingEventHandler(
   sender : Object,
   e : ISDataSourceSelectingEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ISDataSourceSelectingEventHandler(
   Object* sender,
   ISDataSourceSelectingEventArgs* e
)
C++/CLI
public delegate void ISDataSourceSelectingEventHandler(
   Object^ sender,
   ISDataSourceSelectingEventArgs^ e
)

Parameters

sender
The source of the event.
e
An ISDataSourceSelectingEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceSelectingEventHandler Members
ISNet.WebUI.DataSource Namespace


ISDataSourceStatusEventHandler Delegate

[image]
ISDataSource Documentation
ISDataSourceStatusEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : ISDataSourceStatusEventHandler Delegate

sender
The source of the event.
e
An ISDataSourceStatusEventArgs that contains the event data.
Represents the method that will handle the Selected, Updated, Inserted, and Deleted events of the ISDataSource control.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ISDataSourceStatusEventHandler( _
   ByVal sender As Object, _
   ByVal e As ISDataSourceStatusEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New ISDataSourceStatusEventHandler(AddressOf HandlerMethod)
C#
public delegate void ISDataSourceStatusEventHandler(
   object sender,
   ISDataSourceStatusEventArgs e
)
Delphi
public delegate ISDataSourceStatusEventHandler(
    sender: TObject;
    e: ISDataSourceStatusEventArgs
);
JScript
public delegate ISDataSourceStatusEventHandler(
   sender : Object,
   e : ISDataSourceStatusEventArgs
)
Managed Extensions for C++
public: __gc __delegate void ISDataSourceStatusEventHandler(
   Object* sender,
   ISDataSourceStatusEventArgs* e
)
C++/CLI
public delegate void ISDataSourceStatusEventHandler(
   Object^ sender,
   ISDataSourceStatusEventArgs^ e
)

Parameters

sender
The source of the event.
e
An ISDataSourceStatusEventArgs that contains the event data.

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceStatusEventHandler Members
ISNet.WebUI.DataSource Namespace


Assembly Overview

ISNet.WebUI.ISDataSource Assembly
See Also Send Feedback

Namespaces

Namespace | Description
ISNet.WebUI.DataSource |


Getting Started - ISDataSource Documentation

Getting Started
Send Feedback


Introduction - ISDataSource Documentation

Introduction
Send Feedback


AutoIncrementAttribute Class Methods

[image]
ISDataSource Documentation
AutoIncrementAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : AutoIncrementAttribute Class

For a list of all members of this type, see AutoIncrementAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

AutoIncrementAttribute Class
ISNet.WebUI.DataSource Namespace


AutoIncrementAttribute Class Properties

[image]
ISDataSource Documentation
AutoIncrementAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : AutoIncrementAttribute Class

For a list of all members of this type, see AutoIncrementAttribute members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

AutoIncrementAttribute Class
ISNet.WebUI.DataSource Namespace


IsDefaultAttribute Method

[image]
ISDataSource Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > AutoIncrementAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


Match Method

[image]
ISDataSource Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > AutoIncrementAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


TypeId Property

[image]
ISDataSource Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > AutoIncrementAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As AutoIncrementAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

AutoIncrementAttribute Class
AutoIncrementAttribute Members


CaptionAttribute Class Methods

[image]
ISDataSource Documentation
CaptionAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : CaptionAttribute Class

For a list of all members of this type, see CaptionAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

CaptionAttribute Class
ISNet.WebUI.DataSource Namespace


IsDefaultAttribute Method

[image]
ISDataSource Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > CaptionAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


Match Method

[image]
ISDataSource Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > CaptionAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


TypeId Property

[image]
ISDataSource Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > CaptionAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As CaptionAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

CaptionAttribute Class
CaptionAttribute Members


Cancel Property

[image]
ISDataSource Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceCancelEventArgsBase Class : Cancel Property

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceCancelEventArgsBase
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
C#
public bool Cancel {get; set;}
Delphi
public read-write property Cancel: Boolean;
JScript
public function get,set Cancel : boolean
Managed Extensions for C++
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
C++/CLI
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceCancelEventArgsBase Class
ISDataSourceCancelEventArgsBase Members


Cancel Property

[image]
ISDataSource Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceDisposingEventArgs Class : Cancel Property

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceDisposingEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
C#
public bool Cancel {get; set;}
Delphi
public read-write property Cancel: Boolean;
JScript
public function get,set Cancel : boolean
Managed Extensions for C++
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
C++/CLI
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceDisposingEventArgs Class
ISDataSourceDisposingEventArgs Members


Cancel Property

[image]
ISDataSource Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceFilteringEventArgs Class : Cancel Property

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceFilteringEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
C#
public bool Cancel {get; set;}
Delphi
public read-write property Cancel: Boolean;
JScript
public function get,set Cancel : boolean
Managed Extensions for C++
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
C++/CLI
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceFilteringEventArgs Class
ISDataSourceFilteringEventArgs Members


Cancel Property

[image]
ISDataSource Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceMethodEventArgs Class : Cancel Property

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceMethodEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
C#
public bool Cancel {get; set;}
Delphi
public read-write property Cancel: Boolean;
JScript
public function get,set Cancel : boolean
Managed Extensions for C++
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
C++/CLI
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceMethodEventArgs Class
ISDataSourceMethodEventArgs Members


Cancel Property

[image]
ISDataSource Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceSelectingEventArgs Class : Cancel Property

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceSelectingEventArgs
Dim value As Boolean

instance.Cancel = value

value = instance.Cancel
C#
public bool Cancel {get; set;}
Delphi
public read-write property Cancel: Boolean;
JScript
public function get,set Cancel : boolean
Managed Extensions for C++
public: __property bool get_Cancel();
public: __property void set_Cancel(
   bool value
);
C++/CLI
public:
property bool Cancel {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceSelectingEventArgs Class
ISDataSourceSelectingEventArgs Members


Capacity Property

[image]
ISDataSource Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Capacity Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property Capacity As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim value As Integer

instance.Capacity = value

value = instance.Capacity
C#
[ComVisibleAttribute(false)]
public int Capacity {get; set;}
Delphi
public read-write property Capacity: Integer;
JScript
ComVisibleAttribute()
public function get,set Capacity : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_Capacity();
public: __property void set_Capacity(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int Capacity {
   int get();
   void set (    int value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Contains Method

[image]
ISDataSource Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Contains Method

value

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Boolean

value = instance.Contains(value)
C#
public bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : boolean;
Managed Extensions for C++
public: bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


CopyTo Method

[image]
ISDataSource Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : CopyTo Method

array
index

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Count Property

[image]
ISDataSource Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Count Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Exists Method

[image]
ISDataSource Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Exists Method

name

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As String _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim name As String
Dim value As Boolean

value = instance.Exists(name)
C#
public bool Exists(
   string name
)
Delphi
public function Exists(
    name: String
): Boolean;
JScript
public function Exists(
   name : String
) : boolean;
Managed Extensions for C++
public: bool Exists(
   string* name
)
C++/CLI
public:
bool Exists(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


GetItem Method

[image]
ISDataSource Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : GetItem Method

index

Syntax

Visual Basic (Declaration)
Public Overridable Function GetItem( _
   ByVal index As Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   int index
)
Delphi
public function GetItem(
    index: Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   int index
)

Parameters

index

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


IndexOf Method

[image]
ISDataSource Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : IndexOf Method

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


IndexOf(INamedObject) Method

[image]
ISDataSource Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As Integer

value = instance.IndexOf(value)
C#
public int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : int;
Managed Extensions for C++
public: int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members
Overload List


IndexOf(String) Method

[image]
ISDataSource Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class > IndexOf Method : IndexOf(String) Method

name

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As String _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
C#
public virtual int IndexOf(
   string name
)
Delphi
public function IndexOf(
    name: String
): Integer; virtual;
JScript
public function IndexOf(
   name : String
) : int;
Managed Extensions for C++
public: virtual int IndexOf(
   string* name
)
C++/CLI
public:
virtual int IndexOf(
   String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members
Overload List


IntInsert Method

[image]
ISDataSource Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : IntInsert Method

index
value

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim index As Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Parent Property

[image]
ISDataSource Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : Parent Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim value As Object

value = instance.Parent
C#
public object Parent {get;}
Delphi
public read-only property Parent: TObject;
JScript
public function get Parent : Object
Managed Extensions for C++
public: __property Object* get_Parent();
C++/CLI
public:
property Object^ Parent {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


setParent Method

[image]
ISDataSource Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTableCollection Class : setParent Method

parent

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As Object _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTableCollection
Dim parent As Object

instance.setParent(parent)
C#
public virtual void setParent(
   object parent
)
Delphi
public procedure setParent(
    parent: TObject
); virtual;
JScript
public function setParent(
   parent : Object
);
Managed Extensions for C++
public: virtual void setParent(
   Object* parent
)
C++/CLI
public:
virtual void setParent(
   Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTableCollection Class
ISDataSourceTableCollection Members


Clone Method

[image]
ISDataSource Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : Clone Method

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As Object
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Object

value = instance.Clone()
C#
public virtual object Clone()
Delphi
public function Clone(): TObject; virtual;
JScript
public function Clone() : Object;
Managed Extensions for C++
public: virtual Object* Clone();
C++/CLI
public:
virtual Object^ Clone();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


CopyFrom(Object,Boolean) Method

[image]
ISDataSource Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As Object, _
   ByVal cloneSourceValue As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim objSource As Object
Dim cloneSourceValue As Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   object objSource,
   bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: TObject;
    cloneSourceValue: Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : Object,
   cloneSourceValue : boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   Object* objSource,
   bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   Object^ objSource,
   bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members
Overload List


DeSerializeObjectData Method

[image]
ISDataSource Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : DeSerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


GetObjectData Method

[image]
ISDataSource Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


IsEmpty Method

[image]
ISDataSource Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : IsEmpty Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim value As Boolean

value = instance.IsEmpty()
C#
public virtual bool IsEmpty()
Delphi
public function IsEmpty(): Boolean; virtual;
JScript
public function IsEmpty() : boolean;
Managed Extensions for C++
public: virtual bool IsEmpty();
C++/CLI
public:
virtual bool IsEmpty();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


Reset Method

[image]
ISDataSource Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : Reset Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


SerializeObjectData Method

[image]
ISDataSource Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceTable Class : SerializeObjectData Method

type
info
context

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As Type, _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceTable
Dim type As Type
Dim info As SerializationInfo
Dim context As StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   Type type,
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: Type;
    info: SerializationInfo;
    context: StreamingContext
);
JScript
public function SerializeObjectData(
   type : Type,
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   Type* type,
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   Type^ type,
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceTable Class
ISDataSourceTable Members


DataSourceViewChanged Event

[image]
ISDataSource Documentation
DataSourceViewChanged Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class : DataSourceViewChanged Event

Syntax

Visual Basic (Declaration)
Public Event DataSourceViewChanged As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim handler As EventHandler

AddHandler instance.DataSourceViewChanged, handler
C#
public event EventHandler DataSourceViewChanged
Delphi
public event DataSourceViewChanged: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event EventHandler* DataSourceViewChanged
C++/CLI
public:
event EventHandler^ DataSourceViewChanged

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members


Delete(IDictionary,IDictionary,DataSourceViewOperationCallback) Method

[image]
ISDataSource Documentation
Delete(IDictionary,IDictionary,DataSourceViewOperationCallback) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Delete Method : Delete(IDictionary,IDictionary,DataSourceViewOperationCallback) Method

keys
oldValues
callback

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Delete( _
   ByVal keys As IDictionary, _
   ByVal oldValues As IDictionary, _
   ByVal callback As DataSourceViewOperationCallback _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim keys As IDictionary
Dim oldValues As IDictionary
Dim callback As DataSourceViewOperationCallback

instance.Delete(keys, oldValues, callback)
C#
public virtual void Delete(
   IDictionary keys,
   IDictionary oldValues,
   DataSourceViewOperationCallback callback
)
Delphi
public procedure Delete(
    keys: IDictionary;
    oldValues: IDictionary;
    callback: DataSourceViewOperationCallback
); virtual;
JScript
public function Delete(
   keys : IDictionary,
   oldValues : IDictionary,
   callback : DataSourceViewOperationCallback
);
Managed Extensions for C++
public: virtual void Delete(
   IDictionary* keys,
   IDictionary* oldValues,
   DataSourceViewOperationCallback* callback
)
C++/CLI
public:
virtual void Delete(
   IDictionary^ keys,
   IDictionary^ oldValues,
   DataSourceViewOperationCallback^ callback
)

Parameters

keys
oldValues
callback

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


Insert(IDictionary,DataSourceViewOperationCallback) Method

[image]
ISDataSource Documentation
Insert(IDictionary,DataSourceViewOperationCallback) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Insert Method : Insert(IDictionary,DataSourceViewOperationCallback) Method

values
callback

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Insert( _
   ByVal values As IDictionary, _
   ByVal callback As DataSourceViewOperationCallback _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim values As IDictionary
Dim callback As DataSourceViewOperationCallback

instance.Insert(values, callback)
C#
public virtual void Insert(
   IDictionary values,
   DataSourceViewOperationCallback callback
)
Delphi
public procedure Insert(
    values: IDictionary;
    callback: DataSourceViewOperationCallback
); virtual;
JScript
public function Insert(
   values : IDictionary,
   callback : DataSourceViewOperationCallback
);
Managed Extensions for C++
public: virtual void Insert(
   IDictionary* values,
   DataSourceViewOperationCallback* callback
)
C++/CLI
public:
virtual void Insert(
   IDictionary^ values,
   DataSourceViewOperationCallback^ callback
)

Parameters

values
callback

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


Select(DataSourceSelectArguments,DataSourceViewSelectCallback) Method

[image]
ISDataSource Documentation
Select(DataSourceSelectArguments,DataSourceViewSelectCallback) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Select Method : Select(DataSourceSelectArguments,DataSourceViewSelectCallback) Method

arguments
callback

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Select( _
   ByVal arguments As DataSourceSelectArguments, _
   ByVal callback As DataSourceViewSelectCallback _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim arguments As DataSourceSelectArguments
Dim callback As DataSourceViewSelectCallback

instance.Select(arguments, callback)
C#
public virtual void Select(
   DataSourceSelectArguments arguments,
   DataSourceViewSelectCallback callback
)
Delphi
public procedure Select(
    arguments: DataSourceSelectArguments;
    callback: DataSourceViewSelectCallback
); virtual;
JScript
public function Select(
   arguments : DataSourceSelectArguments,
   callback : DataSourceViewSelectCallback
);
Managed Extensions for C++
public: virtual void Select(
   DataSourceSelectArguments* arguments,
   DataSourceViewSelectCallback* callback
)
C++/CLI
public:
virtual void Select(
   DataSourceSelectArguments^ arguments,
   DataSourceViewSelectCallback^ callback
)

Parameters

arguments
callback

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


Update(IDictionary,IDictionary,IDictionary,DataSourceViewOperationCallback) Method

[image]
ISDataSource Documentation
Update(IDictionary,IDictionary,IDictionary,DataSourceViewOperationCallback) Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSourceView Class > Update Method : Update(IDictionary,IDictionary,IDictionary,DataSourceViewOperationCallback) Method

keys
values
oldValues
callback

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub Update( _
   ByVal keys As IDictionary, _
   ByVal values As IDictionary, _
   ByVal oldValues As IDictionary, _
   ByVal callback As DataSourceViewOperationCallback _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSourceView
Dim keys As IDictionary
Dim values As IDictionary
Dim oldValues As IDictionary
Dim callback As DataSourceViewOperationCallback

instance.Update(keys, values, oldValues, callback)
C#
public virtual void Update(
   IDictionary keys,
   IDictionary values,
   IDictionary oldValues,
   DataSourceViewOperationCallback callback
)
Delphi
public procedure Update(
    keys: IDictionary;
    values: IDictionary;
    oldValues: IDictionary;
    callback: DataSourceViewOperationCallback
); virtual;
JScript
public function Update(
   keys : IDictionary,
   values : IDictionary,
   oldValues : IDictionary,
   callback : DataSourceViewOperationCallback
);
Managed Extensions for C++
public: virtual void Update(
   IDictionary* keys,
   IDictionary* values,
   IDictionary* oldValues,
   DataSourceViewOperationCallback* callback
)
C++/CLI
public:
virtual void Update(
   IDictionary^ keys,
   IDictionary^ values,
   IDictionary^ oldValues,
   DataSourceViewOperationCallback^ callback
)

Parameters

keys
values
oldValues
callback

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSourceView Class
ISDataSourceView Members
Overload List


DataBind Method

[image]
ISDataSource Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : DataBind Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource

instance.DataBind()
C#
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
public function DataBind();
Managed Extensions for C++
public: virtual void DataBind();
C++/CLI
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


DataBinding Event

[image]
ISDataSource Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : DataBinding Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event EventHandler DataBinding
Delphi
public event DataBinding: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event EventHandler^ DataBinding

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Dispose Method

[image]
ISDataSource Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Dispose Method

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Disposed Event

[image]
ISDataSource Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Disposed Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event EventHandler Disposed
Delphi
public event Disposed: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event EventHandler^ Disposed

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


EnableViewState Property

[image]
ISDataSource Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : EnableViewState Property

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")>
<DefaultValueAttribute()>
<ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
Public Overridable Property EnableViewState As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[DefaultValueAttribute()]
[ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public virtual bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: Boolean; virtual;
JScript
WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")
DefaultValueAttribute()
ThemeableAttribute()
WebCategoryAttribute("Behavior")
public function get,set EnableViewState : boolean
Managed Extensions for C++
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[DefaultValueAttribute()]
[ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public: __property virtual bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   bool value
);
C++/CLI
[WebSysDescriptionAttribute("Whether the control automatically saves its state for use in round-trips.")]
[DefaultValueAttribute()]
[ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
public:
virtual property bool EnableViewState {
   bool get();
   void set (    bool value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ID Property

[image]
ISDataSource Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ID Property

Syntax

Visual Basic (Declaration)
<ParenthesizePropertyNameAttribute(True)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<FilterableAttribute(False)>
<MergablePropertyAttribute(False)>
<ThemeableAttribute(False)>
Public Overridable Property ID As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim value As String

instance.ID = value

value = instance.ID
C#
[ParenthesizePropertyNameAttribute(true)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[FilterableAttribute(false)]
[MergablePropertyAttribute(false)]
[ThemeableAttribute(false)]
public virtual string ID {get; set;}
Delphi
public read-write property ID: String; virtual;
JScript
ParenthesizePropertyNameAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
FilterableAttribute()
MergablePropertyAttribute()
ThemeableAttribute()
public function get,set ID : String
Managed Extensions for C++
[ParenthesizePropertyNameAttribute(true)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[FilterableAttribute(false)]
[MergablePropertyAttribute(false)]
[ThemeableAttribute(false)]
public: __property virtual string* get_ID();
public: __property virtual void set_ID(
   string* value
);
C++/CLI
[ParenthesizePropertyNameAttribute(true)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[FilterableAttribute(false)]
[MergablePropertyAttribute(false)]
[ThemeableAttribute(false)]
public:
virtual property String^ ID {
   String^ get();
   void set (    String^ value);
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Init Event

[image]
ISDataSource Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Init Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event EventHandler Init
Delphi
public event Init: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event EventHandler^ Init

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Load Event

[image]
ISDataSource Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Load Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event EventHandler Load
Delphi
public event Load: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event EventHandler^ Load

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


PreRender Event

[image]
ISDataSource Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : PreRender Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event EventHandler PreRender
Delphi
public event PreRender: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event EventHandler^ PreRender

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ResolveClientUrl Method

[image]
ISDataSource Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ResolveClientUrl Method

relativeUrl

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim relativeUrl As String
Dim value As String

value = instance.ResolveClientUrl(relativeUrl)
C#
public string ResolveClientUrl(
   string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: String
): String;
JScript
public function ResolveClientUrl(
   relativeUrl : String
) : String;
Managed Extensions for C++
public: string* ResolveClientUrl(
   string* relativeUrl
)
C++/CLI
public:
String^ ResolveClientUrl(
   String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


ResolveUrl Method

[image]
ISDataSource Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : ResolveUrl Method

relativeUrl

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As String _
) As String
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim relativeUrl As String
Dim value As String

value = instance.ResolveUrl(relativeUrl)
C#
public string ResolveUrl(
   string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: String
): String;
JScript
public function ResolveUrl(
   relativeUrl : String
) : String;
Managed Extensions for C++
public: string* ResolveUrl(
   string* relativeUrl
)
C++/CLI
public:
String^ ResolveUrl(
   String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


SetRenderMethodDelegate Method

[image]
ISDataSource Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : SetRenderMethodDelegate Method

renderMethod

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim renderMethod As RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: RenderMethod
);
JScript
EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : RenderMethod
);
Managed Extensions for C++
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   RenderMethod* renderMethod
)
C++/CLI
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


Unload Event

[image]
ISDataSource Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > ISDataSource Class : Unload Event

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ISDataSource
Dim handler As EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event EventHandler Unload
Delphi
public event Unload: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event EventHandler^ Unload

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

ISDataSource Class
ISDataSource Members


NonRetrievableAttribute Class Methods

[image]
ISDataSource Documentation
NonRetrievableAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : NonRetrievableAttribute Class

For a list of all members of this type, see NonRetrievableAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

NonRetrievableAttribute Class
ISNet.WebUI.DataSource Namespace


NonRetrievableAttribute Class Properties

[image]
ISDataSource Documentation
NonRetrievableAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : NonRetrievableAttribute Class

For a list of all members of this type, see NonRetrievableAttribute members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

NonRetrievableAttribute Class
ISNet.WebUI.DataSource Namespace


IsDefaultAttribute Method

[image]
ISDataSource Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > NonRetrievableAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


Match Method

[image]
ISDataSource Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > NonRetrievableAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


TypeId Property

[image]
ISDataSource Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > NonRetrievableAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As NonRetrievableAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

NonRetrievableAttribute Class
NonRetrievableAttribute Members


PrimaryKeyAttribute Class Methods

[image]
ISDataSource Documentation
PrimaryKeyAttribute Class Methods
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : PrimaryKeyAttribute Class

For a list of all members of this type, see PrimaryKeyAttribute members.

Public Methods

 | Name | Description
public Method | IsDefaultAttribute | (Inherited from System.Attribute)
public Method | Match | (Inherited from System.Attribute)
Top

See Also

Reference

PrimaryKeyAttribute Class
ISNet.WebUI.DataSource Namespace


PrimaryKeyAttribute Class Properties

[image]
ISDataSource Documentation
PrimaryKeyAttribute Class Properties
See Also Send Feedback
ISNet.WebUI.DataSource Namespace : PrimaryKeyAttribute Class

For a list of all members of this type, see PrimaryKeyAttribute members.

Public Properties

 | Name | Description
public Property | TypeId | (Inherited from System.Attribute)
Top

See Also

Reference

PrimaryKeyAttribute Class
ISNet.WebUI.DataSource Namespace


IsDefaultAttribute Method

[image]
ISDataSource Documentation
IsDefaultAttribute Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > PrimaryKeyAttribute Class : IsDefaultAttribute Method

Syntax

Visual Basic (Declaration)
Public Overridable Function IsDefaultAttribute() As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim value As Boolean

value = instance.IsDefaultAttribute()
C#
public virtual bool IsDefaultAttribute()
Delphi
public function IsDefaultAttribute(): Boolean; virtual;
JScript
public function IsDefaultAttribute() : boolean;
Managed Extensions for C++
public: virtual bool IsDefaultAttribute();
C++/CLI
public:
virtual bool IsDefaultAttribute();

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


Match Method

[image]
ISDataSource Documentation
Match Method
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > PrimaryKeyAttribute Class : Match Method

obj

Syntax

Visual Basic (Declaration)
Public Overridable Function Match( _
   ByVal obj As Object _
) As Boolean
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim obj As Object
Dim value As Boolean

value = instance.Match(obj)
C#
public virtual bool Match(
   object obj
)
Delphi
public function Match(
    obj: TObject
): Boolean; virtual;
JScript
public function Match(
   obj : Object
) : boolean;
Managed Extensions for C++
public: virtual bool Match(
   Object* obj
)
C++/CLI
public:
virtual bool Match(
   Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


TypeId Property

[image]
ISDataSource Documentation
TypeId Property
See Also Send Feedback
ISNet.WebUI.DataSource Namespace > PrimaryKeyAttribute Class : TypeId Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property TypeId As Object
Visual Basic (Usage) Copy Code
Dim instance As PrimaryKeyAttribute
Dim value As Object

value = instance.TypeId
C#
public virtual object TypeId {get;}
Delphi
public read-only property TypeId: TObject; virtual;
JScript
public function get TypeId : Object
Managed Extensions for C++
public: __property virtual Object* get_TypeId();
C++/CLI
public:
virtual property Object^ TypeId {
   Object^ get();
}

Requirements

Target Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows Server 2008 family

See Also

Reference

PrimaryKeyAttribute Class
PrimaryKeyAttribute Members


ISNet.WebUI.DataSource Namespace Inheritance Hierarchy

ISNet.WebUI.DataSource Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSource.ISDataSourceObjectRelation
ISNet.WebUI.DataSource.ISDataSourceTableSchema
ISNet.WebUI.ISCollectionBase
System.Collections.CollectionBase
ISNet.WebUI.DataSource.ISDataSourceTableCollection
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.DataSource.ISDataSourceTable
System.Attribute
ISNet.WebUI.DataSource.AutoIncrementAttribute
ISNet.WebUI.DataSource.CaptionAttribute
ISNet.WebUI.DataSource.NonRetrievableAttribute
ISNet.WebUI.DataSource.PrimaryKeyAttribute
System.ComponentModel.CancelEventArgs
System.EventArgs
ISNet.WebUI.DataSource.ISDataSourceCancelEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceDisposingEventArgs
ISNet.WebUI.DataSource.ISDataSourceFilteringEventArgs
ISNet.WebUI.DataSource.ISDataSourceMethodEventArgs
ISNet.WebUI.DataSource.ISDataSourceSelectingEventArgs
System.EventArgs
ISNet.WebUI.DataSource.ISDataSourceEventArgsBase
ISNet.WebUI.DataSource.ISDataSourceEventArgs
ISNet.WebUI.DataSource.ISDataSourceStatusEventArgs
System.Web.UI.DataSourceControl
System.Web.UI.Control
ISNet.WebUI.DataSource.ISDataSource
System.Web.UI.DataSourceView
ISNet.WebUI.DataSource.ISDataSourceView

See Also

Reference

ISNet.WebUI.ISDataSource Assembly


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you